nss-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. %define nspr_version 4.11
  4. %define unsupported_tools_directory %{_libdir}/nss/unsupported-tools
  5. # Produce .chk files for the final stripped binaries
  6. #
  7. # NOTE: The LD_LIBRARY_PATH line guarantees shlibsign links
  8. # against the freebl that we just built. This is necessary
  9. # because the signing algorithm changed on 3.14 to DSA2 with SHA256
  10. # whereas we previously signed with DSA and SHA1. We must Keep this line
  11. # until all mock platforms have been updated.
  12. # After %%{__os_install_post} we would add
  13. # export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%%{_libdir}
  14. %define __spec_install_post \
  15. %{?__debug_package:%{__debug_install_post}} \
  16. %{__arch_install_post} \
  17. %{__os_install_post} \
  18. $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libsoftokn3.so \
  19. $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libfreebl3.so \
  20. $RPM_BUILD_ROOT/%{unsupported_tools_directory}/shlibsign -i $RPM_BUILD_ROOT/%{_libdir}/libnssdbm3.so \
  21. %{nil}
  22. Summary: Network Security Services
  23. Name: nss
  24. Version: 3.21.1
  25. Release: 3%{?_dist_release}
  26. License: MPLv1.1 or GPLv2+ or LGPLv2+
  27. URL: http://www.mozilla.org/projects/security/pki/nss/
  28. Group: System Environment/Libraries
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Source0: %{name}-%{version}.tar.gz
  32. Source1: nss.pc.in
  33. Source2: nss-config.in
  34. Source3: blank-cert8.db
  35. Source4: blank-key3.db
  36. Source5: blank-secmod.db
  37. Source6: blank-cert9.db
  38. Source7: blank-key4.db
  39. Source8: system-pkcs11.txt
  40. Source12: %{name}-pem-20140125.tar.bz2
  41. Source101: nss-util.pc.in
  42. Source102: nss-util-config.in
  43. Source103: nss-softokn.pc.in
  44. Source104: nss-softokn-config.in
  45. Patch2: add-relro-linker-option.patch
  46. Patch3: renegotiate-transitional.patch
  47. Patch6: nss-enable-pem.patch
  48. Patch16: nss-539183.patch
  49. Patch18: nss-646045.patch
  50. # TODO: Remove this patch when the ocsp test are fixed
  51. Patch40: nss-3.14.0.0-disble-ocsp-test.patch
  52. Patch50: iquote.patch
  53. # As of nss-3.21 we compile NSS with -Werror.
  54. # see https://bugzilla.mozilla.org/show_bug.cgi?id=1182667
  55. # This requires a cleanup of the PEM module as we have it here.
  56. # TODO: submit a patch to the interim nss-pem upstream project
  57. # The submission will be very different from this patch as
  58. # cleanup there is already in progress there.
  59. Patch51: pem-compile-with-Werror.patch
  60. Patch52: Bug-1001841-disable-sslv2-libssl.patch
  61. Patch53: Bug-1001841-disable-sslv2-tests.patch
  62. Patch54: sslauth-no-v2.patch
  63. Patch55: enable-fips-when-system-is-in-fips-mode.patch
  64. # rhbz: https://bugzilla.redhat.com/show_bug.cgi?id=1026677
  65. Patch56: p-ignore-setpolicy.patch
  66. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=943144
  67. Patch62: nss-fix-deadlock-squash.patch
  68. # Two patches from from rhel6.8 that are also needed for rhel-7
  69. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1054373
  70. Patch74: race.patch
  71. Patch94: nss-3.16-token-init-race.patch
  72. Patch99: ssl-server-min-key-sizes.patch
  73. Patch100: fix-min-library-version-in-SSLVersionRange.patch
  74. # Add support for sha384 tls cipher suites, dss cipher suites, and
  75. # server-side dhe key exchange
  76. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=102794
  77. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
  78. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
  79. Patch101: dhe-sha384-dss-support.patch
  80. # TODO: From upstream review: For the client authentication case, should
  81. # probably drop our hack of swapping between sha256 and sha384 and plan
  82. # on implementing the fix we already have a patch for. What is that fix?
  83. Patch102: client_auth_for_sha384_prf_support.patch
  84. Patch103: nss-fix-client-auth-init-hashes.patch
  85. Patch104: nss-map-oid-to-hashalg.patch
  86. Patch105: nss-remove-bogus-assert.patch
  87. Patch106: nss-old-pkcs11-num.patch
  88. Patch107: nss-enable-384-cipher-tests.patch
  89. Patch108: nss-sni-c-v-fix.patch
  90. Patch109: nss-fix-signature-and-hash.patch
  91. Patch110: nss-sslstress-txt-ssl3-lower-value-in-range.patch
  92. # Enable by default two additional ciphers and fix order of two tables
  93. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
  94. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
  95. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1211403
  96. Patch112: rh1238290.patch
  97. # Local: keep as long nss-softokn lacks support
  98. Patch113: disable-extended-master-secret-with-old-softoken.patch
  99. # extra tests needed
  100. Patch114: tests-extra.patch
  101. Patch115: nss-prevent-abi-issue.patch
  102. Patch116: nss-tests-prevent-abi-issue.patch
  103. Patch117: fix-nss-test-filtering.patch
  104. Patch118: fix-allowed-sig-alg.patch
  105. Patch119: nss-ssl-ssl3con-delete-duplicates.patch
  106. # Local patches
  107. Patch1002: hasht-dont-include-prtypes.patch
  108. Patch1007: pkcs1sig-include-prtypes.patch
  109. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=951455
  110. # Upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=923089
  111. Patch1008: nss-util-3.19.1-tls12-mechanisms.patch
  112. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  113. BuildRequires: nspr-devel >= %{nspr_version}
  114. BuildRequires: sqlite3-devel
  115. BuildRequires: zlib-devel
  116. BuildRequires: pkgconfig
  117. BuildRequires: gawk
  118. BuildRequires: psmisc
  119. BuildRequires: perl
  120. Provides: mozilla-nss
  121. Obsoletes: mozilla-nss
  122. Requires: nspr >= %{nspr_version}
  123. %description
  124. Network Security Services (NSS) is a set of libraries designed to
  125. support cross-platform development of security-enabled client and
  126. server applications. Applications built with NSS can support SSL v2
  127. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  128. v3 certificates, and other security standards.
  129. %package tools
  130. Summary: Tools for the Network Security Services
  131. Group: System Environment/Base
  132. Requires: nss = %{version}-%{release}
  133. %description tools
  134. Network Security Services (NSS) is a set of libraries designed to
  135. support cross-platform development of security-enabled client and
  136. server applications. Applications built with NSS can support SSL v2
  137. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  138. v3 certificates, and other security standards.
  139. Install the nss-tools package if you need command-line tools to
  140. manipulate the NSS certificate and key database.
  141. %package devel
  142. Summary: Development libraries for Network Security Services
  143. Group: Development/Libraries
  144. Requires: nss = %{version}-%{release}
  145. Requires: nspr-devel >= %{nspr_version}
  146. Provides: mozilla-nss-devel
  147. Obsoletes: mozilla-nss-devel
  148. %description devel
  149. Header and Library files for doing development with Network Security Services.
  150. %package pkcs11-devel
  151. Summary: Development libraries for PKCS #11 (Cryptoki) using NSS
  152. Group: Development/Libraries
  153. Requires: nss-devel = %{version}-%{release}
  154. %description pkcs11-devel
  155. Library files for developing PKCS #11 modules using basic NSS
  156. low level services.
  157. ## to build compat32 for x86_64 architecture support
  158. %package -n compat32-%{name}
  159. Summary: Network Security Services
  160. Group: System Environment/Libraries
  161. %description -n compat32-%{name}
  162. Network Security Services (NSS) is a set of libraries designed to
  163. support cross-platform development of security-enabled client and
  164. server applications. Applications built with NSS can support SSL v2
  165. and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509
  166. v3 certificates, and other security standards.
  167. %prep
  168. %setup -q
  169. %setup -q -T -D -n %{name}-%{version} -a 12
  170. %patch2 -p0 -b .relro
  171. %patch3 -p0 -b .transitional
  172. %patch6 -p0 -b .libpem
  173. %patch16 -p0 -b .539183
  174. pushd nss
  175. %patch18 -p1 -b .646045
  176. popd
  177. %patch40 -p0 -b .noocsptest
  178. %patch50 -p0 -b .iquote
  179. %patch51 -p1 -b -Werror
  180. pushd nss
  181. %patch52 -p1 -b .disableSSL2libssl
  182. %patch53 -p1 -b .disableSSL2tests
  183. %patch54 -p1 -b .sslauth-no-v2
  184. %patch55 -p1 -b .852023_enable_fips_when_in_fips_mode
  185. %patch56 -p1 -b .1026677_ignore_set_policy
  186. %patch62 -p1 -b .fix_deadlock
  187. %patch99 -p1 -b .min_key_sizes
  188. %patch100 -p0 -b .1171318
  189. %patch101 -p1 -b .dhe_and_sha384
  190. %patch102 -p1 -b .client_auth_prf
  191. %patch112 -p1 -b .1238290
  192. %patch113 -p1 -b .disable-ems
  193. %patch114 -p1 -b .extra
  194. %patch115 -p1 -b .abi_lib
  195. %patch116 -p1 -b .abi_tests
  196. %patch117 -p1 -b .test-filtering
  197. %patch74 -p1 -b .race
  198. popd
  199. %patch94 -p0 -b .init-token-race
  200. %patch103 -p0 -b .fix_client_auth_crash
  201. %patch104 -p0 -b .use_oids
  202. %patch105 -p0 -b .remove_bogus_assert
  203. %patch106 -p0 -b .old_pkcs11_num
  204. %patch107 -p0 -b .enable_384_cipher_tests
  205. %patch108 -p0 -b .sni_c_v_fix
  206. %patch109 -p0 -b .fix_signature_and_hash
  207. %patch110 -p0 -b .no_ssl2
  208. pushd nss
  209. %patch118 -p1 -b .allowed-sig-alg
  210. popd
  211. %patch119 -p0 -b .delete_duplicates
  212. %patch1002 -p0 -b .prtypes
  213. %patch1007 -p0 -b .include_prtypes
  214. %patch1008 -p1 -b .tls12_mechs
  215. pemNeedsFromSoftoken="lowkeyi lowkeyti softoken softoknt"
  216. for file in ${pemNeedsFromSoftoken}; do
  217. %{__cp} ./nss/lib/softoken/${file}.h ./nss/lib/ckfw/pem/
  218. done
  219. %{__cp} ./nss/lib/softoken/lowkeyi.h ./nss/cmd/rsaperf
  220. %{__cp} ./nss/lib/softoken/lowkeyti.h ./nss/cmd/rsaperf
  221. pushd nss/tests/ssl
  222. # Create versions of sslcov.txt and sslstress.txt that disable tests
  223. # for SSL2 and EXPORT ciphers.
  224. cat sslcov.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslcov.noSSL2orExport.txt
  225. cat sslstress.txt| sed -r "s/^([^#].*EXPORT|^[^#].*SSL2)/#disabled \1/" > sslstress.noSSL2orExport.txt
  226. popd
  227. %build
  228. export NSS_NO_SSL2=1
  229. NSS_NO_PKCS11_BYPASS=1
  230. export NSS_NO_PKCS11_BYPASS
  231. # partial RELRO support as a security enhancement
  232. #LDFLAGS+=-Wl,-z,relro
  233. #export LDFLAGS
  234. FREEBL_NO_DEPEND=1
  235. export FREEBL_NO_DEPEND
  236. # Must export FREEBL_LOWHASH=1 for nsslowhash.h so that it gets
  237. # copied to dist and the rpm install phase can find it
  238. # This due of the upstream changes to fix
  239. # https://bugzilla.mozilla.org/show_bug.cgi?id=717906
  240. FREEBL_LOWHASH=1
  241. export FREEBL_LOWHASH
  242. # Enable compiler optimizations and disable debugging code
  243. BUILD_OPT=1
  244. export BUILD_OPT
  245. # Generate symbolic info for debuggers
  246. XCFLAGS=$RPM_OPT_FLAGS
  247. export XCFLAGS
  248. PKG_CONFIG_ALLOW_SYSTEM_LIBS=1
  249. PKG_CONFIG_ALLOW_SYSTEM_CFLAGS=1
  250. export PKG_CONFIG_ALLOW_SYSTEM_LIBS
  251. export PKG_CONFIG_ALLOW_SYSTEM_CFLAGS
  252. NSPR_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nspr | sed 's/-I//'`
  253. NSPR_LIB_DIR=`/usr/bin/pkg-config --libs-only-L nspr | sed 's/-L//'`
  254. export NSPR_INCLUDE_DIR
  255. export NSPR_LIB_DIR
  256. #export FREEBL_INCLUDE_DIR=`/usr/bin/pkg-config --cflags-only-I nss-softokn | sed 's/-I//'`
  257. #export FREEBL_LIB_DIR=%{_libdir}
  258. export USE_SYSTEM_FREEBL=0
  259. NSS_USE_SYSTEM_SQLITE=1
  260. export NSS_USE_SYSTEM_SQLITE
  261. export USE_SYSTEM_ZLIB=1
  262. export ZLIB_LIBS=%{_libdir}
  263. %ifarch x86_64 ppc64 ia64 s390x
  264. USE_64=1
  265. export USE_64
  266. %endif
  267. # uncomment if the iquote patch is activated
  268. export IN_TREE_FREEBL_HEADERS_FIRST=1
  269. #export NSS_BLTEST_NOT_AVAILABLE=1
  270. #
  271. #%{__make} -C ./nss/coreconf
  272. #%{__make} -C ./nss/lib/dbm
  273. %{__make} -C ./nss
  274. %install
  275. # There is no make install target so we'll do it ourselves.
  276. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3
  277. %{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/nss3/templates
  278. %{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
  279. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}
  280. %{__mkdir_p} $RPM_BUILD_ROOT/%{unsupported_tools_directory}
  281. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  282. # Copy the binary libraries we want
  283. for file in libsoftokn3.so libfreebl3.so libnss3.so libnssutil3.so \
  284. libssl3.so libsmime3.so libnssckbi.so libnsspem.so libnssdbm3.so
  285. do
  286. %{__install} -m 755 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
  287. done
  288. # Install the empty NSS db files
  289. # Legacy db
  290. %{__mkdir_p} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb
  291. %{__install} -m 644 %{SOURCE3} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert8.db
  292. %{__install} -m 644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key3.db
  293. %{__install} -m 644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/secmod.db
  294. # Shared db
  295. %{__install} -p -m 644 %{SOURCE6} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/cert9.db
  296. %{__install} -p -m 644 %{SOURCE7} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/key4.db
  297. %{__install} -p -m 644 %{SOURCE8} $RPM_BUILD_ROOT/%{_sysconfdir}/pki/nssdb/pkcs11.txt
  298. # Copy the development libraries we want
  299. for file in libcrmf.a libnssb.a libnssckfw.a
  300. do
  301. %{__install} -m 644 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
  302. done
  303. # Copy the binaries we want
  304. for file in certutil cmsutil crlutil modutil pk12util signtool signver ssltap
  305. do
  306. %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{_bindir}
  307. done
  308. # Copy the binaries we ship as unsupported
  309. for file in atob btoa derdump ocspclnt pp selfserv shlibsign strsclnt symkeyutil tstclnt vfyserv vfychain
  310. do
  311. %{__install} -m 755 dist/*.OBJ/bin/$file $RPM_BUILD_ROOT/%{unsupported_tools_directory}
  312. done
  313. # Copy the include files
  314. for file in dist/public/nss/*.h
  315. do
  316. %{__install} -m 644 $file $RPM_BUILD_ROOT/%{_includedir}/nss3
  317. done
  318. # Copy some freebl include files we also want
  319. for file in blapi.h alghmac.h
  320. do
  321. %{__install} -p -m 644 dist/private/nss/$file $RPM_BUILD_ROOT/%{_includedir}/nss3
  322. done
  323. # Copy the static freebl library
  324. for file in libfreebl.a
  325. do
  326. %{__install} -p -m 644 dist/*.OBJ/lib/$file $RPM_BUILD_ROOT/%{_libdir}
  327. done
  328. # Set up our package file
  329. %{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
  330. %{__cat} %{SOURCE1} | sed -e "s,%%libdir%%,%{_libdir},g" \
  331. -e "s,%%prefix%%,%{_prefix},g" \
  332. -e "s,%%exec_prefix%%,%{_prefix},g" \
  333. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  334. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  335. -e "s,%%NSS_VERSION%%,%{version},g" \
  336. -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
  337. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss.pc
  338. NSS_VMAJOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
  339. NSS_VMINOR=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
  340. NSS_VPATCH=`cat nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
  341. export NSS_VMAJOR
  342. export NSS_VMINOR
  343. export NSS_VPATCH
  344. %{__mkdir_p} $RPM_BUILD_ROOT/%{_bindir}
  345. %{__cat} %{SOURCE2} | sed -e "s,@libdir@,%{_libdir},g" \
  346. -e "s,@prefix@,%{_prefix},g" \
  347. -e "s,@exec_prefix@,%{_prefix},g" \
  348. -e "s,@includedir@,%{_includedir}/nss3,g" \
  349. -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
  350. -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
  351. -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
  352. > $RPM_BUILD_ROOT/%{_bindir}/nss-config
  353. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-config
  354. %{__cat} %{SOURCE101} | sed -e "s,%%libdir%%,%{_libdir},g" \
  355. -e "s,%%prefix%%,%{_prefix},g" \
  356. -e "s,%%exec_prefix%%,%{_prefix},g" \
  357. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  358. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  359. -e "s,%%NSSUTIL_VERSION%%,%{version},g" > \
  360. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-util.pc
  361. NSSUTIL_VMAJOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMAJOR" | awk '{print $3}'`
  362. NSSUTIL_VMINOR=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VMINOR" | awk '{print $3}'`
  363. NSSUTIL_VPATCH=`cat nss/lib/util/nssutil.h | grep "#define.*NSSUTIL_VPATCH" | awk '{print $3}'`
  364. export NSSUTIL_VMAJOR
  365. export NSSUTIL_VMINOR
  366. export NSSUTIL_VPATCH
  367. %{__cat} %{SOURCE102} | sed -e "s,@libdir@,%{_libdir},g" \
  368. -e "s,@prefix@,%{_prefix},g" \
  369. -e "s,@exec_prefix@,%{_prefix},g" \
  370. -e "s,@includedir@,%{_includedir}/nss3,g" \
  371. -e "s,@MOD_MAJOR_VERSION@,$NSSUTIL_VMAJOR,g" \
  372. -e "s,@MOD_MINOR_VERSION@,$NSSUTIL_VMINOR,g" \
  373. -e "s,@MOD_PATCH_VERSION@,$NSSUTIL_VPATCH,g" \
  374. > $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
  375. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-util-config
  376. %{__cat} %{SOURCE103} | sed -e "s,%%libdir%%,%{_libdir},g" \
  377. -e "s,%%prefix%%,%{_prefix},g" \
  378. -e "s,%%exec_prefix%%,%{_prefix},g" \
  379. -e "s,%%includedir%%,%{_includedir}/nss3,g" \
  380. -e "s,%%NSPR_VERSION%%,%{nspr_version},g" \
  381. -e "s,%%NSSUTIL_VERSION%%,%{version},g" \
  382. -e "s,%%SOFTOKEN_VERSION%%,%{version},g" > \
  383. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/nss-softokn.pc
  384. SOFTOKEN_VMAJOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMAJOR" | awk '{print $3}'`
  385. SOFTOKEN_VMINOR=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VMINOR" | awk '{print $3}'`
  386. SOFTOKEN_VPATCH=`cat nss/lib/softoken/softkver.h | grep "#define.*SOFTOKEN_VPATCH" | awk '{print $3}'`
  387. export SOFTOKEN_VMAJOR
  388. export SOFTOKEN_VMINOR
  389. export SOFTOKEN_VPATCH
  390. %{__cat} %{SOURCE104} | sed -e "s,@libdir@,%{_libdir},g" \
  391. -e "s,@prefix@,%{_prefix},g" \
  392. -e "s,@exec_prefix@,%{_prefix},g" \
  393. -e "s,@includedir@,%{_includedir}/nss3,g" \
  394. -e "s,@MOD_MAJOR_VERSION@,$SOFTOKEN_VMAJOR,g" \
  395. -e "s,@MOD_MINOR_VERSION@,$SOFTOKEN_VMINOR,g" \
  396. -e "s,@MOD_PATCH_VERSION@,$SOFTOKEN_VPATCH,g" \
  397. > $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
  398. chmod 755 $RPM_BUILD_ROOT/%{_bindir}/nss-softokn-config
  399. %clean
  400. %{__rm} -rf $RPM_BUILD_ROOT
  401. %post
  402. /sbin/ldconfig >/dev/null 2>/dev/null
  403. %postun
  404. /sbin/ldconfig >/dev/null 2>/dev/null
  405. %files
  406. %defattr(-,root,root)
  407. %{_libdir}/libnss3.so
  408. %{_libdir}/libnssutil3.so
  409. %{_libdir}/libnssdbm3.so
  410. %{_libdir}/libssl3.so
  411. %{_libdir}/libsmime3.so
  412. %{_libdir}/libsoftokn3.so
  413. %{_libdir}/libnssckbi.so
  414. %{_libdir}/libnsspem.so
  415. %{_libdir}/libfreebl3.so
  416. %{unsupported_tools_directory}/shlibsign
  417. %{_libdir}/libfreebl3.chk
  418. %{_libdir}/libnssdbm3.chk
  419. %{_libdir}/libsoftokn3.chk
  420. %dir %{_sysconfdir}/pki/nssdb
  421. %config(noreplace) %{_sysconfdir}/pki/nssdb/cert8.db
  422. %config(noreplace) %{_sysconfdir}/pki/nssdb/key3.db
  423. %config(noreplace) %{_sysconfdir}/pki/nssdb/secmod.db
  424. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/cert9.db
  425. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/key4.db
  426. %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/pki/nssdb/pkcs11.txt
  427. %files tools
  428. %defattr(-,root,root)
  429. %{_bindir}/certutil
  430. %{_bindir}/cmsutil
  431. %{_bindir}/crlutil
  432. %{_bindir}/modutil
  433. %{_bindir}/pk12util
  434. %{_bindir}/signtool
  435. %{_bindir}/signver
  436. %{_bindir}/ssltap
  437. %{unsupported_tools_directory}/atob
  438. %{unsupported_tools_directory}/btoa
  439. %{unsupported_tools_directory}/derdump
  440. %{unsupported_tools_directory}/ocspclnt
  441. %{unsupported_tools_directory}/pp
  442. %{unsupported_tools_directory}/selfserv
  443. %{unsupported_tools_directory}/strsclnt
  444. %{unsupported_tools_directory}/symkeyutil
  445. %{unsupported_tools_directory}/tstclnt
  446. %{unsupported_tools_directory}/vfyserv
  447. %{unsupported_tools_directory}/vfychain
  448. %files devel
  449. %defattr(-,root,root)
  450. %{_libdir}/libcrmf.a
  451. %{_libdir}/libfreebl.a
  452. %{_libdir}/pkgconfig/nss.pc
  453. %{_libdir}/pkgconfig/nss-softokn.pc
  454. %{_libdir}/pkgconfig/nss-util.pc
  455. %{_bindir}/nss-config
  456. %{_bindir}/nss-softokn-config
  457. %{_bindir}/nss-util-config
  458. %dir %{_includedir}/nss3
  459. %{_includedir}/nss3/alghmac.h
  460. %{_includedir}/nss3/base64.h
  461. %{_includedir}/nss3/blapi.h
  462. %{_includedir}/nss3/blapit.h
  463. %{_includedir}/nss3/cert.h
  464. %{_includedir}/nss3/certdb.h
  465. %{_includedir}/nss3/certt.h
  466. %{_includedir}/nss3/ciferfam.h
  467. %{_includedir}/nss3/cmmf.h
  468. %{_includedir}/nss3/cmmft.h
  469. %{_includedir}/nss3/cms.h
  470. %{_includedir}/nss3/cmsreclist.h
  471. %{_includedir}/nss3/cmst.h
  472. %{_includedir}/nss3/crmf.h
  473. %{_includedir}/nss3/crmft.h
  474. %{_includedir}/nss3/cryptohi.h
  475. %{_includedir}/nss3/cryptoht.h
  476. %{_includedir}/nss3/ecl-exp.h
  477. %{_includedir}/nss3/hasht.h
  478. %{_includedir}/nss3/jar-ds.h
  479. %{_includedir}/nss3/jar.h
  480. %{_includedir}/nss3/jarfile.h
  481. %{_includedir}/nss3/key.h
  482. %{_includedir}/nss3/keyhi.h
  483. %{_includedir}/nss3/keyt.h
  484. %{_includedir}/nss3/keythi.h
  485. %{_includedir}/nss3/nss.h
  486. %{_includedir}/nss3/nssb64.h
  487. %{_includedir}/nss3/nssb64t.h
  488. %{_includedir}/nss3/nssckbi.h
  489. %{_includedir}/nss3/nssilckt.h
  490. %{_includedir}/nss3/nssilock.h
  491. %{_includedir}/nss3/nsslocks.h
  492. %{_includedir}/nss3/nsslowhash.h
  493. %{_includedir}/nss3/nsspem.h
  494. %{_includedir}/nss3/nssrwlk.h
  495. %{_includedir}/nss3/nssrwlkt.h
  496. %{_includedir}/nss3/nssutil.h
  497. %{_includedir}/nss3/ocsp.h
  498. %{_includedir}/nss3/ocspt.h
  499. %{_includedir}/nss3/p12.h
  500. %{_includedir}/nss3/p12plcy.h
  501. %{_includedir}/nss3/p12t.h
  502. %{_includedir}/nss3/pk11func.h
  503. %{_includedir}/nss3/pk11pqg.h
  504. %{_includedir}/nss3/pk11priv.h
  505. %{_includedir}/nss3/pk11pub.h
  506. %{_includedir}/nss3/pk11sdr.h
  507. %{_includedir}/nss3/pkcs11.h
  508. %{_includedir}/nss3/pkcs11f.h
  509. %{_includedir}/nss3/pkcs11n.h
  510. %{_includedir}/nss3/pkcs11p.h
  511. %{_includedir}/nss3/pkcs11t.h
  512. %{_includedir}/nss3/pkcs11u.h
  513. %{_includedir}/nss3/pkcs12.h
  514. %{_includedir}/nss3/pkcs12t.h
  515. %{_includedir}/nss3/pkcs7t.h
  516. %{_includedir}/nss3/pkcs1sig.h
  517. %{_includedir}/nss3/portreg.h
  518. %{_includedir}/nss3/preenc.h
  519. %{_includedir}/nss3/secasn1.h
  520. %{_includedir}/nss3/secasn1t.h
  521. %{_includedir}/nss3/seccomon.h
  522. %{_includedir}/nss3/secder.h
  523. %{_includedir}/nss3/secdert.h
  524. %{_includedir}/nss3/secdig.h
  525. %{_includedir}/nss3/secdigt.h
  526. %{_includedir}/nss3/secerr.h
  527. %{_includedir}/nss3/sechash.h
  528. %{_includedir}/nss3/secitem.h
  529. %{_includedir}/nss3/secmime.h
  530. %{_includedir}/nss3/secmod.h
  531. %{_includedir}/nss3/secmodt.h
  532. %{_includedir}/nss3/secoid.h
  533. %{_includedir}/nss3/secoidt.h
  534. %{_includedir}/nss3/secpkcs5.h
  535. %{_includedir}/nss3/secpkcs7.h
  536. %{_includedir}/nss3/secport.h
  537. %{_includedir}/nss3/shsign.h
  538. %{_includedir}/nss3/smime.h
  539. %{_includedir}/nss3/ssl.h
  540. %{_includedir}/nss3/sslerr.h
  541. %{_includedir}/nss3/sslproto.h
  542. %{_includedir}/nss3/sslt.h
  543. %{_includedir}/nss3/utilrename.h
  544. %{_includedir}/nss3/utilmodt.h
  545. %{_includedir}/nss3/utilpars.h
  546. %{_includedir}/nss3/utilparst.h
  547. %files pkcs11-devel
  548. %defattr(-, root, root)
  549. %{_includedir}/nss3/nssbase.h
  550. %{_includedir}/nss3/nssbaset.h
  551. %{_includedir}/nss3/nssckepv.h
  552. %{_includedir}/nss3/nssckft.h
  553. %{_includedir}/nss3/nssckfw.h
  554. %{_includedir}/nss3/nssckfwc.h
  555. %{_includedir}/nss3/nssckfwt.h
  556. %{_includedir}/nss3/nssckg.h
  557. %{_includedir}/nss3/nssckmdt.h
  558. %{_includedir}/nss3/nssckt.h
  559. %{_libdir}/libnssb.a
  560. %{_libdir}/libnssckfw.a
  561. ## to build compat32 for x86_64 architecture support
  562. %if %{build_compat32}
  563. %files -n compat32-%{name}
  564. %defattr(-,root,root)
  565. %{_libdir}/*.so
  566. %ghost %{_libdir}/libsoftokn3.chk
  567. %ghost %{_libdir}/libfreebl3.chk
  568. %{unsupported_tools_directory}/shlibsign
  569. %endif
  570. %changelog
  571. * Mon Jun 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.21.1-3
  572. - added libfreebl.a.
  573. * Mon Jun 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.21.1-2
  574. - enabled softokn and freebl.
  575. - dropped Patch47 and Patch49.
  576. * Tue May 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.21.1-1
  577. - update to 3.21.1
  578. - import patches from centos package
  579. * Thu Jun 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.16.1-1
  580. - update to 3.16.1
  581. * Thu Apr 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.3-1
  582. - update to 3.14.3
  583. - import patches from fedora package
  584. * Wed Jan 09 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.14.1-1
  585. - update to 3.14.1
  586. * Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.6-2
  587. - add Source101 (nss-util.pc.in)
  588. - add Source102 (nss-util-config.in)
  589. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.6-1
  590. - new upstream release
  591. * Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.13.3-1
  592. - new upstream release
  593. * Thu Dec 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-2
  594. - fix nss.pc
  595. * Wed Dec 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.1-1
  596. - new upstream release
  597. * Fri Sep 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.11-1
  598. - new upstram release
  599. * Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.10-1
  600. - update to 3.12.10
  601. * Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.9-1
  602. - update to 3.12.9.with.ckbi.1.82
  603. - update nss-pem source
  604. - define NSS_USE_SYSTEM_SQLITE, remove unneeded Patch2
  605. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.6-2
  606. - rebuild with rpm-4.8.1 for pkg-config file
  607. * Wed Apr 7 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.12.6-1
  608. - new upstream release
  609. - update nss-pem Source12 to 20091210 (from 3.12.6-2.fc14)
  610. * Sat Jan 23 2010 NAKAMURA Kenta <kenta@vinelinux.org> 3.12.5-2
  611. - built with FREEBL_NO_DEPEND environmental variable to include nsslowhash.h
  612. * Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.5-1
  613. - new upstream release
  614. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-4
  615. - rebuild to fix the package built with broken environment.
  616. * Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-3
  617. - fixed %%files for compat32
  618. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 3.12.3-2
  619. - added compat32 subpackages
  620. * Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12.3-1
  621. - new upstream release
  622. * Wed Jul 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
  623. - new upstream release
  624. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.11.4-0vl1
  625. - initial build for Vine Linux
  626. * Fri Mar 02 2007 Kai Engert <kengert@redhat.com> - 3.11.5-2
  627. - Fix rhbz#230545, failure to enable FIPS mode
  628. - Fix rhbz#220542, make NSS more tolerant of resets when in the
  629. middle of prompting for a user password.
  630. * Sat Feb 24 2007 Kai Engert <kengert@redhat.com> - 3.11.5-1
  631. - Update to 3.11.5
  632. - This update fixes two security vulnerabilities with SSL 2
  633. - Do not use -rpath link option
  634. - Added several unsupported tools to tools package
  635. * Tue Jan 9 2007 Bob Relyea <rrelyea@redhat.com> - 3.11.4-4
  636. - disable ECC, cleanout dead code
  637. * Tue Nov 28 2006 Kai Engert <kengert@redhat.com> - 3.11.4-1
  638. - Update to 3.11.4
  639. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-2
  640. - Revert the attempt to require latest NSPR, as it is not yet available
  641. in the build infrastructure.
  642. * Thu Sep 14 2006 Kai Engert <kengert@redhat.com> - 3.11.3-1
  643. - Update to 3.11.3
  644. * Thu Aug 03 2006 Kai Engert <kengert@redhat.com> - 3.11.2-2
  645. - Add /etc/pki/nssdb
  646. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.11.2-1.1
  647. - rebuild
  648. * Fri Jun 30 2006 Kai Engert <kengert@redhat.com> - 3.11.2-1
  649. - Update to 3.11.2
  650. - Enable executable bit on shared libs, also fixes debug info.
  651. * Wed Jun 14 2006 Kai Engert <kengert@redhat.com> - 3.11.1-2
  652. - Enable Elliptic Curve Cryptography (ECC)
  653. * Fri May 26 2006 Kai Engert <kengert@redhat.com> - 3.11.1-1
  654. - Update to 3.11.1
  655. - Include upstream patch to limit curves
  656. * Wed Feb 15 2006 Kai Engert <kengert@redhat.com> - 3.11-4
  657. - add --noexecstack when compiling assembler on x86_64
  658. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.2
  659. - bump again for double-long bug on ppc(64)
  660. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.11-3.1
  661. - rebuilt for new gcc4.1 snapshot and glibc changes
  662. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 3.11-3
  663. - rebuild
  664. * Fri Dec 16 2005 Christopher Aillon <caillon@redhat.com> 3.11-2
  665. - Update file list for the devel packages
  666. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-1
  667. - Update to 3.11
  668. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs.2
  669. - Add patch to allow building on ppc*
  670. - Update the pkgconfig file to Require nspr
  671. * Thu Dec 15 2005 Christopher Aillon <caillon@redhat.com> 3.11-0.cvs
  672. - Initial import into Fedora Core, based on a CVS snapshot of
  673. the NSS_3_11_RTM tag
  674. - Fix up the pkcs11-devel subpackage to contain the proper headers
  675. - Build with RPM_OPT_FLAGS
  676. - No need to have rpath of /usr/lib in the pc file
  677. * Thu Dec 15 2005 Kai Engert <kengert@redhat.com>
  678. - Adressed review comments by Wan-Teh Chang, Bob Relyea,
  679. Christopher Aillon.
  680. * Sat Jul 9 2005 Rob Crittenden <rcritten@redhat.com> 3.10-1
  681. - Initial build