qtsoap-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. %define _qt4_ver 4.8.6
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  4. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. Name: qtsoap
  6. Summary: The Simple Object Access Protocol Qt-based client side library
  7. Summary(ja): Qt ベースの SOAP クライアントライブラリ
  8. Version: 2.7
  9. Release: 6%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: LGPLv2 with exceptions or GPLv3
  12. URL: http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsoap/
  13. Source0: http://get.qt.nokia.com/qt/solutions/lgpl/qtsoap-%{version}_1-opensource.tar.gz
  14. Patch0: qtsoap-2.7_1-opensource-install-pub-headers.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: qt4-devel
  17. %description
  18. The SOAP (Simple Object Access Protocol) library uses the XML standard
  19. for describing how to exchange messages. Its primary usage is to invoke web
  20. services and get responses from Qt-based applications.
  21. %package devel
  22. Summary: Development files for %{name}
  23. Summary(ja): %{name} の開発用ファイル
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. Requires: qt4-devel >= %{_qt4_version}
  27. %description devel
  28. Development files for %{name}.
  29. %prep
  30. %setup -q -n qtsoap-%{version}_1-opensource
  31. # headers are not installed for shared library
  32. %patch0 -p1 -b .install-pub-headers
  33. sed -i 's:$$DESTDIR:%{_libdir}:g' buildlib/buildlib.pro
  34. %build
  35. # we want shared library
  36. echo "SOLUTIONS_LIBRARY = yes" > config.pri
  37. echo "QTSOAP_LIBNAME = \$\$qtLibraryTarget(qtsoap)" >> common.pri
  38. echo "VERSION=%{version}" >> common.pri
  39. qmake PREFIX=%{_prefix}
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf %{buildroot}
  43. make INSTALL_ROOT=%{buildroot} install
  44. %clean
  45. rm -rf %{buildroot}
  46. %post -p /sbin/ldconfig
  47. %postun -p /sbin/ldconfig
  48. %files
  49. %defattr(-,root,root,-)
  50. %doc README.TXT LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
  51. %{_libdir}/libqtsoap.so.*
  52. %files devel
  53. %defattr(-,root,root,-)
  54. %doc LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
  55. %{_libdir}/libqtsoap.so
  56. %{_qt4_headerdir}/QtSoap/
  57. %changelog
  58. * Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7-6
  59. - rebuild with gcc-5.4.0
  60. * Mon Feb 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7-5
  61. - rebuilt on current VineSeed
  62. - added Japanese summary
  63. * Sun Jan 8 2012 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 2.7-4
  64. - rebuilt with qt-4.8.0
  65. * Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.7-3
  66. - Initial build for Vine Linux
  67. * Thu Jul 14 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-2
  68. - libqtsoap library name
  69. * Thu May 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-1
  70. - fix version
  71. * Tue Oct 26 2010 Jaroslav Reznik <jreznik@redhat.com> - 1.7-1
  72. - Initial spec file