nettle-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. Name: nettle
  2. Version: 2.4
  3. Release: 1%{?_dist_release}
  4. Summary: A low-level cryptographic library
  5. Summary(ja): 低レベル暗号化ライブラリ
  6. Group: Development/Libraries
  7. License: LGPLv2+
  8. URL: http://www.lysator.liu.se/~nisse/nettle/
  9. Source0: http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: gmp-devel
  12. BuildRequires: m4
  13. Requires(post): /sbin/install-info
  14. Requires(preun): /sbin/install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %package devel
  18. Summary: Development headers for a low-level cryptographic library
  19. Summary(ja): 低レベル暗号化ライブラリの開発ヘッダ
  20. Group: Development/Libraries
  21. Requires: %{name} = %{version}-%{release}
  22. #%package static
  23. #Summary: Static libraries for a low-level cryptographic library
  24. #Group: Development/Libraries
  25. #Requires: %{name}-devel = %{version}-%{release}
  26. %description
  27. Nettle is a cryptographic library that is designed to fit easily in more
  28. or less any context: In crypto toolkits for object-oriented languages
  29. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  30. kernel space.
  31. %description devel
  32. Nettle is a cryptographic library that is designed to fit easily in more
  33. or less any context: In crypto toolkits for object-oriented languages
  34. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  35. kernel space. This package contains kernel headers.
  36. #%description static
  37. #Nettle is a cryptographic library that is designed to fit easily in more
  38. #or less any context: In crypto toolkits for object-oriented languages
  39. #(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  40. #kernel space. This package contains a static library.
  41. %prep
  42. %setup -q
  43. %build
  44. %configure --enable-shared
  45. make %{?_smp_mflags}
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  49. make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  50. #/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
  51. #/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
  52. #/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
  53. mkdir -p $RPM_BUILD_ROOT%{_infodir}
  54. install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
  55. rm -rf %{buildroot}/%{_libdir}/*.a
  56. rm -rf %{buildroot}/%{_infodir}/dir
  57. %check
  58. make check
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %files
  62. %defattr(-,root,root,-)
  63. %doc AUTHORS ChangeLog COPYING.LIB NEWS README TODO
  64. %{_infodir}/nettle.info.gz
  65. %{_bindir}/nettle-hash
  66. %{_bindir}/nettle-lfib-stream
  67. %{_bindir}/pkcs1-conv
  68. %{_bindir}/sexp-conv
  69. %{_libdir}/libhogweed.so*
  70. %{_libdir}/libnettle.so*
  71. %files devel
  72. %defattr(-,root,root,-)
  73. %doc descore.README nettle.html nettle.pdf COPYING.LIB
  74. %{_includedir}/nettle
  75. %{_libdir}/pkgconfig/
  76. #%files static
  77. #%defattr(-,root,root,-)
  78. #%doc COPYING
  79. #%{_libdir}/libhogweed.a
  80. #%{_libdir}/libnettle.a
  81. %post
  82. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  83. /sbin/ldconfig
  84. %preun
  85. if [ $1 = 0 ]; then
  86. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
  87. fi
  88. %postun -p /sbin/ldconfig
  89. %changelog
  90. * Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
  91. - initial build for VineSeed
  92. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  94. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  96. * Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
  97. - Moved static lib to -static
  98. * Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
  99. - Added libraries and ldconfig
  100. * Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
  101. - Added provides -static to -devel
  102. * Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
  103. - Removed redundant requires
  104. - Removed redundant documentation between packages
  105. - Fixed license tag
  106. - Fixed -devel description
  107. - Added the static library back to -devel
  108. - Added make clean
  109. * Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
  110. - First package build.