gnome-print-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268
  1. # Note that this is NOT a relocatable package
  2. %define ver 0.37
  3. %define rel 2%{?_dist_release}
  4. %define name gnome-print
  5. %define sover 15
  6. Summary: Gnome Print - Printing libraries for GNOME.
  7. Summary(ja): Gnome Print - GNOME用印刷ライブラリ
  8. Name: %{name}
  9. Version: %{ver}
  10. Release: %{rel}
  11. License: LGPL
  12. Group: Applications/Publishing
  13. Source: ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{ver}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gnome-libs-devel >= 1.4.2-2vl5
  16. BuildRequires: libxml-devel
  17. BuildRequires: gdk-pixbuf-devel
  18. BuildRequires: freetype2-devel
  19. BuildRequires: automake14, autoconf213
  20. Requires: libgnomeprint%{sover} = %{version}
  21. Requires: urw-fonts ghostscript-fonts
  22. Prereq: libxml urw-fonts ghostscript-fonts
  23. Obsoletes: gnome-print-beta < 0.26, gnome-print-bin < 0.26, gnome-print-beta-bin < 0.26, gnome-print-data < 0.26
  24. # RH patches
  25. Patch2: gnome-print-0.30-nofontmaps.patch
  26. # for Vine
  27. Patch50: gnome-print-0.34-fallback.patch
  28. Patch51: gnome-print-0.35-dynamicfallback.patch
  29. Patch52: gnome-print-0.37-ft2build.patch
  30. %description
  31. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  32. applications and desktop tools to be used in conjunction with a window
  33. manager for the X Window System. GNOME is similar in purpose and scope
  34. to CDE and KDE, but GNOME is based completely on free software.
  35. The gnome-print package contains libraries and fonts that are needed by
  36. GNOME applications wanting to print.
  37. You should install the gnome-print package if you intend on using any of
  38. the GNOME applications that can print. If you would like to develop GNOME
  39. applications that can print you will also need to install the gnome-print
  40. devel package.
  41. %description -l ja
  42. 印刷できるGNOMEアプリケーションを使いたいなら、gnome-printパッケージを
  43. インストールする必要があります。もし印刷できるGNOMEアプリケーションを
  44. 開発したいなら、gnome-print-develパッケージをインストールする必要が
  45. あります。
  46. %package -n libgnomeprint%{sover}
  47. Summary: Printing libraries for GNOME
  48. Summary(ja): GNOME用印刷ライブラリ
  49. Group: System Environment/Libraries
  50. Obsoletes: gnome-print-beta < 0.26
  51. %description -n libgnomeprint%{sover}
  52. This package contains the printing apparatus for GNOME, the complete
  53. graphical desktop environment based entirely on free software.
  54. %package devel
  55. Summary: Libraries and include files for developing GNOME applications.
  56. Summary(ja): GNOME用印刷アプリケーション開発用ライブラリとヘッダファイル
  57. Group: Development/Libraries
  58. Obsoletes: gnome-print-beta-devel < 0.26
  59. Requires: %{name} = %{version}
  60. Requires: libgnomeprint%{sover} = %{version}
  61. Requires: gdk-pixbuf-devel
  62. %description devel
  63. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  64. applications and desktop tools to be used in conjunction with a window
  65. manager for the X Window System. GNOME is similar in purpose and scope
  66. to CDE and KDE, but GNOME is based completely on free software.
  67. The gnome-print-devel package includes the libraries and include files that
  68. you will need when developing applications that use the GNOME printing
  69. facilities.
  70. You should install the gnome-print-devel package if you would like to
  71. develop GNOME applications that will use the GNOME printing facilities.
  72. You don't need to install the gnome-print-devel package if you just want
  73. to use the GNOME desktop enviornment.
  74. #'
  75. %prep
  76. %setup -q
  77. %patch2 -p1 -b .nofontmaps
  78. %patch50 -p1 -b .fallback
  79. %patch51 -p1 -b .dynamic
  80. %patch52 -p1 -b .ft2build
  81. %build
  82. libtoolize --copy --force
  83. autoheader-2.13
  84. automake-1.4
  85. autoconf-2.13
  86. %configure --disable-static
  87. make LIBTOOL=/usr/bin/libtool
  88. %install
  89. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  90. %makeinstall LIBTOOL=/usr/bin/libtool
  91. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
  92. ./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gnome/fonts
  93. install -c fonts/*.font $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
  94. cat > $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install <<__EOF__
  95. #! /bin/sh
  96. %{_bindir}/gnome-font-install --clean \
  97. --aliases=%{_datadir}/gnome-print/fonts/adobe-urw.font \
  98. --target=%{_sysconfdir}/gnome/fonts/gnome-print-rpm.fontmap \
  99. --recursive \
  100. %{_prefix}/X11R6/lib/X11/fonts \
  101. %{_datadir}/fonts
  102. __EOF__
  103. chmod a+x $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install
  104. %find_lang %{name}
  105. ## remove unuse files
  106. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  107. %clean
  108. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  109. %post -p %{_bindir}/vine-update-gnome-font-install
  110. %post -n libgnomeprint%{sover} -p /sbin/ldconfig
  111. %postun -n libgnomeprint%{sover} -p /sbin/ldconfig
  112. %files -f %{name}.lang
  113. %defattr(-, root, root)
  114. %doc AUTHORS COPYING ChangeLog NEWS README
  115. %dir %{_datadir}/gnome-print
  116. %dir %{_datadir}/gnome-print/profiles
  117. %dir %{_sysconfdir}/gnome/fonts
  118. %{_datadir}/gnome-print/profiles/*
  119. %{_bindir}/*
  120. %{_datadir}/fonts/afms/adobe/*
  121. %{_datadir}/gnome-print/fonts
  122. %files -n libgnomeprint%{sover}
  123. %defattr(-, root, root)
  124. %{_libdir}/*.so.%{sover}.*
  125. %{_libdir}/*.so.%{sover}
  126. %files devel
  127. %defattr(-, root, root)
  128. %{_libdir}/*.so
  129. #{_libdir}/*.a
  130. #{_libdir}/*.la
  131. %{_libdir}/*.sh
  132. %{_includedir}/*
  133. %changelog
  134. * Sat May 2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-2
  135. - rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6.21)
  136. - removed *.a
  137. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.37-1vl5
  138. - applied new versioning policy, spec in utf-8
  139. - removed *.la
  140. * Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl2
  141. - rebuilt with db4-4.3.29
  142. * Mon Oct 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl1
  143. - updated to 0.37
  144. - rebuilt with db4-4.2.52
  145. - added Patch52 to build with freetype2
  146. - s/Copyright/License/
  147. - fixed %post, %postun section
  148. * Fri Jan 17 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.35-0vl2
  149. - rebuilt with db4 environment
  150. - added BuildPreReq: automake14, autoconf213
  151. * Wed Mar 20 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.35-0vl1
  152. - New upstream release.
  153. - vine-update-gnome-font-install: added a wrapper script for generating
  154. gnome-print's fontmap. it will helps us if font packages will calls it
  155. with %%post and %%postun.
  156. - %%post: changed calling vine-update-gnome-font-install.
  157. - gnome-print-0.35-dynamicfallback.patch:
  158. generate hash using NAMES file.
  159. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl3
  160. - Fixed fontmap generation.
  161. Note: don't remove --clean option. when gnome-font-install regenerate
  162. fontmap, it don't add the fonts which already exists.
  163. * Wed Dec 26 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.34-0vl2
  164. - added PreReq: freetype2 for gnome-font-install invoked from %%post section
  165. - commented out Requires: %%{name} >= %%{ver} from libgnomeprint15
  166. * Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl1
  167. - New upstream release.
  168. * Sun Apr 1 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl3
  169. - Added Obsolates to libgnomeprint11.
  170. - Added some build requires.
  171. * Mon Mar 12 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl2
  172. - New upstream release.
  173. * Tue Jan 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl6
  174. - Fixed -devel conflicts.
  175. * Tue Jan 9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl5
  176. - Added Conflicts: line in -devel.
  177. * Wed Dec 27 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl4
  178. - separated binary and data packages.
  179. * Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
  180. - added prereq urw-fonts
  181. * Wed May 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  182. - modified jahack pach to fix threshold value of MB_CUR_MAX for glibc 2.1.3.
  183. * Mon May 30 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  184. - updated to 0.20
  185. * Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  186. - modified jahack patch for satbility of memory allocation.
  187. - modified jahack patch to fix text alignment.
  188. * Sat May 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  189. - modified jahack patch for preview.
  190. - added i18n_fix for nls.
  191. - added orignal ja.po.
  192. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  193. - updated to 0.19
  194. * Mon May 1 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  195. - updated to 0.18
  196. * Wed Feb 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  197. - updated to 0.12
  198. * Mon Jan 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  199. - added "quick hacked" ja patch.
  200. * Tue Nov 23 1999 Norihito Ohmori <ohmori@flatotu.org>
  201. - add Provides: libgnomeprint.so.2
  202. * Sat Oct 13 1999 Kazuhito Nishi <nishi@imasy.or.jp>
  203. - Added Prereq: zlib
  204. * Sun Aug 01 1999 Gregory McLean <gregm@comstar.net>
  205. - Undo my draconian uninstall stuff.
  206. * Tue Jul 20 1999 Gregory McLean <gregm@comstar.net>
  207. - Stab at cleaning up properly when we uninstall.
  208. * Fri Jul 16 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  209. - fixed typo in spec
  210. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  211. - Added fonts to the spec.
  212. * Mon Jul 05 1999 Gregory McLean <gregm@comstar.net>
  213. - Fleshed out the descriptions.