libindi-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. %define majorver 0
  2. Name: libindi
  3. Summary: Instrument Neutral Distributed Interface
  4. Version: 0.8
  5. Release: 3%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+ and GPLv2+
  8. # The code is LGPLv2+ except:
  9. # some files for v4l2 conversion under libs/webcam are GPLv2+
  10. # drivers/video/stvdriver (indi_stv driver) appears to contain GPL code
  11. # upstream bug https://sourceforge.net/tracker2/?func=detail&aid=2572902&group_id=90275&atid=593019
  12. URL: http://indi.sourceforge.net/
  13. Source0: http://downloads.sourceforge.net/indi/%{name}_%{version}.tar.gz
  14. Patch0: libindi-suffix.patch
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: cmake
  17. BuildRequires: cfitsio-devel >= 3.03
  18. BuildRequires: libboost-devel
  19. BuildRequires: libnova-devel >= 0.12.1
  20. BuildRequires: libusb-devel
  21. BuildRequires: zlib-devel
  22. Conflicts: kdeedu3
  23. %description
  24. INDI is a distributed control protocol designed to operate
  25. astronomical instrumentation. INDI is small, flexible, easy to parse,
  26. and scalable. It supports common DCS functions such as remote control,
  27. data acquisition, monitoring, and a lot more.
  28. %package devel
  29. Summary: Libraries, includes, etc. used to develop an application with %{name}
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. Provides: libindi-static = %{version}-%{release}
  33. %description devel
  34. These are the header files needed to develop a %{name} application
  35. %prep
  36. %setup -q -n %{name}-%{version}
  37. %patch0 -p1
  38. #patch1 -p1
  39. %build
  40. mkdir -p %{_target_platform}
  41. pushd %{_target_platform}
  42. CFLAGS="${CFLAGS:-%optflags}" \
  43. CXXFLAGS="${CXXFLAGS:-%optflags}" \
  44. FFLAGS="${FFLAGS:-%optflags}" \
  45. %cmake \
  46. -DCMAKE_BUILD_TYPE=release \
  47. -DDATA_INSTALL_DIR:PATH=%{_datadir} \
  48. ..
  49. popd
  50. make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
  51. %install
  52. rm -fr %{buildroot}
  53. make install DESTDIR=%{buildroot} -C %{_target_platform}
  54. %clean
  55. rm -fr %{buildroot}
  56. %post -p /sbin/ldconfig
  57. %postun -p /sbin/ldconfig
  58. %files
  59. %defattr(-,root,root,-)
  60. %doc AUTHORS ChangeLog COPYING.LIB LICENSE README README.drivers
  61. %{_bindir}/*
  62. %{_libdir}/*.so.*
  63. %{_datadir}/indi
  64. %files devel
  65. %defattr(-,root,root,-)
  66. %doc README COPYING.LIB LICENSE
  67. %{_includedir}/*
  68. %{_libdir}/*.so
  69. %{_libdir}/*.a
  70. %{_libdir}/pkgconfig/*.pc
  71. %changelog
  72. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.0-3
  73. - rebuild with gcc-5.4.0
  74. * Wed Feb 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.8.0-2
  75. - rebuilt with cfitsio 3.370 and libnova 0.15.0
  76. * Sun Aug 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.8.0-1
  77. - new upstream release
  78. - updated Patch0
  79. - built with libnova-0.14
  80. * Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.3-1
  81. - rebuilt with rpm-4.8.1 for pkg-config
  82. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.2-1
  83. - new upstream release
  84. - updated Patch0
  85. * Wed Jul 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-12
  86. - added Conflicts: kdeedu3
  87. * Sat Apr 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-11
  88. - rebuilt with new toolchain and libnova-0.13
  89. * Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.6-10
  90. - use %%cmake macro
  91. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-9
  92. - Inisital build for Vine Linux
  93. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  95. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  97. * Wed Feb 18 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-6
  98. - Provides libindi-static
  99. * Tue Feb 17 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-5
  100. - Need to provide the static library libindidriver.a to build indi-apogee
  101. * Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-4
  102. - Fixed patch to find cfitsio
  103. * Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-3
  104. - Patch to detect cfitsio in all architectures
  105. * Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-2
  106. - Commands (rm, make) instead of macros
  107. - Upstream bug about licenses (GPLv2 missing)
  108. - Upstream bug about libindi calling exit
  109. * Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-1
  110. - First version