mplayer-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438
  1. %define with_vaapi 1
  2. %define with_libvpx 1
  3. %define name mplayer
  4. %define version 1.0
  5. %define extver rc3
  6. #% define release 4%{?extver:.%{extver}}%{?_dist_release}
  7. %define svndate 20100709
  8. %define release 39.%{svndate}%{?_dist_release}
  9. %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
  10. %define ttfontdir /usr/share/fonts
  11. %define ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  12. TrueType-sazanami-gothic/sazanami-gothic
  13. %endif
  14. Summary: The Movie Player
  15. Summary(ja): 動画プレイヤー
  16. Name: %{name}
  17. Version: %{version}
  18. Release: %{release}
  19. #Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  20. Source0: mplayer-export-%{svndate}.tar.bz2
  21. Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
  22. Source10: mplayer-snapshot-vine.sh
  23. #Patch2: %{name}-config.patch
  24. Patch2: %{name}-config-20100709-vine.patch
  25. Patch8: %{name}-manlinks.patch
  26. Patch14: %{name}-nodvdcss.patch
  27. ## Vine
  28. Patch50: mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  29. License: GPLv2+
  30. Group: Applications/Multimedia
  31. URL: http://www.mplayerhq.hu/
  32. BuildRequires: gtk2-devel
  33. BuildRequires: freetype2-devel
  34. BuildRequires: SDL-devel
  35. BuildRequires: alsa-lib-devel
  36. BuildRequires: esound-devel
  37. BuildRequires: cdparanoia-devel
  38. BuildRequires: libvorbis-devel
  39. BuildRequires: pulseaudio-lib-devel
  40. BuildRequires: libjpeg-devel
  41. BuildRequires: libpng-devel
  42. BuildRequires: giflib-devel
  43. BuildRequires: zlib-devel
  44. BuildRequires: libdvdread
  45. BuildRequires: libmpcdec-devel
  46. BuildRequires: twolame-devel
  47. BuildRequires: yasm
  48. BuildRequires: libvdpau-devel
  49. %{?with_vaapi:BuildRequires:libva-devel}
  50. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.1}
  51. BuildRequires: libXinerama-devel
  52. BuildRequires: libXScrnSaver-devel
  53. # *-devel packages provided by other self-build-* should only be listed
  54. # in self-build-%{name}.spec as PreReq.
  55. ##Requires: self-build-mplayer-codecs
  56. ##BuildRequires: self-build-libdvdcss
  57. ##BuildRequires: self-build-libdvdnav
  58. ##BuildRequires: self-build-faac
  59. ##BuildRequires: self-build-lame
  60. ##BuildRequires: self-build-libdca
  61. ##BuildRequires: self-build-x264 >= 0.0.0-4.20090110
  62. ##BuildRequires: self-build-xvidcore >= 0.9.2
  63. ##BuildRequires: self-build-faad2 >= 2.6
  64. ##BuildRequires: self-build-libmad
  65. ##BuildRequires: self-build-libmpeg2
  66. Requires: TrueType-vlgothic
  67. %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
  68. Requires: mesa-libGL
  69. BuildRequires: xorg-x11-devel
  70. BuildRequires: mesa-libGL-devel
  71. %endif
  72. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  73. %description
  74. MPlayer can play most standard video formats out of the box and almost
  75. all others with the help of external codecs.
  76. MPlayer currently works best from the command line, but visual feedback
  77. for many functions is available from its onscreen status display (OSD),
  78. which is also used for displaying subtitles.
  79. MPlayer also has a GUI with skin support and several unofficial alternative
  80. graphical frontends are available.
  81. MEncoder is a command line video encoder for advanced users that can
  82. be built from the MPlayer source tree. Unofficial graphical frontends
  83. exist but arenot included.
  84. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  85. support for some newer codecs are not yet inpmlemented.
  86. You should install mplayer-codecs package if you want to play videos
  87. using those new codecs.
  88. %description -l ja
  89. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  90. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用することで再生できます。
  91. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  92. 多くの操作は字幕と同様に、
  93. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  94. MPlayer には スキンを変更できる GUI も用意されていますし、
  95. また複数の非公式なフロントエンドも利用できます。
  96. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  97. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  98. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  99. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  100. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  101. をインストールする必要があります。
  102. %prep
  103. #% setup -q -n MPlayer-%{version}%{extver}
  104. %setup -q -n mplayer-export-%{svndate}
  105. %patch2 -p1 -b .config
  106. %patch8 -p1 -b .manlinks
  107. %patch14 -p1 -b .nodvdcss
  108. %patch50 -p1 -b .x11
  109. %build
  110. ./configure \
  111. --prefix=%{_prefix} \
  112. --confdir=%{_sysconfdir}/mplayer \
  113. --enable-runtime-cpudetection \
  114. --extra-cflags="$RPM_OPT_FLAGS" \
  115. --disable-libdvdcss-internal \
  116. --disable-dvdread-internal \
  117. --enable-dvdread \
  118. --enable-dvdnav \
  119. \
  120. --disable-faac-lavc \
  121. --disable-mp3lame-lavc \
  122. --disable-x264-lavc \
  123. \
  124. --disable-faad-internal \
  125. \
  126. --disable-libopenjpeg \
  127. \
  128. --disable-bitmap-font \
  129. --disable-termcap \
  130. --enable-xvmc \
  131. --with-xvmclib=XvMCW \
  132. \
  133. --enable-largefiles \
  134. --enable-menu \
  135. --enable-gui \
  136. --language=ja,en \
  137. ;
  138. %{__make} %{?_smp_mflags}
  139. %install
  140. %{__rm} -rf ${RPM_BUILD_ROOT}
  141. %{__make} install INSTALLSTRIP= \
  142. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  143. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  144. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  145. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  146. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  147. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  148. ;
  149. ## install some default config files
  150. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  151. %{__install} -pm 644 etc/example.conf \
  152. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  153. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  154. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  155. # install default skin
  156. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  157. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  158. %{__tar} xjf %{SOURCE1}
  159. %{__ln_s} Blue default
  160. popd
  161. # make sybolic link to ttf font for subtitle
  162. for i in %{ttfontlist}; do
  163. if [ -e %{ttfontdir}/$i.ttf ];then
  164. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  165. break;
  166. fi;
  167. done
  168. ## install TOOLS
  169. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  170. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  171. done
  172. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  173. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  174. done
  175. for file in vobshift.py ; do
  176. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  177. done
  178. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  179. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  180. %clean
  181. %{__rm} -rf ${RPM_BUILD_ROOT}
  182. %files
  183. %defattr(-,root,root)
  184. %doc AUTHORS Changelog Copyright LICENSE README
  185. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  186. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  187. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  188. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  189. %{_bindir}/mplayer
  190. %{_bindir}/gmplayer
  191. %{_bindir}/mencoder
  192. %{_datadir}/mplayer/skins/Blue
  193. %{_datadir}/mplayer/skins/default
  194. %{_datadir}/mplayer/subfont.ttf
  195. %{_datadir}/applications/mplayer.desktop
  196. %{_datadir}/pixmaps/mplayer.xpm
  197. %{_mandir}/man1/mplayer.1*
  198. %{_mandir}/man1/mencoder.1*
  199. ## TOOLS
  200. %{_bindir}/aconvert
  201. %{_bindir}/calcbpp
  202. %{_bindir}/countquant
  203. %{_bindir}/divx2svcd
  204. %{_bindir}/dvd2divxscript
  205. %{_bindir}/mencvcd
  206. %{_bindir}/midentify
  207. %{_bindir}/mpconsole
  208. %{_bindir}/qepdvcd
  209. %{_bindir}/subsearch
  210. %{_bindir}/vobshift
  211. %{_datadir}/mplayer/*.fp
  212. %changelog
  213. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  214. - updated fixed %{name}-config.patch
  215. - applied %{name}-config-20100709-vine.patch
  216. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  217. - change release to sync with self-build-mplayer
  218. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  219. - updated source snapshot 20100709
  220. - renamed %%Source10 to mplayer-snapshot-vine.sh
  221. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  222. - added BuildRequires: libvpx-devel >= 0.9.1
  223. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  224. - updated source snapshot 20100621
  225. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  226. - updated source snapshot 20100615
  227. - added BuildRequires: libXinerama-devel
  228. - dropped vl4 support
  229. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  230. - updated source snapshot 20100410
  231. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  232. - updated source snapshot 20100401
  233. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  234. - updated source snapshot 20100326
  235. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  236. - updated source snapshot 20100317
  237. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  238. - updated source snapshot 20100216
  239. - moved scripts from TOOLS
  240. - added --disable-libopenjpeg in configure options
  241. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  242. - updated source snapshot 20100201
  243. - dropped obsolete patches
  244. - added BuildRequires:
  245. - libvdpau-devel
  246. - libXScrnSaver-devel
  247. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  248. - update mplayer-config-20091215-vine.patch
  249. - update mplayer-20091215-x86_32-compile.patch
  250. - added --enable-runtime-cpudetection in configure options
  251. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  252. - source snapshot 20091031
  253. - updated mplayer-20091031-x86_32-compile.patch
  254. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  255. - source snapshot 20091003
  256. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  257. - change release to sync with self-build-mplayer
  258. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  259. - source snapshot 20090905
  260. - added settings for vl6
  261. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  262. - source snapshot 20090821
  263. - replaced BR: libungif-devel with BR: giflib-devel
  264. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  265. - source snapshot 20090722
  266. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  267. - source snapshot 20090702
  268. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  269. - source snapshot 20090611
  270. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  271. - added Requires: TrueType-vlgothic
  272. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  273. - source snapshot 20090522
  274. - build with x264 >= 0.0.0-9.20090522
  275. - updated mplayer-20090522-nodvdcss.patch
  276. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  277. - change release to sync with self-build-mplayer
  278. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  279. - source snapshot 20090502
  280. - updated mplayer-20090503-x86_32-compile.patch
  281. - updated mplayer-20090502-nodvdcss.patch
  282. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  283. - applied mplayer-config-vine.patch
  284. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  285. - source snapshot 20090327
  286. - updated mplayer-20090327-x86_32-compile.patch
  287. - updated mplayer-20090325-nodvdcss.patch
  288. - dropped gmplayer-about-vine.patch
  289. - install some default config files
  290. - added configure options:
  291. - --disable-termcap
  292. - --enable-xvmc
  293. - --with-xvmclib=XvMCW
  294. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  295. - fixed %%files for *.conf
  296. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  297. - source snapshot 20090305
  298. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  299. - source snapshot 20090227
  300. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  301. - source snapshot 20090216
  302. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  303. - source snapshot 20090206
  304. - dropped mplayer-man-zh_CN.patch
  305. - updated mplayer-20090206-nodvdcss.patch
  306. - changed to PreReq: self-build-faad2 from faad2-devel
  307. - added PreReq: self-build-libmad
  308. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  309. - source snapshot 20090131
  310. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  311. - change release to sync with self-build-mplayer
  312. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  313. - source snapshot
  314. - update mplayer-20090122-nodvdcss.patch
  315. - added BuildRequires:
  316. - faad2-devel
  317. - libmpcdec-devel
  318. - twolame-devel
  319. - yasm
  320. - faac-devel (as PreReq in self-build-%{name})
  321. - lame-devel (as PreReq in self-build-%{name})
  322. - libdca-devel (as PreReq in self-build-%{name})
  323. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  324. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  325. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  326. - source snapshot
  327. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  328. --disable-faad-internal in configure options
  329. - dropped gmplayer-add-flv-extension.patch
  330. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  331. - source snapshot
  332. - fixed License
  333. - added some patches from RPM Fusion
  334. - updated gmplayer-about-vine.patch for 20081001 snapshot
  335. - added BuildRequires: libdvdread
  336. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  337. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  338. in configure options
  339. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  340. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  341. - fixed License
  342. - added some devel packages to support OpenGL
  343. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  344. - spec in utf8
  345. - fix sybolic link of subfont for vl5
  346. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  347. - add "Patch105: CVE-2008-1558.patch".
  348. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  349. - build with new versioning policy.
  350. - fix Source[01] URLs.
  351. - add "Patch200: gmplayer-about-vine.patch".
  352. - add "Patch201: gmplayer-add-flv-extension.patch".
  353. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  354. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  355. CVE-2008-0629, CVE-2008-0630)
  356. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  357. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  358. - change source download URL. <BTS:VineLinux:603>
  359. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  360. - fix CONFDIR for make install. <BTS:wishes:33>
  361. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  362. - initial build for Vine Linux