pcre-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: pcre
  3. Version: 8.39
  4. Release: 2%{?_dist_release}
  5. Summary: Perl-compatible regular expression library
  6. Summary(ja): Perl 互換の正規表現ライブラリ
  7. Group: System Environment/Libraries
  8. License: BSD
  9. URL: http://www.pcre.org/
  10. Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
  11. # Upstream thinks RPATH is good idea.
  12. Patch0: pcre-8.21-multilib.patch
  13. # Refused by upstream, bug #675477
  14. Patch1: pcre-8.32-refused_spelling_terminated.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: zlib-devel
  17. BuildRequires: bzip2-devel
  18. BuildRequires: libedit-devel
  19. # New libtool to get rid of rpath
  20. BuildRequires: autoconf, automake, libtool
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: inagaki
  24. %description
  25. Perl-compatible regular expression library.
  26. PCRE has its own native API, but a set of "wrapper" functions that are based on
  27. the POSIX API are also supplied in the library libpcreposix. Note that this
  28. just provides a POSIX calling interface to PCRE: the regular expressions
  29. themselves still follow Perl syntax and semantics. The header file
  30. for the POSIX-style functions is called pcreposix.h.
  31. %package devel
  32. Summary: Development files for %{name}
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. Development files (Headers, libraries for static linking, etc) for %{name}.
  38. %package -n compat32-%{name}
  39. Summary: Perl-compatible regular expression library
  40. Summary(ja): Perl 互換の正規表現ライブラリ
  41. Group: System Environment/Libraries
  42. %description -n compat32-%{name}
  43. Perl-compatible regular expression library.
  44. PCRE has its own native API, but a set of "wrapper" functions that are based on
  45. the POSIX API are also supplied in the library libpcreposix. Note that this
  46. just provides a POSIX calling interface to PCRE: the regular expressions
  47. themselves still follow Perl syntax and semantics. The header file
  48. for the POSIX-style functions is called pcreposix.h.
  49. %package -n compat32-%{name}-devel
  50. Summary: Development files for %{name}
  51. Summary(ja): %{name} の開発用ファイル
  52. Group: Development/Libraries
  53. Requires: compat32-%{name} = %{version}-%{release}
  54. %description -n compat32-%{name}-devel
  55. Development files (Headers, libraries for static linking, etc) for %{name}.
  56. %prep
  57. %setup -q
  58. # Get rid of rpath
  59. %patch0 -p1 -b .multilib
  60. %patch1 -p1 -b .terminated_typos
  61. # Because of rpath patch
  62. libtoolize --copy --force && autoreconf -vif
  63. # One contributor's name is non-UTF-8
  64. for F in ChangeLog; do
  65. iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
  66. touch --reference "$F" "${F}.utf8"
  67. mv "${F}.utf8" "$F"
  68. done
  69. %build
  70. %configure \
  71. --enable-jit \
  72. --disable-static \
  73. --enable-utf8 \
  74. --enable-unicode-properties \
  75. --enable-pcregrep-libz \
  76. --enable-pcregrep-libbz2 \
  77. --enable-pcretest-libedit \
  78. --enable-pcre8 \
  79. --enable-pcre16 \
  80. --enable-pcre32
  81. make %{?_smp_mflags}
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. make install DESTDIR=$RPM_BUILD_ROOT
  85. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  87. %check
  88. %ifarch s390 s390x ppc
  89. # larger stack is needed on s390, ppc
  90. ulimit -s 10240
  91. %endif
  92. make %{?_smp_mflags} check VERBOSE=yes
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post -p /sbin/ldconfig
  96. %postun -p /sbin/ldconfig
  97. %post -n compat32-%{name} -p /sbin/ldconfig
  98. %postun -n compat32-%{name} -p /sbin/ldconfig
  99. %files
  100. %defattr(-,root,root)
  101. %doc AUTHORS COPYING ChangeLog LICENCE NEWS README
  102. %{_bindir}/pcregrep
  103. %{_libdir}/*.so.*
  104. %{_mandir}/man1/pcregrep.*
  105. %files devel
  106. %defattr(-,root,root)
  107. %doc doc/html/*
  108. %{_bindir}/pcre-config
  109. %{_bindir}/pcretest
  110. %{_includedir}/*
  111. %{_libdir}/*.so
  112. %{_libdir}/pkgconfig/*.pc
  113. %{_mandir}/man1/pcre-config.*
  114. %{_mandir}/man1/pcretest.*
  115. %{_mandir}/man3/*
  116. %if %{build_compat32}
  117. %files -n compat32-%{name}
  118. %defattr(-, root, root)
  119. %{_libdir}/*.so.*
  120. %files -n compat32-%{name}-devel
  121. %defattr(-, root, root)
  122. %{_libdir}/*.so
  123. %endif
  124. %changelog
  125. * Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
  126. - create comapt32 packages
  127. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
  128. - new upstream release.
  129. - dropped Patch1000,1001: fixed in upstream.
  130. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
  131. - new upstream release.
  132. - removed Patch2,Patch3 (no longer needed).
  133. - added Patch1000 to fix CVE-2016-1283.
  134. * Sun Apr 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
  135. - new upstream release
  136. - added patches including security fix from Fedora (CVE-2014-8964)
  137. * Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
  138. - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
  139. (bug #1165626)
  140. * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
  141. - Reset non-matched groups within capturing group up to forced match
  142. (bug #1161587)
  143. * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
  144. - Fix typos in manual pages (bugs #675476, #675477)
  145. * Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
  146. - new upstream release
  147. - add --enable-pcre32 and --enable-pcretest-libedit
  148. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
  149. - new upstream release
  150. - add --enable-pcre16 --enable-pcre8 --enable-jit
  151. - API change
  152. - change includedir to /usr/include
  153. * Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
  154. - new upstream release
  155. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
  156. - new upstream release
  157. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
  158. - rebuilt with rpm-4.8.1 for pkg-config
  159. * Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
  160. - new upstream release
  161. * Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
  162. - new upstream release with security fix
  163. * Sat Feb 6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
  164. - new upstream release
  165. * Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
  166. - new upstream release
  167. * Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
  168. - add --enable-unicode-properties to configure option
  169. * Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
  170. - new upstream release
  171. - added BR: zlib-devel, bzip2-devel
  172. - removed static libraries from devel package
  173. - added Packager tag
  174. * Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
  175. - new upstream release
  176. - spec in UTF-8
  177. * Sun Jul 6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
  178. - new upstream release
  179. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  180. - use macro for Release
  181. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
  182. - apply new virsioning policy.
  183. - remove *.la
  184. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
  185. - new upstream release
  186. * Wed Nov 7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
  187. - new upstream release
  188. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
  189. - new upstream release
  190. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
  191. - rebuild with new environment/toolchain
  192. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  193. - new upstream release
  194. * Mon Sep 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
  195. - added --enable-utf8 option
  196. * Sun Sep 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
  197. - new upstream release
  198. * Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
  199. - new upstream release
  200. - added Japanese summary
  201. * Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
  202. - new upstream release
  203. * Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
  204. - new upstream release
  205. * Mon May 5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
  206. - skip 'make check' on alpha
  207. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
  208. - change install section
  209. - change files section
  210. * Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
  211. - update to 4.1
  212. - add %{_bindir}/pcretest
  213. - add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
  214. * Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
  215. - rebuild with new toolchains
  216. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
  217. - Update to 3.9
  218. * Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
  219. - Update to 3.7
  220. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
  221. - Update to 3.5
  222. * Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
  223. - Build for VineSeed
  224. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
  225. - Move libpcre to /lib, grep uses it these days (#41104)
  226. * Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  227. - Move this to a separate package, used to be in kdesupport, but it's
  228. generally useful...