nginx-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. %define nginx_user nginx
  4. %define nginx_group %{nginx_user}
  5. %define nginx_home %{_localstatedir}/lib/nginx
  6. %define nginx_home_tmp %{nginx_home}/tmp
  7. %define nginx_home_cache %{nginx_home}/cache
  8. %define nginx_logdir %{_localstatedir}/log/nginx
  9. %define nginx_confdir %{_sysconfdir}/nginx
  10. %define nginx_datadir %{_datadir}/nginx
  11. %define nginx_webroot %{nginx_datadir}/html
  12. Summary: Robust, small and high performance http and reverse proxy server
  13. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  14. Name: nginx
  15. Version: 1.0.2
  16. Release: 2%{?_dist_release}
  17. Group: System Environment/Daemons
  18. # BSD License (two clause)
  19. # http://www.freebsd.org/copyright/freebsd-license.html
  20. License: BSD
  21. URL: http://nginx.net/
  22. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  23. Source1: %{name}.init
  24. Source2: %{name}.logrotate
  25. Source3: nginx-virtual.conf.template
  26. Source4: nginx-ssl.conf
  27. Source5: %{name}.sysconfig
  28. Source10: nginx-vine.conf
  29. Source11: nginx-default-vine
  30. Source20: proxy_cache.conf
  31. Source100: nginx-index.html
  32. Source101: poweredby-vine.png
  33. Source102: nginx-logo.png
  34. Source103: nginx-50x.html
  35. Source104: nginx-404.html
  36. %define ngx_fancyindex_version 0.3
  37. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  38. %define nginx_accept_language_module_version 02262ce
  39. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  40. %define mod_wsgi_version 6975f0ec7eeb
  41. Source1020: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  42. %define passenger_version 3.0.5
  43. Source1030: passenger-%{passenger_version}.tar.gz
  44. # removes -Werror in upstream build scripts. -Werror conflicts with
  45. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  46. Patch0: nginx-auto-cc-gcc.patch
  47. # configuration patch to match all the Vine Linux paths for logs, pid files
  48. # etc.
  49. Patch1: nginx-conf.patch
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  51. BuildRequires: pcre-devel
  52. BuildRequires: zlib-devel
  53. BuildRequires: openssl-devel
  54. BuildRequires: gd-devel
  55. BuildRequires: perl
  56. BuildRequires: perl(ExtUtils::Embed)
  57. BuildRequires: libxml2-devel
  58. BuildRequires: libxslt-devel
  59. %if "%{?_dist_release}" == "vl4"
  60. Requires: perl >= 5.8.6
  61. %else
  62. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  63. %endif
  64. # for /usr/sbin/useradd
  65. Requires(pre): shadow-utils
  66. Requires(post): chkconfig
  67. # for /sbin/service
  68. Requires(preun): chkconfig, initscripts
  69. Requires(postun): initscripts
  70. Provides: webserver
  71. Vendor: Project Vine
  72. Distribution: Vine Linux
  73. Packager: daisuke
  74. %description
  75. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  76. proxy server written by Igor Sysoev.
  77. %description -l ja
  78. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  79. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  80. - HTTP(S) サーバ
  81. - HTTP(S) リバースプロキシサーバ
  82. - IMAP/POP3 プロキシサーバ
  83. %package passenger
  84. Summary: Nginx with mod_passenger support
  85. Summary(ja): Passenger サポート入りの Nginx
  86. Group: System Environment/Daemons
  87. BuildRequires: ruby, rubygems, rubygem-rake
  88. Requires: nginx
  89. %description passenger
  90. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  91. This package contains nginx server with passenger support.
  92. %description -l ja passenger
  93. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  94. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  95. - HTTP(S) サーバ
  96. - HTTP(S) リバースプロキシサーバ
  97. - IMAP/POP3 プロキシサーバ
  98. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  99. %prep
  100. %setup -q -a 1000 -a 1010 -a 1030 %{?with_wsgi:-a 1020}
  101. %patch0 -p0
  102. %patch1 -p1
  103. %build
  104. # nginx does not utilize a standard configure script. It has its own
  105. # and the standard configure options cause the nginx configure script
  106. # to error out. This is is also the reason for the DESTDIR environment
  107. # variable. The configure script(s) have been patched (Patch1 and
  108. # Patch2) in order to support installing into a build environment.
  109. export DESTDIR=%{buildroot}
  110. ## build with passenger
  111. ./configure \
  112. --user=%{nginx_user} \
  113. --group=%{nginx_group} \
  114. --prefix=%{nginx_datadir} \
  115. --sbin-path=%{_sbindir}/%{name} \
  116. --conf-path=%{nginx_confdir}/%{name}.conf \
  117. --error-log-path=%{nginx_logdir}/error.log \
  118. --http-log-path=%{nginx_logdir}/access.log \
  119. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  120. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  121. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  122. --pid-path=%{_localstatedir}/run/%{name}.pid \
  123. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  124. --with-file-aio \
  125. --with-ipv6 \
  126. --with-http_ssl_module \
  127. --with-http_realip_module \
  128. --with-http_addition_module \
  129. --with-http_xslt_module \
  130. --with-http_image_filter_module \
  131. --with-http_sub_module \
  132. --with-http_dav_module \
  133. --with-http_flv_module \
  134. --with-http_gzip_static_module \
  135. --with-http_random_index_module \
  136. --with-http_secure_link_module \
  137. --with-http_stub_status_module \
  138. --with-http_perl_module \
  139. --with-mail \
  140. --with-mail_ssl_module \
  141. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  142. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  143. %if %{with wsgi}
  144. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  145. %endif
  146. --add-module=passenger-%{passenger_version}/ext/nginx \
  147. %ifarch i686
  148. --with-cpu-opt=pentiumpro \
  149. --with-zlib-asm=pentiumpro \
  150. --with-md5-asm \
  151. --with-sha1-asm \
  152. %endif
  153. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  154. make %{?_smp_mflags}
  155. mv objs/nginx objs/nginx.passenger
  156. ## build without passenger
  157. ./configure \
  158. --user=%{nginx_user} \
  159. --group=%{nginx_group} \
  160. --prefix=%{nginx_datadir} \
  161. --sbin-path=%{_sbindir}/%{name} \
  162. --conf-path=%{nginx_confdir}/%{name}.conf \
  163. --error-log-path=%{nginx_logdir}/error.log \
  164. --http-log-path=%{nginx_logdir}/access.log \
  165. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  166. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  167. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  168. --pid-path=%{_localstatedir}/run/%{name}.pid \
  169. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  170. --with-file-aio \
  171. --with-ipv6 \
  172. --with-http_ssl_module \
  173. --with-http_realip_module \
  174. --with-http_addition_module \
  175. --with-http_xslt_module \
  176. --with-http_image_filter_module \
  177. --with-http_sub_module \
  178. --with-http_dav_module \
  179. --with-http_flv_module \
  180. --with-http_gzip_static_module \
  181. --with-http_random_index_module \
  182. --with-http_secure_link_module \
  183. --with-http_stub_status_module \
  184. --with-http_perl_module \
  185. --with-mail \
  186. --with-mail_ssl_module \
  187. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  188. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  189. %if %{with wsgi}
  190. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  191. %endif
  192. %ifarch i686
  193. --with-cpu-opt=pentiumpro \
  194. --with-zlib-asm=pentiumpro \
  195. --with-md5-asm \
  196. --with-sha1-asm \
  197. %endif
  198. --with-cc-opt="-O6 %{optflags} $(pcre-config --cflags)"
  199. make %{?_smp_mflags}
  200. %install
  201. rm -rf %{buildroot}
  202. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  203. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  204. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  205. find %{buildroot} -type f -empty -exec rm -f {} \;
  206. find %{buildroot} -type f -exec chmod 0644 {} \;
  207. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  208. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  209. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  210. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  211. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  212. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  213. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  214. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  215. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  216. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  217. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  218. %{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf
  219. %{__install} -p -m 0644 %{SOURCE10} %{buildroot}%{nginx_confdir}/nginx.conf.default
  220. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  221. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  222. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  223. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  224. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  225. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  226. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  227. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  228. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  229. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  230. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  231. %if %{with wsgi}
  232. %{__install} -p -m 0644 \
  233. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  234. %{buildroot}%{nginx_confdir}
  235. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  236. %endif
  237. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  238. # convert to UTF-8 all files that give warnings.
  239. for textfile in CHANGES
  240. do
  241. mv $textfile $textfile.old
  242. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  243. rm -f $textfile.old
  244. done
  245. %clean
  246. rm -rf %{buildroot}
  247. %pre
  248. if [ $1 == 1 ]; then
  249. %{_sbindir}/useradd -c "Nginx user" -s /bin/false -r -d %{nginx_home} %{nginx_user} 2>/dev/null || :
  250. fi
  251. %post
  252. if [ $1 == 1 ]; then
  253. /sbin/chkconfig --add %{name}
  254. fi
  255. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  256. %post passenger
  257. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  258. %preun
  259. if [ $1 = 0 ]; then
  260. /sbin/service %{name} stop >/dev/null 2>&1
  261. /sbin/chkconfig --del %{name}
  262. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  263. fi
  264. %preun passenger
  265. if [ $1 = 0 ]; then
  266. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  267. fi
  268. %postun
  269. if [ $1 == 2 ]; then
  270. /sbin/service %{name} upgrade || :
  271. fi
  272. %files
  273. %defattr(-,root,root,-)
  274. %doc LICENSE CHANGES README %{?with_wsgi:README.mod_wsgi}
  275. %{nginx_datadir}/
  276. %{_sbindir}/%{name}.normal
  277. %{_mandir}/man3/%{name}.3pm.gz
  278. %{_initrddir}/%{name}
  279. %dir %{nginx_confdir}
  280. %dir %{nginx_confdir}/conf.d
  281. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  282. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  283. %config(noreplace) %{nginx_confdir}/sites.d/*
  284. %config(noreplace) %{nginx_confdir}/win-utf
  285. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  286. %config(noreplace) %{nginx_confdir}/mime.types.default
  287. %config(noreplace) %{nginx_confdir}/fastcgi_params
  288. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  289. %config(noreplace) %{nginx_confdir}/koi-win
  290. %config(noreplace) %{nginx_confdir}/koi-utf
  291. %config(noreplace) %{nginx_confdir}/%{name}.conf
  292. %config(noreplace) %{nginx_confdir}/mime.types
  293. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  294. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  295. %config(noreplace) %{nginx_confdir}/scgi_params
  296. %config(noreplace) %{nginx_confdir}/scgi_params.default
  297. %config(noreplace) %{nginx_confdir}/uwsgi_params
  298. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  299. %if %{with wsgi}
  300. %config(noreplace) %{nginx_confdir}/wsgi_vars
  301. %endif
  302. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  303. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  304. %dir %{perl_vendorarch}/auto/%{name}
  305. %{perl_vendorarch}/%{name}.pm
  306. %{perl_vendorarch}/auto/%{name}/%{name}.so
  307. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  308. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  309. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  310. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  311. %files passenger
  312. %defattr(-,root,root,-)
  313. %doc passenger-%{passenger_version}/doc/Users\ guide\ Nginx.*
  314. %doc passenger-%{passenger_version}/doc/ApplicationPool\ algorithm.txt
  315. %doc passenger-%{passenger_version}/doc/Architectural\ overview.*
  316. %doc passenger-%{passenger_version}/doc/Security\ of\ user\ switching\ support.*
  317. %doc passenger-%{passenger_version}/doc/template
  318. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  319. %doc passenger-%{passenger_version}/doc/images
  320. %{_sbindir}/%{name}.passenger
  321. %changelog
  322. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  323. - add nginx-passenger sub pakckage
  324. - use alternatives to choose nginx with or without passenger
  325. - add BR: ruby, rubygems, rubygem-rake
  326. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  327. - update to 1.0.2
  328. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  329. - update to 1.0.1
  330. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  331. - add bcond_with wsgi for mod_wsgi
  332. - add bcond_with passenger
  333. - you need to install rake.gem to build with this option.
  334. - add Provides: webserver
  335. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  336. - new upstream release 1.0.0!
  337. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  338. - rebuild with perl-5.12.3
  339. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  340. - update to 0.8.54
  341. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  342. - update to 0.8.53
  343. - add nginx_accept_language_module
  344. * Sat Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  345. - update to 0.8.50
  346. - update ngx-fancyindex to 0.3
  347. - add BR: libxml2-devel, libxslt-devel
  348. - add scgi_params* and uwsgi_params* to %%files
  349. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  350. - update to 0.8.35 (development version)
  351. - add sites.d/ to store vitualhost settings
  352. - split out default server settings to sites.d/default
  353. - add fancyindex module
  354. * Wed Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  355. - new upstream release
  356. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  357. - update to 0.7.62 (included security fix: VU#180065)
  358. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  359. - fix typo
  360. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  361. - add translated descriptions
  362. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  363. - update 404.html/50x.html to use powered by vine logo.
  364. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  365. - initial build for Vine Linux
  366. - update to 0.7.61
  367. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  368. - init script updates from Gena Makhomed
  369. - remove nginx-upstream-fair
  370. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  371. - update to 0.6.36
  372. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  373. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  374. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  375. - rebuild
  376. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  377. - update to 0.6.35
  378. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  379. - rebuild with new openssl
  380. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  381. - update to 0.6.34
  382. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  383. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  384. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  385. - update to 0.6.33
  386. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  387. - update to 0.6.32
  388. - nginx now supports DESTDIR so removed the patches that enabled it
  389. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  390. - init script fixes
  391. - resolve 'listen 80 default' [#447873]
  392. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  393. - update to 0.6.31
  394. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  395. - upate to new upstream stable branch 0.6
  396. - added 3rd party module nginx-upstream-fair
  397. - added default webpages
  398. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  399. - update init script to match recommended guidelines
  400. - add /etc/nginx/conf.d support [#443280]
  401. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  402. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  403. - add Requires for versioned perl (libperl.so)
  404. - drop silly file Requires
  405. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  406. - Autorebuild for GCC 4.3
  407. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  408. - update to 0.5.35
  409. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  410. - update to 0.5.34
  411. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  412. - Rebuild for deps
  413. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  414. - update to 0.5.33
  415. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  416. - updated to 0.5.32
  417. - fixed rpmlint UTF-8 complaints.
  418. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  419. - added --with-http_stub_status_module build option.
  420. - added --with-http_sub_module build option.
  421. - added use of pcre-config --cflags
  422. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  423. - Update to 0.5.31
  424. - specify license is BSD
  425. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  426. - Add BuildRequires: perl-devel - fixing rawhide build
  427. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  428. - Update to 0.5.30
  429. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  430. - Update to 0.5.29
  431. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  432. - Update to 0.5.28
  433. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  434. - Update to 0.5.27
  435. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  436. - Update to 0.5.26
  437. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  438. - Update to 0.5.19
  439. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  440. - Update to 0.5.17
  441. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  442. - Update to 0.5.16
  443. - add ownership of /usr/share/nginx/html (#233950)
  444. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  445. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  446. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  447. - fixed package review bugs (#233522) given by kevin@tummy.com
  448. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  449. - create patches to assist with building for Fedora
  450. - initial packaging for Fedora