conky-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259
  1. # TODO: - make libXNVCtrl-devel
  2. # - with --enable-lua-imlib2
  3. %define with_alsa 0
  4. %define with_audacious 0
  5. %define with_imlib 1
  6. %define with_lua 1
  7. %define with_lua_cairo 1
  8. %define with_lua_imlib 1
  9. %define with_moc 1
  10. %define with_mpd 0
  11. %define with_nvidia 0
  12. %define with_rss 1
  13. %define with_smapi 0
  14. %define with_ibm 0
  15. %define with_wlan 0
  16. Name: conky
  17. Version: 1.8.1
  18. Release: 2%{?_dist_release}
  19. Summary: A lightweight system monitor for X
  20. Summary(ja): X 用軽量システムモニタ
  21. Group: User Interface/X
  22. License: GPLv3+
  23. URL: http://conky.sf.net/
  24. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  25. Patch0: conky-1.8.1-delete-curl_types.h.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: glib2-devel
  28. BuildRequires: libxml2-devel
  29. BuildRequires: libXft-devel
  30. BuildRequires: libXt-devel
  31. BuildRequires: libXdamage-devel
  32. BuildRequires: libXext-devel
  33. %if %{with_alsa}
  34. BuildRequires: alsa-lib-devel
  35. %endif
  36. %if %{with_imlib}
  37. BuildRequires: imlib2-devel
  38. %endif
  39. %if %{with_lua}
  40. BuildRequires: lua-devel
  41. %endif
  42. %if %{with_lua_cairo}
  43. BuildRequires: cairo-devel tolua++-devel
  44. %endif
  45. %if %{with_lua_imlib}
  46. BuildRequires: imlib2-devel tolua++-devel
  47. %endif
  48. %if %{with_audacious}
  49. BuildRequires: audacious-devel
  50. BuildRequires: dbus-glib-devel
  51. %endif
  52. %if %{with_nvidia}
  53. BuildRequires: libXNVCtrl-devel
  54. %endif
  55. %if %{with_rss}
  56. BuildRequires: curl-devel
  57. %endif
  58. %if %{with_wlan}
  59. BuildRequires: wireless-tools-devel
  60. %endif
  61. Vendor: Project Vine
  62. Distribution: Vine Linux
  63. %description
  64. A system monitor for X originally based on the torsmo code. but more kickass.
  65. It just keeps on given'er. Yeah.
  66. #'
  67. %description -l ja
  68. torsmo をベースにした X 用のシステムモニタです。
  69. %prep
  70. %setup -q
  71. %if %{?_dist_release} >= "vl7"
  72. %patch0
  73. %endif
  74. for i in AUTHORS ChangeLog; do
  75. iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
  76. done
  77. %build
  78. #sh autogen.sh
  79. %configure \
  80. --disable-rpath \
  81. %if !%{with_alsa}
  82. --disable-alsa \
  83. %endif
  84. %if %{with_audacious}
  85. --enable-audacious=yes \
  86. %endif
  87. %if %{with_imlib}
  88. --enable-imlib2 \
  89. %endif
  90. %if !%{with_lua}
  91. --disable-lua \
  92. %endif
  93. %if %{with_lua_cairo}
  94. --enable-lua-cairo \
  95. %endif
  96. %if %{with_lua_imlib}
  97. --enable-lua-imlib2 \
  98. %endif
  99. %if !%{with_moc}
  100. --disable-moc \
  101. %endif
  102. %if !%{with_mpd}
  103. --disable-mpd \
  104. %endif
  105. %if %{with_nvidia}
  106. --enable-nvidia \
  107. %endif
  108. %if %{with_rss}
  109. --enable-rss \
  110. %endif
  111. %if %{with_ibm}
  112. --enable-ibm \
  113. %endif
  114. %if %{with_smapi}
  115. --enable-smapi \
  116. %endif
  117. %if %{with_wlan}
  118. --enable-wlan \
  119. %endif
  120. ;
  121. # don't use rpath
  122. %__sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  123. %__sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  124. %__make %{?_smp_mflags}
  125. %install
  126. %__rm -rf $RPM_BUILD_ROOT
  127. %__make install DESTDIR=$RPM_BUILD_ROOT
  128. %__rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conky/conky_no_x11.conf
  129. %__rm -f $RPM_BUILD_ROOT%{_libdir}/conky/*.{la,a}
  130. %clean
  131. %__rm -rf $RPM_BUILD_ROOT
  132. %files
  133. %defattr(-,root,root,-)
  134. %doc AUTHORS ChangeLog COPYING TODO README NEWS extras/* doc/docs.html
  135. %dir %{_sysconfdir}/%{name}
  136. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  137. %{_bindir}/%{name}
  138. %if %{with_lua_cairo} || %{with_lua_imlib}
  139. %{_libdir}/conky
  140. %endif
  141. %{_mandir}/man1/*
  142. %changelog
  143. * Wed Nov 16 2016 Toshiaki Ara <ara_t@384.jp> 1.10.4-1
  144. - new upstream release
  145. - add Vendor and Distribution
  146. * Sun Jun 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.8.1-1
  147. - new upstream release
  148. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.2-1
  149. - new upstream release
  150. - enable lua, lua-cairo
  151. - added BuildRequires: glib2-devel
  152. * Mon Feb 15 2010 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-2
  153. - fix building with new audacious (#556317)
  154. * Tue Aug 25 2009 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-1
  155. - Update to 1.7.2
  156. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.7.1.1-1
  157. - new upstream release
  158. * Sat Nov 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.6.1-1
  159. - initial build based on Fedora package
  160. - applied conky-1.6.0-rdtsc.patch, conky-1.6.1-ifaddrs.patch
  161. * Tue Aug 26 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.1-1
  162. - Update to 1.6.1
  163. - Fix buffer overflow when reading interface addresses
  164. * Tue Jul 22 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.0-1
  165. - Update to 1.6.0
  166. - Fix freq_dyn on x86_64
  167. * Tue Apr 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.1-1
  168. - Update to 1.5.1
  169. * Sun Mar 23 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.0-1
  170. - Update to 1.5.0
  171. - Convert doc files to UTF-8
  172. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.9-2
  173. - Autorebuild for GCC 4.3
  174. * Tue Nov 27 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.9-1
  175. - Update to 1.4.9
  176. - Enable support for Audacious 1.4.0
  177. * Sun Oct 21 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.8-1
  178. - Update to 1.4.8
  179. - Enable mpd, rss and wireless support
  180. - Update license tag
  181. * Wed Apr 18 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-4
  182. - Rebuild to match audacious lib in fc6 bug: 236989
  183. * Mon Apr 09 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-3
  184. - Rebuild for devel
  185. * Thu Dec 14 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-2
  186. - Ship NEWS
  187. - Add patch for license of timed_thread and NEWS
  188. * Tue Dec 12 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-1
  189. - version bump
  190. - change group
  191. * Wed Dec 06 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-3
  192. - rebuild for new audacious lib version
  193. * Thu Nov 30 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-2
  194. - Move nano and vim files into docs
  195. - remove unneeded BR's
  196. * Tue Nov 21 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-1
  197. - Version bump
  198. - Add vim and nano syntax files to package
  199. * Thu Oct 05 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.3-1
  200. - Version bump
  201. - Remove Install file from docs
  202. * Mon Oct 02 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-4
  203. - moved to configure macro from ./configure
  204. - clean up changelog and make more informative entrys
  205. - Fixed sumary in spec file
  206. - remove NEWS file since it was empty
  207. - remove xmms support due to possible security issue
  208. - remove bmp support due to possible security issue
  209. - add missing BR for libXext-devel and remove unneeded libX11-devel
  210. * Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-3
  211. - use the GPL as licence since the whole package is GPL
  212. * Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-2
  213. - remove unneeded deps
  214. * Tue Sep 26 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-1
  215. - Initial RPM release