newt-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: A development library for text mode user interfaces.
  4. Summary(ja): テキストモードインターフェースのための開発ライブラリ
  5. Name: newt
  6. Version: 0.52.12
  7. Release: 1%{?_dist_release}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. URL: https://fedorahosted.org/newt/
  11. Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
  12. Patch0: newt-0.52.12-nostdin.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  17. BuildRequires: python-devel, popt-devel, slang-devel
  18. Provides: snack = %{version}-%{release}
  19. %description
  20. Newt is a programming library for color text mode, widget based user
  21. interfaces. Newt can be used to add stacked windows, entry widgets,
  22. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  23. etc., to text mode user interfaces. This package also contains the
  24. shared library needed by programs built with newt, as well as a
  25. /usr/bin/dialog replacement called whiptail. Newt is based on the
  26. slang library.
  27. %package devel
  28. Summary: Newt windowing toolkit development files.
  29. Summary(ja): Newt ウィンドウツールキット開発ファイル集
  30. Requires: slang-devel %{name} = %{version}
  31. Group: Development/Libraries
  32. %description devel
  33. The newt-devel package contains the header files and libraries
  34. necessary for developing applications which use newt. Newt is a
  35. development library for text mode user interfaces. Newt is based on
  36. the slang library.
  37. Install newt-devel if you want to develop applications which will use
  38. newt.
  39. ## to build compat32 for x86_64 architecture support
  40. %package -n compat32-%{name}
  41. Summary: A development library for text mode user interfaces.
  42. Group: System Environment/Libraries
  43. %description -n compat32-%{name}
  44. Newt is a programming library for color text mode, widget based user
  45. interfaces. Newt can be used to add stacked windows, entry widgets,
  46. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  47. etc., to text mode user interfaces. This package also contains the
  48. shared library needed by programs built with newt, as well as a
  49. /usr/bin/dialog replacement called whiptail. Newt is based on the
  50. slang library.
  51. %package -n compat32-%{name}-devel
  52. Summary: Newt windowing toolkit development files.
  53. Group: Development/Libraries
  54. Requires: compat32-%{name} = %{version}
  55. %description -n compat32-%{name}-devel
  56. The newt-devel package contains the header files and libraries
  57. necessary for developing applications which use newt. Newt is a
  58. development library for text mode user interfaces. Newt is based on
  59. the slang library.
  60. Install newt-devel if you want to develop applications which will use
  61. newt.
  62. %prep
  63. %setup -q -n %{name}-%{version}
  64. %patch0 -p1 -b .nostdin
  65. %build
  66. %if %{build_compat32}
  67. export CC='gcc -m32'
  68. %configure --without-tcl
  69. make CC='gcc -m32'
  70. #make CC='gcc -m32' shared
  71. %else
  72. %configure --without-tcl
  73. make
  74. make shared
  75. %endif
  76. chmod 0644 peanuts.py popcorn.py
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. make instroot=$RPM_BUILD_ROOT install
  80. %find_lang %{name}
  81. %post -p /sbin/ldconfig
  82. %postun -p /sbin/ldconfig
  83. %if %{build_compat32}
  84. %post -n compat32-%{name} -p /sbin/ldconfig
  85. %postun -n compat32-%{name} -p /sbin/ldconfig
  86. %endif
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %files -f %{name}.lang
  90. %defattr (-,root,root)
  91. %doc CHANGES COPYING
  92. %{_libdir}/libnewt.so.*
  93. %{_bindir}/whiptail
  94. %{python_sitearch}/*.py*
  95. %{python_sitearch}/*.so
  96. %{_mandir}/man1/whiptail.1*
  97. %files devel
  98. %defattr (-,root,root)
  99. %doc tutorial.sgml peanuts.py popcorn.py
  100. %{_includedir}/newt.h
  101. %{_libdir}/libnewt.a
  102. %{_libdir}/libnewt.so
  103. %{_libdir}/pkgconfig/libnewt.pc
  104. %if %{build_compat32}
  105. %files -n compat32-%{name}
  106. %defattr (-,root,root)
  107. %{_libdir}/libnewt.so.*
  108. %{python_sitearch}/*.py*
  109. %{python_sitearch}/*.so
  110. %files -n compat32-%{name}-devel
  111. %defattr (-,root,root)
  112. %{_libdir}/libnewt.a
  113. %{_libdir}/libnewt.so
  114. %endif
  115. %changelog
  116. * Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-1
  117. - update to 0.52.12
  118. - add patch0: don't hang in form when stdin disappears
  119. - remove patch100, fixed in upstream
  120. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
  121. - rebuilt with recent environment.
  122. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
  123. - rebuilt with gcc-4.4.3-3 on ppc
  124. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
  125. - rebuilt with rpm-4.8.0-3 (on ppc)
  126. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
  127. - rebuilt with python-2.6.4
  128. * Thu Oct 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
  129. - fix build_compat32 if-endif
  130. * Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
  131. - add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
  132. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
  133. - new upstream release
  134. - use %%python_sitearch macro
  135. - remove --with-gpm-support
  136. - drop obsolete patches
  137. * Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
  138. - rebuild to fix dependency problem on x86_64 architecture
  139. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
  140. - added BuildRequires: slang-devel
  141. - added newt-0.50.35-Makefile.in.patch
  142. - updated newt-0.50.35-make.patch
  143. - changed /usr/lib to %%{_libdir}
  144. - added compat32-* packages for x86_64 architecture support
  145. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
  146. - rebuild with python-2.4.1-0vl1
  147. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
  148. - rebuild with python-2.3.3-0vl1
  149. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
  150. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  151. * Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
  152. - build against python-2.2
  153. - drop Patch20
  154. * Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
  155. - updated to new upstream release 0.50.35
  156. - updated Patch11 and added Patch20
  157. (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
  158. * Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
  159. - update to new upstream release
  160. * Mon Jul 2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  161. - 0.50.22-0vl1
  162. - updated to 0.50.22
  163. - use Release No for Vine Linux
  164. - use better macros
  165. - bytecompile the snack python module
  166. * Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
  167. - fix spec file
  168. * Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
  169. - added Japanese support patch
  170. * Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
  171. - added suspend/resume to snack
  172. * Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
  173. - enable gpm support
  174. * Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
  175. - added hotkey assignment for gridforms, changed listbox.setcurrent to
  176. take the item key
  177. * Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
  178. - fixed snack callback function refcounts, as well as optional data args
  179. - fixed suspend callback ref counts
  180. * Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
  181. - added buttons argument to entrywindow
  182. * Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
  183. - multi-state checkboxtrees. Woohoo.
  184. * Mon Aug 9 1999 Matt Wilson <msw@redhat.com>
  185. - added snack wrappings for checkbox flag setting
  186. * Thu Aug 5 1999 Matt Wilson <msw@redhat.com>
  187. - added snack bindings for setting current listbox selection
  188. - added argument to set default selection in snack ListboxChoiceWindow
  189. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  190. - added checkboxtree
  191. - improved snack binding
  192. * Fri Apr 9 1999 Matt Wilson <msw@redhat.com>
  193. - fixed a glibc related bug in reflow that was truncating all text to 1000
  194. chars
  195. * Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
  196. - fixed bug that made newt apps crash when you hit <insert> followed by lots
  197. of keys
  198. * Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
  199. - fix from Jakub Jelinek for listbox keypresses
  200. * Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
  201. - fixed support for navigating listboxes with alphabetical keypresses
  202. * Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
  203. - updated descriptions
  204. - added support for navigating listboxes with alphabetical keypresses
  205. * Mon Feb 8 1999 Matt Wilson <msw@redhat.com>
  206. - made grid wrapped windows at least the size of their title bars
  207. * Fri Feb 5 1999 Matt Wilson <msw@redhat.com>
  208. - Function to set checkbox flags. This will go away later when I have
  209. a generic flag setting function and signals to comps to go insensitive.
  210. * Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
  211. - Stopped using libgpm, internalized all gpm calls. Still need some cleanups.
  212. * Thu Jan 7 1999 Matt Wilson <msw@redhat.com>
  213. - Added GPM mouse support
  214. - Moved to autoconf to allow compiling without GPM support
  215. - Changed revision to 0.40
  216. * Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
  217. - built against slang-1.2.2
  218. * Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
  219. - bugfixes for text reflow
  220. - added docs
  221. * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
  222. - devel package moved to Development/Libraries
  223. * Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
  224. - removed whiptcl.so -- it should be in a separate package
  225. * Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
  226. - added newtWinMenu()
  227. - many bug fixes in grid code
  228. * Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
  229. - removed newtWinTernary()
  230. - made newtWinChoice() return codes consistent with newtWinTernary()
  231. * Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
  232. - added changes from Bruce Perens
  233. - small cleanups
  234. - lets whiptail automatically resize windows
  235. - the order of placing a grid and adding components to a form no longer
  236. matters
  237. - added newtGridAddComponentsToForm()
  238. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  239. - added newtWinTernary()
  240. * Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
  241. - made Make/spec files use a buildroot
  242. - added grid support (for newt 0.11 actually)
  243. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  244. - Added patched from Clarence Smith for setting the size of a listbox
  245. - Version 0.9
  246. * Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
  247. - Touchups on Makefile
  248. - Cleaned up NEWT_FLAGS_*
  249. * Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
  250. - Cleaned up listbox
  251. - Added whiptail
  252. - Added newtButtonCompact button type and associated colors
  253. - Added newtTextboxGetNumLines() and newtTextboxSetHeight()
  254. * Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
  255. - Added changes from sopwith for C++ cleanliness and some listbox fixes.