ModemManager-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. #%define git_snapshot .git20130607
  2. %define git_snapshot %{nil}
  3. %define ppp_version 2.4.5
  4. %define glib2_version 2.36
  5. Summary: Mobile broadband modem management service
  6. Summary(ja): Mobile broadband modem management service
  7. Name: ModemManager
  8. Version: 1.0.0
  9. Release: 1%{git_snapshot}%{?_dist_release}
  10. License: GPLv2+
  11. Group: System Environment/Base
  12. URL: http://www.gnome.org/projects/NetworkManager/
  13. #
  14. # Source from git://anongit.freedesktop.org/ModemManager/ModemManager
  15. # tarball built with:
  16. # ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  17. # make distcheck
  18. #
  19. #Source: %{name}-%{version}%{git_snapshot}.tar.bz2
  20. Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  21. Patch0: buildsys-hates-openpty.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. Requires: dbus-glib
  24. Requires: glib2
  25. BuildRequires: glib2-devel >= %{glib2_version}
  26. BuildRequires: dbus-glib-devel >= 0.92
  27. BuildRequires: libgudev1-devel >= 143
  28. BuildRequires: ppp = %{ppp_version}
  29. BuildRequires: ppp-devel = %{ppp_version}
  30. BuildRequires: automake autoconf intltool libtool
  31. BuildRequires: gtk-doc
  32. # for xsltproc
  33. BuildRequires: libxslt
  34. %description
  35. The ModemManager service manages WWAN modems and provides a consistent API for
  36. interacting with these devices to client applications.
  37. %package devel
  38. Summary: Development tools for %{name}
  39. Summary(ja): %{name} の開発環境
  40. Group: Development/Libraries
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: pkgconfig
  43. %description devel
  44. Header files and libraries for building a extension library for the %{name}.
  45. %package glib
  46. Summary: Libraries for adding ModemManager support to applications that use glib.
  47. Group: Development/Libraries
  48. Requires: glib2 >= %{glib2_version}
  49. %description glib
  50. This package contains the libraries that make it easier to use some ModemManager
  51. functionality from applications that use glib.
  52. %package glib-devel
  53. Summary: Development tools for %{name}-glib
  54. Summary(ja): %{name}-glib の開発環境
  55. Group: Development/Libraries
  56. Requires: %{name}-glib = %{version}-%{release}
  57. Requires: %{name}-devel = %{version}-%{release}
  58. Requires: glib2-devel
  59. Requires: pkgconfig
  60. %description glib-devel
  61. Header files and libraries for building a extension library for the %{name}-glib.
  62. %prep
  63. %setup -q
  64. %patch0 -p1 -b .pty
  65. %build
  66. autoreconf -if
  67. intltoolize --force
  68. pppddir=`ls -1d %{_libdir}/pppd/2*`
  69. %configure \
  70. --enable-more-warnings=yes \
  71. --with-udev-base-dir=/lib/udev \
  72. --with-tests=yes \
  73. --enable-gtk-doc=yes \
  74. --without-qmi \
  75. --disable-static \
  76. --with-pppd-plugin-dir=$pppddir \
  77. --with-polkit=no \
  78. --with-mbim=no
  79. make %{?_smp_mflags}
  80. %check
  81. make check
  82. %install
  83. make install DESTDIR=$RPM_BUILD_ROOT
  84. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  86. %post
  87. /sbin/ldconfig
  88. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  89. %postun
  90. /sbin/ldconfig
  91. if [ $1 -eq 0 ]; then
  92. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  93. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  94. fi
  95. %posttrans
  96. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  97. %post glib -p /sbin/ldconfig
  98. %postun glib -p /sbin/ldconfig
  99. %files
  100. %defattr(0644, root, root, 0755)
  101. %doc COPYING README
  102. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  103. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  104. %attr(0755,root,root) %{_sbindir}/ModemManager
  105. %attr(0755,root,root) %{_bindir}/mmcli
  106. %dir %{_libdir}/%{name}
  107. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  108. /lib/udev/rules.d/*
  109. %{_datadir}/dbus-1/interfaces/*.xml
  110. %{_datadir}/icons/hicolor/22x22/apps/*.png
  111. %{_mandir}/man8/*
  112. %files devel
  113. %defattr(0644, root, root, 0755)
  114. %{_includedir}/ModemManager/*.h
  115. %dir %{_datadir}/gtk-doc/html/%{name}
  116. %{_datadir}/gtk-doc/html/%{name}/*
  117. %{_libdir}/pkgconfig/%{name}.pc
  118. %files glib
  119. %defattr(0644, root, root, 0755)
  120. %{_libdir}/libmm-glib.so.*
  121. %files glib-devel
  122. %defattr(0644, root, root, 0755)
  123. %{_libdir}/libmm-glib.so
  124. %dir %{_includedir}/libmm-glib
  125. %{_includedir}/libmm-glib/*.h
  126. %{_libdir}/pkgconfig/mm-glib.pc
  127. %dir %{_datadir}/gtk-doc/html/libmm-glib
  128. %{_datadir}/gtk-doc/html/libmm-glib/*
  129. %changelog
  130. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  131. - new upstream release
  132. - update Patch0
  133. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  134. - update to 0.7.991 snapshot
  135. - fix spec file based on FC package
  136. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  137. - Update to 0.7.991 snapshot
  138. - Fix SMS validity parsing
  139. - Allow registration changes to 'searching' without disconnecting
  140. - Fix reading SMS messages from some QMI-based devices
  141. - Increase connection timeout for Novatel E362
  142. - Fix PIN retries checking when unlocking Ericsson devices
  143. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  144. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  145. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  146. - new upstream release
  147. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  148. - new upstream release
  149. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  150. - delete Patch20
  151. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  152. - update Patch20 (ModemManager-0.4-git20110428.patch)
  153. - delete Patch21,22
  154. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  155. - update to 0.4
  156. - add Patch20 (ModemManager-0.4-git20100720.patch)
  157. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  158. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  159. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  160. - initial build for Vine Linux
  161. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  162. - core: ignore some failures on disconnect (rh #578280)
  163. - core: add support for platform serial devices
  164. - gsm: better Blackberry DUN support
  165. - gsm: periodically poll access technology
  166. - cdma: prevent crash on modem removal (rh #571921)
  167. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  168. - novatel: better signal strength reporting on CDMA cards
  169. - novatel: add access technology and mode preference support on GSM cards
  170. - zte: fix mode preference retrieval
  171. - longcheer: add support for Zoom modems (4595, 4596, etc)
  172. - longcheer: add access technology and mode preference support
  173. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  174. - Silence %%post
  175. - Update scripts
  176. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  177. - gsm: fix parsing Blackberry supported character sets response
  178. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  179. - mbm: fix retrieval of current allowed mode
  180. - gsm: fix initialization issues with some devices (like Blackberries)
  181. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  182. - core: fix detection of some generic devices (rh #579247)
  183. - core: fix detection regression of some Huawei devices in 0.3-5
  184. - cdma: periodically poll registration state and signal quality
  185. - cdma: really fix registration detection on various devices (rh #569067)
  186. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  187. - core: fix PPC/SPARC/etc builds
  188. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  189. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  190. - cdma: handle signal quality requests while connected for more devices
  191. - cdma: handle serving system requests while connected for more devices
  192. - gsm: determine current access technology earlier
  193. - huawei: work around automatic registration issues on some devices
  194. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  195. - core: ensure enabled modems are disabled when MM stops
  196. - core: better capability detection for Blackberry devices (rh #573510)
  197. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  198. - gsm: don't block modem when it requires PIN2
  199. - option: fix access technology updates
  200. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  201. - mbm: add device IDs for C3607w
  202. - mbm: fail earlier during connection failures
  203. - mbm: fix username/password authentication when checked by the network
  204. - hso: implement asynchronous signal quality updates
  205. - option: implement asynchronous signal quality updates
  206. - novatel: correctly handle CDMA signal quality
  207. - core: basic PolicyKit support
  208. - core: fix direct GSM registration information requests
  209. - core: general GSM PIN/PUK unlock fixes
  210. - core: poll GSM registration state internally for quicker status updates
  211. - core: implement GSM 2G/3G preference
  212. - core: implement GSM roaming allowed/disallowed preference
  213. - core: emit signals on access technology changes
  214. - core: better handling of disconnections
  215. - core: fix simple CDMA status requests
  216. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  217. - core: startup speed improvements
  218. - core: GSM PIN checking improvements
  219. - huawei: fix EVDO-only connections on various devices (rh #553199)
  220. - longcheer: add support for more devices
  221. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  222. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  223. - core: fix crashes when devices are unplugged during operation (rh #553953)
  224. - cdma: prefer primary port for status/registration queries
  225. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  226. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  227. - gsm: fix Nokia N80 network scan parsing
  228. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  229. - core: fix apparent hangs by limiting retried serial writes
  230. - gsm: ensure modem state is reset when disabled
  231. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  232. - sierra: fix CDMA registration detection in some cases (rh #547513)
  233. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  234. - sierra: ensure CDMA device is powered up when trying to use it
  235. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  236. - zte: handle unsolicited messages better during probing
  237. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  238. - cdma: fix signal strength reporting on some devices
  239. - cdma: better registration state detection when dialing (ex Sierra 5275)
  240. - option: always use the correct tty for dialing commands
  241. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  242. - core: fix reconnect after manual disconnect (rh #541314)
  243. - core: fix various segfaults during registration
  244. - core: fix probing of various modems on big-endian architectures (ie PPC)
  245. - core: implement modem states to avoid duplicate operations
  246. - hso: fix authentication for Icera-based devices like iCON 505
  247. - zte: use correct port for new devices
  248. - nozomi: fix detection
  249. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  250. - Update to latest git
  251. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  252. - cdma: wait for network registration before trying to connect
  253. - gsm: add cell access technology reporting
  254. - gsm: allow longer-running network scans
  255. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  256. - nokia: don't power down phones on disconnect
  257. - hso: fix disconnection/disable
  258. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  259. - Fixes for Motorola and Ericsson devices
  260. - Fixes for CDMA "serving-system" command parsing
  261. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  262. - Fix a typo in one of the udev rules files
  263. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  264. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  265. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  266. - Fix source repo location
  267. - Fix directory ownership
  268. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  269. - Initial version