colord-vl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261
  1. %bcond_with firstbuild
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. Summary: Color daemon
  4. Name: colord
  5. Version: 1.0.3
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Daemons
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://gitorious.org/colord
  10. Source0: http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
  11. BuildRequires: dbus-devel
  12. BuildRequires: docbook-utils
  13. BuildRequires: gettext
  14. BuildRequires: glib2-devel
  15. BuildRequires: intltool
  16. BuildRequires: lcms2-devel
  17. BuildRequires: libgudev1-devel
  18. BuildRequires: libgusb-devel
  19. BuildRequires: polkit-devel
  20. BuildRequires: sqlite3-devel
  21. BuildRequires: bash-completion
  22. %{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
  23. Requires: shared-color-profiles
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: Takemikaduchi
  27. %description
  28. colord is a low level system activated daemon that maps color devices
  29. to color profiles in the system context.
  30. %package devel
  31. Summary: Development package for %{name}
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: glib2-devel
  35. Requires: dbus-devel
  36. Requires: lcms2-devel
  37. %description devel
  38. Files for development with %{name}.
  39. # compat32
  40. %package -n compat32-%{name}
  41. Summary: Color daemon
  42. Group: System Environment/Daemons
  43. Requires: %{name} = %{version}-%{release}
  44. %description -n compat32-%{name}
  45. colord is a low level system activated daemon that maps color devices
  46. to color profiles in the system context.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development package for %{name}
  49. Group: Development/Libraries
  50. Requires: compat32-%{name} = %{version}-%{release}
  51. %description -n compat32-%{name}-devel
  52. Files for development with %{name}.
  53. %prep
  54. %setup -q
  55. %build
  56. %configure \
  57. --disable-static \
  58. --disable-rpath \
  59. --disable-examples \
  60. --disable-dependency-tracking \
  61. --disable-systemd-login
  62. make %{?_smp_mflags}
  63. %install
  64. make install DESTDIR=$RPM_BUILD_ROOT
  65. # Remove static libs and libtool archives.
  66. find %{buildroot} -name '*.la' -exec rm -f {} ';'
  67. find %{buildroot} -name '*.a' -exec rm -f {} ';'
  68. # databases
  69. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
  70. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
  71. %find_lang %{name}
  72. %post -p /sbin/ldconfig
  73. %postun
  74. /sbin/ldconfig
  75. if [ $1 -eq 0 ]; then
  76. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  77. fi
  78. %posttrans
  79. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  80. %post -n compat32-%{name} -p /sbin/ldconfig
  81. %postun -n compat32-%{name} -p /sbin/ldconfig
  82. %files -f %{name}.lang
  83. %defattr(-,root,root,-)
  84. %doc README AUTHORS NEWS COPYING
  85. %{_libexecdir}/colord
  86. %{_libexecdir}/colord-session
  87. %dir %{_localstatedir}/lib/colord
  88. %{_bindir}/*
  89. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
  90. %{_datadir}/bash-completion/completions/colormgr
  91. %{_datadir}/color
  92. %{_datadir}/colord
  93. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
  94. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
  95. %{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
  96. %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
  97. %{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
  98. %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
  99. %{_datadir}/man/man1/*.1.gz
  100. %{_libdir}/libcolord.so.*
  101. %{_libdir}/libcolordprivate.so.*
  102. %{_libdir}/libcolorhug.so.*
  103. %{_libdir}/colord-plugins/libcd_plugin_camera.so
  104. %{_libdir}/colord-plugins/libcd_plugin_scanner.so
  105. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
  106. %{!?with_firstbuild:%{_libdir}/girepository-1.0/ColorHug-1.0.typelib}
  107. %config %{_sysconfdir}/colord.conf
  108. /lib/udev/rules.d/*.rules
  109. %{_libdir}/colord-sensors
  110. %ghost %{_localstatedir}/lib/colord/*.db
  111. %files devel
  112. %defattr(-,root,root,-)
  113. %{_includedir}/colord-1
  114. %{_libdir}/libcolord.so
  115. %{_libdir}/libcolordprivate.so
  116. %{_libdir}/libcolorhug.so
  117. %{_libdir}/pkgconfig/colord.pc
  118. %{_libdir}/pkgconfig/colorhug.pc
  119. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
  120. %{!?with_firstbuild:%{_datadir}/gir-1.0/ColorHug-1.0.gir}
  121. # compat32
  122. %if %{build_compat32}
  123. %files -n compat32-%{name}
  124. %defattr(-,root,root,-)
  125. %{_libdir}/libcolord.so.*
  126. %files -n compat32-%{name}-devel
  127. %defattr(-,root,root,-)
  128. %{_libdir}/libcolord.so
  129. %endif
  130. %changelog
  131. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  132. - new upstream release
  133. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  134. - new upstream release
  135. - add BuildRequires: bash-completion
  136. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
  137. - new upstream release
  138. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
  139. - new upstream release
  140. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
  141. - new upstream release
  142. - remove BuildRequires: sane-devel
  143. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
  144. - new upstream release
  145. - change BuildRequires: libgusb-devel instead of libusb1-devel
  146. - add BuildRequires: gobject-introspection-devel
  147. * Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
  148. - new upstream release
  149. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
  150. - new upstream release
  151. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
  152. - new upstream release
  153. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
  154. - new upstream release
  155. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
  156. - new upstream release
  157. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
  158. - new upstream release
  159. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
  160. - new upstream release
  161. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
  162. - new upstream release
  163. - create compat32 sub packages
  164. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
  165. - initial build for Vine Linux
  166. * Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
  167. - New upstream version
  168. * Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
  169. - New upstream version
  170. * Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
  171. - New upstream version
  172. - Add a webcam device kind
  173. - Add a timestamp when making profiles default
  174. - Add support for reading and writing ICC profile metadata
  175. - Allow the client to pass file descriptors out of band to CreateProfile
  176. - Prettify the device vendor and model names
  177. - Split out the sensors into runtime-loadable shared objects
  178. - Provide some GIO async variants for the methods in CdClient
  179. - Ensure GPhoto2 devices get added to the device list
  180. * Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
  181. - New upstream version.
  182. - Create /var/lib/colord at buildtime not runtime for SELinux
  183. - Ensure profiles with embedded profile checksums are parsed correctly
  184. - Move the colorimeter rules to be run before 70-acl.rules
  185. - Stop watching the client when the sensor is finalized
  186. - Ensure the source is destroyed when we unref CdUsb to prevent a crash
  187. - Only enable the volume mount tracking when searching volumes
  188. * Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
  189. - Own /var/lib/colord and /var/lib/colord/*.db
  190. * Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
  191. - New upstream version.
  192. * Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
  193. - New upstream version.
  194. * Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
  195. - New upstream version.
  196. * Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
  197. - New upstream version.
  198. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  200. * Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
  201. - Rebuild in the vain hope koji isn't broken today.
  202. * Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
  203. - New upstream version.
  204. * Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
  205. - Initial version for Fedora package review.