gstreamer1-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195
  1. # keep in sync with the VERSION. gstreamer can append a .0.1 to CVS snapshots.
  2. %define major 1.0
  3. %define _gtk_doc_ver 1.6
  4. %define po_package gstreamer-%{major}
  5. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  6. Name: gstreamer1
  7. Summary: GStreamer streaming media framework runtime.
  8. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  9. Version: 1.0.10
  10. Release: 1%{?_dist_release}
  11. Group: System Environment/Libraries
  12. License: LGPL
  13. URL: http://gstreamer.freedesktop.org/
  14. Source: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gobject-introspection-devel
  17. BuildRequires: bison
  18. BuildRequires: gtk-doc >= %{_gtk_doc_ver}
  19. BuildRequires: flex
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: Takemikaduchi
  23. %description
  24. GStreamer is a streaming-media framework, based on graphs of filters which
  25. operate on media data. Applications using this library can do anything
  26. from real-time sound processing to playing videos, and just about anything
  27. else media-related. Its plugin-based architecture means that new data
  28. types or processing capabilities can be added simply by installing new
  29. plugins.
  30. %package devel
  31. Summary: Libraries/header files for GStreamer streaming media framework.
  32. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. GStreamer is a streaming-media framework, based on graphs of filters which
  37. operate on media data. Applications using this library can do anything
  38. from real-time sound processing to playing videos, and just about anything
  39. else media-related. Its plugin-based architecture means that new data
  40. types or processing capabilities can be added simply by installing new
  41. plugins.
  42. This package contains the libraries and includes files necessary to develop
  43. applications and plugins for GStreamer.
  44. # compat32
  45. %package -n compat32-%{name}
  46. Summary: GStreamer streaming media framework runtime.
  47. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  48. Group: System Environment/Libraries
  49. %description -n compat32-%{name}
  50. GStreamer is a streaming-media framework, based on graphs of filters which
  51. operate on media data. Applications using this library can do anything
  52. from real-time sound processing to playing videos, and just about anything
  53. else media-related. Its plugin-based architecture means that new data
  54. types or processing capabilities can be added simply by installing new
  55. plugins.
  56. %package -n compat32-%{name}-devel
  57. Summary: Libraries/header files for GStreamer streaming media framework.
  58. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  59. Group: Development/Libraries
  60. Requires: compat32-%{name} = %{version}-%{release}
  61. Requires: %{name}-devel = %{version}-%{release}
  62. %description -n compat32-%{name}-devel
  63. GStreamer is a streaming-media framework, based on graphs of filters which
  64. operate on media data. Applications using this library can do anything
  65. from real-time sound processing to playing videos, and just about anything
  66. else media-related. Its plugin-based architecture means that new data
  67. types or processing capabilities can be added simply by installing new
  68. plugins.
  69. This package contains the libraries and includes files necessary to develop
  70. applications and plugins for GStreamer.
  71. %prep
  72. %setup -q -n gstreamer-%{version}
  73. %build
  74. %configure \
  75. --with-package-name='Vine Linux gstreamer package' \
  76. --with-cachedir=%{_var}/cache/gstreamer-%{major} \
  77. --enable-introspection=yes \
  78. --disable-docbook --enable-gtk-doc \
  79. --disable-static --disable-examples \
  80. --disable-tests --disable-debug
  81. make %{?_smp_mflags}
  82. %install
  83. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  84. make install DESTDIR=$RPM_BUILD_ROOT
  85. mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  88. #rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
  89. %find_lang %{po_package}
  90. %clean
  91. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  92. %post -p /sbin/ldconfig
  93. %postun -p /sbin/ldconfig
  94. %post -n compat32-%{name} -p /sbin/ldconfig
  95. %postun -n compat32-%{name} -p /sbin/ldconfig
  96. %files -f %{po_package}.lang
  97. %defattr(-, root, root)
  98. %doc AUTHORS ChangeLog COPYING README NEWS RELEASE
  99. %doc TODO ABOUT-NLS
  100. %{_bindir}/*
  101. %dir %{_libdir}/gstreamer-%{major}
  102. %{_libdir}/gstreamer-%{major}/*.so*
  103. %{_libdir}/*.so.*
  104. %{_libdir}/girepository-1.0/*.typelib
  105. %dir %{_libexecdir}/gstreamer-%{major}
  106. %{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
  107. %{_mandir}/man1/*
  108. %dir %{_var}/cache/gstreamer-%{major}
  109. %files devel
  110. %defattr(-, root, root)
  111. %dir %{_includedir}/gstreamer-%{major}
  112. %{_includedir}/gstreamer-%{major}/*
  113. %{_libdir}/*.so
  114. %{_libdir}/pkgconfig/gstreamer*.pc
  115. %{_datadir}/aclocal/*.m4
  116. %{_datadir}/gtk-doc/html/gstreamer-%{major}
  117. %{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
  118. %{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
  119. %{_datadir}/gir-1.0/*.gir
  120. # compat32
  121. %if %{build_compat32}
  122. %files -n compat32-%{name}
  123. %defattr(-, root, root)
  124. %dir %{_libdir}/gstreamer-%{major}
  125. %{_libdir}/gstreamer-%{major}/*.so*
  126. %{_libdir}/*.so.*
  127. %files -n compat32-%{name}-devel
  128. %defattr(-, root, root)
  129. %{_libdir}/*.so
  130. %endif
  131. %changelog
  132. * Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  133. - new upstream release
  134. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
  135. - new upstream release
  136. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  137. - new upstream release
  138. * Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  139. - new upstream release
  140. * Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  141. - new upstream release
  142. * Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  143. - new upstream release
  144. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  145. - new upstream release
  146. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  147. - new upstream release
  148. * Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
  149. - new upstream release
  150. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  151. - initial build