self-build-gstreamer1-plugins-ugly-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. %define pkgname gstreamer1-plugins-ugly
  2. %define major 1.0
  3. %define _gst_ver 1.0.10
  4. %define _gstpb_ver 1.0.10
  5. %define version 1.0.10
  6. %define release 1%{?_dist_release}
  7. %define sourceurl http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-%{version}.tar.xz
  8. Summary: Package to automatically build %{pkgname} rpm package
  9. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  10. Name: self-build-%{pkgname}
  11. Version: %{version}
  12. Release: %{release}
  13. Source0: %{pkgname}-vl.spec
  14. License: LGPLv2+
  15. Group: Restricted Software
  16. Requires(post): self-build-setup >= 0.9.9
  17. # (build)requies of target package.
  18. Requires(post): libogg-devel, libtheora-devel, libvorbis-devel
  19. Requires(post): gstreamer1-devel >= %{_gst_ver}
  20. Requires(post): gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  21. #Requires(post): gtk-doc >= 1.3
  22. Requires(post): python >= 2.1, python-pyxml
  23. Requires(post): glib2-devel >= 2.6
  24. Requires(post): twolame-devel
  25. Requires(post): liboil-devel >= 0.3.0
  26. Requires(post): libcdio-devel >= 0.82
  27. Requires(post): libdvdread-devel
  28. Requires(post): PyXML
  29. Requires(post): self-build-libmad >= 0.15
  30. Requires(post): libid3tag-devel >= 0.15
  31. Requires(post): self-build-ffmpeg
  32. Requires(post): self-build-x264
  33. Requires(post): self-build-libmpeg2
  34. Requires(post): self-build-a52dec
  35. Requires(post): self-build-lame
  36. Requires(post): self-build-libmad
  37. BuildArch: noarch
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. Packager: Takemikaduchi
  40. %description
  41. gstreamer1-plugins-ugly is a set of ugly plugins for Gstreamer
  42. streaming-media framework.
  43. If you install this package, it automaticaly downloads source
  44. code, compile it, and create rpm packages of
  45. %{pkgname}-%{version}.
  46. And the created rpm packages are automatically installed
  47. if installation is executed by apt-get command or synaptic
  48. package manager.
  49. [Note]
  50. This package requires many other packages to compile
  51. targetsoftware. So it consume more disk space than usual.
  52. Also installation takes logner time because of compilation.
  53. (This will take a few minutes to quarter or half of an hour,
  54. depends on building environment)
  55. [About self-build package]
  56. For some kind of software, distributing of binary package
  57. may viorate the patent or law. Therefore we chose self-build
  58. packge, create binary package on your machine, for such kind
  59. of softwares instead of distributing binary package.
  60. Please obey the national law when you use the created binary
  61. packages. And if you want to use the softwares using patented
  62. thechnology, it may be required to get a permission, make an
  63. agreement or purchas a license. Please consider it with your
  64. purpose or way of use and take appropriate action.
  65. %description -l ja
  66. gstreamer1-plugins-ugly は GStreamer ストリーミングメディア
  67. フレームワーク用 ugly プラグイン集です。
  68. このパッケージをインストールすると、自動的にソースコードを
  69. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  70. の rpm パッケージを作成します。
  71. また apt-get コマンドや synaptic パッケージマネージャから実行
  72. した場合は、作成された rpm パッケージのインストールも自動的に
  73. 行います。
  74. [注意]
  75. コンパイルに必要な多くの関連パッケージを要求するので通常より
  76. ディスクの領域を多く消費します。
  77. またインストール時にコンパイルを行うため、通常より時間がかか
  78. る場合があります。(環境にもよりますが数分から数十分程度)
  79. [self-build パッケージについて]
  80. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  81. 違反する可能性があるものがあります。その為、このような問題が
  82. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  83. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  84. ジという方法を採っています。
  85. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  86. アのライセンス、および利用する国の各種法令に従ってください。
  87. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  88. センスの購入などが必要となる場合がありますので、利用する目的
  89. や形態に応じて各自で判断し適切な対応を取ってください。
  90. %prep
  91. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  92. %install
  93. %{__rm} -rf ${RPM_BUILD_ROOT}
  94. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  95. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  96. %clean
  97. %{__rm} -rf ${RPM_BUILD_ROOT}
  98. %posttrans
  99. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 83000
  100. %files
  101. %defattr(-,root,root)
  102. %{_datadir}/%{name}
  103. %changelog
  104. * Sat Aug 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
  105. - new upstream release
  106. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.9-1
  107. - new upstream release
  108. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
  109. - new upstream release
  110. * Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  111. - new upstream release
  112. * Sat Mar 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  113. - new upstream release
  114. * Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  115. - new upstream release
  116. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  117. - new upstream release
  118. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
  119. - new upstream release
  120. - rename package
  121. * Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.19-1
  122. - new upstream relase
  123. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.18-1
  124. - new upstream relase
  125. - built with new x264
  126. - License: LGPLv2+
  127. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.17-1
  128. - new upstream relase
  129. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.16-1
  130. - new upstream relase
  131. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.15-1
  132. - new upstream relase
  133. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.14-1
  134. - new upstream relase
  135. - renamed %%{Source0} to gstreamer-plugins-ugly-vl.spec
  136. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.13-1
  137. - new upstream relase
  138. * Sat Oct 24 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.10.12-1
  139. - new upstream relase
  140. - added Requires(post): self-build-libmpeg2
  141. - enable mpeg2dec with libmpeg2-devel in %%configure
  142. - check version between original spec and self-build spec in %%prep
  143. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-3
  144. - avoided to execute self-build-rpm.sh on RPM transaction
  145. - moved %%post actions to %%posttrans
  146. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-2
  147. - added BuildArch: noarch
  148. - dropped PreReq: gtk-doc >= 1.3
  149. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.11-1
  150. - new upstream relase
  151. * Mon Feb 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-2
  152. - changed to PreReq: self-build-libmad >= 0.15 from libmad-devel
  153. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.10.10-1
  154. - new upstream relase
  155. * Sun Aug 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.10.8-1
  156. - initial build for Vine Linux.