PyQt4-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342
  1. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  2. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  3. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  4. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.5)
  5. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  6. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  7. %define qt4qmake %{_qt4_prefix}/bin/qmake
  8. Name: PyQt4
  9. Summary: Python bindings for Qt4
  10. Summary(ja): Qt4 の Python バインディング
  11. Version: 4.10.3
  12. Release: 1%{?_dist_release}
  13. # GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
  14. License: GPLv3 or GPLv2 with exceptions
  15. Group: Development/Languages
  16. URL: http://www.riverbankcomputing.com/software/pyqt/
  17. Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
  18. Patch1: PyQt-x11-gpl-4.9.4-64bit.patch
  19. # HACK! FIXME: ping upstream why this isn't working right. -- Rex
  20. Patch2: PyQt-x11-gpl-4.5.2-QT_SHARED.patch
  21. Patch4: PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
  22. # Vine Patch
  23. Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: dbus-devel dbus-python-devel
  26. BuildRequires: findutils
  27. BuildRequires: libXext-devel
  28. BuildRequires: phonon-devel
  29. BuildRequires: python-devel
  30. # beware of PyQt4/qscintilla bootstap issues
  31. #BuildRequires: qscintilla
  32. BuildRequires: qt4-devel >= 4.5.0
  33. BuildRequires: qt-assistant-adp-devel
  34. BuildRequires: sip-devel >= 4.13.1
  35. Requires: sip >= 4.13.1
  36. Requires: dbus-python
  37. Requires: qt4
  38. %description
  39. These are Python bindings for Qt4.
  40. %package devel
  41. Summary: Files needed to build other bindings based on Qt4
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: qt4-devel >= 4.5.0
  45. Requires: qt-assistant-adp-devel
  46. Requires: sip-devel >= 4.13.1
  47. %description devel
  48. Files needed to build other bindings for C++ classes that inherit from any
  49. of the Qt4 classes (e.g. KDE or your own).
  50. %prep
  51. %setup -q -n PyQt-x11-gpl-%{version}
  52. %ifarch x86_64
  53. %patch1 -p1 -b .64bit
  54. %endif
  55. %patch2 -p1 -b .QT_SHARED
  56. #patch100 -p1 -b .phononpath_vine
  57. ## permissions
  58. # mark examples non-executable
  59. find examples/ -name "*.py" | xargs chmod a-x
  60. chmod a+rx pyuic/uic/pyuic.py
  61. %build
  62. CFLAGS="${CFLAGS:-%optflags}" \
  63. CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
  64. sed -i "s|0x040f00|0x040e07|" configure.py
  65. sed -i "s|4.15|4.14.7|" configure-ng.py
  66. %{__python} configure.py \
  67. --confirm-license \
  68. --qmake=%{qt4qmake} \
  69. --no-qsci-api \
  70. --verbose
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
  75. # HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
  76. rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
  77. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
  78. $RPM_BUILD_ROOT%{_bindir}/pyuic4
  79. ln -s %{_bindir}/pyuic4 \
  80. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %files
  84. %defattr(-,root,root,-)
  85. %doc NEWS README
  86. %doc OPENSOURCE-NOTICE.TXT
  87. %doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
  88. %doc LICENSE.GPL3
  89. %{python_sitearch}/PyQt4/
  90. %exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
  91. # fixme? -> sitearch? -- Rex
  92. %{python_sitelib}/dbus/mainloop/qt.so
  93. %{_qt4_plugindir}/designer/*
  94. %files devel
  95. %defattr(-,root,root,-)
  96. %doc doc/*
  97. %doc examples/
  98. %{_bindir}/pylupdate4
  99. %{_bindir}/pyrcc4
  100. %{_bindir}/pyuic4
  101. %{python_sitearch}/PyQt4/uic/pyuic.py*
  102. %{_datadir}/sip/PyQt4/
  103. #{_qt4_prefix}/qsci/api/python/PyQt4.api
  104. %changelog
  105. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.3-1
  106. - new upstream release
  107. * Sat Sep 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.2-1
  108. - new upstream release
  109. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.1-1
  110. - new upstream release
  111. * Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.4-1
  112. - new upstream release
  113. - update Patch1 (PyQt-x11-gpl-4.9.4-64bit.patch)
  114. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-2
  115. - rebuild with python-2.7.2
  116. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.9.0-1
  117. - new upstream release
  118. - aaded BR: qt-assistant-adp-devel
  119. * Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.4-2
  120. - update Patch1 (PyQt-x11-gpl-4.8.4-64bit.patch) (x86_64 only)
  121. * Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.4-1
  122. - new upstream release
  123. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-4
  124. - re-add Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch) (x86_64 only)
  125. - remove %%sip_ver
  126. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-3
  127. - rebuilt with qt4-4.7.2
  128. * Tue Feb 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.8.3-2
  129. - update Patch1 (PyQt-x11-gpl-4.8.3-64bit.patch)
  130. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
  131. - new upstream release
  132. - built with sip-4.12.1 and qt4-4.7.1
  133. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
  134. - rebuild with qt4-4.6.3
  135. - fix %qtver (from 4.6.1 to 4.6.3)
  136. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  137. - new upstream release
  138. - rebuilt with sip-4.10.5 and qt4-4.6.3
  139. * Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
  140. - new upstream release
  141. - updated Patch100
  142. * Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
  143. - updated Patch100 to build phonon module
  144. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
  145. - new upstream release
  146. - rebuilt with python-2.6.4
  147. - dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
  148. * Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
  149. - now BuildRequires sip-devel >= 4.9 (was 4.8.2)
  150. * Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
  151. - new upstream release
  152. - added BR: libXext-devel
  153. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
  154. - added Patch100 for building phonon modules
  155. * Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
  156. - Initial build for Vine
  157. * Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
  158. - PyQt4-4.5.4
  159. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
  160. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  161. * Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
  162. - PyQt4-4.5.2
  163. * Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
  164. - fix build with qt-4.5.2
  165. - PyQt4-devel multilib conflict (#509415)
  166. * Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
  167. - PyQt-4.5.1
  168. * Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
  169. - PyQt-4.5
  170. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
  171. - fix generation of sip_ver
  172. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
  173. - PyQt-4.5-snapshot-20090520
  174. * Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
  175. - rebuild for phonon bindings (#497680)
  176. * Thu Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
  177. - move designer plugins to main/runtime (#487622)
  178. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  180. * Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
  181. - rebuild against qt-4.5rc1
  182. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
  183. - Rebuild for Python 2.6
  184. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
  185. - PyQt-4.4.4
  186. * Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
  187. - PyQt-4.4.3
  188. * Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
  189. - PyQt4 is built without QtWebKit support (#451490)
  190. * Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
  191. - PyQt-4.4.2
  192. * Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
  193. - PyQt-4.4
  194. - License: GPLv3 or GPLv2 with exceptions
  195. * Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
  196. - respin (gcc43)
  197. * Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
  198. - PyQt-4.3.3
  199. * Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
  200. - dbus support (#395741)
  201. * Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
  202. - PyQt-4.3.1
  203. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
  204. - drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
  205. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
  206. - fix QtDesigner plugin install
  207. * Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
  208. - 64bit QtDesigner patch
  209. * Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
  210. - -devel: Requires: qt4-devel
  211. * Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
  212. - use %%python_sitearch
  213. - License: GPLv2
  214. * Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
  215. - fix python_sitelib typo (wrt chrpath call)
  216. - move %%_bindir stuff to -devel
  217. - mark %%doc examples non-executable
  218. - add shebang to %%_bindir/pyuic4
  219. * Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
  220. - remove rpath from QtDesigner.so
  221. - BR: qt4-devel > 4.3.0-8
  222. * Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
  223. - PyQt4-4.2
  224. * Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
  225. - fix build against multilib'd qt4
  226. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
  227. - PyQt4-4.1.1
  228. - BR: sip-devel >= 4.5.1
  229. * Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
  230. - PyQt4-4.1
  231. * Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
  232. - don't own %%_datadir/sip (bug #206633)
  233. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
  234. - BR: qt4-devel < 4.2
  235. * Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
  236. - fix reference(s) to qmake(4)
  237. * Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
  238. - PyQt-4.0.1
  239. * Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
  240. - PyQt-4.0(final)
  241. - BR: sip-devel >= 4.4.4 (see bug #199430)
  242. * Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
  243. - drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
  244. - drop usage of (undefined) %%sip_min
  245. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
  246. - cleanup for Extras
  247. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
  248. - 4.0beta1
  249. * Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
  250. - respin for sip-4.4.3
  251. - use sip-abi, sip-abi-min
  252. * Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
  253. - 20060421 snapshot
  254. * Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
  255. - first try, using 20060417 snapshot