TrueType-sazanami-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391
  1. # Command macros
  2. %define __mkfontdir umask 133;/usr/bin/mkfontdir
  3. %define __mkfontscale umask 133;/usr/bin/mkfontscale
  4. # Use this macro to call fc-cache throughout the specfile.
  5. %define __fccache umask 133;which fc-cache &> /dev/null && fc-cache -f
  6. %define version 4.2
  7. %define release 2%{?_dist_release}
  8. %define sazanami_date 20040629-vl-20061231
  9. %define ttfjp_version 6.0
  10. %define xfontdir %{_datadir}/fonts/TrueType-sazanami
  11. %define fontpathdir %{_sysconfdir}/X11/fontpath.d
  12. Summary: Free Japanese True Type Font (Sazanami)
  13. Summary(ja): フリーの日本語 True Type フォント(さざなみ明朝/さざなみゴシック)
  14. Name: TrueType-sazanami
  15. Version: %{version}
  16. Release: %{release}
  17. BuildArch: noarch
  18. Obsoletes: TrueTypeFonts_jp < 4.1
  19. Obsoletes: TrueType-kochi <= 4.4.1
  20. Provides: TrueType-kochi = %{ttfjp_version}
  21. Requires: %{name}-mincho = %{version}-%{release}
  22. Requires: %{name}-gothic = %{version}-%{release}
  23. # This is not really required, but usefull to upgrade.
  24. Requires: TrueType-vlgothic
  25. Source: %{name}.tar.bz2
  26. Source10: 60-sazanami-mincho.conf
  27. Source11: 60-sazanami-gothic.conf
  28. Source20: cidfmap.ja.sazanami-mincho
  29. Source21: cidfmap.ja.sazanami-gothic
  30. # Sazanami Font Family
  31. Source4: sazanami-%{sazanami_date}.tar.bz2
  32. License: distributable
  33. Group: User Interface/X
  34. Buildroot: %{_tmppath}/%{name}-root
  35. Distribution: Vine Linux
  36. Vendor: Project Vine
  37. Packager: daisuke
  38. %description
  39. This is meta package for Free Japanese True Type Font 'Sazanami Font'
  40. - Sazanami-Mincho
  41. - Sazanami-Gothic
  42. %description -l ja
  43. このパッケージはフリーの日本語 True Type フォント「さざなみフォント」
  44. の明朝、ゴシック両書体をインストールするためのメタパッケージです。この
  45. パッケージで以下のフォントがインストールされます。
  46. - さざなみ明朝
  47. - さざなみゴシック
  48. %package mincho
  49. Summary: Sazanami Mincho TrueType Fonts
  50. Summary(ja): さざなみ明朝 True Type フォント
  51. Group: User Interface/X
  52. Requires(post,postun): mktcapdir >= 0.5.4
  53. Requires(post,postun): fontconfig, xorg-x11-font-utils
  54. %description mincho
  55. This package includes Sazanami Mincho TrueType fonts.
  56. %description -l ja mincho
  57. このパッケージにはさざなみ明朝フォントが含まれています。
  58. %package gothic
  59. Summary: Sazanami Gothic TrueType Fonts
  60. Summary(ja): さざなみゴシック 日本語 True Type フォント
  61. Group: User Interface/X
  62. Requires(post,postun): mktcapdir >= 0.5.4
  63. Requires(post,postun): fontconfig, xorg-x11-font-utils
  64. %description gothic
  65. This package includes Sazanami Gothic TrueType fonts.
  66. %description -l ja gothic
  67. このパッケージにはさざなみゴシックフォントがふくまれています。
  68. %prep
  69. rm -rf ${RPM_BUILD_ROOT}
  70. %setup -n %{name} -a 4
  71. mv sazanami-%{sazanami_date}/* .
  72. %install
  73. # mkdir fontdirs
  74. mkdir -p $RPM_BUILD_ROOT/%{xfontdir}-{mincho,gothic}
  75. # install ttfconf
  76. install -m644 *-mincho.ttfconf *-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho
  77. install -m644 *-gothic.ttfconf *-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic
  78. # install fonts
  79. ln -sf sazanami-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho/kochi-mincho.ttf
  80. ln -sf sazanami-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic/kochi-gothic.ttf
  81. # install fontpath.d symlink
  82. mkdir -p $RPM_BUILD_ROOT/%{fontpathdir}
  83. ln -sf %{xfontdir}-mincho $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-mincho
  84. ln -sf %{xfontdir}-gothic $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-gothic
  85. # install fontconfig files
  86. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
  87. install -m644 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
  88. for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
  89. do
  90. ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
  91. done
  92. # install ghostscript8 cidfmap
  93. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
  94. install -m644 %{SOURCE20} %{SOURCE21} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
  95. %post mincho
  96. %{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
  97. ( %__fccache %{xfontdir}-mincho ) ||:
  98. %post gothic
  99. %{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
  100. ( %__fccache %{xfontdir}-gothic ) ||:
  101. %postun mincho
  102. %{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
  103. ( %__fccache %{xfontdir}-mincho ) ||:
  104. %postun gothic
  105. %{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
  106. ( %__fccache %{xfontdir}-gothic ) ||:
  107. %clean
  108. rm -rf $RPM_BUILD_ROOT
  109. %files
  110. %defattr(-,root,root)
  111. %doc README doc/
  112. %files mincho
  113. %defattr(-,root,root)
  114. %{xfontdir}-mincho/*
  115. %{fontpathdir}/%{name}-mincho
  116. %{_sysconfdir}/fonts/conf.avail/60-sazanami-mincho.conf
  117. %config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-mincho.conf
  118. %config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-mincho
  119. %files gothic
  120. %defattr(-,root,root)
  121. %{xfontdir}-gothic/*
  122. %{fontpathdir}/%{name}-gothic
  123. %{_sysconfdir}/fonts/conf.avail/60-sazanami-gothic.conf
  124. %config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-gothic.conf
  125. %config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-gothic
  126. %changelog
  127. * Sun Apr 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-2
  128. - remove R: TrueType-base
  129. - remove P: TrueTypeFonts_jp
  130. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-1
  131. - add gs8 cidfmap for sazanami
  132. * Sat Jun 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  133. - split mincho and gothic to its own fontdir
  134. - add fontpath.d symlink
  135. * Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
  136. - build for xorg-x11-7.3
  137. - change font location to %{_datadir}/fonts/TrueType-sazanami
  138. - require(post,postun) fontconfig and xorg-x11-font-utils
  139. - split to TrueType-sazanami-mincho and TrueType-sazanami-gothic
  140. * Sat Sep 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-0vl1
  141. - split out VLGothic to TrueType-vlgothic package.
  142. * Sat Sep 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
  143. - update VLGothic to 20070901
  144. - update some kanji glyphs
  145. * Thu Aug 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-0vl1
  146. - update VLGothic to 20070830
  147. - update M+1C/M+1M to CVS head
  148. - update some kanji glyphs
  149. * Mon Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-0vl1
  150. - update VLGothic to 20070731
  151. - update M+1C/M+1M to CVS head
  152. - add new glyphs to VL-PGothic/VL-Gothic
  153. - add Roman Numeral Glyphs (some part of Number Forms)
  154. - update some glyphs
  155. * Mon May 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-0vl1
  156. - update VLGothic to 20070507
  157. - add new glyphs to VL-Gothic
  158. - add ISO8859-1 Glyphs (Latin-1 Supplement)
  159. - add ISO8859-15 Glyphs (some part of Latin Extended-A)
  160. * Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-0vl1
  161. - update VLGothic to 20070506
  162. - add new glyphs to VL-PGothic
  163. - add ISO8859-1 Glyphs (Latin-1 Supplement)
  164. - add ISO8859-15 Glyphs (some part of Latin Extended-A)
  165. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
  166. - update VLGothic to 20070503
  167. - update M+1C/1M to CVS head
  168. * Wed Mar 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-0vl1
  169. - update VLGothic to 20070328
  170. - update M+1C/1M to CVS head
  171. - fix embolden problem on freetype-2.2
  172. * Sat Mar 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-0vl1
  173. - update VLGothic to 20070317
  174. - update M+1C/1M to CVS head
  175. - include M+ Kanji glyphs
  176. - update some glyphs
  177. - add some special sign characters
  178. - fix broken glyphs
  179. * Mon Jan 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-0vl1
  180. - update VLGothic to 20070101
  181. - fix embolden problem on freetype-2.2
  182. * Sun Dec 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-0vl1
  183. - update VLGothic to 20061231
  184. - update M+1C/M+1M to cvs head 20061231
  185. - update kanji glyphs
  186. - update Sazanami to 20040629-vl-20061231
  187. - fix broken glyphs of sazanami-mincho
  188. * Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl1
  189. - bump up version to 2.0
  190. - update VLGothic to 20061026
  191. - update greek letter glyphs
  192. - split license information file from README.
  193. - add english version of license.
  194. * Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
  195. - update VLGothic to 20061021
  196. * Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28-0vl1
  197. - update VLGothic to 20061020 (<BTS:221>)
  198. - update M+1C/M+1M to TESTFILGHT012
  199. - update some glyphs
  200. - fix outline direction
  201. - remove overlap path
  202. * Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-0vl1
  203. - update VLGothic to 20061005 (<BTS:221>)
  204. - update some glyphs
  205. - fix outline direction
  206. - remove overlap path
  207. * Sat Sep 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26-0vl1
  208. - update VLGothic to 20060930 (<BTS:221>)
  209. - fix outline direction
  210. - remove overlap path
  211. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.25-0vl1
  212. - update VLGothic to 20060929
  213. - update some glyphs
  214. - fix outline direction
  215. - remove overlap path
  216. * Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24-0vl1
  217. - update VLGothic to 20060925
  218. - update some glyphs
  219. - add minimum gsub table for vertical writing
  220. * Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.23-0vl1
  221. - update VLGothic to 20060921
  222. - update few glyphs
  223. - update M+1C/M+1M to cvs head 2006/09/21
  224. * Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-0vl1
  225. - update VLGothic to 20060913
  226. - update some glyphs
  227. - fix half width space
  228. * Mon Sep 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-0vl1
  229. - update VLGothic to 20060911
  230. - update M+1C/M+1M to cvs head 2006/09/11
  231. - use VL-PGothic for -alias-gothic-p- (legacy core font)
  232. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-0vl1
  233. - update VLGothic to 20060831
  234. - add VL-Gothic-Regular.ttf for
  235. - use M+1C for VLPGothic instead of M+1P
  236. * Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19-0vl1
  237. - fix sazanami.ttfconf
  238. * Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18-0vl1
  239. - change the fontname to VLPGothic
  240. - update VLPGothic
  241. - TODO:
  242. - split VLGothic family to new package.
  243. - add M+1M based VLGothic for monospace font.
  244. * Wed Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17-0vl1
  245. - update M+1P+Sazanami.ttf
  246. - refine more glyphs
  247. * Wed Aug 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-0vl1
  248. - update M+1P+Sazanami.ttf
  249. - refine more glyphs
  250. - add some glyphs for windows compatibility
  251. - update sazanami.ttfconf
  252. - add -fake-kochi gothic-, -fake-kochi mincho- without TTCap
  253. for Flash Plugin. (<BTS:0100>)
  254. * Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15-0vl1
  255. - update M+1P+Sazanami.ttf
  256. - refine more glyphs
  257. - add new full-width alphabets and numeric letters based on M+1P
  258. * Mon Jul 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
  259. - update M+1P+Sazanami.ttf
  260. - refine more glyphs
  261. * Sun Jul 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13-0vl1
  262. - update M+1P+Sazanami.ttf
  263. - refine more glyphs
  264. - redesign greek letter based on M+ 1P fonts
  265. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl1
  266. - update M+1P+Sazanami.ttf
  267. - refine more glyphs
  268. * Sun Jul 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11-0vl1
  269. - update M+1P+Sazanami.ttf
  270. - refine more glyphs
  271. * Fri Jul 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-0vl1
  272. - update M+1P+Sazanami.ttf
  273. - refine more glyphs
  274. - fix encoding
  275. * Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-0vl1
  276. - update M+1P+Sazanami.ttf
  277. - refine more glyphs
  278. - fix outline direction (fix corruption on emboldening)
  279. * Wed Jul 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
  280. - update M+1P+Sazanami.ttf
  281. - refine more glyphs
  282. - fix broken glyph
  283. - refine greek letters
  284. * Tue Jul 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
  285. - update M+1P+Sazanami.ttf
  286. - refine more glyphs
  287. - TODO: should rename the fontname?
  288. * Sun Jul 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
  289. - update M+1P+Sazanami.ttf
  290. - fix outline direction (fix corruption of some glyphs)
  291. - refine more glyphs
  292. * Wed Jul 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
  293. - update M+1P+Sazanami.ttf
  294. - refine some glyphs.. (modified 200 or more)
  295. - update sazanami.ttfconf to use M+1P+Sazanami for alias-{sans,gothic}-p
  296. * Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
  297. - update M+1P+Sazanami.ttf
  298. - refine some glyphs.. (modified 100 or more)
  299. * Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
  300. - update M+1P-Sazanami.ttf
  301. - fix corruption of some glyphs
  302. - refine some glyphs to make it more usable..
  303. * Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
  304. - add M+1P+Sazanami.ttf (Mplus 1P Font + Sazanami Gothic)
  305. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
  306. - new upstream release
  307. * Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  308. - initial build for Vine Linux based on TrueType-kochi-subst package
  309. - Provides TrueType-kochi, TrueTypeFonts_jp
  310. - include Kochi-{mincho,gothic}.ttf symlinks for compatibility