accerciser-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. %{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
  2. %define pkg_version 3.8.2
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: An interactive Python accessibility explorer for the GNOME desktop.
  5. Summary(ja): GNOME デスクトップ用 Python アクセシビリティエクスプローラ
  6. Name: accerciser
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. Source0: http://ftp.gnome.org/pub/GNOME/sources/accerciser/3.8/%{name}-%{version}.tar.xz
  10. License: BSD
  11. Group: Desktop/Accessibility
  12. URL: http://live.gnome.org/Accerciser
  13. Requires: python3 >= 3.2
  14. Requires: python3-pygobject >= 2.90.3
  15. Requires: python3-pyatspi >= 2.5.2
  16. Requires: at-spi2-core
  17. Requires(post): desktop-file-utils
  18. Requires(postun): desktop-file-utils
  19. BuildRequires: python3-devel >= 3.2
  20. BuildRequires: python3-pygobject-devel
  21. BuildRequires: gtk3-devel
  22. BuildRequires: at-spi2-core-devel
  23. BuildRequires: python3-pyatspi
  24. BuildRequires: glib2-devel >= 2.26.0
  25. BuildRequires: docbook-dtds
  26. BuildRequires: yelp-tools
  27. BuildRequires: autoconf
  28. BuildRequires: gnome-common
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: Takemikaduchi
  33. %description
  34. Accerciser is an interactive Python accessibility explorer for the GNOME
  35. desktop. It uses AT-SPI to inspect and control widgets, allowing you to check
  36. if an application is providing correct information to assistive technologies
  37. and automated test frameworks. Accerciser has a simple plugin framework which
  38. you can use to create custom views of accessibility information.
  39. %prep
  40. %setup -q
  41. %build
  42. %configure --disable-static
  43. %{__make} %{?_smp_mflags}
  44. %install
  45. %{__rm} -rf ${RPM_BUILD_ROOT}
  46. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  47. %find_lang %{name} --with-gnome --all-name
  48. %clean
  49. %{__rm} -rf ${RPM_BUILD_ROOT}
  50. %post
  51. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  52. update-desktop-database & > /dev/null || :
  53. %postun
  54. if [ $1 -eq 0 ]; then
  55. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  56. update-desktop-database & > /dev/null || :
  57. glib-compile-schemas %{_datadir}/glib-2.0/schemas
  58. fi
  59. %posttrans
  60. glib-compile-schemas %{_datadir}/glib-2.0/schemas
  61. %files -f %{name}.lang
  62. %defattr(-,root,root)
  63. %doc AUTHORS COPYING ChangeLog NEWS README
  64. %{_bindir}/accerciser
  65. %{python3_sitelib}/accerciser
  66. %{_datadir}/applications/accerciser.desktop
  67. %{_datadir}/accerciser/*
  68. %{_datadir}/glib-2.0/schemas/*.xml
  69. %{_datadir}/icons/hicolor/*/apps/*
  70. %{_datadir}/icons/HighContrast/*/apps/*
  71. %{_mandir}/man1/accerciser.1.gz
  72. %changelog
  73. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-2
  74. - change BuildRequires: python3-pygobject-devel instead of pygobject3
  75. - change BuildRequires: python3-pyatspi instead of pyatspi
  76. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  77. - new upstream release
  78. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  79. - new upstream release
  80. - add BuildRequires: autoconf, gnome-common
  81. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  82. - new upstream release
  83. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  84. - new upstream release
  85. - change BuildRequires: yelp-tools instead of gome-doc-utils
  86. * Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
  87. - new upstream release
  88. - remove BuildRequires: GConf2-devel
  89. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  90. - new upstream release
  91. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  92. - new upstream release
  93. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  94. - new upstream release
  95. - add BuildRequires: gtk3-devel, pygobject3-devel
  96. - change BuildRequires: at-spi2-core-devel instead of at-spi-devel
  97. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.5-1
  98. - new upstream release
  99. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  100. - new upstream release
  101. * Mon May 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
  102. - new upstream release
  103. * Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  104. - initial build for Vine Linux