asymptote-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define texmf %{_datadir}/texmf
  4. %define build_texmf %{buildroot}%{texmf}
  5. %define exec_texhash [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
  6. %define emacspkg asy-mode
  7. Name: asymptote
  8. Version: 2.15
  9. Release: 1%{?_dist_release}
  10. Summary: Descriptive vector graphics language
  11. Summary(ja): MetaPost に触発されたスクリプトベースのベクターグラフィック言語
  12. Group: Applications/Publishing
  13. License: GPLv3+
  14. URL: http://asymptote.sourceforge.net/
  15. Source0: http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
  16. Source1: asy.gif
  17. Source2: xasy.desktop
  18. #Source3: asymptote.sty.204
  19. Source11: %{emacspkg}-install.sh
  20. Source12: %{emacspkg}-remove.sh
  21. #Source13: %{name}-init.el
  22. #Patch0: asymptote-2.00-settings.patch
  23. %if %{?_dist_release} == "vl6"
  24. Patch0: asymptote-2.00-settings-vine-vl6.patch
  25. %else
  26. Patch0: asymptote-2.00-settings-vine-vl7.patch
  27. %endif
  28. Patch2: asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
  29. # This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
  30. Patch3: asymptote-2.08-info-path-fix.patch
  31. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  32. BuildRequires: ncurses-devel
  33. BuildRequires: readline-devel
  34. BuildRequires: fftw3-devel >= 3.0
  35. BuildRequires: gc-devel >= 6.8
  36. BuildRequires: gsl-devel
  37. BuildRequires: texlive-common
  38. BuildRequires: texlive-collection-texinfo
  39. BuildRequires: texlive-collection-genericrecommended
  40. BuildRequires: ghostscript
  41. BuildRequires: texinfo
  42. BuildRequires: ImageMagick
  43. BuildRequires: desktop-file-utils
  44. BuildRequires: freeglut-devel
  45. BuildRequires: zlib-devel
  46. BuildRequires: libtool
  47. Requires: texlive-common
  48. Requires(post): desktop-file-utils
  49. Requires(postun): desktop-file-utils
  50. # for /usr/bin/texhash and /sbin/install-info
  51. Requires(post): texlive, info
  52. Requires(postun): texlive, info
  53. %define texpkgdir %{texmf}/tex/latex/%{name}
  54. %description
  55. Asymptote is a powerful descriptive vector graphics language for technical
  56. drawings, inspired by MetaPost but with an improved C++-like syntax.
  57. Asymptote provides for figures the same high-quality level of typesetting
  58. that LaTeX does for scientific text.
  59. This package is custmized for Japanese.
  60. - added eplatex, platex to latex engines
  61. - use pdvips as dvips command
  62. %description -l ja
  63. Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
  64. テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
  65. Asymptote は科学的なテキストに対して LaTeX がしている組版のと
  66. 同じくらい高品質なレベルの図を提供します.
  67. このパッケージは日本語向けにカスタマイズされています.
  68. - latex エンジンに eplatex, platex を追加
  69. - dvips コマンドとして pdvips を使う
  70. %package gui
  71. Summary: A graphical interface for Asymptote
  72. Summary(ja): Asymptote のためのグラフィカルインターフェース
  73. Group: Applications/Graphics
  74. Requires: %{name} = %{version}-%{release}
  75. Requires: tkinter
  76. Requires: python-imaging
  77. BuildArch: noarch
  78. %description gui
  79. A graphical interface for Asymptote
  80. %package -n %{emacspkg}
  81. Summary: Emacs mode for editing Asymptote source code
  82. Summary(ja): Asymptote ソースコードを編集するための Emacs モード
  83. Group: Applications/Editors/Emacs
  84. Requires: %{name} = %{version}-%{release}
  85. BuildRequires: emacsen
  86. %prereq_ge emacsen-common
  87. BuildArch: noarch
  88. %description -n %{emacspkg}
  89. Emacs mode for editing Asymptote source code
  90. %prep
  91. %setup -q
  92. %patch0 -p1 -b .settings
  93. %patch2 -p1 -b .DSO
  94. %patch3 -p1 -b .path-fix
  95. %{__sed} -i 's/\r//' doc/CAD1.asy
  96. # convert to UTF-8
  97. iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
  98. %__mv examples/interpolate1.asy{.utf8,}
  99. autoreconf -i
  100. %build
  101. %configure \
  102. --enable-gc=system \
  103. --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
  104. --with-latex=%{texmf}/tex/latex \
  105. --with-context=%{texmf}/tex/context \
  106. ;
  107. %__make %{?_smp_mflags}
  108. cd doc/
  109. %__make asy-latex.pdf
  110. %__make all
  111. %install
  112. %__rm -rf $RPM_BUILD_ROOT
  113. %__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
  114. %__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
  115. $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
  116. # # Vim syntax file
  117. # for vimver in 63 64 70 71 ; do
  118. # install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  119. # cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
  120. # ln -s ../../../%{name}/asy.vim .
  121. # done
  122. # Move info file
  123. %__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
  124. # copy icon to pixmaps dir
  125. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  126. %__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
  127. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
  128. desktop-file-install --vendor "vine" \
  129. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  130. %{SOURCE2}
  131. # Clean up symlink
  132. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
  133. cd $RPM_BUILD_ROOT%{_bindir}
  134. %__ln_s ../share/%{name}/GUI/xasy.py xasy
  135. ## <asy-mode>
  136. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
  137. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  138. %__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  139. #
  140. # install el files
  141. #
  142. # install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  143. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}
  144. # ln -s ../../%{name}/asy-{mode,keywords}.el .
  145. # cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
  146. # ln -s ../../../%{name}/asy-init.el .
  147. %__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
  148. $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
  149. #
  150. # install script (bytecompile el and install elc, remove)
  151. #
  152. %_installemacsenscript %{name} %{SOURCE11}
  153. %_removeemacsenscript %{name} %{SOURCE12}
  154. ## </asy-mode>
  155. %clean
  156. %__rm -rf $RPM_BUILD_ROOT
  157. %post
  158. /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
  159. /sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
  160. %{exec_texhash}
  161. %post -n %{emacspkg}
  162. if [ "$1" = 2 ]; then
  163. %_emacsenPackageRemove %{name}
  164. fi
  165. %_addemacsenlist %{name}
  166. %_emacsenPackageInstall %{name}
  167. %postun
  168. if [ $1 = 0 ]; then
  169. /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
  170. /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
  171. %{exec_texhash}
  172. fi
  173. %preun -n %{emacspkg}
  174. if [ "$1" = 0 ]; then
  175. %_emacsenPackageRemove %{name}
  176. %_removeemacsenlist %{name}
  177. fi
  178. %files
  179. %defattr(-,root,root,-)
  180. %doc %{_defaultdocdir}/%{name}-%{version}/
  181. %{_bindir}/asy
  182. %{_datadir}/%{name}/
  183. %exclude %{_datadir}/asymptote/GUI/
  184. %{texpkgdir}/
  185. %{texmf}/tex/context/
  186. %{_mandir}/man1/*.1*
  187. %{_infodir}/*.info*
  188. ##%{_datadir}/vim/vim*/syntax/asy.vim
  189. %files gui
  190. %{_bindir}/xasy
  191. %{_datadir}/applications/vine-xasy.desktop
  192. %{_datadir}/pixmaps/asy.gif
  193. %{_datadir}/asymptote/GUI/
  194. %{_mandir}/man*/xasy.*
  195. %files -n %{emacspkg}
  196. %defattr(-,root,root)
  197. %{_datadir}/emacs/site-lisp/%{name}
  198. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  199. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  200. %changelog
  201. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15-1
  202. - new upstream release
  203. - added asymptote-2.00-settings-vine-vl7.patch (vl7)
  204. - For vl6, renamed asymptote-2.00-settings-vine.patch as
  205. asymptote-2.00-settings-vine-vl6.patch
  206. - TeX Live 2011
  207. * Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
  208. - new upstream release
  209. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
  210. - TeX Live 2009
  211. * Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
  212. - rebuilt with new toolchain, libsigsegv-2.8
  213. - appled Patch1 again
  214. * Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
  215. - don't apply Patch1 until gcc44 comes to VineSeed
  216. * Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
  217. - separated Xasy to gui subpackage
  218. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
  219. - initial build based on Fedora Development (fc11) package
  220. - applied asymptote-1.70-settings-vine.patch
  221. * Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
  222. - update to 1.70
  223. * Tue Apr 7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
  224. - update to 1.69
  225. * Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
  226. - update to 1.68
  227. * Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
  228. - update to 1.67
  229. * Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
  230. - update to 1.66
  231. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
  232. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  233. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
  234. - more gcc44 fixes with BIG_ENDIAN platforms
  235. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
  236. - fix gcc44 issue with BIG_ENDIAN platforms
  237. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
  238. - forgot to put in new source
  239. * Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
  240. - 1.63
  241. * Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
  242. - 1.60
  243. * Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
  244. - 1.59
  245. * Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
  246. - 1.58
  247. * Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
  248. - 1.57
  249. * Tue Dec 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
  250. - 1.56
  251. * Tue Dec 2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
  252. - 1.54
  253. * Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
  254. - 1.52
  255. * Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
  256. - update to 1.51
  257. * Mon Nov 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
  258. - update to 1.49
  259. * Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
  260. - update to 1.47
  261. * Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
  262. - update to 1.46
  263. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
  264. - add missing BuildRequires
  265. * Mon Oct 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
  266. - update to 1.44
  267. * Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
  268. - update to 1.43
  269. * Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
  270. - explicitly call "make asymptote.pdf" in doc/
  271. * Fri Apr 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
  272. - fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
  273. * Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
  274. - update to 1.42
  275. * Wed Feb 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
  276. - update to 1.41
  277. - enable desktop file for xasy
  278. * Thu Jan 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
  279. - bump to 1.37
  280. - fix gcc43 failures
  281. - drop triggers
  282. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
  283. - Rebuild for selinux ppc32 issue.
  284. * Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
  285. - Update 1.33.
  286. * Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
  287. - Update to 1.32.
  288. - vim-common triggers: correction and improvements (#246131).
  289. * Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
  290. - Update to 1.31.
  291. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
  292. - Update to 1.30.
  293. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
  294. - Using "evince" as the default PS and PDF viewers (#244151).
  295. (patch file: asymptote-1.29-settings.patch)
  296. - Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
  297. - Use relative symbolic links in the vim-common triggers.
  298. * Sat Jun 2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
  299. - Add asy-faq to install-info (#155750).
  300. - Add support for vim 7.1.
  301. * Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
  302. - Update to 1.29.
  303. * Tue May 8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
  304. - Update to 1.28.
  305. * Sat May 5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
  306. - Update to 1.27.
  307. * Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
  308. - Update to 1.26.
  309. * Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
  310. - Update to 1.25.
  311. * Sun Apr 1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
  312. - Update to 1.24.
  313. * Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
  314. - Update to 1.23.
  315. * Tue Mar 6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
  316. - Update to 1.22.
  317. * Sat Mar 3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
  318. - Update to 1.21.
  319. * Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
  320. - Update to 1.20.
  321. * Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
  322. - Update to 1.19.
  323. * Sun Nov 5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
  324. - Update to 1.18.
  325. * Wed Nov 1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
  326. - Update to 1.17.
  327. * Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
  328. - Update to 1.16.
  329. * Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
  330. - Update to 1.15.
  331. * Wed Sep 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
  332. - Update to 1.13.
  333. * Thu Aug 3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
  334. - Update to 1.12.
  335. * Thu Jul 6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
  336. - Update to 1.11.
  337. * Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
  338. - Update to 1.10.
  339. * Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
  340. - Update to 1.09.
  341. * Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
  342. - Update to 1.08.
  343. - Also installs the info file.
  344. * Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
  345. - Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
  346. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
  347. - Group: Development/Tools -> Applications/Publishing (#193154).
  348. * Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
  349. - Emacs/Xemacs init file (#193154 comment 6).
  350. * Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
  351. - Directories ownership (#193154).
  352. * Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
  353. - Update to 1.06.
  354. - Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
  355. * Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  356. - Update to 1.05.
  357. * Sun May 7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
  358. - Update to 1.04.
  359. * Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  360. - Update to 1.03.
  361. * Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
  362. - First build.
  363. # vim:set ai ts=4 sw=4 sts=4 et: