audacious-plugins-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471
  1. # Now, these features provide self-build-audacious-plugins-extra package
  2. # to enable features, rpmbuild with '--with feature'
  3. #define with_aac %{?_with_aac:1}%{!?_with_aac:0}
  4. #define with_wma %{?_with_wma:1}%{!?_with_wma:0}
  5. #define with_lame %{?_with_lame:1}%{!?_with_lame:0}
  6. %define _audacious_ver 2.3-1%{?_dist_release}
  7. %define _gtk2_ver 2.8.0
  8. %define _glib2_ver 2.12.0
  9. # to build OSD plugin, pango >= 1.14.7, cairo >= 1.2.6 are required
  10. %define _pango_ver 1.14.7
  11. %define _esound_ver 0.2
  12. %define _libvorbis_ver 1.0
  13. %define _libogg_ver 1.0
  14. %define _libsndfile_ver 0.19
  15. %define _flac_ver 1.2.0
  16. %define _alsa_ver 1.0
  17. %define _libxml2_ver 2.0.0
  18. %define _sdl_ver 1.2.5
  19. %define _libmtp_ver 0.3.5
  20. #define extraver alpha5
  21. %define plugindir %{_libdir}/audacious
  22. Summary: Audacious Media Player plugins
  23. Summary(ja): Audacious メディアプレイヤー プラグイン集
  24. Name: audacious-plugins
  25. Version: 2.3
  26. Release: 3%{?_dist_release}
  27. # LGPLv2+: adplug, bio2jack, rocklight
  28. # MIT: crystalizer, dockalbumart
  29. # BSD: lastfm
  30. License: GPLv2 and GPLv2+ and LGPLv2+ and MIT and BSD
  31. Group: Applications/Multimedia
  32. URL: http://audacious-media-player.org/
  33. Source: http://distfiles.atheme.org/audacious-plugins-%{version}%{?extraver:-%extraver}.tgz
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. BuildRequires: audacious-devel >= %{_audacious_ver}
  36. BuildRequires: glib2-devel >= %{_glib2_ver}
  37. BuildRequires: gtk2-devel >= %{_gtk2_ver}
  38. BuildRequires: pango-devel >= %{_pango_ver}
  39. BuildRequires: dbus-devel >= 0.80
  40. BuildRequires: dbus-glib-devel >= 0.60
  41. BuildRequires: libmowgli-devel >= 0.4.0
  42. BuildRequires: esound-devel >= %{_esound_ver}
  43. BuildRequires: pulseaudio-libs-devel >= 0.9.9
  44. BuildRequires: libshout-devel >= 2.0.0
  45. BuildRequires: lirc
  46. BuildRequires: libogg-devel >= %{_libogg_ver}
  47. BuildRequires: libvorbis-devel >= %{_libvorbis_ver}
  48. BuildRequires: flac-devel >= %{_flac_ver}
  49. BuildRequires: libsndfile-devel >= %{_libsndfile_ver}
  50. BuildRequires: jack-audio-connection-kit-devel
  51. BuildRequires: alsa-lib-devel >= %{_alsa_ver}
  52. BuildRequires: libcdio-devel >= 0.70
  53. BuildRequires: libcddb-devel >= 1.2.1
  54. BuildRequires: neon-devel >= 0.26
  55. BuildRequires: libmtp-devel >= %{_libmtp_ver}
  56. # bluetooth plugin has been broken by the output plugin on-demand work
  57. #BuildRequires: bluez-libs-devel
  58. BuildRequires: libxml2-devel >= %{_libxml2_ver}
  59. BuildRequires: libprojectm-devel
  60. BuildRequires: SDL-devel >= %{_sdl_ver}
  61. BuildRequires: gtkglext-devel
  62. BuildRequires: libsamplerate-devel
  63. BuildRequires: mesa-libGLU-devel
  64. BuildRequires: libSM-devel
  65. BuildRequires: libXmu-devel
  66. BuildRequires: libXt-devel
  67. BuildRequires: wavpack-devel
  68. Requires: audacious >= %{_audacious_ver}
  69. Requires: glib2 >= %{_glib2_ver}, gtk2 >= %{_gtk2_ver}
  70. Requires: pango >= %{_pango_ver}
  71. Requires: libvorbis >= %{_libvorbis_ver}
  72. Requires: libogg >= %{_libogg_ver}
  73. Requires: libsndfile >= %{_libsndfile_ver}
  74. Requires: alsa-lib >= %{_alsa_ver}
  75. Requires: libxml2 >= %{_libxml2_ver}
  76. Requires(post): /sbin/update-alternatives
  77. Requires(postun): /sbin/update-alternatives
  78. Obsoletes: audacious < 1.2.0
  79. Obsoletes: beepmp, beepmp-alsa
  80. Vendor: Project Vine
  81. Distribution: Vine Linux
  82. %description
  83. Audacious is a media player that currently uses a skinned user interface
  84. based on Winamp 2.x skins.
  85. This package provides essential plugins for audio input, audio output and
  86. visualization.
  87. %package -n audacious-jack
  88. Summary: Audacious output plugin for JACK sound service
  89. Group: Applications/Multimedia
  90. Requires: audacious >= %{_audacious_ver}
  91. %description -n audacious-jack
  92. This package provides an Audacious output plugin that uses the
  93. JACK sound service.
  94. %package -n audacious-flac
  95. Summary: Audacious plugin to play FLAC files
  96. Summary(ja): FLAC ファイルを再生するための Audacious プラグイン
  97. Group: Applications/Multimedia
  98. Requires: audacious >= %{_audacious_ver}
  99. Requires: flac >= %{_flac_ver}
  100. Obsoletes: beepmp-flac
  101. %description -n audacious-flac
  102. This package contains a input plugin that enables playback of FLAC files
  103. in Audacious.
  104. %description -l ja -n audacious-flac
  105. このパッケージには、Audacious で FLAC ファイル (*.flac/fla) を再生するため
  106. の入力プラグインが含まれています。
  107. %package -n audacious-esd
  108. Summary: Audacious plugin to output audio via EsounD
  109. Summary(ja): Audacious EsounD オーディオ出力プラグイン
  110. Group: Applications/Multimedia
  111. Requires: audacious >= %{_audacious_ver}
  112. Requires: esound >= %{_esound_ver}
  113. %description -n audacious-esd
  114. This package contains an audio output plugin via EsounD for Audacious.
  115. %description -l ja -n audacious-esd
  116. このパッケージには、Audacious で EsounD を用いて音声を出力するための
  117. プラグインが含まれています。
  118. %package -n audacious-visualization
  119. Summary: Audacious visualization plugins
  120. Summary(ja): Audacious 視覚化プラグイン
  121. Group: Applications/Multimedia
  122. Requires: audacious >= %{_audacious_ver}
  123. Requires: SDL >= %{_sdl_ver}
  124. Requires: libprojectm
  125. Obsoletes: audacious-paranormal
  126. %description -n audacious-visualization
  127. This package contains extra visualization plugin for Audacious.
  128. %description -l ja -n audacious-visualization
  129. このパッケージには、Audacious で再生した音声を視覚化する追加のプラグインが
  130. 含まれています。
  131. %prep
  132. %setup -q -n %{name}-%{version}%{?extraver:-%extraver}
  133. %build
  134. %configure \
  135. --enable-ipv6 \
  136. --enable-chardet \
  137. --disable-aac \
  138. --disable-ffaudio \
  139. --disable-filewriter_mp3 \
  140. --disable-mp3
  141. %__make %{_smp_mflags} VERBOSE=1
  142. %install
  143. %__rm -rf %{buildroot}
  144. %__make DESTDIR=%{buildroot} install
  145. # rename for alternatives
  146. pushd $RPM_BUILD_ROOT%{plugindir}/Output/
  147. mkdir filewriter
  148. mv filewriter.so filewriter/plus.so
  149. popd
  150. %find_lang %{name}
  151. %clean
  152. %__rm -rf %{buildroot}
  153. %post
  154. /sbin/update-alternatives --install \
  155. %{plugindir}/Output/filewriter.so \
  156. filewriter.so \
  157. %{plugindir}/Output/filewriter/plus.so 10
  158. %postun
  159. if [ $1 = 0 ]; then
  160. /sbin/update-alternatives --remove filewriter.so %{plugindir}/Output/filewriter/plus.so
  161. /sbin/update-alternatives --auto filewriter.so
  162. fi
  163. %posttrans
  164. # fix broken symlink if it's there
  165. if [ ! -f %{plugindir}/Output/filewriter.so ] ; then
  166. /sbin/update-alternatives --auto filewriter.so
  167. fi
  168. %files -f %{name}.lang
  169. %defattr(-,root,root,-)
  170. %doc AUTHORS COPYING
  171. # container plugins
  172. %{plugindir}/Container/m3u.so
  173. %{plugindir}/Container/pls.so
  174. %{plugindir}/Container/xspf.so
  175. # effect plugins
  176. %{plugindir}/Effect/compressor.so
  177. %{plugindir}/Effect/crystalizer.so
  178. %{plugindir}/Effect/echo.so
  179. %{plugindir}/Effect/ladspa.so
  180. %{plugindir}/Effect/resample.so
  181. %{plugindir}/Effect/sndstretch.so
  182. %{plugindir}/Effect/stereo.so
  183. %{plugindir}/Effect/voice_removal.so
  184. # general plugins
  185. %{plugindir}/General/alarm.so
  186. %{plugindir}/General/aosd.so
  187. #{plugindir}/General/bluetooth.so
  188. %{plugindir}/General/cd-menu-items.so
  189. %{plugindir}/General/evdev-plug.so
  190. %{plugindir}/General/gnomeshortcuts.so
  191. %{plugindir}/General/gtkui.so
  192. %{plugindir}/General/hotkey.so
  193. %{plugindir}/General/lirc.so
  194. %{plugindir}/General/mtp_up.so
  195. %{plugindir}/General/skins.so
  196. %{plugindir}/General/song_change.so
  197. %{plugindir}/General/statusicon.so
  198. %{plugindir}/General/streambrowser.so
  199. %{plugindir}/General/vfstrace.so
  200. # input plugins
  201. #{plugindir}/Input/alac.so
  202. %{plugindir}/Input/amidi-plug.so
  203. %{plugindir}/Input/amidi-plug/ap-alsa.so
  204. %{plugindir}/Input/cdaudio-ng.so
  205. %{plugindir}/Input/console.so
  206. #{plugindir}/Input/cuesheet_ng.so
  207. #{plugindir}/Input/demac.so
  208. #{plugindir}/Input/madplug.so
  209. %{plugindir}/Input/metronom.so
  210. %{plugindir}/Input/modplug.so
  211. %exclude %{plugindir}/Input/psf2.so
  212. %{plugindir}/Input/sndfile.so
  213. %{plugindir}/Input/tonegen.so
  214. %{plugindir}/Input/vorbis.so
  215. %{plugindir}/Input/vtx.so
  216. %{plugindir}/Input/wavpack.so
  217. %exclude %{plugindir}/Input/xsf.so
  218. # output plugins
  219. %{plugindir}/Output/alsa.so
  220. %{plugindir}/Output/OSS.so
  221. %{plugindir}/Output/crossfade.so
  222. #{plugindir}/Output/filewriter.so
  223. %{plugindir}/Output/filewriter/plus.so
  224. %{plugindir}/Output/icecast.so
  225. %{plugindir}/Output/null.so
  226. %{plugindir}/Output/pulse_audio.so
  227. # transport plugins
  228. %{plugindir}/Transport/gio.so
  229. %{plugindir}/Transport/neon.so
  230. %{plugindir}/Transport/unix-io.so
  231. # visualization plugins
  232. %{plugindir}/Visualization/blur_scope.so
  233. %{plugindir}/Visualization/spectrum.so
  234. %dir %{_datadir}/audacious
  235. %{_datadir}/audacious/images/bookmarks.png
  236. %{_datadir}/audacious/images/shoutcast.png
  237. %{_datadir}/audacious/images/streambrowser-*.png
  238. %{_datadir}/audacious/images/xiph.png
  239. # skins
  240. %{_datadir}/audacious/Skins/*
  241. %files -n audacious-jack
  242. %defattr(-,root,root,-)
  243. %{plugindir}/Output/jackout.so
  244. %files -n audacious-flac
  245. %defattr(-,root,root,-)
  246. %{plugindir}/Input/flacng.so
  247. %files -n audacious-esd
  248. %defattr(-,root,root,-)
  249. %{plugindir}/Output/ESD.so
  250. %files -n audacious-visualization
  251. %defattr(-,root,root,-)
  252. %{plugindir}/Visualization/paranormal.so
  253. %{plugindir}/Visualization/rocklight.so
  254. %{plugindir}/Visualization/projectm-1.0.so
  255. %{_datadir}/audacious/paranormal
  256. %changelog
  257. * Tue Feb 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.3-3
  258. - rebuild with Vine6 environment
  259. - add BuildRequires: libSM-devel, libXmu-devel, libXt-devel, wavpack-devel
  260. * Sat Jun 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3-2
  261. - rebuilt with libprojectm-2.0.1
  262. - added BR: libshout-devel
  263. - renamed filewriter.so for alternatives (audacious-lame)
  264. * Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3-1
  265. - new upstream release
  266. - remove BR: arts-devel
  267. - added BR: libcdio-devel, libcddb-devel
  268. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-1
  269. - new upstream release
  270. - added --disable-mp3 options
  271. * Tue Apr 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.1-4
  272. - add BuildRequires: libmtp-devel >= 0.3.5
  273. - add Patch10 to fix mtp.c for API changes on libmtp >= 0.3.0
  274. * Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-3
  275. - rebuilt with libmowgli-0.7.0
  276. * Sat Mar 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.1-2
  277. - add BuildRequires: libsamplerate-devel and mesa-libGLU-devel
  278. - add BuildRequires: neon-devel, lirc and pulseaudio-libs-devel
  279. * Sat Dec 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-1vl5
  280. - new upstream release
  281. * Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.5-1vl5
  282. - applied new versioning policy, spec in utf-8
  283. * Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.3.5-0vl2
  284. - add Obsoletes: beepmp, beepmp-alsa
  285. - add Obsoletes: beepmp-flac to audacious-flac package
  286. - add Obsoletes: audioscrobbler-beepmp to audacious-scrobbler package
  287. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-0vl1
  288. - new upstream release
  289. - rebuilt with flac-1.2.0
  290. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.4-0vl1
  291. - new upstream release
  292. - build with new environment/toolchain
  293. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  294. - new upstream release
  295. * Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
  296. - new upstream release
  297. - update ja.po (source1)
  298. - update %%_audacious_ver
  299. - overwrite POTFILES.in (source3)
  300. - 1.3.0 contains old version of POTFILES.in
  301. - drop obsolete id3tag.h.patch (patch0)
  302. - drop BuildRequires: libglade2-devel, taglib-devel
  303. - add %%with_lame macro
  304. - enable lame plugin if rpmbuild with '--with lame'
  305. * Thu Feb 22 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5.1
  306. - add BuildRequires: libmad-devel
  307. - add id3tag.h.patch (patch0)
  308. * Wed Feb 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5
  309. - update to 1.3.0alpha5
  310. - update ja.po (source1)
  311. - update %%_audacious_ver
  312. - drop obsolete avoid-null-dereference.patch (patch0)
  313. - drop BuildRequires: libid3tag-devel
  314. - NOTE: taglib is not used, but required in configure.ac
  315. - add plugin to core package
  316. - libmadplug.so instead of libmpg123.so (Input)
  317. - move plugin to visualization package
  318. - librocklight.so (Visualization)
  319. - add Requires: audacious instead of %%{name} to sub packages
  320. * Fri Feb 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4.1
  321. - add avoid-null-dereference.patch (patch0) to avoid crash
  322. r1316 | nenolod | 2007-02-08 03:35:13 +0900 (Thu, 08 Feb 2007) | 2 lines
  323. - avoid NULL dereference. closes mandriva #28603.
  324. * Thu Feb 08 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4
  325. - update to 1.3.0alpha4
  326. - update ja.po (source1)
  327. - update %%_audacious_ver
  328. - update URLs
  329. - add BuildRequires: libprojectM-devel
  330. - add plugin to visualization package
  331. - libprojectm.so (Visualization)
  332. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha3
  333. - update to 1.3.0alpha3
  334. - update ja.po (source1)
  335. - add BuildRequires: libid3tag-devel
  336. - add plugins to core package
  337. - libcurl.so, libevdev-plug.so, libstatusicon.so (General)
  338. - add new package: audacious-tta
  339. - libtta.so (Input)
  340. * Sun Jan 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2.1
  341. - update ja.po (source1)
  342. * Sat Jan 13 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2
  343. - update to 1.3.0alpha2
  344. - update %%_audacious_ver
  345. - drop '--disable-gnome-vfs' option from %%configure (no longer supported)
  346. - add audacious-1.2.2's ja.po (source1)
  347. to use some translations prior to plugin separation
  348. - add plugins to core package:
  349. - libstdio.so (Container)
  350. - libmetronom.so, libmodplug.so (Input)
  351. - librocklight.so (Visualization)
  352. - rename paranormal package to visualization
  353. - add Obsoletes: audacious-paranormal
  354. - add plugin: librovascope.so
  355. - fix typo
  356. * Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl2
  357. - separate paranormal package
  358. - add BuildRequires: SDL-devel
  359. * Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl1
  360. - initial build based on audacious
  361. * Sun Aug 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
  362. - new upstream release
  363. * Tue Aug 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
  364. - oops, really update ja.po (source2)
  365. * Mon Jul 31 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
  366. - new upstream release
  367. - make with 'VERBOSE=1'
  368. - drop obsolete POTFILES.in (source3)
  369. - make update-po before make
  370. - 1.1.1 contains old version of audacious.pot...
  371. - update ja.po (source2)
  372. * Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
  373. - overwrite POTFILES.in (source3)
  374. - 1.1.0 contains old version of POTFILES.in
  375. - update ja.po (source2)
  376. * Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
  377. - new upstream release
  378. - drop unneeded patch0 (was merged)
  379. - add '--enable-ipv6 --enable-chardet' to %%configure option
  380. - add BuildRequires: taglib-devel instead of id3lib-devel
  381. - update ja.po (source2)
  382. * Sun Jun 04 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl2
  383. - add flac-filename-utf8.patch (patch0)
  384. to convert filename on fileinfo box for FLAC files to UTF-8
  385. - add use-xfont.patch (patch1)
  386. to disable 'Use Bitmap fonts if available' by default
  387. - add ja.po (source2)
  388. * Sat Jun 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl1
  389. - initial build