blender-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299
  1. %define blenderlib %{_datadir}/blender
  2. %define plugins %{_libdir}/blender/plugins
  3. Summary: 3D modeling, animation, rendering and post-production.
  4. Summary(ja): 3D モデリング、アニメーション、レンダリング、ポストプロダクション
  5. Name: blender
  6. Version: 2.49b
  7. Release: 1%{?_dist_release}
  8. Group: Applications/Multimedia
  9. License: GPL
  10. URL: http://www.blender.org/
  11. Source0: http://download.blender.org/source/blender-%{version}.tar.gz
  12. Source1: http://bane.servebeer.com/programming/blender/import-3ds-0.92.py
  13. Source2: http://bane.servebeer.com/programming/blender/export-3ds-0.72.py
  14. Source3: blender.png
  15. Source4: blender.desktop
  16. Source5: blender.xml
  17. Patch1: blender-2.49-scons.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: desktop-file-utils
  20. BuildRequires: esound-devel
  21. BuildRequires: glut-devel
  22. BuildRequires: gettext-devel
  23. BuildRequires: libjpeg-devel
  24. BuildRequires: libogg-devel
  25. BuildRequires: libpng-devel
  26. BuildRequires: libtiff-devel
  27. BuildRequires: libtool
  28. BuildRequires: libvorbis-devel
  29. BuildRequires: freealut-devel
  30. BuildRequires: openssl-devel
  31. BuildRequires: python-devel
  32. BuildRequires: scons
  33. BuildRequires: SDL-devel
  34. BuildRequires: zlib-devel
  35. BuildRequires: libXi-devel
  36. BuildRequires: xorg-x11-proto-devel
  37. BuildRequires: mesa-libGL-devel
  38. BuildRequires: mesa-libGLU-devel
  39. BuildRequires: freetype-devel
  40. BuildRequires: OpenEXR-devel
  41. BuildRequires: glew-devel
  42. BuildRequires: freetype2-devel
  43. Requires(post): desktop-file-utils
  44. Requires(post): shared-mime-info
  45. Requires(postun): desktop-file-utils
  46. Requires(postun): shared-mime-info
  47. %description
  48. Blender is an integrated suite of tools enabling the creation of a broad
  49. range of 3D content. It offers full functionality for modelling, rendering,
  50. animation, post-production, creation and playback of interactive 3D content
  51. with the singular benefits of cross-platform operability.
  52. Aimed at media professionals and artists, Blender can be used to create 3D
  53. visualizations, stills as well as broadcast quality video, while the
  54. incorporation of a real-time 3D engine allows for the creation of 3D
  55. interactive content for stand-alone playback.
  56. %description -l ja
  57. Blender は、幅広い 3D コンテンツの製作を可能にする統合ソフトウェアです。
  58. Blender は、モデリング、レンダリング、アニメーション、ポストプロダクション、
  59. インタラクティブな 3D コンテンツの製作と再生といった全機能を、複数の OS への
  60. 対応という他には類のない利点と共に提供しています。
  61. Blender は、メディアの専門家や達人もターゲットにしているので、3D の視覚化や、
  62. 良質なテレビ放送映像や静止画像の作成にも使用できます。さらに、リアルタイム
  63. 3D エンジンを統合したことにより、スタンドアロン再生用のインタラクティブな
  64. 3D コンテンツの製作も可能です。
  65. %prep
  66. %setup -q -n %{name}-%{version}
  67. #%patch1 -p1 -b .scons
  68. %build
  69. cat > user-config.py <<EOF
  70. WITH_BF_OPENAL = 'false'
  71. #BF_OPENAL = '%{_prefix}'
  72. #BF_OPENAL_INC = '%{_includedir}/AL'
  73. #BF_OPENAL_LIB = '%{_libdir}'
  74. WITH_BF_FFMPEG = 'false'
  75. BF_PYTHON = '%{_prefix}'
  76. BF_PYTHON_INC = '%{_includedir}/python%{pyver}'
  77. BF_PYTHON_LIB = 'python%{pyver}'
  78. BF_OPENEXR_INC = '%{_includedir}/OpenEXR'
  79. BF_GETTEXT = '%{_prefix}'
  80. BF_GETTEXT_INC = '%{_includedir}'
  81. BF_GETTEXT_LIB = 'gettextlib'
  82. BF_BUILDDIR = './builddir'
  83. BF_INSTALLDIR='./installdir'
  84. EOF
  85. ## don't use parallel build
  86. #scons -i -k %{?_smp_mflags} BF_QUIET=0
  87. scons BF_QUIET=0
  88. install -d release/plugins/include
  89. install -m 644 source/blender/blenpluginapi/*.h release/plugins/include
  90. chmod +x release/plugins/bmake
  91. make -C release/plugins/
  92. %install
  93. rm -rf ${RPM_BUILD_ROOT}
  94. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  95. install -D -m 755 ./builddir/bin/blender ${RPM_BUILD_ROOT}/%{_bindir}/blender
  96. install -D -m 755 ./builddir/bin/blenderplayer ${RPM_BUILD_ROOT}/%{_bindir}/blenderplayer
  97. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}
  98. pushd bin/.blender/locale
  99. rm -rf $(find -name '.svn' -print)
  100. popd
  101. cp -a bin/.blender/locale ${RPM_BUILD_ROOT}/%{_datadir}
  102. install -p -D -m0644 %{SOURCE3} ${RPM_BUILD_ROOT}%{_datadir}/pixmaps/blender.png
  103. install -p -D -m0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_datadir}/mime/packages/blender.xml
  104. mkdir -p ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
  105. install -p -D -m0644 release/scripts/*.py ${RPM_BUILD_ROOT}%{blenderlib}/scripts/
  106. install -m 644 release/VERSION ${RPM_BUILD_ROOT}/%{blenderlib}
  107. install -m 644 bin/.blender/.Blanguages ${RPM_BUILD_ROOT}/%{blenderlib}
  108. install -m 644 bin/.blender/.bfont.ttf ${RPM_BUILD_ROOT}/%{blenderlib}
  109. install -p -D -m0644 %{SOURCE1} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/import-3ds-0.7.py
  110. install -p -D -m0644 %{SOURCE2} ${RPM_BUILD_ROOT}%{blenderlib}/scripts/export-3ds-0.71.py
  111. install -d ${RPM_BUILD_ROOT}/%{plugins}/sequence
  112. install -d ${RPM_BUILD_ROOT}/%{plugins}/texture
  113. install -m 644 release/plugins/sequence/*.so ${RPM_BUILD_ROOT}/%{plugins}/sequence
  114. install -m 655 release/plugins/texture/*.so ${RPM_BUILD_ROOT}/%{plugins}/texture
  115. desktop-file-install --vendor "" --dir ${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE4}
  116. %find_lang %name
  117. %clean
  118. rm -rf ${RPM_BUILD_ROOT}
  119. %post
  120. update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
  121. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  122. %postun
  123. update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
  124. update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
  125. %files -f %name.lang
  126. %defattr(-,root,root,-)
  127. %doc COPYING README doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt
  128. %{_bindir}/*
  129. %{_libdir}/blender/
  130. %{blenderlib}/
  131. %{_datadir}/applications/blender.desktop
  132. %{_datadir}/pixmaps/*.png
  133. %{_datadir}/mime/packages/blender.xml
  134. %changelog
  135. * Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.49b-1
  136. - new upstream release
  137. - add BuildRequires: freetype2-devel
  138. * Sat Nov 13 2010 Shu KONNO <owa@bg.wakwak.com> 2.49-2
  139. - rebuilt with gettext-0.18
  140. * Wed May 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.49-1
  141. - updated blender to 2.49
  142. - applied new versioning policy, and spec in utf-8
  143. - built without smp option
  144. - disable OpenAL, FFMPEG at user-config.py
  145. - added BR: libXi-devel xorg-x11-proto-devel mesa-libGL-devel mesa-libGLU-devel
  146. - added BR: freetype-devel OpenEXR-devel glew-devel
  147. * Mon Jan 02 2006 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.40-0vl2
  148. - new upstream release.
  149. * Sat Oct 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.35-0vl1
  150. - initial build for Vine Linux
  151. * Mon Nov 15 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.35-1
  152. - 2.35.
  153. * Thu Nov 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 2.34-0.fdr.3
  154. - Mime-type corrections for FC3.
  155. - Dropped redundent BR XFree86-devel.
  156. * Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.2
  157. - blender.applications file.
  158. - blender.xml file.
  159. - post/postun update-mime-database.
  160. * Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.34-0.fdr.1
  161. - Updated to 2.34.
  162. * Thu Aug 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.2.a
  163. - Include 3ds import/export scripts.
  164. - Added mime info.
  165. - Added mime icon (from yattacier theme).
  166. * Wed Aug 04 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.33-0.fdr.1.a
  167. - 2.33a.
  168. - Now building with scons.
  169. * Tue Feb 10 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.2
  170. - Now including scripts.
  171. * Thu Feb 05 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.32-0.fdr.1
  172. - Updated to 2.32.
  173. * Sun Jan 11 2004 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.3.a
  174. - --enable-openal.
  175. - --disable-rpath.
  176. - remove --enable-international.
  177. - modify .desktop to execute with -w.
  178. * Thu Dec 04 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.2.a
  179. - Updated to 2.31a.
  180. * Sun Nov 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.31-0.fdr.1
  181. - Updated to 2.31.
  182. - enable-international.
  183. * Tue Nov 18 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.30-0.fdr.1
  184. - Updated to 2.30.
  185. * Fri Oct 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.5.c
  186. - Updated to 2.28c.
  187. * Tue Oct 07 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.4.a
  188. - Removed BuildReq smpeg-devel
  189. * Mon Sep 15 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.3.a
  190. - Moved 'a' out of version according to naming guidelines.
  191. * Fri Sep 12 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.2
  192. - changed file permission on tarball.
  193. - dropped redundant messages about aclocal, etc.
  194. - configure --disable-shared.
  195. - automake --foreign.
  196. - added doc/python-dev-guide.txt doc/GPL-license.txt doc/bf-members.txt to %%doc.
  197. * Wed Sep 10 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28a-0.fdr.1
  198. - Updated to 2.28a.
  199. * Wed Aug 13 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.2
  200. - New Icon.
  201. * Thu Jul 24 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.28-0.fdr.1
  202. - Updated to 2.28.
  203. - BuildReq libvorbis-devel.
  204. - BuildReq smpeg-devel.
  205. - BuildReq esound-devel.
  206. - BuildReq libogg-devel.
  207. - BuildReq vorbis-tools.
  208. - BuildReq openal-devel
  209. - BuildReq libtool
  210. * Mon May 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.2
  211. - Removed post/postun ldconfig.
  212. - Added autoconf workaround.
  213. * Mon May 19 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.27-0.fdr.1
  214. - Updated to 2.27.
  215. - Removed devel package.
  216. * Wed Apr 09 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.9
  217. - Corrected devel Group.
  218. * Tue Apr 01 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.8
  219. - Added desktop-file-utils to BuildRequires.
  220. - Changed category to X-Fedora-Extra.
  221. * Mon Mar 31 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.7
  222. - Added Missing BuildRequires.
  223. * Sun Mar 30 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 0:2.26-0.fdr.6
  224. - Cleaned up BuildRequires.
  225. - Added Epoch:0.
  226. * Sat Mar 22 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-0.fdr.5
  227. - Spec file cleanup.
  228. * Sat Mar 08 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fdr.4
  229. - Spec file cleanup.
  230. * Wed Feb 26 2003 Phillip Compton <pcompton[AT]proteinmedia.com> 2.26-1.fedora.3
  231. - Spec file cleanup.
  232. * Thu Feb 20 2003 Warren Togami
  233. - Add BuildRequires python-devel
  234. * Wed Feb 19 2003 Phillip Compton
  235. - Initial RPM release.