cln-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191
  1. Name: cln
  2. Summary: Class Library for Numbers
  3. Version: 1.3.1
  4. Release: 2%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: GPLv2+
  7. URL: http://www.ginac.de/CLN/
  8. Source0: http://www.ginac.de/CLN/%{name}-%{version}.tar.bz2
  9. Patch0: cln-1.2.2-s390x.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: gmp-devel
  12. BuildRequires: texinfo
  13. #BuildRequires: texi2html texinfo
  14. Requires(post): /sbin/install-info
  15. Requires(preun): /sbin/install-info
  16. %description
  17. A collection of C++ math classes and functions, which are designed for
  18. memory and speed efficiency, and enable type safety and algebraic
  19. syntax.
  20. %package devel
  21. Summary: Development files for programs using the CLN library
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. %description devel
  25. A collection of C++ math classes and functions, which are designed for
  26. memory and speed efficiency, and enable type safety and algebraic
  27. syntax.
  28. This package is necessary if you wish to develop software based on
  29. the CLN library.
  30. %prep
  31. %setup -q
  32. %patch0 -p1 -b .s390x
  33. %build
  34. %configure --disable-static
  35. make %{?_smp_mflags}
  36. make pdf
  37. make html
  38. %install
  39. rm -rf %{buildroot}
  40. make DESTDIR=%{buildroot} install
  41. mkdir -p %{buildroot}%{_docdir}/%{name}-devel-%{version}
  42. cp -p doc/cln.pdf doc/cln.html %{buildroot}%{_docdir}/%{name}-devel-%{version}/
  43. find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
  44. rm -f %{buildroot}%{_infodir}/dir
  45. rm -rf %{buildroot}%{_bindir} %{buildroot}%{_mandir}/man1/pi.*
  46. %check
  47. make %{?_smp_mflags} check
  48. %clean
  49. rm -rf %{buildroot}
  50. %post -p /sbin/ldconfig
  51. %postun -p /sbin/ldconfig
  52. %post devel
  53. /sbin/install-info --section="Math" %{_infodir}/cln.info.gz %{_infodir}/dir 2>/dev/null || :
  54. %preun devel
  55. if [ "$1" = 0 ]; then
  56. /sbin/install-info --delete %{_infodir}/cln.info.gz %{_infodir}/dir 2>/dev/null || :
  57. fi
  58. %files
  59. %defattr(-,root,root)
  60. %doc COPYING ChangeLog NEWS README TODO*
  61. %{_libdir}/*.so.*
  62. %files devel
  63. %defattr(-,root,root)
  64. %{_libdir}/*.so
  65. %{_libdir}/pkgconfig/cln.pc
  66. %{_includedir}/cln
  67. %{_infodir}/*.info*
  68. %{_docdir}/%{name}-devel-%{version}
  69. %changelog
  70. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-2
  71. - rebuilt with rpm-4.8.1 for pkg-config
  72. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
  73. - new upstream release
  74. - built with new toolchain
  75. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.0-3
  76. - Initial build for Vine Linux
  77. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  79. * Thu Jul 02 2009 Deji Akingunola <dakingun@gmail.com> - 1.3.0-1
  80. - Update to latest upstream release 1.3.0
  81. * Thu May 28 2009 Dan Horak <dan[at]danny.cz> - 1.2.2-5
  82. - fix build on s390x
  83. - run the test-suite during build
  84. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-4
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  86. * Wed Feb 04 2009 Deji Akingunola <dakingun@gmail.com> - 1.2.2-3
  87. - Add upstream patch to build with gcc-4.4
  88. * Fri Jan 16 2009 Rakesh Pandit <rakesh@fedoraproject.org> 1.2.2-2
  89. - Bump to solve dependency for ginac-devel
  90. * Tue Apr 29 2008 Quentin Spencer <qspencer@users.sf.net> 1.2.2-1
  91. - Update to 1.2.2.
  92. * Mon Feb 25 2008 Quentin Spencer <qspencer@users.sf.net> 1.2.0-1
  93. - Update to 1.2.0.
  94. - Update License tag.
  95. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.13-5
  96. - Autorebuild for GCC 4.3
  97. * Thu Sep 13 2007 Quentin Spencer <qspencer@users.sf.net> 1.1.13-4
  98. - Add pkgconfig as a dependency of -devel.
  99. * Tue Aug 21 2007 Quentin Spencer <qspencer@users.sf.net> 1.1.13-3
  100. - Rebuild for F8.
  101. * Mon Aug 28 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.13-2
  102. - Rebuild for FC-6.
  103. * Thu Aug 17 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.13-1
  104. - New release.
  105. * Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-5
  106. - Disable static build.
  107. - Enable parallel build.
  108. * Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-4
  109. - Rebuild for Fedora Extras 5.
  110. - Remove /usr/share/info/dir after install.
  111. - Exclude static libs.
  112. * Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-3
  113. - Exclude /usr/share/info/dir from package (bug 178660).
  114. * Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-2
  115. - Update source URL.
  116. * Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-1
  117. - New upstream release.
  118. * Mon Oct 31 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.10-1
  119. - New upstream release, incorporating previous patch.
  120. * Mon Jun 20 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-8
  121. - Rebuild
  122. * Mon Jun 13 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-4
  123. - Patched include/cln/string.h to correctly compile on gcc-c++-4.0.0-9
  124. * Fri May 27 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-3
  125. - Added gmp-devel to Requires for devel
  126. * Fri May 20 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-2
  127. - Added dist tag.
  128. * Wed May 11 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
  129. - Excluded .la file
  130. * Fri Apr 22 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
  131. - Added gmp-devel in BuildRequires, fixes in files
  132. - Added release to name in Requires for devel
  133. * Mon Mar 21 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
  134. - Adapted spec file for Fedora Extras
  135. * Thu Nov 20 2003 Christian Bauer <Christian.Bauer@uni-mainz.de>
  136. Added pkg-config metadata file to devel package
  137. * Wed Nov 6 2002 Christian Bauer <Christian.Bauer@uni-mainz.de>
  138. Added HTML and DVI docs to devel package
  139. * Tue Nov 5 2001 Christian Bauer <Christian.Bauer@uni-mainz.de>
  140. Added Packager