db43-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
  3. %define java_arches %{ix86} alpha ia64 ppc ppc64 s390 s390x sparc sparcv9 x86_64
  4. ##VINE##
  5. %undefine java_arches
  6. # compatibility with legacy versions of rpm
  7. %{!?_lib:%define _lib lib}
  8. %define __soversion 4.3
  9. %define _libdb_a libdb-%{__soversion}.a
  10. %define _libcxx_a libdb_cxx-%{__soversion}.a
  11. Summary: The Berkeley DB database library (version 4) for C.
  12. Name: db43
  13. Version: 4.3.29
  14. Release: 10%{?_dist_release}
  15. Source: http://www.sleepycat.com/update/%{version}/db-%{version}.tar.gz
  16. Source1: http://www.sleepycat.com/update/1.85/db.1.85.tar.gz
  17. Source2: nptl-abi-note.S
  18. Patch1: db-4.3.29-64bit.patch
  19. Patch2: db-4.2.52-gcj.patch
  20. Patch3: db-4.3.29-sparc64.patch
  21. Patch10: http://www.sleepycat.com/update/1.85/patch.1.1
  22. Patch11: http://www.sleepycat.com/update/1.85/patch.1.2
  23. Patch12: http://www.sleepycat.com/update/1.85/patch.1.3
  24. Patch13: http://www.sleepycat.com/update/1.85/patch.1.4
  25. Patch14: db-1.85-errno.patch
  26. # Security/Bug Patches
  27. # http://www.oracle.com/technology/products/berkeley-db/db/update/4.3.29/patch.4.3.29.html
  28. Patch100: patch.4.3.29.1
  29. URL: http://www.sleepycat.com/
  30. License: GPL
  31. Group: System Environment/Libraries
  32. Obsoletes: db1, db2, db3
  33. BuildRequires: perl, libtool, ed, tcl >= 8.4.4
  34. %ifarch %{java_arches}
  35. BuildRequires: gcc-java
  36. BuildRequires: java-1.4.2-gcj-compat
  37. BuildRequires: java-1.4.2-gcj-compat-devel
  38. %endif
  39. BuildRoot: %{_tmppath}/%{name}-root
  40. %description
  41. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  42. provides embedded database support for both traditional and
  43. client/server applications. The Berkeley DB includes B+tree, Extended
  44. Linear Hashing, Fixed and Variable-length record access methods,
  45. transactions, locking, logging, shared memory caching, and database
  46. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  47. used by many applications, including Python and Perl, so this should
  48. be installed on all systems.
  49. %package -n compat32-%{name}
  50. Summary: The Berkeley DB database library (version 4) for C.
  51. Group: System Environment/Libraries
  52. Requires: db4 = %{version}-%{release}
  53. %description -n compat32-%{name}
  54. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  55. provides embedded database support for both traditional and
  56. client/server applications. The Berkeley DB includes B+tree, Extended
  57. Linear Hashing, Fixed and Variable-length record access methods,
  58. transactions, locking, logging, shared memory caching, and database
  59. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  60. used by many applications, including Python and Perl, so this should
  61. be installed on all systems.
  62. %package utils
  63. Summary: Command line tools for managing Berkeley DB (version 4) databases.
  64. Group: Applications/System
  65. Requires: db4 = %{version}-%{release}
  66. Obsoletes: db2-utils, db3-utils
  67. %description utils
  68. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  69. provides embedded database support for both traditional and
  70. client/server applications. Berkeley DB includes B+tree, Extended
  71. Linear Hashing, Fixed and Variable-length record access methods,
  72. transactions, locking, logging, shared memory caching, and database
  73. recovery. DB supports C, C++, Java and Perl APIs.
  74. This package contains command line tools for managing Berkeley DB
  75. (version 4) databases.
  76. %package devel
  77. Summary: Development files for the Berkeley DB (version 4) library.
  78. Group: Development/Libraries
  79. Requires: db4 = %{version}-%{release}
  80. Obsoletes: db2-devel, db3-devel
  81. %description devel
  82. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  83. provides embedded database support for both traditional and
  84. client/server applications. This package contains the header files,
  85. libraries, and documentation for building programs which use the
  86. Berkeley DB.
  87. %package -n compat32-%{name}-devel
  88. Summary: Development files for the Berkeley DB (version 4) library.
  89. Group: Development/Libraries
  90. Requires: compat32-%{name} = %{version}-%{release}
  91. Requires: %{name}-devel = %{version}-%{release}
  92. %description -n compat32-%{name}-devel
  93. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  94. provides embedded database support for both traditional and
  95. client/server applications. This package contains the header files,
  96. libraries, and documentation for building programs which use the
  97. Berkeley DB.
  98. %package tcl
  99. Summary: Development files for using the Berkeley DB (version 4) with tcl.
  100. Group: Development/Libraries
  101. Requires: %{name} = %{version}-%{release}
  102. %description tcl
  103. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  104. provides embedded database support for both traditional and
  105. client/server applications. This package contains the libraries
  106. for building programs which use the Berkeley DB in Tcl.
  107. %package -n compat32-%{name}-tcl
  108. Summary: Development files for using the Berkeley DB (version 4) with tcl.
  109. Group: Development/Libraries
  110. Requires: compat32-%{name} = %{version}-%{release}
  111. Requires: %{name}-tcl = %{version}-%{release}
  112. %description -n compat32-%{name}-tcl
  113. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  114. provides embedded database support for both traditional and
  115. client/server applications. This package contains the libraries
  116. for building programs which use the Berkeley DB in Tcl.
  117. %package java
  118. Summary: Development files for using the Berkeley DB (version 4) with Java.
  119. Group: Development/Libraries
  120. Requires: %{name} = %{version}-%{release}
  121. %description java
  122. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  123. provides embedded database support for both traditional and
  124. client/server applications. This package contains the libraries
  125. for building programs which use the Berkeley DB in Java.
  126. %prep
  127. %setup -q -n db-%{version} -a 1
  128. %patch1 -p1 -b .64bit
  129. %patch2 -p1 -b .gcj
  130. %patch3 -p1 -b .sparc64
  131. pushd dist
  132. #libtoolize --copy --force
  133. #cat %{_datadir}/aclocal/libtool.m4 >> aclocal.m4
  134. popd
  135. pushd db.1.85/PORT/linux
  136. %patch10 -p0 -b .1
  137. popd
  138. pushd db.1.85
  139. %patch11 -p0 -b .1
  140. %patch12 -p0 -b .2
  141. %patch13 -p0 -b .3
  142. %patch14 -p1 -b .errno
  143. popd
  144. %patch100 -p0 -b .1
  145. # Remove tags files which we don't need.
  146. find . -name tags | xargs rm -f
  147. # Define a shell function for fixing HREF references in the docs, which
  148. # would otherwise break when we split the docs up into subpackages.
  149. fixup_href() {
  150. for doc in $@ ; do
  151. chmod u+w ${doc}
  152. sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
  153. -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
  154. -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
  155. -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
  156. -e 's,="../api_java/,="../../%{name}-devel-%{version}/api_java/,g' \
  157. -e 's,="api_java/,="../%{name}-devel-%{version}/api_java/,g' \
  158. -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
  159. -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
  160. -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
  161. -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
  162. -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
  163. -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
  164. -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
  165. -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
  166. -e 's,="../sleepycat/,="../../%{name}-devel-%{version}/sleepycat/,g' \
  167. -e 's,="sleepycat/,="../%{name}-devel-%{version}/sleepycat/,g' \
  168. -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
  169. -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
  170. -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
  171. -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
  172. touch -r ${doc} ${doc}.new
  173. cat ${doc}.new > ${doc}
  174. touch -r ${doc}.new ${doc}
  175. rm -f ${doc}.new
  176. done
  177. }
  178. set +x # XXX painful to watch
  179. # Fix all of the HTML files.
  180. fixup_href `find . -name "*.html"`
  181. set -x # XXX painful to watch
  182. cd dist
  183. #./s_config
  184. %build
  185. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
  186. # Build the old db-185 libraries.
  187. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  188. build() {
  189. test -d dist/$1 || mkdir dist/$1
  190. # Static link db_dump185 with old db-185 libraries.
  191. /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
  192. /bin/sh libtool --mode=link %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  193. pushd dist/$1
  194. # Force the threading model used, for selecting whether or not we will
  195. # depend on NPTL-specific features.
  196. echo ${2:+db_cv_mutex=$2} > config.cache
  197. if test -n "$nptl_lo" ; then
  198. /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS \
  199. -o $nptl_lo -c $nptl_s
  200. fi
  201. ln -sf ../configure .
  202. # XXX --enable-diagnostic should be disabled for production (but is
  203. # useful).
  204. # XXX --enable-debug_{r,w}op should be disabled for production.
  205. %configure -C \
  206. --enable-compat185 --enable-dump185 \
  207. --enable-shared --enable-static --enable-rpc \
  208. --enable-tcl --with-tcl=%{_libdir} \
  209. --enable-cxx \
  210. %ifarch %{java_arches}
  211. --enable-java \
  212. %else
  213. --disable-java \
  214. %endif
  215. --enable-test \
  216. # --enable-diagnostic \
  217. # --enable-debug --enable-debug_rop --enable-debug_wop \
  218. # Remove libtool predep_objects and postdep_objects wonkiness so that
  219. # building without -nostdlib doesn't include them twice. Because we
  220. # already link with g++, weird stuff happens if you don't let the
  221. # compiler handle this.
  222. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  223. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  224. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  225. # make libdb=%{_libdb_a} libcxx=%{_libcxx_a} %{?_smp_mflags} \
  226. make %{?_smp_mflags} \
  227. LIBSO_LIBS='$(LIBS)'" $nptl_lo" \
  228. LIBXSO_LIBS='$(LIBS)'" $nptl_lo" \
  229. LIBJSO_LIBS='$(LIBS)'" $nptl_lo" \
  230. LIBTSO_LIBS='$(LIBS)'" $nptl_lo"
  231. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  232. LDBJ=./.libs/libdb_java-%{__soversion}.la
  233. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  234. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  235. fi
  236. popd
  237. }
  238. unset nptl_s nptl_lo
  239. case %{_os} in
  240. linux|Linux)
  241. nptl_s=%{SOURCE2}
  242. nptl_lo=nptl-abi-note.lo
  243. ;;
  244. esac
  245. build dist-tls POSIX/pthreads/library
  246. unset nptl_s nptl_lo
  247. %install
  248. rm -rf ${RPM_BUILD_ROOT}
  249. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  250. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  251. %makeinstall -C dist/dist-tls
  252. # XXX Nuke non-versioned archives and symlinks
  253. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
  254. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
  255. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
  256. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
  257. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
  258. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  259. # Move the main shared library from /usr/lib* to /lib* directory.
  260. if [ "%{_libdir}" != "/%{_lib}" ]; then
  261. mkdir -p $RPM_BUILD_ROOT/%{_lib}/
  262. mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
  263. # Leave relative symlinks in %{_libdir}.
  264. touch $RPM_BUILD_ROOT/rootfile
  265. root=..
  266. while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
  267. root=${root}/..
  268. done
  269. rm $RPM_BUILD_ROOT/rootfile
  270. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
  271. ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
  272. ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
  273. fi
  274. # Move the header files to a subdirectory, in case we're deploying on a
  275. # system with multiple versions of DB installed.
  276. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
  277. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
  278. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  279. for i in db.h db_cxx.h db_185.h; do
  280. ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
  281. done
  282. %ifarch %{java_arches}
  283. # Move java jar file to the correct place
  284. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  285. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  286. %endif
  287. # Eliminate installed doco
  288. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  289. # XXX Avoid Permission denied. strip when building as non-root.
  290. chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
  291. %clean
  292. rm -rf ${RPM_BUILD_ROOT}
  293. %post -p /sbin/ldconfig
  294. %postun -p /sbin/ldconfig
  295. %post -n compat32-%{name} -p /sbin/ldconfig
  296. %postun -n compat32-%{name} -p /sbin/ldconfig
  297. %post -p /sbin/ldconfig tcl
  298. %postun -p /sbin/ldconfig tcl
  299. %post -n compat32-%{name}-tcl -p /sbin/ldconfig
  300. %postun -n compat32-%{name}-tcl -p /sbin/ldconfig
  301. %post -p /sbin/ldconfig java
  302. %postun -p /sbin/ldconfig java
  303. %files
  304. %defattr(-,root,root)
  305. %doc LICENSE README
  306. /%{_lib}/libdb-%{__soversion}.so
  307. %{_libdir}/libdb-%{__soversion}.so
  308. %{_libdir}/libdb_cxx-%{__soversion}.so
  309. #%files utils
  310. #%defattr(-,root,root)
  311. #%doc docs/utility
  312. #%{_bindir}/berkeley_db*_svc
  313. #%{_bindir}/db*_archive
  314. #%{_bindir}/db*_checkpoint
  315. #%{_bindir}/db*_deadlock
  316. #%{_bindir}/db*_dump*
  317. #%{_bindir}/db*_load
  318. #%{_bindir}/db*_printlog
  319. #%{_bindir}/db*_recover
  320. #%{_bindir}/db*_stat
  321. #%{_bindir}/db*_upgrade
  322. #%{_bindir}/db*_verify
  323. #%files devel
  324. #%defattr(-,root,root)
  325. #%doc docs/api_c docs/api_cxx docs/api_tcl docs/index.html
  326. #%doc docs/ref docs/sleepycat docs/images
  327. #%doc examples_c examples_cxx
  328. #%{_libdir}/libdb.so
  329. #%{_libdir}/libdb_cxx.so
  330. #%{_libdir}/libdb-%{__soversion}.la
  331. #%{_libdir}/libdb_cxx-%{__soversion}.la
  332. #%{_libdir}/%{_libdb_a}
  333. #%{_libdir}/%{_libcxx_a}
  334. #%{_includedir}/%{name}
  335. #%{_includedir}/*.h
  336. #%files tcl
  337. #%defattr(-,root,root)
  338. #%{_libdir}/libdb_tcl-%{__soversion}.a
  339. #%{_libdir}/libdb_tcl-%{__soversion}.la
  340. #%{_libdir}/libdb_tcl-%{__soversion}.so
  341. #%ifarch %{java_arches}
  342. #%files java
  343. #%defattr(-,root,root)
  344. #%doc docs/java
  345. #%doc examples_java
  346. #%{_libdir}/libdb_java*
  347. #%{_datadir}/java/*.jar
  348. #%endif
  349. %if %{build_compat32}
  350. %files -n compat32-%{name}
  351. %defattr(-,root,root)
  352. /%{_lib}/libdb-%{__soversion}.so
  353. %{_libdir}/libdb-%{__soversion}.so
  354. %{_libdir}/libdb_cxx-%{__soversion}.so
  355. #%files -n compat32-%{name}-devel
  356. #%defattr(-,root,root)
  357. #%{_libdir}/libdb.so
  358. #%{_libdir}/libdb-%{__soversion}.la
  359. #%{_libdir}/libdb_cxx-%{__soversion}.la
  360. #%{_libdir}/%{_libdb_a}
  361. #%{_libdir}/%{_libcxx_a}
  362. #%files -n compat32-%{name}-tcl
  363. #%defattr(-,root,root)
  364. #%{_libdir}/libdb_tcl-%{__soversion}.a
  365. #%{_libdir}/libdb_tcl-%{__soversion}.la
  366. #%{_libdir}/libdb_tcl-%{__soversion}.so
  367. %endif
  368. %changelog
  369. * Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.3.29-10
  370. - package name changed to db43
  371. - temporarily commented out "libtoolize" and "s_config" lines
  372. until Vine's autotools get updated (maybe?)
  373. * Tue May 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.3.29-9vl1
  374. - based on 4.3.29-9.fc6, merged changes from 4.2.52-6vl7
  375. - Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.52-6vl6
  376. - changed db4-utils Group to Applications/System <BTS:VineLinux:163>
  377. - changed *-devel Group to Development/Libraries
  378. - changed db4-tcl Group to Devalopment/Libraries
  379. - Fri Feb 10 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.2.52-6vl5
  380. - added compat32-* packages for x86_64 architecture support
  381. * Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
  382. - rebuild
  383. * Wed Sep 6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
  384. - revert the previous fix, it crashes OOo help
  385. * Sun Sep 3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
  386. - fix memleak caused by SET_TXN macro in xa_db.c, when opening
  387. database created with DB_XA_CREATE flag (#204920)
  388. * Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
  389. - fix sparc64 build (#199358)
  390. * Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
  391. - rebuild because of gnu_hash
  392. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
  393. - rebuild
  394. * Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
  395. - drop useless java, lfs patches
  396. * Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
  397. - apply x86_64 fix from Henrik Nordstrom (#184588)
  398. - don't nuke non-versioned archives twice
  399. * Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
  400. - don't package /usr/share/doc/images in the main db4 package
  401. and move it to db4-devel (#33328)
  402. - make db4 LFS capable (#33849)
  403. - move db4-devel, db4-tcl, db4-java to Development/Libraries
  404. group instead of System Environment/Libraries (#54320)
  405. - BuildPrereq -> BuildRequires
  406. - don't use RPM_SOURCE_DIR
  407. - Obsoletes db3, db2
  408. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
  409. - bump again for double-long bug on ppc(64)
  410. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
  411. - rebuilt for new gcc4.1 snapshot and glibc changes
  412. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  413. - rebuilt
  414. * Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
  415. - New upstream release
  416. * Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
  417. - Re-enable java for ppc64
  418. * Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
  419. - Add fno-strict-aliasing for java (#168965)
  420. * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
  421. - no java for ppc64 for now (#166657)
  422. * Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
  423. - FC5 is nptl only (derived from jbj's spec)
  424. - upgrade to 4.3.28
  425. * Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
  426. - re-enable db4-java
  427. * Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
  428. - /usr/lib/tls/ix86 dirs (#151371)
  429. * Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
  430. - add libdb_cxx.so link (#149191)
  431. * Fri Mar 4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
  432. - rebuild with gcc4.
  433. * Sat Jan 1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
  434. - upgrade to 4.3.27.
  435. * Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
  436. - upgrade to 4.3.21, no db4-java for the moment again again.
  437. * Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
  438. - on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
  439. the availability of an NPTL libpthread in glibc > 2.3.3-48
  440. - run ldconfig in db4-java's %%post/%%postun
  441. - when building java support, assume that libgcj is equivalent enough to 1.3
  442. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  443. - rebuilt
  444. * Mon Jun 7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
  445. - remove dangling symlinks (#123721 et al).
  446. - remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
  447. - apply 2 patches from sleepycat.
  448. - resurrect db4-java using sun jvm-1.4.2.
  449. - cripple autoconf sufficiently to build db4-java with gcj, without jvm.
  450. - check javac first, gcj34 next, then gcj-ssa, finally gcj.
  451. - add ed build dependency (#125180).
  452. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  453. - rebuilt
  454. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  455. - rebuilt
  456. * Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
  457. - fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
  458. * Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
  459. - upgrade to db-4.2.52, no db4-java for the moment.
  460. * Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
  461. - Add build requires tcl-devel
  462. * Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
  463. - symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
  464. that the run-time linker can find the right copy for of apps which use an
  465. RPATH to point at %%{_libdir}/libdb-4.1.so
  466. * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
  467. - add another section to the ABI note for the TLS libdb so that it's marked as
  468. not needing an executable stack (from Arjan Van de Ven)
  469. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
  470. - build both with and without support for shared mutex locks, which require NPTL
  471. - make behavior wrt where we put libdb the same for all OSs
  472. - revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
  473. doesn't work
  474. - fix dangling HREFs in utility docs (pointed to main docs dir, while they're
  475. actually in the -utils docs dir)
  476. - run ldconfig when installing/removing the -utils subpackage, as it contains
  477. shared libraries
  478. * Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
  479. - fix multiple-inclusion problem of startup files when building shlibs without
  480. the -nostdlib flag
  481. * Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
  482. - link shared libraries without -nostdlib, which created an unresolvable dep
  483. on a hidden symbol
  484. * Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  485. - allow compiling without tcl dependency
  486. * Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
  487. - update to 4.2.42.
  488. - build in build_unix subdir.
  489. - eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
  490. - create db4-tcl sub-pkg to isolate libtcl dependencies.
  491. * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
  492. - rebuild
  493. * Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
  494. - add missing tcl-devel buildrequires (#101814)
  495. * Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
  496. - rebuild
  497. * Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
  498. - build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
  499. - whack out libtool predep_objects wonkiness.
  500. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
  501. - rebuild.
  502. * Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
  503. - hack out O_DIRECT support in db4 for now.
  504. * Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
  505. - replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
  506. cause a mismatch
  507. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  508. - rebuilt
  509. * Wed Jun 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
  510. - change configure to only warn if JNI includes aren't found, assuming that
  511. the C compiler can find them
  512. - remove build requirement on jdkgcj -- gcj is sufficient
  513. * Mon May 5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
  514. - upgrade to 4.1.25, crypto version.
  515. - enable posix mutexes using nptl on all arches.
  516. * Mon Mar 3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
  517. - enabled db4-java for x86_64
  518. * Wed Feb 5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
  519. - add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
  520. linking with -ldb-4.0 will work again
  521. * Tue Feb 4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
  522. - rebuild to use link the shared object with the same libraries we use
  523. for the bundled utils, should pull in libpthread when needed
  524. - move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
  525. * Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
  526. - add java for s390x
  527. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
  528. - rebuilt
  529. * Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
  530. - add java for s390
  531. * Tue Oct 8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
  532. - add java bits back in for x86 boxes
  533. * Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
  534. - Added better fix for s390/s390x/x86_64
  535. * Thu Sep 05 2002 Arjan van de Ven
  536. - remove java bits for x86-64
  537. * Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
  538. - include libdb_tcl-4.1.a library.
  539. - obsolete db1 packages.
  540. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
  541. - include patch to avoid db_recover (#70362)
  542. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  543. - rebuilt with gcc-3.2 (we hope)
  544. * Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
  545. - own %%{_includedir}/%{name}
  546. * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
  547. - build using gcc-3.2-0.1
  548. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  549. - automated rebuild
  550. * Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
  551. - Add java bindings
  552. - Fix C++ bindings
  553. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  554. - automated rebuild
  555. * Thu May 9 2002 Jeff Johnson <jbj@redhat.com>
  556. - re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
  557. - make sure that -ldb is functional.
  558. * Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
  559. - avoid db_util name collisions with multiple versions installed.
  560. * Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
  561. - remove relocatability stuffs
  562. - swallow a local copy of db1 and build db185_dump statically with it, to
  563. remove the build dependency and simplify bootstrapping new arches
  564. * Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
  565. - have subpackages obsolete their db3 counterparts, because they conflict anyway
  566. * Tue Jan 8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
  567. - upgrade to 4.0.14.
  568. * Sun Aug 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  569. - fix dangling docs symlinks
  570. - fix dangling doc HREFs (#33328)
  571. - apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
  572. * Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
  573. - turn off --enable-debug
  574. * Thu May 10 2001 Than Ngo <than@redhat.com>
  575. - fixed to build on s390x
  576. * Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
  577. - update to 3.2.9.
  578. * Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
  579. - rebuild to remove 777 directories.
  580. * Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
  581. - don't build with --enable-diagnostic.
  582. - add build prereq on tcl.
  583. - default value for %%_lib macro if not found.
  584. * Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
  585. - add /usr/lib/libdb-3.1.so symlink to %%files.
  586. - remove dangling tags symlink from examples.
  587. * Mon Oct 9 2000 Jeff Johnson <jbj@redhat.com>
  588. - rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
  589. - turn off --enable-diagnostic for performance.
  590. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  591. - update to 3.1.17.
  592. - disable posix mutexes Yet Again.
  593. * Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
  594. - add c++ and posix mutex support.
  595. * Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
  596. - put nss_db into a separate package
  597. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  598. - rebuild to cope with glibc locale binary incompatibility, again
  599. * Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
  600. - remove redundant strip of libnss_db* that is nuking symbols.
  601. - change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
  602. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  603. - summaries from specspo.
  604. - all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
  605. * Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
  606. - temporarily build nss_db in this package, should be moved
  607. into separate nss_db package soon
  608. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  609. - rebuild to cope with glibc locale binary incompatibility
  610. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  611. - automatic rebuild
  612. * Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
  613. - upgrade to 3.1.14.
  614. - create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
  615. - FHS packaging.
  616. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  617. - disable tcl Yet Again, base packages cannot depend on libtcl.so.
  618. * Sat Jun 3 2000 Jeff Johnson <jbj@redhat.com>
  619. - enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
  620. * Tue May 30 2000 Matt Wilson <msw@redhat.com>
  621. - include /lib/libdb.so in the devel package
  622. * Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
  623. - put in "System Environment/Libraries" per msw instructions.
  624. * Tue May 9 2000 Jeff Johnson <jbj@redhat.com>
  625. - install shared library in /lib, not /usr/lib.
  626. - move API docs to db3-devel.
  627. * Mon May 8 2000 Jeff Johnson <jbj@redhat.com>
  628. - don't rename db_* to db3_*.
  629. * Tue May 2 2000 Jeff Johnson <jbj@redhat.com>
  630. - disable --enable-test --enable-debug_rop --enable-debug_wop.
  631. - disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
  632. problems.
  633. * Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
  634. - add 3.0.55.1 alignment patch.
  635. - add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
  636. - add --enable-tcl (needed -lpthreads).
  637. * Sat Apr 1 2000 Jeff Johnson <jbj@redhat.com>
  638. - add --enable-debug_{r,w}op for now.
  639. - add variable to set shm perms.
  640. * Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
  641. - update to 3.0.55
  642. * Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
  643. - Add --enable-cxx to configure.
  644. * Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
  645. - Create.