expect-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351
  1. %{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
  2. %{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
  3. %define tcl_major 8.4
  4. %define thread_major 2.5
  5. %define majorver 5.44
  6. Summary: A Tcl/Tk development environment: expect
  7. Summary(ja): Tcl/Tk 開発環境: expect
  8. Name: expect
  9. Version: %{majorver}.1.15
  10. Release: 1%{?_dist_release}
  11. Group: Development/Languages
  12. URL: http://expect.nist.gov/
  13. License: Public Domain
  14. Source0: http://expect.nist.gov/src/%{name}-%{version}.tar.bz2
  15. # Patch500: fixes change log file permissions
  16. Patch500: expect-5.43.0-log_file.patch
  17. # Patch501: fixes install location, change pkgIndex
  18. Patch501: expect-5.43.0-pkgpath.patch
  19. # Patch502: fixes bz456738, expectk is unsupported by upstream actually,
  20. # but the patch is under discussion (patch by Sergei Golovan)
  21. Patch502: expect-5.44.1.15-tk-init.patch
  22. # Patch503: fixes bz742911
  23. Patch503: expect-5.44.1.15-match-gt-numchars-segfault.patch
  24. # Patch504: bz674866, proposed upstream, not accepted yet
  25. # https://sourceforge.net/tracker/?func=detail&aid=3404934&group_id=13179&atid=113179
  26. Patch504: expect-5.45-man-page.patch
  27. # examples patches
  28. # Patch600: changes random function
  29. Patch600: expect-5.32.2-random.patch
  30. # Patch601: bz547686, no response from upstream
  31. Patch601: expect-5.44.1.15-unbuffer-exit-code.patch
  32. # Patch602: bz735962, proposed to upstream, not accepted yet
  33. # https://sourceforge.net/tracker/?func=detail&aid=3404914&group_id=13179&atid=113179
  34. Patch602: expect-5.45-passmass-su-full-path.patch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. BuildRequires: tcl >= %{tcl_major}
  37. BuildRequires: tk >= %{tcl_major}
  38. BuildRequires: thread >= %{thread_major}
  39. BuildRequires: autoconf
  40. BuildRequires: libX11-devel
  41. BuildRequires: chrpath
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. %description -n expect
  45. Expect is a tcl extension for automating interactive applications such
  46. as telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect is also useful
  47. for testing the named applications. Expect makes it easy for a script
  48. to control another program and interact with it.
  49. Install the expect package if you'd like to develop scripts which interact
  50. with interactive applications. You'll also need to install the tcl
  51. package.
  52. %package devel
  53. Summary: Development files for expect library.
  54. Group: Development/Libraries
  55. Requires: expect = %{version}-%{release}
  56. Obsoletes: expect <= 5.43-0vl4
  57. %description devel
  58. This package contains development files for the expect library.
  59. %package -n expectk
  60. Summary: expectk and some scripts
  61. Group: Development/Languages
  62. Requires: expect = %{version}-%{release}
  63. Obsoletes: expect <= 5.43-0vl4
  64. %description -n expectk
  65. This package contains expectk and some scripts that use it.
  66. %prep
  67. %setup -q
  68. %patch500 -p1 -b .log_file
  69. %patch501 -p1 -b .pkgpath
  70. %patch502 -p1 -b .tk-init
  71. %patch503 -p1 -b .match-gt-numchars-segfault
  72. %patch504 -p1 -b .man-page
  73. # examples fixes
  74. %patch600 -p1 -b .random
  75. %patch601 -p1 -b .unbuffer-exit-code
  76. %patch602 -p1 -b .passmass-su-full-path
  77. # -pkgpath.patch touch configure.in
  78. aclocal
  79. autoconf
  80. ( cd testsuite
  81. autoconf -I.. )
  82. %build
  83. %configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
  84. --with-tclinclude=%{_includedir}/tcl-private
  85. make %{?_smp_mflags}
  86. %check
  87. make test
  88. %install
  89. rm -rf ${RPM_BUILD_ROOT}
  90. make install DESTDIR="$RPM_BUILD_ROOT"
  91. # move
  92. mv "$RPM_BUILD_ROOT"%{tcl_sitearch}/expect%{version}/libexpect%{version}.so "$RPM_BUILD_ROOT"%{_libdir}
  93. # for linking with -lexpect
  94. ln -s libexpect%{majorver}.1.15.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
  95. # remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
  96. rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
  97. rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
  98. rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
  99. # remove rpath
  100. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
  101. %post -p /sbin/ldconfig -n expect
  102. %postun -p /sbin/ldconfig -n expect
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %files
  106. %%defattr(-,root,root)
  107. %doc FAQ HISTORY NEWS README
  108. %{_bindir}/expect
  109. %{_bindir}/autoexpect
  110. %{_bindir}/dislocate
  111. %{_bindir}/ftp-rfc
  112. %{_bindir}/kibitz
  113. %{_bindir}/lpunlock
  114. %{_bindir}/mkpasswd
  115. %{_bindir}/passmass
  116. %{_bindir}/rftp
  117. %{_bindir}/rlogin-cwd
  118. %{_bindir}/timed-read
  119. %{_bindir}/timed-run
  120. %{_bindir}/unbuffer
  121. %{_bindir}/weather
  122. %{_bindir}/xkibitz
  123. %dir %{tcl_sitearch}/expect%{version}
  124. %{tcl_sitearch}/expect%{version}/pkgIndex.tcl
  125. %{_libdir}/libexpect%{version}.so
  126. %{_mandir}/man1/autoexpect.1.gz
  127. %{_mandir}/man1/dislocate.1.gz
  128. %{_mandir}/man1/expect.1.gz
  129. %{_mandir}/man1/kibitz.1.gz
  130. %{_mandir}/man1/mkpasswd.1.gz
  131. %{_mandir}/man1/passmass.1.gz
  132. %{_mandir}/man1/tknewsbiff.1.gz
  133. %{_mandir}/man1/unbuffer.1.gz
  134. %{_mandir}/man1/xkibitz.1.gz
  135. %files devel
  136. %defattr(-,root,root,-)
  137. %{_libdir}/libexpect.so
  138. %{_mandir}/man3/libexpect.3*
  139. %{_includedir}/*
  140. %files -n expectk
  141. %defattr(-,root,root,-)
  142. %{_bindir}/expectk
  143. %{_bindir}/multixterm
  144. %{_bindir}/tknewsbiff
  145. %{_bindir}/tkpasswd
  146. %{_bindir}/xpstat
  147. %{_mandir}/man1/expectk.1*
  148. %{_mandir}/man1/multixterm.1*
  149. %{_mandir}/man1/tknewsbiff.1*
  150. %changelog
  151. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 5.44.1.15-1
  152. - update to 5.44.1.15:sync ed Hat Enterprise Linux 6 expect-5.44.1.15-4.el6
  153. - add BuildRequires: tk, chrpath
  154. - update License: Public Domain
  155. - drop obsolete patches
  156. - random patch (Patch0)
  157. - spawn-43310 patch (Patch6)
  158. - setpgrp patch (Patch8)
  159. - lib spec patch (Patch10)
  160. - libdir patch (Patch11)
  161. - add some patches from RHEL expect-5.44.1.15-4.el6
  162. - fixes log file permissions patch (Patch500)
  163. - fixes install location patch (Patch501)
  164. - tk init patch (Patch502)
  165. - match gt numchars segfault patch (Patch503)
  166. - man page patch (Patch504)
  167. - random patch (Patch600)
  168. - unbuffer exit code patch (Patch601)
  169. - passmass su full path Patch (Patch602)
  170. - update build and install section: sync RHEL expect-5.44.1.15-4.el6
  171. - add Vendor and Distribution tags
  172. * Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
  173. - add missing BuildRequires: libX11-devel
  174. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
  175. - rebuilt with rpm-4.8.1-3
  176. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
  177. - rebuilt with tcl/tk-8.4.19-2
  178. * Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
  179. - rebuilt with new toolchain
  180. - changed devel Group to Development/Libraries
  181. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
  182. - applied new versioning policy and spec in utf-8
  183. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
  184. - rebuilt with tcl/tk-8.4.18
  185. * Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
  186. - split to expect-devel and expectk sub package.
  187. - add libexpect.so to expect-devel (<BTS:wishes:0136>)
  188. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
  189. - rebuilt with tcl/tk-8.4.16
  190. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
  191. - rebuilt with new toolchain
  192. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
  193. - rebuild for tcl/tk-8.4.12
  194. - added --enable-64bit to configure's option
  195. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
  196. - updated expect to 5.43.0
  197. - dropped expect-5.39.0-64bit-82547.patch (for fixed)
  198. - dropped expect-5.32.2-kibitz.patch (for fixed)
  199. - dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
  200. - rebuilt with tcl/tk 8.4.11
  201. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
  202. - rebuild for tcl/tk-8.4.6
  203. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
  204. - update based on fedora
  205. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  206. - update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
  207. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  208. - splite source package
  209. - add include files
  210. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  211. - expand some macros.. (FIXME)
  212. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  213. - use %configure macros
  214. - add Patch 47,50
  215. * Thu May 31 2001 <sagami@vinelinux.org>
  216. - 8.0.5_jp-10
  217. - unexpand old %%{configure}, new one causes build failure
  218. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  219. - install manpages into %%{_mandir} and mode 644
  220. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  221. - 8.0.5_jp-9
  222. - modified %install section to handle compressed man pages
  223. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  224. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  225. - changed default fonts
  226. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  227. - added defattr
  228. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  229. - added some symlinks, such as libtcl8.0.so.
  230. - obsoletes version number using _jp, now 8.0.5-31vl1
  231. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  232. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  233. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  234. - fix tclX symlinks.
  235. - compile on systems where SIGPWR == SIGLOST.
  236. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  237. - update tcl/tk to 8.0.5.
  238. - avoid "containing" in Tix (#2332).
  239. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  240. - use /usr/bin/write in kibitz (#1320).
  241. - use cirrus.sprl.umich.edu in weather (#1926).
  242. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  243. - auto rebuild in the new build environment (release 28)
  244. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  245. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  246. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  247. - expect does unaligned access on alpha (#989)
  248. - upgrade tcl/tk/tclX to 8.0.4
  249. - upgrade expect to 5.28.
  250. - add itcl 3.0.1
  251. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  252. - call libtoolize to allow building on the arm
  253. - build for glibc 2.1
  254. - strip binaries
  255. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  256. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  257. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  258. - expect: mkpasswd needs delay before sending password (problem #576)
  259. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  260. - translations modified for de, fr, tr
  261. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  262. - fixed expect binaries exec permissions
  263. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  264. - updated to Tix 4.1.0.006
  265. - updated version numbers of tcl/tk to relflect includsion of p2
  266. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  267. - updated tcl/tk to patch level 2
  268. - updated tclX to 8.0.2
  269. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  270. - fixed filelist for tix... replacing path to the expect binary in scripts
  271. was leaving junk files around.
  272. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  273. - added patch to remove libieee test in configure.in for tcl and tk.
  274. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  275. solution for all systems
  276. - fixed src urls
  277. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  278. - removed version numbers from descriptions
  279. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  280. - updated to tcl/tk 8.0 and related versions of packages
  281. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  282. - built against glibc
  283. - fixed dangling tclx/tkx symlinks