gnome-phone-manager-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261
  1. Name: gnome-phone-manager
  2. Summary: Gnome Phone Manager
  3. Summary(ja): Gnome Phone マネージャー
  4. Version: 0.68
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/System
  8. Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-phone-manager/%{version}/%{name}-%{version}.tar.xz
  9. URL: http://usefulinc.com/software/phonemgr/
  10. #----------------------------------------------------------------------------
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. #----------------------------------------------------------------------------
  13. BuildRequires: gtk3-devel >= 3.0.0
  14. BuildRequires: gnome-bluetooth-devel >= 3.0.0
  15. BuildRequires: bluez-libs-devel
  16. BuildRequires: gnokii-devel >= 0.6.28
  17. BuildRequires: gstreamer-devel >= 0.10
  18. BuildRequires: gnome-icon-theme >= 2.19.1
  19. # For libebook (evolution address book)
  20. BuildRequires: evolution-data-server-devel >= 3.0.0
  21. BuildRequires: gtkspell-devel
  22. BuildRequires: telepathy-glib-devel
  23. BuildRequires: libcanberra-gtk3-devel
  24. # search telepathy
  25. # empathy - GNOME インスタントメッセージクラアイント
  26. # libtelepathy - Telepathy クライアントを簡単に記述するための GLibライブラリ
  27. # libtelepathy-devel - Development files for libtelepathy
  28. # telepathy-filesystem - Telepathy ファイルシステムレイアウト
  29. # telepathy-gabble - Jabber/XMPP 接続マネージャ
  30. # telepathy-glib - Telepathy の GLib バインディング
  31. # telepathy-glib-devel - Development files for telepathy-glib
  32. # telepathy-haze - マルチプロトコル Libpurple 接続マネージャ
  33. # telepathy-mission-control - Central control for Telepathy connection manager
  34. # telepathy-mission-control-devel - Development files for telepathy-mission-control
  35. # telepathy-salut - Link-local XMPP telepathy 接続マネージャ
  36. # telepathy-stream-engine - メディアストリーミングを扱うための Telepathy クライア ント
  37. BuildRequires: perl(XML::Parser)
  38. BuildRequires: gettext
  39. BuildRequires: desktop-file-utils
  40. # https://bugzilla.redhat.com/show_bug.cgi?id=436773
  41. Patch0: gpm-telepathy-workaround.patch
  42. #----------------------------------------------------------------------------
  43. %description
  44. This program will connect to your mobile phone over a serial port,
  45. either via a cable, infrared (IrDA) or Bluetooth connection.
  46. For example it listens for text messages, and when they arrive,
  47. displays them on the desktop. A visual indicator is displayed in
  48. the notification area, if one is presently added to the panel.
  49. #----------------------------------------------------------------------------
  50. %package telepathy
  51. Summary: Telepathy connection manager to send and receive SMSes
  52. Group: Applications/System
  53. %description telepathy
  54. This program will connect to your mobile phone over a serial port,
  55. either via a cable, infrared (IrDA) or Bluetooth connection.
  56. This plugin to Telepathy allows you to send and receive messages using any
  57. Instant Messaging application that uses Telepathy, such as Empathy.
  58. #----------------------------------------------------------------------------
  59. %prep
  60. %setup -q
  61. ## %patch0 -p0
  62. %build
  63. %configure
  64. make %{?_smp_mflags}
  65. #----------------------------------------------------------------------------
  66. %install
  67. %{__rm} -rf $RPM_BUILD_ROOT
  68. make DESTDIR=$RPM_BUILD_ROOT install
  69. # This should be in empathy instead
  70. install -m0644 -D telepathy/sms.profile $RPM_BUILD_ROOT%{_datadir}/mission-control/profiles/sms.profile
  71. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
  72. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  73. desktop-file-install \
  74. --delete-original \
  75. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  76. --add-category X-VineLinux \
  77. $RPM_BUILD_ROOT%{_datadir}/applications/gnome-phone-manager.desktop
  78. %find_lang %{name}
  79. %post
  80. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  81. gconftool-2 --makefile-install-rule \
  82. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas \
  83. >& /dev/null || :
  84. %pre
  85. if [ "$1" -gt 1 ]; then
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-uninstall-rule \
  88. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas \
  89. >& /dev/null || :
  90. fi
  91. %preun
  92. if [ "$1" -eq 0 ]; then
  93. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  94. gconftool-2 --makefile-uninstall-rule \
  95. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas \
  96. >& /dev/null || :
  97. fi
  98. %clean
  99. %{__rm} -rf $RPM_BUILD_ROOT
  100. %files -f %{name}.lang
  101. %defattr(-, root, root, -)
  102. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  103. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas
  104. %{_bindir}/gnome-phone-manager
  105. %{_libdir}/gnome-bluetooth/plugins/libphonemgr.so
  106. %{_datadir}/applications/*.desktop
  107. %{_datadir}/gnome-phone-manager/
  108. %{_mandir}/man1/gnome-phone-manager.1.gz
  109. %files telepathy
  110. %{_libexecdir}/telepathy-phoney
  111. %{_datadir}/telepathy/managers/*
  112. %{_datadir}/dbus-1/services/*
  113. %{_datadir}/mission-control/profiles/*
  114. #----------------------------------------------------------------------------
  115. # Maintainers: babasaki@mindgear.org
  116. #
  117. #----------------------------------------------------------------------------
  118. %changelog
  119. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.68-1
  120. - new upstream release
  121. * Sun Sep 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.67-2
  122. - rebuild with evolution-data-server-3.1.90
  123. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.67-1
  124. - new upstream release
  125. - change BuildRequires: gtk3-devel instead of gtk2-devel
  126. - change BuildRequires: libcanberra-gtk3-devel instead of libcanberra-devel
  127. * Wed Nov 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-2
  128. - rebuils with evolution-data-server-2.32.0 and gnome-bluetooth-2.32.0
  129. * Sat Jul 24 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.65-1
  130. - new upstream release
  131. - add BuildRequires: libcanberra-devel
  132. - drop Patch0
  133. * Mon Oct 27 2008 Seiichirou Babasaki - 0.60-4
  134. - Import gnome-phone-manager - Packager: Babasaki
  135. - Updated specfile
  136. #----------------------------------------------------------------------------
  137. * Tue Oct 07 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-3
  138. - Rebuild for new libgnokii
  139. * Thu Sep 11 2008 Matthias Clasen <mclasen@redhat.com>
  140. - Rebuild
  141. * Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-1
  142. - Update to 0.60
  143. - Remove vendor from desktop file
  144. * Wed May 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-2
  145. - Rebuild
  146. * Fri Mar 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-1
  147. - Update to 0.51
  148. * Fri Mar 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-3
  149. - Add a patch from upstream to fix connection to serial devices (#356861)
  150. * Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-2
  151. - Work-around for telepathy brokeness
  152. * Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-1
  153. - Update to 0.50
  154. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.40-3
  155. - Autorebuild for GCC 4.3
  156. * Wed Dec 12 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-2
  157. - Rebuild against new release of gnokii
  158. * Wed Nov 14 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-1
  159. - Update to 0.40
  160. - Add experimental telepathy backend in a subpackage
  161. * Mon Oct 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.30-1
  162. - Update to 0.30
  163. - Fix sending non-ASCII texts (for real)
  164. - Add debugging improvements
  165. * Wed Oct 17 2007 - Bastien Nocera <bnocera@redhat.com> - 0.20-1
  166. - Update to 0.20
  167. * Sun Aug 19 2007 - Bastien Nocera <bnocera@redhat.com> - 0.10-1
  168. - Update to 0.10 (#253400)
  169. - Remove obsolete work-arounds and dependencies
  170. - Update BRs
  171. - Add GConf scriptlets
  172. * Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.8-6
  173. - Update license field from GPL to GPLv2+
  174. * Sun Nov 15 2006 Linus Walleij <triad@df.lth.se> 0.8-5
  175. - Rebuild to pick up libbtctl i/f bump.
  176. * Sun Oct 29 2006 Linus Walleij <triad@df.lth.se> 0.8-4
  177. - Rebuild to pick up libedataserver i/f bump.
  178. * Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-3
  179. - Pick up intltool.
  180. * Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-2
  181. - Pick up libtool.
  182. * Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-1
  183. - New upstream version including patch.
  184. - The icon is an an even weirder place now!
  185. - Have to run som autotools on this one to get it working.
  186. * Tue Sep 5 2006 Linus Walleij <triad@df.lth.se> 0.7-5
  187. - Patch to compile with new version of E-D-S.
  188. * Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> 0.7-4
  189. - Missing BR
  190. * Thu Aug 3 2006 Linus Walleij <triad@df.lth.se> 0.7-3
  191. - Updated after feedback from Chris Weyl
  192. - Bogus problem with cellphone.png icon image
  193. * Sat Jul 29 2006 Linus Walleij <triad@df.lth.se> 0.7-2
  194. - Updated after feedback from Parag and Paul
  195. * Tue Jun 27 2006 Linus Walleij <triad@df.lth.se> 0.7-1
  196. - 0.7 Release
  197. - Took Matthews nrpm package and Fedora Extrasificated it
  198. * Fri Sep 09 2005 Matthew Hall <matt@nrpms.net> 0.6-1
  199. - 0.6 Release
  200. * Mon Jun 20 2005 Matthew Hall <matt@nrpms.net> 0.4-1
  201. - 0.4 Release