grantlee-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. %define apidocs 0
  2. # apidocs disabled until we agree on a standard path.
  3. Name: grantlee
  4. Summary: Qt string template engine based on the Django template system
  5. Version: 0.3.0
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.gitorious.org/grantlee/pages/Home
  10. Source0: http://downloads.%{name}.org/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: qt4-devel qt4-designer cmake
  13. %if 0%{?apidocs}
  14. BuildRequires: doxygen
  15. %endif
  16. %description
  17. Grantlee is a plug-in based String Template system written
  18. using the Qt framework. The goals of the project are to make it easier for
  19. application developers to separate the structure of documents from the
  20. data they contain, opening the door for theming.
  21. The syntax is intended to follow the syntax of the Django template system,
  22. and the design of Django is reused in Grantlee.
  23. Django is covered by a BSD style license.
  24. Part of the design of both is that application developers can extend
  25. the syntax by implementing their own tags and filters. For details of
  26. how to do that, see the API documentation.
  27. For template authors, different applications using Grantlee will present
  28. the same interface and core syntax for creating new themes. For details of
  29. how to write templates, see the documentation.
  30. %package devel
  31. Summary: Development files for %{name}
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. The %{name}-devel package contains libraries and header files for
  36. developing applications that use %{name}.
  37. %package apidocs
  38. Group: Documentation
  39. Summary: Grantlee API documentation
  40. BuildArch: noarch
  41. %description apidocs
  42. This package includes the Grantlee API documentation in HTML
  43. format for easy browsing.
  44. %prep
  45. %setup -q -n %{name}-%{version}
  46. sed -i 's,${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX},%{_libdir},' CMakeLists.txt
  47. %build
  48. mkdir -p %{_target_platform}
  49. pushd %{_target_platform}
  50. %cmake .. -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=%{_prefix}
  51. popd
  52. make %{?_smp_mflags} -C %{_target_platform}
  53. %if 0%{?apidocs}
  54. make docs -C %{_target_platform}
  55. %endif
  56. %install
  57. rm -rf %{buildroot}
  58. make install -C %{_target_platform} DESTDIR=%{buildroot}
  59. %if 0%{?apidocs}
  60. mkdir -p %{buildroot}%{_docdir}/HTML/en/grantlee-apidocs
  61. cp -prf %{_target_platform}/apidocs/html/* %{buildroot}%{_docdir}/HTML/en/grantlee-apidocs
  62. %endif
  63. %clean
  64. rm -rf %{buildroot}
  65. %post -p /sbin/ldconfig
  66. %postun -p /sbin/ldconfig
  67. %files
  68. %defattr(-,root,root,-)
  69. %doc AUTHORS CHANGELOG COPYING.LIB README GOALS
  70. %{_libdir}/lib%{name}*.so.*
  71. %{_libdir}/%{name}
  72. %files devel
  73. %defattr(-,root,root,-)
  74. %{_includedir}/%{name}
  75. %{_includedir}/%{name}_core.h
  76. %{_includedir}/%{name}_templates.h
  77. %{_libdir}/lib%{name}*.so
  78. %{_libdir}/cmake/%{name}
  79. # %files apidocs
  80. # %{_docdir}/HTML/en/grantlee-apidocs
  81. %changelog
  82. * Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.0-1
  83. - new upstream release
  84. * Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.8-2
  85. - added BR: qt4-designer
  86. * Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.8-1
  87. - Initial build for VineSeed
  88. * Mon Sep 27 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.6-1
  89. - grantlee 0.1.6
  90. * Fri Aug 27 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.5-1
  91. - grantlee 0.1.5
  92. * Sun Jul 04 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.2-1
  93. - grantlee 0.1.2
  94. * Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.1-3
  95. - disabled apidocs until we find a standard path
  96. * Tue May 11 2010 Jaroslav Reznik <jreznik@redhat.com> 0.1.1-2
  97. - added -apidocs subpackage
  98. * Sun May 09 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.1-1
  99. - grantlee 0.1.1
  100. - fixed Group
  101. * Thu Apr 15 2010 Thomas Janssen <thomasj@fedoraproject.org> 0.1.0-1
  102. - initial fedora release