gsm-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Shared libraries for GSM speech compressor
  3. Name: gsm
  4. Version: 1.0.12
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: MIT
  8. URL: http://kbs.cs.tu-berlin.de/~jutta/toast.html
  9. Source: http://kbs.cs.tu-berlin.de/~jutta/gsm/%{name}-%{version}.tar.gz
  10. Patch0: %{name}-makefile.patch
  11. Patch1: %{name}-warnings.patch
  12. Patch2: %{name}-64bit.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. %define srcver 1.0-pl12
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. Contains runtime shared libraries for libgsm, an implementation of
  19. the European GSM 06.10 provisional standard for full-rate speech
  20. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  21. excitation/long term prediction) coding at 13 kbit/s.
  22. GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
  23. rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
  24. with typical UNIX applications, our implementation turns frames of 160
  25. 16-bit linear samples into 33-byte frames (1650 Bytes/s).
  26. The quality of the algorithm is good enough for reliable speaker
  27. recognition; even music often survives transcoding in recognizable
  28. form (given the bandwidth limitations of 8 kHz sampling rate).
  29. The interfaces offered are a front end modelled after compress(1), and
  30. a library API. Compression and decompression run faster than realtime
  31. on most SPARCstations. The implementation has been verified against the
  32. ETSI standard test patterns.
  33. %package tools
  34. Summary: GSM speech compressor tools
  35. Group: Applications/Multimedia
  36. %description tools
  37. Contains command line utilities for libgsm, an implementation of
  38. the European GSM 06.10 provisional standard for full-rate speech
  39. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  40. excitation/long term prediction) coding at 13 kbit/s.
  41. %package devel
  42. Summary: Header files and development libraries for libgsm
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description devel
  46. Contains header files and development libraries for libgsm, an
  47. implementation of the European GSM 06.10 provisional standard for
  48. full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
  49. (residual pulse excitation/long term prediction) coding at 13 kbit/s.
  50. # compat32
  51. %package -n compat32-%{name}
  52. Summary: Shared libraries for GSM speech compressor
  53. Group: System Environment/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. %description -n compat32-%{name}
  56. Contains runtime shared libraries for libgsm, an implementation of
  57. the European GSM 06.10 provisional standard for full-rate speech
  58. transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse
  59. excitation/long term prediction) coding at 13 kbit/s.
  60. GSM 06.10 compresses frames of 162 13-bit samples (8 kHz sampling
  61. rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility
  62. with typical UNIX applications, our implementation turns frames of 160
  63. 16-bit linear samples into 33-byte frames (1650 Bytes/s).
  64. The quality of the algorithm is good enough for reliable speaker
  65. recognition; even music often survives transcoding in recognizable
  66. form (given the bandwidth limitations of 8 kHz sampling rate).
  67. The interfaces offered are a front end modelled after compress(1), and
  68. a library API. Compression and decompression run faster than realtime
  69. on most SPARCstations. The implementation has been verified against the
  70. ETSI standard test patterns.
  71. %package -n compat32-%{name}-devel
  72. Summary: Header files and development libraries for libgsm
  73. Group: Development/Libraries
  74. Requires: %{name}-devel = %{version}-%{release}
  75. %description -n compat32-%{name}-devel
  76. Contains header files and development libraries for libgsm, an
  77. implementation of the European GSM 06.10 provisional standard for
  78. full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP
  79. (residual pulse excitation/long term prediction) coding at 13 kbit/s.
  80. %prep
  81. %setup -n gsm-%{srcver} -q
  82. %patch0 -p1 -b .mk
  83. %patch1 -p1 -b .warn
  84. %patch2 -p1 -b .64bit
  85. %build
  86. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -fPIC";
  87. make %{?_smp_mflags} all
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  91. mkdir -p $RPM_BUILD_ROOT%{_includedir}/gsm
  92. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  93. mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man1,man3}
  94. make install \
  95. INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix} \
  96. GSM_INSTALL_INC=$RPM_BUILD_ROOT%{_includedir}/gsm \
  97. GSM_INSTALL_LIB=$RPM_BUILD_ROOT%{_libdir}
  98. cp -p $RPM_BUILD_DIR/gsm-%{srcver}/lib/libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}
  99. ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so.1
  100. ln -s libgsm.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgsm.so
  101. # some apps look for this in /usr/include
  102. ln -s gsm/gsm.h $RPM_BUILD_ROOT%{_includedir}
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
  104. %check
  105. # This is to ensure that the patch creates the proper library version.
  106. [ -f $RPM_BUILD_ROOT%{_libdir}/libgsm.so.%{version} ]
  107. make addtst
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %post -p /sbin/ldconfig
  111. %postun -p /sbin/ldconfig
  112. %post -n compat32-%{name} -p /sbin/ldconfig
  113. %postun -n compat32-%{name} -p /sbin/ldconfig
  114. %files
  115. %defattr(-,root,root,-)
  116. %doc ChangeLog COPYRIGHT MACHINES README
  117. %{_libdir}/libgsm.so.*
  118. %files tools
  119. %{_bindir}/tcat
  120. %{_bindir}/toast
  121. %{_bindir}/untoast
  122. %{_mandir}/man1/toast.1*
  123. %files devel
  124. %defattr(-,root,root,-)
  125. %dir %{_includedir}/gsm
  126. %{_includedir}/gsm/gsm.h
  127. %{_includedir}/gsm.h
  128. %{_libdir}/libgsm.so
  129. %{_mandir}/man3/*
  130. # compat32
  131. %if %{build_compat32}
  132. %files -n compat32-%{name}
  133. %defattr(-,root,root,-)
  134. %{_libdir}/libgsm.so.*
  135. %files -n compat32-%{name}-devel
  136. %defattr(-,root,root,-)
  137. %{_libdir}/libgsm.so
  138. %endif
  139. %changelog
  140. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.12-3
  141. - create compat32 sub package
  142. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.12-2
  143. - rebuilt with current VineSeed
  144. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  145. - initial build for Vine Linux
  146. * Mon Feb 11 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.0.12-6
  147. - Rebuild for GCC 4.3
  148. * Sun Aug 26 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-5
  149. - install symlinks instead of binaries in -devel
  150. * Sat Aug 25 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-4
  151. - rebuild for BuildID
  152. - specfile cleanups
  153. * Sun May 13 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-3
  154. - fix parallel make
  155. * Fri May 11 2007 Dominik Mierzejewski <rpm[AT]greysector.net> 1.0.12-2
  156. - fix some warnings
  157. - fix 64bit testsuite issue as described at gsm homepage
  158. - add compatibility header symlink
  159. - split off binaries into a separate package
  160. * Sun Apr 15 2007 Michael Schwendt <mschwendt[AT]users.sf.net> 1.0.12-1
  161. - Update to Release 1.0 Patchlevel 12.
  162. - Build with -fPIC not just for non-ix86.
  163. - Add check section to ensure proper library version.
  164. - Remove static library.
  165. * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.0.10-12
  166. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  167. * Tue Sep 26 2006 Thomas Vander Stichele <thomas at apestaart dot org>
  168. - 1.0.10-11
  169. - rebuild for FC6
  170. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  171. - switch to new release field
  172. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  173. - add dist
  174. * Mon Jun 27 2005 David Woodhouse <dwmw2@infradead.org>
  175. - 1.0.10-0.lvn.10: Clean up installation
  176. * Sat Jun 25 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  177. - 1.0.10-0.lvn.9: mv libgsm.a only when needed
  178. * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>
  179. - 1.0.10-0.lvn.8: Use -fPIC on non ix86
  180. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  181. - 1.0.10-0.lvn.7: moved to rpm.livna.org
  182. * Tue Mar 02 2004 Thomas Vander Stichele <thomas at apestaart dot org>
  183. - 1.0.10-0.fdr.7: applied patch from Ville, remove epoch since it's allowed
  184. * Sat Sep 13 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  185. - 0:1.0.10-0.fdr.6: remove second makeinstall
  186. * Sun Sep 07 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  187. - 0:1.0.10-0.fdr.5
  188. - added back epochs, I surrender
  189. - fix RPM_OPT_FLAGS hackery
  190. * Fri Jul 18 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  191. - 1.0.10-0.fdr.4: remove epoch mentions
  192. * Sat Jul 05 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  193. - 1.0.10-0.fdr.3
  194. - pull in RPM_OPT_FLAGS in patch instead of using perl to wedge it in
  195. - fix group
  196. - -p'ize ldconfig
  197. * Tue Jun 10 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  198. - 1.0.10-0.fdr.2
  199. - Fix libgsm.so.* being files instead of symlinks
  200. * Thu May 29 2003 Thomas Vander Stichele <thomas at apestaart dot org>
  201. - 0:1.0.10-0.fdr.1: initial RPM release