gtest-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. Summary: Google C++ testing framework
  2. Summary(ja): Google C++ テスティングフレームワーク
  3. Name: gtest
  4. Version: 1.6.0
  5. Release: 1%{?_dist_release}
  6. License: New BSD
  7. Group: Development/Tools
  8. URL: http://code.google.com/p/googletest/
  9. Source0: http://googletest.googlecode.com/files/%{name}-%{version}.tar.xz
  10. Patch0: gtest-1.6.0_install.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: chrpath
  13. BuildRequires: python >= 2.3
  14. %description
  15. Google's framework for writing C++ tests on a variety of platforms (GNU/Linux,
  16. Mac OS X, Windows, Windows CE, and Symbian). Based on the xUnit architecture.
  17. Supports automatic test discovery, a rich set of assertions, user-defined
  18. assertions, death tests, fatal and non-fatal failures, various options for
  19. running the tests, and XML test report generation.
  20. %package devel
  21. Summary: Development files for %{name}
  22. Summary(ja): %{name} の開発ファイル
  23. Group: Development/Libraries
  24. Requires: automake
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. This package contains development files for %{name}.
  28. %prep
  29. %setup -q
  30. %patch0 -p1
  31. # Keep a clean copy of samples.
  32. cp -pr ./samples ./samples.orig
  33. %build
  34. %configure --disable-static
  35. # Omit unused direct shared library dependencies.
  36. sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
  37. make %{?_smp_mflags}
  38. %check
  39. # Two tests fail here, unclear as to why.
  40. make check
  41. # Restore the clean copy of samples.
  42. # To be later listed against %doc.
  43. rm -rf ./samples
  44. mv ./samples.orig ./samples
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
  48. find $RPM_BUILD_ROOT -type f -name "*.la" -delete
  49. # Remove rpaths.
  50. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libgtest_main.so.0.0.0
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %post -p /sbin/ldconfig
  54. %postun -p /sbin/ldconfig
  55. %files
  56. %defattr(-,root,root,-)
  57. %doc CHANGES
  58. %doc CONTRIBUTORS
  59. %doc COPYING
  60. %doc README
  61. %{_libdir}/libgtest.so.*
  62. %{_libdir}/libgtest_main.so.*
  63. %files devel
  64. %defattr(-,root,root,-)
  65. %doc samples
  66. #%{_bindir}/%{name}-config
  67. %{_datadir}/aclocal/%{name}.m4
  68. %{_libdir}/libgtest.so
  69. %{_libdir}/libgtest_main.so
  70. %dir %{_includedir}/%{name}
  71. %{_includedir}/%{name}/*.h
  72. %{_includedir}/%{name}/internal
  73. %changelog
  74. * Sun Apr 29 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.0-1
  75. - new upstream release
  76. - changed source archive type to xz
  77. - added Patch0 from Mandriva
  78. * Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
  79. - rebuilt with rpm-4.8.1 for pkg-config
  80. * Sun May 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
  81. - initial build for VineSeed
  82. * Sat Nov 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.4.0-1
  83. - Version bump to 1.4.0.
  84. * New feature: the event listener API.
  85. * New feature: test shuffling.
  86. * New feature: the XML report format is closer to junitreport and can
  87. be parsed by Hudson now.
  88. * New feature: elapsed time for the tests is printed by default.
  89. * New feature: comes with a TR1 tuple implementation such that Boost
  90. is no longer needed for Combine().
  91. * New feature: EXPECT_DEATH_IF_SUPPORTED macro and friends.
  92. * New feature: the Xcode project can now produce static gtest libraries in
  93. addition to a framework.
  94. * Compatibility fixes for gcc and minGW.
  95. * Bug fixes and implementation clean-ups.
  96. * Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 1.3.0-2.20090601svn257
  97. - Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  98. * Mon Jun 01 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.0-1
  99. - Version bump to 1.3.0.
  100. * New feature: ability to use Google Test assertions in other testing
  101. frameworks.
  102. * New feature: ability to run disabled test via
  103. --gtest_also_run_disabled_tests.
  104. * New feature: the --help flag for printing the usage.
  105. * New feature: access to Google Test flag values in user code.
  106. * New feature: a script that packs Google Test into one .h and one .cc file
  107. for easy deployment.
  108. * New feature: support for distributing test functions to multiple machines
  109. (requires support from the test runner).
  110. * Bug fixes and implementation clean-ups.
  111. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  113. * Sat Jul 05 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.0.0-1
  114. - Initial build.