haveged-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. Summary: A Linux entropy source using the HAVEGE algorithm
  2. Summary(ja): HAVEFE アルゴリズムを使った Linux のエントロピーソース
  3. Name: haveged
  4. Version: 1.7a
  5. Release: 1%{?_dist_release}
  6. License: GPLv3+
  7. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  8. Group: System Environment/Daemons
  9. URL: http://www.irisa.fr/caps/projects/hipsor/
  10. Source0: http://www.issihosts.com/haveged/%{name}-%{version}.tar.gz
  11. Requires(post): chkconfig
  12. Requires(preun): chkconfig, initscripts
  13. Requires(postun): initscripts
  14. BuildRequires: automake gdb coreutils glibc-common
  15. %description
  16. A Linux entropy source using the HAVEGE algorithm
  17. Haveged is a user space entropy daemon which is not dependent upon the
  18. standard mechanisms for harvesting randomness for the system entropy
  19. pool. This is important in systems with high entropy needs or limited
  20. user interaction (e.g. headless servers).
  21. Haveged uses HAVEGE (HArdware Volatile Entropy Gathering and Expansion)
  22. to maintain a 1M pool of random bytes used to fill /dev/random
  23. whenever the supply of random bits in /dev/random falls below the low
  24. water mark of the device. The principle inputs to haveged are the
  25. sizes of the processor instruction and data caches used to setup the
  26. HAVEGE collector. The haveged default is a 4kb data cache and a 16kb
  27. instruction cache. On machines with a cpuid instruction, haveged will
  28. attempt to select appropriate values from internal tables.
  29. %package devel
  30. Summary: Headers and shared development libraries for HAVEGE algorithm
  31. Summary(ja): Headers and shared development libraries for HAVEGE algorithm
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. Headers and shared object symbolic links for the HAVEGE algorithm
  36. %prep
  37. %setup -q
  38. %build
  39. #autoreconf -fiv
  40. %configure --enable-init=sysv.redhat
  41. #SMP build is not working
  42. #make %{?_smp_mflags}
  43. make
  44. %check
  45. make check
  46. %install
  47. rm -rf %{buildroot}
  48. make install DESTDIR=%{buildroot} INSTALL="install -p"
  49. chmod 0644 COPYING README ChangeLog AUTHORS
  50. # We don't ship .la files.
  51. rm -rf %{buildroot}%{_libdir}/libhavege.*a
  52. %clean
  53. rm -rf %{buildroot}
  54. %post
  55. /sbin/chkconfig --add haveged
  56. %preun
  57. if [ "$1" -eq "0" ]; then
  58. /sbin/service haveged stop >/dev/null 2>&1
  59. /sbin/chkconfig --del haveged
  60. fi
  61. %postun
  62. if [ "$1" -ge "1" ]; then
  63. /sbin/service haveged condrestart >/dev/null 2>&1
  64. fi
  65. %files
  66. %defattr(-, root, root, -)
  67. %doc COPYING README ChangeLog AUTHORS contrib/build/havege_sample.c
  68. %{_mandir}/man8/haveged.8*
  69. %{_sbindir}/haveged
  70. %{_libdir}/*so.*
  71. %{_sysconfdir}/init.d/haveged
  72. %files devel
  73. %defattr(-, root, root, -)
  74. %{_mandir}/man3/libhavege.3*
  75. %dir %{_includedir}/%{name}
  76. %{_includedir}/%{name}/havege.h
  77. %{_libdir}/*.so
  78. %changelog
  79. * Sun Mar 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7a-1
  80. - update to 1.7a
  81. * Sat Mar 23 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-1
  82. - initial build for Vine Linux
  83. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-1
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  85. * Sat Jan 19 2013 Jirka Hladky <hladky.jiri@gmail.com> - 1.7-0
  86. - Updated to the version 1.7
  87. - Version 1.7 brings developement libraries
  88. - Added devel package
  89. * Sat Oct 13 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-2
  90. - BZ 850144
  91. - Introduce new systemd-rpm macros in haveged spec file
  92. - Fedora 19 changes the way how to work with services in spec files.
  93. - It introduces new macros - systemd_post, systemd_preun and systemd_postun;
  94. - which replace scriptlets from Fedora 18 and older
  95. - see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
  96. * Tue Aug 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.5-1
  97. - Update to the version 1.5
  98. - Main new feature is a run time verification of the produced random numbers
  99. - PIDFILE set to /run/haveged.pid
  100. - converted README and man page to UTF-8. Informed the upstream to fix it.
  101. * Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-3
  102. - PIDFile should be stored at /run instead of the default location /var/run
  103. - There is long term plan that directory /var/run will not further exist in the future Fedora versions
  104. - Asked upstream to add -p <PID_FILE_location> switch to influence the location of the PID File
  105. - Set PIDFile=/var/run/haveged.pid This is needed as long -p option is not implemented
  106. - https://bugzilla.redhat.com/show_bug.cgi?id=770306#c10
  107. * Wed Feb 15 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-2
  108. - Updated systemd service file, https://bugzilla.redhat.com/show_bug.cgi?id=770306
  109. * Tue Feb 14 2012 Jirka Hladky <hladky.jiri@gmail.com> - 1.4-1
  110. - Update to the version 1.4
  111. - Conversion to systemd, drop init script
  112. * Sun Nov 06 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-2
  113. - Fixed a bug on non x86 systems
  114. * Sat Nov 05 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-1
  115. - update from the upstream (1.3 stable)
  116. * Mon Oct 03 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.3-0
  117. -version 1.3 beta
  118. * Fri Sep 30 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-4
  119. - ppc64 build
  120. * Mon Sep 26 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-3
  121. - Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c11
  122. * Sat Sep 24 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-2
  123. - Added comment to explain why we need use Fedora specific start script
  124. * Wed Sep 21 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-1
  125. - Cleaned spec file according to https://bugzilla.redhat.com/show_bug.cgi?id=739347#c1
  126. * Wed Sep 07 2011 Jirka Hladky <hladky.jiri@gmail.com> - 1.2-0
  127. - Initial build