havp.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129
  1. %define clamav_version 0.96
  2. Summary: HAVP - HTTP Anti Virus Proxy
  3. Name: havp
  4. Version: 0.92a
  5. Release: 1%{_dist_release}
  6. License: GPL
  7. Group: Applications/System
  8. URL: http://www.server-side.de/
  9. Source0: http://www.server-side.de/download/havp-%{version}.tar.gz
  10. Patch0: havp.patch
  11. BuildRequires: libstdc++-devel, zlib-devel, bzip2-devel, gmp-devel
  12. BuildRequires: clamav-devel => %{clamav_version}
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root/
  14. #Requires: libstdc++, zlib, bzip2, gmp
  15. Requires: clamav => %{clamav_version}
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: tomop
  19. %description
  20. HAVP (HTTP AntiVirus proxy) is a proxy with an anti-virus filter.
  21. It does not cache or filter content. At the moment the complete
  22. traffic is scanned. The reason for this is the chance of malicious
  23. code in nearly every filetype e.g. HTML (JavaScript) or Jpeg. I aim
  24. to stop especially dialer or browser exploits. But writing a http
  25. Anti Virus Proxy is a real dilemma! Huge downloads are a problem
  26. for virus scanning proxies. A Client should not receive data which
  27. is unchecked by the virus scanner, but big downloads should not timeout.
  28. %prep
  29. %setup -q
  30. %patch0 -p0
  31. #%patch1 -p1
  32. %build
  33. %configure --with-scanner=libclamav --enable-ssl-tunnel
  34. make %{?_smp_mflags}
  35. %install
  36. rm -rf %{buildroot}
  37. mkdir -p %{buildroot}%{_sbindir}
  38. mkdir -p %{buildroot}%{_sysconfdir}/havp/templates
  39. mkdir -p %{buildroot}%{_localstatedir}/log/havp
  40. mkdir -p %{buildroot}%{_localstatedir}/tmp/havp
  41. mkdir -p %{buildroot}%{_localstatedir}/run/havp
  42. mkdir -p %{buildroot}%{_initdir}
  43. install -m755 havp/havp %{buildroot}%{_sbindir}
  44. install -m755 etc/init.d/havp %{buildroot}%{_initdir}
  45. install -m644 etc/havp/havp.config %{buildroot}%{_sysconfdir}/havp/havp.config
  46. install -m644 etc/havp/whitelist %{buildroot}%{_sysconfdir}/havp/whitelist
  47. install -m644 etc/havp/blacklist %{buildroot}%{_sysconfdir}/havp/blacklist
  48. cp -r etc/havp/templates/* %{buildroot}%{_sysconfdir}/havp/templates
  49. chmod -R a+rX %{buildroot}/etc/havp/templates
  50. %clean
  51. rm -rf %{buildroot}
  52. %pre
  53. if ! grep -q '^havp:' /etc/group; then
  54. /usr/sbin/groupadd -r havp
  55. fi
  56. if ! grep -q '^havp:' /etc/passwd; then
  57. /usr/sbin/useradd -M -r -s /sbin/nologin -g havp havp || :
  58. fi
  59. %postun
  60. /sbin/ldconfig
  61. if [ $1 = 0 ]; then
  62. if [ `grep havp /etc/passwd | wc -l` = 1 ]; then
  63. /usr/sbin/userdel havp
  64. fi
  65. if [ `grep havp /etc/group | wc -l` = 1 ]; then
  66. /usr/sbin/groupdel havp
  67. fi
  68. fi
  69. %post -p /sbin/ldconfig
  70. %files
  71. %defattr(-,root,root,-)
  72. %doc INSTALL COPYING ChangeLog
  73. %{_initdir}/havp
  74. %{_sbindir}/havp
  75. %config(noreplace) %{_sysconfdir}/havp/havp.config
  76. %config(noreplace) %{_sysconfdir}/havp/whitelist
  77. %config(noreplace) %{_sysconfdir}/havp/blacklist
  78. %{_sysconfdir}/havp/templates/*
  79. %attr(750,havp,havp) %dir /var/log/havp
  80. %attr(750,havp,havp) %dir /var/tmp/havp
  81. %attr(750,havp,havp) %dir /var/run/havp
  82. %changelog
  83. * Sun Dec 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92a-1
  84. - new upstream release.
  85. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92-1
  86. - new upstream release.
  87. * Thu Jun 11 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.90-1
  88. - new upstream release.
  89. * Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.89-1
  90. - new upstream release.
  91. - built with clamav-0.95.
  92. * Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-2
  93. - rebuild with clamav-0.93.
  94. * Mon Apr 14 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-1
  95. - rebuilt with VineSeed.
  96. * Sat Mar 1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.87-0vl1
  97. - new upstream release.
  98. * Sun Mar 11 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl2
  99. - built with clamav-0.90.1.
  100. * Mon Feb 26 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.85-0vl1
  101. - new upstream release.
  102. * Thu Oct 19 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.82-0vl1
  103. - new upstream release.
  104. * Thu Jul 20 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.81-0vl1
  105. - initial build.