htdig-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324
  1. %define buildweb 1
  2. %define beta b6
  3. %define contentdir /var/www
  4. %define apachebin %{_sbindir}/apache2
  5. Name: htdig
  6. Summary: ht://Dig - Web search engine
  7. Summary(ja): ht://Dig Web 検索エンジン
  8. Version: 3.2.0
  9. Release: 8.%{beta}%{?_dist_release}
  10. License: GPLv2
  11. Group: Applications/Internet
  12. URL: http://www.htdig.org/
  13. Source: http://www.htdig.org/files/%{name}-%{version}%{beta}.tar.bz2
  14. Source1: htdig.conf
  15. Patch1: htdig-3.1.5-rh.patch
  16. Patch2: htdig-3.2.0b4-xopen.patch
  17. Patch4: htdig-3.2.0b5-overflow.patch
  18. Patch5: htdig-3.2.0b6-robots.patch
  19. Patch6: htdig-3.2.0b6-unescaped_output.patch
  20. Patch8: htdig-3.2.0b6-compile-fix.patch
  21. Patch9: htdig-3.2.0b6-opts.patch
  22. Patch11: htdig-3.2.0b6-incremental.patch
  23. Patch12: htdig-3.2-CVE-2007-6110.patch
  24. Patch13: htdig-3.2.0b6-htstat-segv.patch
  25. Patch14: htdig-3.2.0-external_parsers.patch
  26. Patch15: htdig-3.2.0-allow_numbers.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: flex >= 2.5.4a-13
  29. BuildRequires: zlib-devel
  30. BuildRequires: openssl-devel
  31. BuildRequires: apache2
  32. BuildRequires: autoconf automake libtool
  33. %package web
  34. Summary: Scripts and HTML code needed for using ht://Dig as a web search engine
  35. Group: Applications/Internet
  36. Requires: %{name} = %{version}
  37. Requires: webserver
  38. %description
  39. The ht://Dig system is a complete world wide web indexing and searching
  40. system for a small domain or intranet. This system is not meant to replace
  41. the need for powerful internet-wide search systems like Lycos, Infoseek,
  42. Webcrawler and AltaVista. Instead it is meant to cover the search needs for
  43. a single company, campus, or even a particular sub section of a web site. As
  44. opposed to some WAIS-based or web-server based search engines, ht://Dig can
  45. span several web servers at a site. The type of these different web servers
  46. doesn't matter as long as they understand the HTTP 1.0 protocol.
  47. ht://Dig is also used by KDE to search KDE's HTML documentation.
  48. ht://Dig was developed at San Diego State University as a way to search the
  49. various web servers on the campus network.
  50. %description web
  51. The ht://Dig system is a complete world wide web indexing and searching
  52. system for a small domain or intranet. This system is not meant to replace
  53. the need for powerful internet-wide search systems like Lycos, Infoseek,
  54. Webcrawler and AltaVista. Instead it is meant to cover the search needs for
  55. a single company, campus, or even a particular sub section of a web site. As
  56. opposed to some WAIS-based or web-server based search engines, ht://Dig can
  57. span several web servers at a site. The type of these different web servers
  58. doesn't matter as long as they understand the HTTP 1.0 protocol.
  59. The %{name}-web package includes CGI scripts and HTML code needed to use
  60. ht://Dig on a website.
  61. ht://Dig was developed at San Diego State University as a way to search the
  62. various web servers on the campus network.
  63. %prep
  64. %setup -q -n %{name}-%{version}%{beta}
  65. %patch1 -p1 -b .rh
  66. %patch2 -p1 -b .xopen
  67. %patch4 -p1 -b .overflow
  68. %patch5 -p1 -b .robots
  69. %patch6 -p1 -b .unescaped_output
  70. %patch8 -p1 -b .compile-fix
  71. %patch9 -p1 -b .opts
  72. %patch11 -p1 -b .incremental
  73. %patch12 -p1 -b .CVE-2007-6110
  74. %patch13 -p1 -b .htstat-segv
  75. %patch14 -p1 -b .external_parsers
  76. %patch15 -p1 -b .allow_numbers
  77. autoreconf -fiv
  78. %build
  79. %configure \
  80. --enable-shared \
  81. --enable-tests \
  82. --enable-bigfile \
  83. --with-config-dir=%{_sysconfdir}/htdig \
  84. --with-common-dir=%{contentdir}/html/htdig \
  85. --with-database-dir=/var/lib/htdig \
  86. --localstatedir=/var/lib/htdig \
  87. --with-cgi-bin-dir=%{contentdir}/cgi-bin \
  88. --with-image-dir=%{contentdir}/html/htdig \
  89. --with-search-dir=%{contentdir}/html/htdig \
  90. --with-default-config-file=%{_sysconfdir}/htdig/htdig.conf \
  91. --with-apache=%{apachebin} \
  92. --with-zlib=%{_prefix} \
  93. --with-ssl
  94. make
  95. %install
  96. rm -rf $RPM_BUILD_ROOT
  97. make install DESTDIR=$RPM_BUILD_ROOT
  98. ln $RPM_BUILD_ROOT%{contentdir}/cgi-bin/htsearch $RPM_BUILD_ROOT%{_bindir}
  99. chmod 644 $RPM_BUILD_ROOT%{contentdir}/html/htdig/*
  100. ln -sf search.html $RPM_BUILD_ROOT%{contentdir}/html/htdig/index.html
  101. # now get rid of the $RPM_BUILD_ROOT paths in the conf files
  102. for i in %{_sysconfdir}/htdig/htdig.conf /usr/bin/rundig ; do
  103. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT/$i
  104. done
  105. mkdir -p $RPM_BUILD_ROOT%{_prefix}/share
  106. mv $RPM_BUILD_ROOT%{contentdir}/html/htdig $RPM_BUILD_ROOT%{_prefix}/share
  107. mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
  108. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/httpd/conf.d/htdig.conf
  109. rm -rf $RPM_BUILD_ROOT%{_includedir}
  110. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.a
  111. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig/*.la
  112. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.a
  113. rm -rf $RPM_BUILD_ROOT%{_libdir}/htdig_db/*.la
  114. %clean
  115. rm -rf $RPM_BUILD_ROOT
  116. %files
  117. %defattr(-,root,root)
  118. %doc htdoc/*
  119. %dir %{_sysconfdir}/htdig
  120. %config %{_sysconfdir}/htdig/htdig.conf
  121. %config %{_sysconfdir}/htdig/cookies.txt
  122. %{_sysconfdir}/htdig/HtFileType-magic.mime
  123. %{_sysconfdir}/htdig/mime.types
  124. %dir /var/lib/htdig
  125. %{_bindir}/*
  126. %{_libdir}/htdig
  127. %{_libdir}/htdig_db
  128. %{_mandir}/man1/*
  129. %if %buildweb
  130. %files web
  131. %defattr(-,root,root)
  132. %{contentdir}/cgi-bin/*
  133. %config %{_sysconfdir}/httpd/conf.d/htdig.conf
  134. %dir %{_datadir}/htdig
  135. %{_datadir}/htdig/*
  136. %{_mandir}/man8/*
  137. %endif
  138. %changelog
  139. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-8.b6
  140. - rebuilt with current VineSeed
  141. - replaced Patch100 to Patch8
  142. - added --with-ssl option to %%configure
  143. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.0-7.b6vl5
  144. - applied new versioning policy
  145. * Sun Sep 2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2.0-6.1vl1.b6
  146. - new upstream release
  147. - added Patch100 for building with gcc4
  148. * Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl1.b5
  149. - rebuild for VineSeedPlus
  150. * Thu Mar 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.0-6.1vl0.b5
  151. - build for VinePlus/2.6
  152. - remove commented lines
  153. - change configure options for apache of Vine
  154. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  155. - rebuilt
  156. * Thu Feb 26 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-6
  157. - Removed buildroot cruft from HtFileFype (#116442).
  158. - Use mktemp in HtFileFype to create temporary file (#116443).
  159. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  160. - rebuilt
  161. * Thu Jan 15 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-4
  162. - Fixed missing & in if clause.
  163. * Tue Jan 13 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-3
  164. - Fixed latin1 char translation (#71921).
  165. - Fixed overflow bug in WordDBPage.cc (#110802).
  166. * Mon Jan 12 2004 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-2
  167. - Moved /usr/share/htdig files to web package (#111938).
  168. * Fri Dec 12 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0b5-1
  169. - Update to latest stable upstream version htdig-3.2.0b5.
  170. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  171. - rebuilt
  172. * Wed Jun 04 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-18.20030601
  173. - Update to htdig-3.2.0b4-20030601 snapshot.
  174. - Fixed build problems.
  175. * Thu Mar 06 2003 Phil Knirsch <pknirsch@redhat.com> 3.2.0-17.20030302
  176. - Update to htdig-3.2.0b4-20030302 snapshot.
  177. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  178. - rebuilt
  179. * Wed Jan 8 2003 Jeff Johnson <jbj@redhat.com> 3.2.0-15.20021103
  180. - don't include -debuginfo files in package.
  181. * Tue Dec 17 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-14.20021103
  182. - Forgot to create conf.d directory. Fixed.
  183. - Fixed wrong files section.
  184. * Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-13.20021103
  185. - Removed symlink from %{contentdir}/html and replaced it with httpd.d conf
  186. file (#73518).
  187. * Tue Dec 10 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-12.20021103
  188. - Added webserver requirement for htdig-web package (#73986).
  189. * Wed Dec 04 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-11.20021103
  190. - Fix for autoFOO patch.
  191. - Fix x64_64 build.
  192. * Wed Nov 27 2002 Tim Powers <timp@redhat.com> 3.2.0-9.20021103
  193. - rebuild on all arches
  194. * Fri Nov 08 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-8.20021103
  195. - Updated to htdig-3.2.0b4-20021103.
  196. - Fixed %files section errors.
  197. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.2.0-7.20020505
  198. - rebuilt with gcc-3.2 (we hope)
  199. * Tue Jul 23 2002 Tim Powers <timp@redhat.com> 3.2.0-6.20020505
  200. - build using gcc-3.2-0.1
  201. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 3.2.0-5.20020505
  202. - automated rebuild
  203. * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 3.2.0-4.20020505
  204. - Don't forcibly strip binaries
  205. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  206. - automated rebuild
  207. * Mon May 6 2002 Bernhard Rosenkraenzer <bero@linux-easy.com> 3.2.0-2.20020505
  208. - Fix build with current toolchain (automake 1.6, autoconf 2.53 changes)
  209. - Update snapshot, fixes some more problems
  210. * Thu Jan 24 2002 Phil Knirsch <pknirsch@redhat.com>
  211. - Updated to latest snapshot to fix several problems.
  212. - Fixed a problem with htdig segfaulting on s390 (#58202).
  213. * Fri Jul 20 2001 Philipp Knirsch <pknirsch@redhat.de>
  214. - Added missing BuildRequires: zlib-devel (#49500)
  215. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  216. - Bump release + rebuild.
  217. * Fri Apr 27 2001 Bill Nottingham <notting@redhat.com>
  218. - rebuild for C++ exception handling on ia64
  219. * Wed Mar 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.2.0-0.b3.4
  220. - move pictures etc. to base package and to a directory outside of
  221. /var/www - The current KDevelop search function doesn't work without
  222. them.
  223. * Mon Mar 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  224. - Add htsearch to the base package, kdevelop needs it
  225. * Wed Jan 10 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  226. - Move the web related files to a separate package
  227. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  228. - 3.2.0b2
  229. - fix build with glibc 2.2 and gcc 2.96
  230. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  231. - fix syntax error introduced in our patch (#16598)
  232. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  233. - fixed group to be a valid one
  234. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  235. - rebuilt
  236. * Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  237. - rebuild for Power Tools
  238. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  239. - rebuild for Power Tools
  240. * Sat Feb 26 2000 Nalin Dahyabhai <nalin@redhat.com>
  241. - 3.1.5
  242. * Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  243. - 3.1.4
  244. - fix URL and source location
  245. * Tue Sep 28 1999 Preston Brown <pbrown@redhat.com>
  246. - 3.1.3 for SWS 3.1
  247. * Wed May 05 1999 Preston Brown <pbrown@redhat.com>
  248. - updates for SWS 3.0
  249. * Mon Aug 31 1998 Preston Brown <pbrown@redhat.com>
  250. - Updates for SWS 2.0
  251. * Sat Feb 07 1998 Cristian Gafton <gafton@redhat.com>
  252. - built against glibc
  253. - build all the fuzzy databases before packaging, because it is time
  254. consuming operation and we don't want the user to be impatient