js-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312
  1. #% global hgdate 51702867d932
  2. Summary: JavaScript interpreter and libraries
  3. Name: js
  4. Version: 1.8.5
  5. Release: 2%{?hgdate:.hg%{hgdate}}%{?_dist_release}
  6. # The sources are triple licensed, but when we link against readline which is
  7. # GPL, the result can only be GPL.
  8. %if 0%{?_without_readline:1}
  9. License: GPLv2+ or LGPLv2+ or MPLv1.1
  10. %else
  11. License: GPLv2+
  12. %endif
  13. Group: Development/Languages
  14. URL: http://www.mozilla.org/js/
  15. Source0: http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
  16. Patch0: js-1.8.5-64bit-big-endian.patch
  17. Patch1: js-1.8.5-secondary-jit.patch
  18. Patch2: js185-destdir.patch
  19. Patch3: js-1.8.5-configure.patch
  20. Patch4: js-1.8.5-537701.patch
  21. Patch5: js185-arm-nosoftfp.patch
  22. Provides: libjs = %{version}-%{release}
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. Buildrequires: nspr-devel >= 4.7, python, zip
  25. Buildrequires: readline-devel, ncurses-devel, autoconf213
  26. Epoch: 1
  27. Vendor: Project Vine
  28. Distribution: Vine Linux
  29. %description
  30. JavaScript is the Netscape-developed object scripting language used in millions
  31. of web pages and server applications worldwide. Netscape's JavaScript is a
  32. superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
  33. with only mild differences from the published standard.
  34. %package devel
  35. Summary: Header files, libraries and development documentation for %{name}
  36. Group: Development/Libraries
  37. Requires: %{name} = %{epoch}:%{version}-%{release}
  38. Requires: pkgconfig
  39. Requires: ncurses-devel readline-devel
  40. Provides: libjs-devel = %{version}-%{release}
  41. %description devel
  42. This package contains the header files, static libraries and development
  43. documentation for %{name}. If you like to develop programs using %{name},
  44. you will need to install %{name}-devel.
  45. %prep
  46. # All patches come from old version and maintainer. I think it is Fedora related only
  47. %setup -q -n %{name}-%{version}
  48. %patch0 -p2 -b .64bit-big-endian
  49. %patch1 -p2 -b .secondary-jit
  50. %patch2 -p0 -b .destdir
  51. %patch3 -p1 -b .version
  52. %patch4 -p1 -b .537701
  53. %patch5 -p1 -b .armhfp
  54. cd js
  55. # Rm parts with spurios licenses, binaries
  56. # Some parts under BSD (but different suppliers): src/assembler
  57. #rm -rf src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
  58. rm -rf src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8
  59. pushd src
  60. autoconf-2.13
  61. %configure \
  62. --with-system-nspr \
  63. --enable-threadsafe \
  64. %if 0%{!?_without_readline:1}
  65. --enable-readline \
  66. %endif
  67. popd
  68. # Create pkgconfig file
  69. %{__cat} > libjs.pc << 'EOF'
  70. prefix=%{_prefix}
  71. exec_prefix=%{_prefix}
  72. libdir=%{_libdir}
  73. includedir=%{_includedir}
  74. Name: libjs
  75. Description: JS library
  76. Requires: nspr >= 4.7
  77. Version: %{version}
  78. Libs: -L${libdir} -ljs
  79. Cflags: -DXP_UNIX=1 -DJS_THREADSAFE=1 -I${includedir}/js
  80. EOF
  81. %build
  82. cd js
  83. %{__make} %{?_smp_mflags} -C src
  84. %install
  85. cd js
  86. %{__make} -C src install DESTDIR=%{buildroot}
  87. # We don't want this
  88. %{__rm} -f %{buildroot}%{_bindir}/js-config
  89. %{__install} -m 0755 src/jscpucfg src/shell/js %{buildroot}%{_bindir}/
  90. %{__rm} -rf %{buildroot}%{_libdir}/*.a
  91. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  92. %{__install} -m 0644 src/js*.h src/prmjtime.h src/js.msg src/*.tbl %{buildroot}%{_includedir}/
  93. # For compatibility
  94. # XXX do we really need libjs?!?!?!
  95. pushd %{buildroot}%{_libdir}
  96. %{__ln_s} libmozjs185.so.1.0 libmozjs.so.1
  97. %{__ln_s} libmozjs185.so.1.0 libjs.so.1
  98. %{__ln_s} libmozjs185.so libmozjs.so
  99. %{__ln_s} libmozjs185.so libjs.so
  100. popd
  101. %{__install} -m 0644 libjs.pc %{buildroot}%{_libdir}/pkgconfig/
  102. %clean
  103. %{__rm} -rf %{buildroot}
  104. %post -p /sbin/ldconfig
  105. %postun -p /sbin/ldconfig
  106. %files
  107. %defattr(-,root,root,-)
  108. %doc js/src/README.html
  109. %{_bindir}/js
  110. %{_libdir}/*.so.*
  111. %files devel
  112. %defattr(-,root,root,-)
  113. %{_bindir}/jscpucfg
  114. %{_libdir}/pkgconfig/*.pc
  115. %{_libdir}/*.so
  116. %{_includedir}/js
  117. %{_includedir}/js*.h
  118. %{_includedir}/*.tbl
  119. %{_includedir}/js.msg
  120. %{_includedir}/prmjtime.h
  121. %changelog
  122. * Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-2
  123. - add Patch4 (js-1.8.5-537701.patch) from fedora
  124. - add Patch5 (js185-arm-nosoftfp.patch) from fedora
  125. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1:1.8.5-1
  126. - add Patch3 (js-1.8.5-configure.patch)
  127. - merge spec file with fedora package
  128. * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.70-1
  129. - new upstream release
  130. - applied new versioning policy
  131. - removed no longer provided perlconnect parts.
  132. * Mon Jun 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-2vl1
  133. - initial build for Vine Linux
  134. * Thu Jun 23 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1:1.8.5-7
  135. - Make build system more proper (bz#710837), thanks to Jasper St. Pierre.
  136. - Add missing header prmjtime.h (bz#709955), thanks to Jim Meyering.
  137. - Merge Colin Walters build changes http://www.spinics.net/lists/fedora-devel/msg153214.html (1:1.8.5-6)
  138. * Wed Jun 22 2011 Colin Walters <walters@verbum.org> - 1:1.8.5-6
  139. - Include mozjs185.pc, clean up build
  140. - Based on work from Christopher Aillon <caillon@redhat.com>
  141. - Switch to using make install DESTDIR=, instead of hardcoding build rules.
  142. - Add DESTDIR= patch from GNOME 3.2 jhbuild
  143. - Make mozjs185 the canonical target for both libmozjs and libmozjs185.
  144. * Fri May 27 2011 Dan Horák <dan[at]danny.cz> - 1.8.5-5
  145. - add secondary arch patches from xulrunner
  146. * Tue Apr 12 2011 Christopher Aillon <caillon@redhat.com> - 1.8.5-4
  147. - devel subpackage needs to ask for the newly added epoch
  148. * Tue Apr 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-3
  149. - Add Epoch: 1 to allow update of 1.70-13 version.
  150. * Sat Apr 9 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-2
  151. - Correct symlink to provide backward capabiliies libjs.so.1
  152. * Wed Apr 6 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-1
  153. - Update to release.
  154. - Remove unneeded anymore patches.
  155. - Add backward capability symlink.
  156. * Sat Feb 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-0.hg51702867d932
  157. - Build version 1.8.5 by update request - BZ#676441 from Firefox 4.0 mercurial repository.
  158. - Gone -DJS_C_STRINGS_ARE_UTF8
  159. - Add BR autoconf213, change build system to use configure.
  160. - Adopt patch0 (js-1.7.0-make.patch -> js-1.8.5-make.patch)
  161. - Adopt patch1 (js-shlib.patch -> js-1.8.5-shlib.patch)
  162. - Remove Patch2 (js-1.5-va_copy.patch) and Patch3 (js-ldflags.patch)
  163. - Add BR python, zip.
  164. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-13
  165. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  166. * Wed Jun 16 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-12
  167. - Add UTF-8 support (add -DJS_C_STRINGS_ARE_UTF8 ) by request Peter Halliday: BZ#576585
  168. * Mon Jun 14 2010 Dan Horák <dan[at]danny.cz> - 1.70-11
  169. - updated the va_copy patch for s390
  170. * Mon Jan 25 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-10
  171. - Remove static library from -devel - %%{_libdir}/*.a (bz#556057) to meet guidelines.
  172. * Sun Aug 2 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-8
  173. - Reformat spec with tabs.
  174. - By report of Thomas Sondergaard (BZ#511162) Add -DXP_UNIX=1 -DJS_THREADSAFE=1 flags and nspr requires into libjs.pc
  175. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-7
  176. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  177. * Fri May 29 2009 Dan Horak <dan[at]danny.cz> 1.70-6
  178. - update the va_copy patch for s390x
  179. * Thu Apr 9 2009 Matthias Saou <http://freshrpms.net/> 1.70-5
  180. - Update description (#487903).
  181. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  183. * Wed Jun 4 2008 Jon McCann <jmccann@redhat.com> - 1.70-3
  184. - Add two missing files (#449715)
  185. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-2
  186. - Rebuild for perl 5.10 (again)
  187. * Sun Feb 3 2008 Matthias Saou <http://freshrpms.net/> 1.70-1
  188. - Update to 1.7.0, as 1.70 to avoid introducing an epoch for now...
  189. - Remove no longer provided perlconnect parts.
  190. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-6
  191. - BR: perl(ExtUtils::Embed)
  192. * Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-5
  193. - rebuild for new perl
  194. * Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 1.60-4
  195. - Rebuild for new BuildID feature.
  196. * Mon Aug 6 2007 Matthias Saou <http://freshrpms.net/> 1.60-3
  197. - Update License field.
  198. - Add perl(ExtUtils::MakeMaker) build requirement to pull in perl-devel.
  199. * Fri Feb 2 2007 Matthias Saou <http://freshrpms.net/> 1.60-2
  200. - Include jsopcode.tbl and js.msg in devel (#235481).
  201. - Install static lib mode 644 instead of 755.
  202. * Fri Feb 2 2007 Matthias Saou <http://freshrpms.net/> 1.60-1
  203. - Update to 1.60.
  204. - Rebuild in order to link against ncurses instead of termcap (#226773).
  205. - Add ncurses-devel build requirement and patch s/termcap/ncurses/ in.
  206. - Change mode of perl library from 555 to 755 (#224603).
  207. * Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.5-6
  208. - Fix pkgconfig file (#204232 & dupe #204236).
  209. * Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 1.5-5
  210. - FC6 rebuild.
  211. - Enable JS_THREADSAFE in the build (#199696), add patch and nspr build req.
  212. * Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 1.5-4
  213. - FC5 rebuild.
  214. * Thu Feb 9 2006 Matthias Saou <http://freshrpms.net/> 1.5-3
  215. - Rebuild for new gcc/glibc.
  216. * Mon Jan 30 2006 Matthias Saou <http://freshrpms.net/> 1.5-2
  217. - Fix .pc file.
  218. * Thu Jan 26 2006 Matthias Saou <http://freshrpms.net/> 1.5-1
  219. - Update to 1.5.0 final.
  220. - Spec file cleanups.
  221. - Move docs from devel to main, since we need the license there.
  222. - Remove no longer needed js-perlconnect.patch.
  223. - Update js-1.5-va_copy.patch.
  224. - Include a pkgconfig file (#178993).
  225. * Tue Apr 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.6
  226. - Link shared lib with libperl.
  227. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  228. - rebuilt
  229. * Mon Feb 14 2005 David Woodhouse <dwmw2@infradead.org> - 1.5-0.rc6a.4
  230. - Take js-va_copy.patch out of %%ifarch x86_64 so it fixes the PPC build too
  231. * Sun Feb 13 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 1.5-0.rc6a.3
  232. - Add js-va_copy.patch to fix x86_64; Patch was found in a Mandrake srpm
  233. * Sat Dec 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.2
  234. - Include perlconnect.
  235. - Include readline support, rebuild using "--without readline" to disable.
  236. - Add libjs* provides for upstream compatibility.
  237. - Install header files in %%{_includedir} instead of %%{_includedir}/js.
  238. * Tue Jun 15 2004 Matthias Saou <http://freshrpms.net> 1.5-0.rc6a
  239. - Update to 1.5rc6a.
  240. * Tue Mar 02 2004 Dag Wieers <dag@wieers.com> - 1.5-0.rc6
  241. - Initial package. (using DAR)