kate-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. Name: kate
  2. Summary: Advanced Text Editor
  3. Summary(ja): 高機能なテキストエディタ
  4. Version: 4.11.4
  5. Release: 1%{?_dist_release}
  6. # kwrite LGPLv2+
  7. # kate: app LGPLv2, plugins, LGPLv2 and LGPLv2+ and GPLv2+
  8. # ktexteditor: LGPLv2
  9. # katepart: LGPLv2
  10. License: LGPLv2 and LGPLv2+ and GPLv2+
  11. Group: Applications/Editors
  12. URL: https://projects.kde.org/projects/kde/kdebase/kate
  13. Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/%{name}-%{version}.tar.xz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: kdelibs4-devel >= %{version}
  17. BuildRequires: kactivities-devel >= %{version}
  18. BuildRequires: soprano-devel
  19. BuildRequires: sip-devel
  20. BuildRequires: python-devel
  21. BuildRequires: PyQt4-devel
  22. BuildRequires: PyKDE4-devel
  23. BuildRequires: qjson-devel
  24. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  25. Requires: %{name}-part = %{version}-%{release}
  26. Requires: %{name}-libs = %{version}-%{release}
  27. %description
  28. %{summary}.
  29. %package devel
  30. Summary: Development files for %{name}
  31. Summary(ja): %{name} の開発用ファイル
  32. Group: Development/Libraries
  33. Requires: %{name}-libs = %{version}-%{release}
  34. Requires: kdelibs4-devel
  35. %description devel
  36. %{summary}.
  37. %package libs
  38. Summary: Runtime files for %{name}
  39. Summary(ja): %{name} のランタイムライブラリ
  40. Group: System Environment/Libraries
  41. # when split occurred
  42. Conflicts: kdesdk4-libs < 4.6.95-10
  43. #Requires: %{name} = %{version}-%{release}
  44. %description libs
  45. %{summary}.
  46. %package part
  47. Summary: Kate kpart plugin
  48. Summary(ja): Kate kpart プラグイン
  49. License: LGPLv2
  50. Group: Applications/Editors
  51. # when split occurred
  52. Conflicts: kdelibs4 < 4.6.95-10
  53. %description part
  54. %{summary}.
  55. %package -n kwrite
  56. Summary: Text Editor
  57. Summary(ja): テキストエディタ
  58. License: LGPLv2+
  59. Group: Applications/Editors
  60. # when split occurred
  61. Conflicts: kdebase4 < 4.6.95-10
  62. Requires: %{name}-part = %{version}-%{release}
  63. Requires: kdebase-runtime%{?_kde4_version: >= %{_kde4_version}}
  64. %description -n kwrite
  65. %{summary}.
  66. %package pate
  67. Summary: Kate python plugin
  68. Summary(ja): Kate python プラグイン
  69. License: LGPLv2
  70. Group: System Environment/Libraries
  71. %description pate
  72. %{summary}.
  73. %prep
  74. %setup -q
  75. %build
  76. mkdir -p %{_target_platform}
  77. pushd %{_target_platform}
  78. %cmake \
  79. -DCMAKE_BUILD_TYPE=release \
  80. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  81. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  82. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  83. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  84. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  85. ..
  86. popd
  87. make %{?_smp_mflags} -C %{_target_platform}
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  91. # move devel symlinks (that would otherwise conflict with kdelibs3-devel)
  92. mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/devel
  93. pushd $RPM_BUILD_ROOT%{_libdir}
  94. for i in lib*.so
  95. do
  96. case "$i" in
  97. libkate*interfaces.so)
  98. linktarget=`readlink "$i"`
  99. rm -f "$i"
  100. ln -sf "../../$linktarget" "kde4/devel/$i"
  101. ;;
  102. esac
  103. done
  104. popd
  105. ## unpackaged files
  106. # playground artsticomment -devel bits
  107. rm -fv $RPM_BUILD_ROOT%{_includedir}/kde4/artisticcomment.h
  108. rm -fv $RPM_BUILD_ROOT%{_libdir}/libacomment.a
  109. %check
  110. for f in $RPM_BUILD_ROOT%{_datadir}/applications/kde4/*.desktop ; do
  111. desktop-file-validate $f
  112. done
  113. %post
  114. touch --no-create %{_datadir}icons/hicolor &> /dev/null || :
  115. %posttrans
  116. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  117. update-mime-database %{_datadir}/mime >& /dev/null
  118. %postun
  119. if [ $1 -eq 0 ] ; then
  120. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  121. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  122. update-mime-database %{_datadir}/mime >& /dev/null
  123. fi
  124. %post part -p /sbin/ldconfig
  125. %postun part -p /sbin/ldconfig
  126. %files
  127. %doc kate/AUTHORS kate/ChangeLog kate/COPYING.LIB kate/README kate/TODO
  128. %{_bindir}/kate
  129. %{_libdir}/libkdeinit4_kate.so
  130. %{_datadir}/applications/kde4/kate.desktop
  131. %{_datadir}/kde4/apps/kate/
  132. %{_datadir}/kde4/apps/katexmltools/
  133. %{_datadir}/kde4/apps/kconf_update/kate*.upd
  134. %{_datadir}/icons/hicolor/*/*/*
  135. %{_mandir}/man1/kate.1.gz
  136. %{_datadir}/config/katerc
  137. %{_datadir}/kde4/services/kate*.desktop
  138. %{_libdir}/kde4/kate*plugin.so
  139. %{_libdir}/kde4/katefiletemplates.so
  140. %{_datadir}/kde4/apps/katepart/
  141. %{_datadir}/kde4/apps/ktexteditor_*/
  142. %{_datadir}/kde4/services/ktexteditor_*.desktop
  143. %{_libdir}/kde4/ktexteditor_*.so
  144. %{_datadir}/kde4/services/plasma-applet-katesession.desktop
  145. %{_datadir}/kde4/servicetypes/kateplugin.desktop
  146. %{_libdir}/kde4/plasma_applet_katesession.so
  147. %{_libdir}/kde4/kate_kttsd.so
  148. %{_datadir}/config/ktexteditor_codesnippets_core.knsrc
  149. # these should *probably* be moved to hicolor -- rex
  150. %{_datadir}/doc/HTML/en/kate/
  151. %files libs
  152. %{_libdir}/libkateinterfaces.so.4*
  153. %{_libdir}/libkatepartinterfaces.so.4*
  154. %files devel
  155. %{_libdir}/kde4/devel/libkateinterfaces.so
  156. %{_libdir}/kde4/devel/libkatepartinterfaces.so
  157. %{_includedir}/kde4/kate_export.h
  158. %{_includedir}/kde4/kate/
  159. %files part
  160. %doc part/AUTHORS part/ChangeLog part/COPYING.LIB
  161. %doc part/INDENTATION part/NEWS part/README* part/TODO*
  162. %{_libdir}/kde4/katepart.so
  163. %{_libdir}/libkatepartinterfaces.so.4*
  164. %{_datadir}/config/katemoderc
  165. %{_datadir}/kde4/services/katepart.desktop
  166. %files -n kwrite
  167. %{_bindir}/kwrite
  168. %{_datadir}/kde4/apps/kwrite
  169. %{_libdir}/libkdeinit4_kwrite.so
  170. %{_datadir}/applications/kde4/kwrite.desktop
  171. %{_datadir}/doc/HTML/en/kwrite/
  172. %files pate
  173. %{python_sitearch}/PyKate4
  174. %{_datadir}/config/kateschemarc
  175. %{_datadir}/config/katesyntaxhighlightingrc
  176. %{_datadir}/kde4/services/pate.desktop
  177. %changelog
  178. * Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
  179. - new upstream release
  180. * Sun Sep 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
  181. - new upstream release
  182. * Sat Jul 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.10.5-1
  183. - new upstream release
  184. - add BuildRequires: kactivities-devel, sip-devel, python-devel, PyQt4-devel, PyKDE4-devel, qjson-devel
  185. - create %%{name}-pate subpackage
  186. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.5-1
  187. - new upstream release
  188. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.3-1
  189. - new upstream release
  190. * Sun Oct 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.2-1
  191. - new upstream release
  192. * Thu Sep 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.1-1
  193. - new upstream release
  194. * Sun Aug 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.9.0-1
  195. - new upstream release
  196. * Fri Dec 23 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  197. - new upstream release
  198. * Sat Oct 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.2-1
  199. - new upstream release
  200. * Mon Aug 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-2
  201. - Initial build for Vine Linux
  202. * Tue Jul 26 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.0-1
  203. - 4.7.0
  204. * Mon Jul 18 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.95-1
  205. - first try