libsigc++-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define name libsigc++
  2. %define version 2.2.11
  3. %define release 1%{?_dist_release}
  4. %define lib_name sigc++-2.0
  5. Summary: The Typesafe Signal Framework for C++
  6. Summary(ja): C++ 用の型安全なシグナルフレームワーク
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Group: System Environment/Libraries
  11. License: LGPLv2
  12. URL: http://libsigc.sourceforge.net/
  13. Source: ftp://download.sourceforge.net/pub/sourceforge/libsigc/%{name}-%{version}.tar.xz
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gcc-c++
  16. BuildRequires: m4
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. This library implements a full callback system for use in widget libraries,
  21. abstract interfaces, and general programming. Originally part of the Gtk--
  22. widget set, %{name} is now a seperate library to provide for more general
  23. use. It is the most complete library of its kind with the ablity to connect
  24. an abstract callback to a class method, function, or function object. It
  25. contains adaptor classes for connection of dissimilar callbacks and has an
  26. ease of use unmatched by other C++ callback libraries.
  27. Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
  28. %package devel
  29. Summary: development tools for the Typesafe Signal Framework for C++
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. Requires: pkgconfig
  33. %description devel
  34. The %{name}-devel package contains the static libraries and header files
  35. needed for development with %{name}.
  36. %package examples
  37. Summary: examples and tests for the Typesafe Signal Framework for C++
  38. Group: Development/Libraries
  39. Requires: %{name}-devel = %{version}-%{release}
  40. %description examples
  41. The %{name}-devel package contains source code of example and test
  42. programs for %{name}.
  43. %prep
  44. %setup -q
  45. %build
  46. %configure --disable-static --enable-silent-rules
  47. make %{_smp_mflags}
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. make install DESTDIR=$RPM_BUILD_ROOT
  51. # removed unpackage files
  52. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  53. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  54. cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  55. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
  56. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
  57. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
  58. grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
  59. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
  60. rm -f $i.*
  61. done
  62. rm -rf docs-toinstall
  63. mkdir -p docs-to-install
  64. cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
  65. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
  66. # devhelp path fix
  67. sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
  68. #sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
  69. %post -p /sbin/ldconfig
  70. %postun -p /sbin/ldconfig
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %files
  74. %defattr(-,root,root,755)
  75. %doc AUTHORS COPYING README NEWS ChangeLog TODO
  76. %attr(755,root,root) %{_libdir}/lib*.so.*
  77. %files devel
  78. %defattr(-,root,root,755)
  79. %{_includedir}/*
  80. %{_libdir}/%{lib_name}/include
  81. %{_libdir}/pkgconfig/*.pc
  82. #{_libdir}/lib*.la
  83. %{_libdir}/lib*.so
  84. %{_datadir}/devhelp/books/%{name}-2.0/*
  85. %doc docs-to-install/index.html docs-to-install/images
  86. %doc docs-to-install/reference docs-to-install/tutorial
  87. %files examples
  88. %defattr(-,root,root,755)
  89. %{_libdir}/%{lib_name}/examples
  90. %{_libdir}/%{lib_name}/tests
  91. %changelog
  92. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
  93. - new upstream release
  94. * Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
  95. - new upstream release
  96. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
  97. - build with rpm-4.8.1-1 for pkg-config file
  98. * Thu Sep 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
  99. - new upstream release
  100. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
  101. - new upstream release
  102. - built with new toolchain
  103. * Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
  104. - new upstream release
  105. - remove static libraries from devel package
  106. * Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  107. - new upstream release
  108. - spec in UTF-8
  109. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
  110. - removed .la files from devel package
  111. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
  112. - new upstream release
  113. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
  114. - rebuild with new environment/toolchain
  115. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
  116. - new upstream release
  117. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
  118. - rebuild with new libtool
  119. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
  120. - new upstream release
  121. * Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  122. - new upstream release
  123. * Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
  124. - new upstream release
  125. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
  126. - new upstream release
  127. - added tutorial to devel package
  128. * Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
  129. - update to 2.0.6
  130. * Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  131. - update to 1.2.5
  132. - add Requires: pkgconfig
  133. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
  134. - rebuild to remove dependance <5371>
  135. - add Japanese summary
  136. - use better macros
  137. - s/Copyright/License/
  138. * Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
  139. - rebuild with new toolchain
  140. * Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
  141. - 1.0.4-0vl1
  142. - Build for Vine Linux 2.5
  143. * Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  144. - packaged for Vine Linux 2.1
  145. * Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
  146. - updated Url and Source fileds
  147. - 1.0.0 stable release
  148. * Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
  149. - filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
  150. - minor install section cleanup
  151. * Wed Jan 19 2000 Allan Rae <rae@lyx.org>
  152. - autogen just creates configure, not runs it, so cleaned that up too.
  153. * Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
  154. - minor attr fix
  155. - removed unnecessary curly braces
  156. - fixed Herbert's adjustement
  157. * Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
  158. - minor package dependence fix
  159. * Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
  160. - fixed typo of mine
  161. - added traditional CUSTOM_RELEASE stuff
  162. - added SMP support
  163. * Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
  164. - adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
  165. * Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
  166. - split into three packages: %name, %name-devel and %name-examples
  167. * Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  168. - updated source field and merged conflicts between revisions.
  169. * Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
  170. - updated Prefix and BuildRoot fields
  171. * Thu Aug 5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  172. - made sure configure works on all alphas
  173. * Wed Jul 7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  174. - Added autoconf macro for sigc.
  175. * Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  176. - Made into a .in to keep version field up to date
  177. - Still need to do release by hand
  178. * Mon Jun 7 1999 Dmitry V. Levin <ldv@fandra.org>
  179. - added Vendor and Packager fields
  180. * Sat Jun 5 1999 Dmitry V. Levin <ldv@fandra.org>
  181. - updated to 0.8.0
  182. * Tue Jun 1 1999 Dmitry V. Levin <ldv@fandra.org>
  183. - initial revision