libssh2-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library implementing the SSH2 protocol
  3. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  4. Name: libssh2
  5. Version: 1.4.2
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: BSD
  9. URL: http://www.libssh2.org/
  10. Source0: http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: openssl-devel
  13. BuildRequires: zlib-devel
  14. %description
  15. libssh2 is a library implementing the SSH2 protocol as defined by
  16. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  17. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  18. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  19. %package devel
  20. Summary: Development files for %{name}
  21. Summary(ja): %{name} の開発ファイル
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. %description devel
  25. The %{name}-devel package contains libraries and header files for
  26. developing applications that use %{name}.
  27. %package docs
  28. Summary: Documentation for %{name}
  29. Summary(ja): %{name} のドキュメント
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. %description docs
  33. The %{name}-docs package contains man pages and examples for
  34. developing applications that use %{name}.
  35. ## to build compat32 for x86_64 architecture support
  36. %package -n compat32-%{name}
  37. Summary: A library implementing the SSH2 protocol
  38. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  39. Group: System Environment/Libraries
  40. %description -n compat32-%{name}
  41. libssh2 is a library implementing the SSH2 protocol as defined by
  42. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  43. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  44. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  45. %prep
  46. %setup -q
  47. # make sure things are UTF-8...
  48. for i in ChangeLog NEWS ; do
  49. iconv --from=ISO-8859-1 --to=UTF-8 $i > new
  50. mv new $i
  51. done
  52. %build
  53. %configure --disable-static --enable-shared
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf %{buildroot}
  57. make install DESTDIR=%{buildroot} INSTALL="install -p"
  58. find %{buildroot} -name '*.la' -exec rm -f {} +
  59. # clean things up a bit for packaging
  60. ( cd example && make clean )
  61. rm -rf example/simple/.deps
  62. find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
  63. %check
  64. (cd tests && make check)
  65. %clean
  66. rm -rf %{buildroot}
  67. %post -p /sbin/ldconfig
  68. %postun -p /sbin/ldconfig
  69. %post -n compat32-%{name} -p /sbin/ldconfig
  70. %postun -n compat32-%{name} -p /sbin/ldconfig
  71. %files
  72. %defattr(-,root,root,-)
  73. %doc AUTHORS ChangeLog COPYING README NEWS
  74. %{_libdir}/*.so.*
  75. %files docs
  76. %defattr(-,root,root,-)
  77. %doc COPYING HACKING example/
  78. %{_mandir}/man?/*
  79. %files devel
  80. %defattr(-,root,root,-)
  81. %doc COPYING
  82. %{_includedir}/*
  83. %{_libdir}/*.so
  84. %{_libdir}/pkgconfig/libssh2.pc
  85. %if %{build_compat32}
  86. %files -n compat32-%{name}
  87. %defattr(-,root,root,-)
  88. %{_libdir}/*.so.*
  89. %endif
  90. %changelog
  91. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
  92. - new upstream reelase
  93. - add compat32 package
  94. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
  95. - new upstream release
  96. - fix %%files
  97. * Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
  98. - initial build for Vine Linux
  99. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
  100. - rebuilt with new openssl
  101. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  103. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  105. * Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
  106. - update to 1.0
  107. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
  108. - rebuild with new openssl
  109. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
  110. - Autorebuild for GCC 4.3
  111. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
  112. - rebuild for new openssl...
  113. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
  114. - bump
  115. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
  116. - add INSTALL arg to make install vs env. var
  117. * Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
  118. - run tests; don't package test
  119. * Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
  120. - split docs into -docs (they seemed... large.)
  121. * Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
  122. - update to 0.18
  123. * Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
  124. - update to 0.17
  125. - many spec file changes
  126. * Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
  127. - Fix release tag
  128. - Move manpages to -devel package
  129. - Add Examples dir to -devel package
  130. * Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
  131. - Initial build