mozjs17-vl.spec 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106
  1. Summary: The Mozilla library for JavaScript
  2. Name: mozjs17
  3. Version: 17.0.0
  4. Release: 1%{?_dist_release}
  5. # The sources are triple licensed, but when we link against readline which is
  6. # GPL, the result can only be GPL.
  7. %if 0%{?_without_readline:1}
  8. License: GPLv2+ or LGPLv2+ or MPLv1.1
  9. %else
  10. License: GPLv2+
  11. %endif
  12. Group: Development/Languages
  13. URL: http://www.mozilla.org/js/
  14. Source0: http://ftp.mozilla.org/pub/mozilla.org/js/mozjs17.0.0.tar.gz
  15. Patch0: mozjs17-17.0.0-Makefile.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Buildrequires: nspr-devel >= 4.7
  18. Buildrequires: readline-devel
  19. BuildRequires: autoconf213
  20. BuildRequires: python
  21. BuildRequires: zip
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. JavaScript is the Netscape-developed object scripting language used in millions
  26. of web pages and server applications worldwide. Netscape's JavaScript is a
  27. superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
  28. with only mild differences from the published standard.
  29. %package devel
  30. Summary: Header files, libraries and development documentation for %{name}
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: pkgconfig
  34. Requires: ncurses-devel readline-devel
  35. Provides: libjs-devel = %{version}-%{release}
  36. %description devel
  37. This package contains the header files, static libraries and development
  38. documentation for %{name}. If you like to develop programs using %{name},
  39. you will need to install %{name}-devel.
  40. %prep
  41. %setup -q -n mozjs%{version}
  42. %patch0 -p1
  43. cd js
  44. # Rm parts with spurios licenses, binaries
  45. rm -rf src/ctypes/libffi src/editline
  46. pushd src
  47. autoconf-2.13
  48. %configure \
  49. --with-system-nspr \
  50. --enable-threadsafe \
  51. %if 0%{!?_without_readline:1}
  52. --enable-readline \
  53. %endif
  54. popd
  55. %build
  56. cd js
  57. %{__make} %{?_smp_mflags} -C src
  58. %install
  59. cd js
  60. %{__make} -C src install DESTDIR=%{buildroot}
  61. %{__rm} -rf %{buildroot}%{_libdir}/*.a
  62. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  63. %clean
  64. %{__rm} -rf %{buildroot}
  65. %post -p /sbin/ldconfig
  66. %postun -p /sbin/ldconfig
  67. %files
  68. %defattr(-,root,root,-)
  69. %doc js/src/README.html
  70. %{_bindir}/js17
  71. %{_libdir}/libmozjs-17.0.so
  72. %files devel
  73. %defattr(-,root,root,-)
  74. %{_bindir}/js17-config
  75. %{_includedir}/js-17.0
  76. %{_libdir}/pkgconfig/mozjs-17.0.pc
  77. %changelog
  78. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.0-1
  79. - initial build