faac-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186
  1. %define name faac
  2. %define version 1.28
  3. %define release 8%{?_dist_release}
  4. %define enable_libmp4v2_external 1
  5. Summary: Reference encoder and encoding library for MPEG2/4 AAC
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. Source: http://prdownloads.sourceforge.net/faac/faac-%{version}.tar.bz2
  10. Patch0: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
  11. ## this patch is based on http://launchpadlibrarian.net/33120980/mp4v2-strcasestr.diff
  12. Patch1: mp4v2-strcasestr-vine.diff
  13. License: LGPLv2+
  14. Group: Applications/Multimedia
  15. URL: http://www.audiocoding.com/
  16. BuildRequires: nkf
  17. BuildRequires: autoconf, automake, libtool, gcc-c++
  18. %if %{enable_libmp4v2_external}
  19. BuildRequires: libmp4v2-devel
  20. %endif
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. %description
  23. FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
  24. COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
  25. multichannel and gapless encoding.
  26. %package devel
  27. Summary: Development libraries of the FAAC AAC encoder
  28. Group: Development/Libraries
  29. Requires: %{name} = %{version}
  30. %description devel
  31. FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
  32. COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
  33. multichannel and gapless encoding.
  34. This package contains development files and documentation for libfaac.
  35. %if !%{enable_libmp4v2_external}
  36. %package -n libmp4v2
  37. Summary: Library for working with files using the mp4 container format
  38. Group: System Environment/Libraries
  39. %description -n libmp4v2
  40. The libmp4v2 library provides an abstraction layer for working with files
  41. using the mp4 container format. This library is developed by mpeg4ip project
  42. and is an exact copy of the library distributed in the mpeg4ip package.
  43. This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
  44. %package -n libmp4v2-devel
  45. Summary: Development files for the mp4v2 library
  46. Group: Development/Libraries
  47. Requires: libmp4v2 = %{version}-%{release}
  48. %description -n libmp4v2-devel
  49. The libmp4v2 library provides an abstraction layer for working with files
  50. using the mp4 container format. This library is developed by mpeg4ip project
  51. and is an exact copy of the library distributed in the mpeg4ip package.
  52. This package contains development files for libmp4v2.
  53. This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
  54. %endif
  55. %prep
  56. %setup -q
  57. #find . -type f -print|xargs nkf --unix --overwrite
  58. %if %{enable_libmp4v2_external}
  59. %patch0 -p1 -b .mp4v2
  60. %patch1 -p1 -b .mp4v2
  61. #touch -r configure.in.mp4v2 configure.in
  62. %endif
  63. # # avoid to append the string "2005-02-02" to the tag Requires:
  64. # chmod 644 ChangeLog
  65. # # modify configure.in to escape error
  66. # %__mv configure.in configure.in.org
  67. # %__sed -e 's/^CFLAGS=.*$/CFLAGS="-O2 -Wall"/' configure.in.org > configure.in
  68. %build
  69. sh bootstrap
  70. %configure \
  71. --disable-static \
  72. %if !%{enable_libmp4v2_external}
  73. --with-mp4v2
  74. %endif
  75. %{__make} %{?_smp_mflags}
  76. %install
  77. %{__rm} -rf %{buildroot}
  78. %{__make} install DESTDIR=%{buildroot}
  79. %clean
  80. %{__rm} -rf %{buildroot}
  81. %post
  82. /sbin/ldconfig 2>/dev/null
  83. %postun
  84. /sbin/ldconfig 2>/dev/null
  85. %files
  86. %defattr(-,root,root,-)
  87. %doc AUTHORS COPYING ChangeLog NEWS README TODO docs/*
  88. %{_bindir}/*
  89. %{_libdir}/*.so.*
  90. %{_mandir}/man1/%{name}*
  91. %files devel
  92. %defattr(-,root,root,-)
  93. %exclude %{_libdir}/*.la
  94. %{_libdir}/*.so
  95. %{_includedir}/*.h
  96. %if !%{enable_libmp4v2_external}
  97. %files -n libmp4v2
  98. %defattr(-,root,root,-)
  99. %{_libdir}/libmp4v2.so.*
  100. %files -n libmp4v2-devel
  101. %defattr(-,root,root,-)
  102. %{_libdir}/libmp4v2.so
  103. %{_libdir}/libmp4v2.a
  104. %endif
  105. %changelog
  106. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-8
  107. - s/self-build-libmp4v2/libmp4v2/
  108. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
  109. - change release to sync with self-build-faac
  110. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
  111. - applied mp4v2-strcasestr.diff from lauchpad
  112. - fixed wrong declaration of strcasestr() in mpeg4ip.h
  113. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
  114. - rebuilt with mp4v2 v1.9.1
  115. - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
  116. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
  117. - change release to sync with self-build-faac
  118. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
  119. - added BuildRequires: nkf
  120. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
  121. - change release to sync with self-build-faac
  122. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
  123. - new upstream release
  124. * Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
  125. - fixed Summary: , %%description
  126. - removed internal mp4v2
  127. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
  128. - new upstream release
  129. - added --disable-static in %%configure
  130. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
  131. - spec in utf8
  132. - remove *.la
  133. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
  134. - apply new versioning policy
  135. * Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
  136. - initial build
  137. ### end of file