self-build-ffmpeg-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387
  1. %global gpac_postinstall \
  2. gpac_postinstall_sh=$(mktemp) ; \
  3. rpm -q --scripts self-build-gpac | \
  4. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} ; \
  5. /bin/bash ${gpac_postinstall_sh} ; /bin/rm -f ${gpac_postinstall_sh}
  6. %global x264_postinstall \
  7. x264_postinstall_sh=$(mktemp) ; \
  8. rpm -q --scripts self-build-x264 | \
  9. /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} ; \
  10. /bin/bash ${x264_postinstall_sh} ; /bin/rm -f ${x264_postinstall_sh}
  11. %global pkgname ffmpeg
  12. %global name self-build-%{pkgname}
  13. %global major_version 1.2
  14. %global version %{major_version}.4
  15. #% define svndate 20110326
  16. %global release 1%{?svndate:.%svndate}%{?_dist_release}
  17. %global sourceurl0 http://ffmpeg.org/releases/%{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  18. %global with_faac 1
  19. %global with_vaapi 1
  20. %global with_libvpx 1
  21. #% define enable_avconv 1
  22. Summary: Package to automatically build %{pkgname} rpm package
  23. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  24. Name: %{name}
  25. Version: %{version}
  26. Release: %{release}
  27. Source0: %{pkgname}-vl.spec
  28. #Source1: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  29. ## prebuilt man pages
  30. Source10: %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}-doc.tar.xz
  31. License: GPLv2+
  32. Group: Restricted Software
  33. Obsoletes: ffmpeg < %{major_version}, ffmpeg-libs < %{major_version}, ffmpeg-devel < %{major_version}
  34. Obsoletes: self-build-ffmpeg < %{version}
  35. Requires(post): self-build-setup >= 0.9.9
  36. #Requires(post): subversion
  37. # (build)requies of target package.
  38. Requires(post): bzip2-devel
  39. Requires(post): celt-devel
  40. ##Requires(post): dirac-devel
  41. Requires(post): freetype2-devel
  42. Requires(post): gnutls-devel
  43. Requires(post): gsm-devel
  44. Requires(post): imlib2-devel
  45. Requires(post): libdc1394-devel
  46. Requires(post): libogg-devel
  47. Requires(post): libass-devel
  48. %{!?_without_cdio:Requires(post): libcdio-devel}
  49. #libcrystalhd is currently broken
  50. %{?_with_crystalhd:Requires(post): libcrystalhd-devel}
  51. Requires(post): libraw1394-devel
  52. Requires(post): librtmp-devel >= 2.3
  53. Requires(post): libtheora-devel
  54. %{?with_vaapi:Requires(post): libva-devel >= 0.31.0}
  55. Requires(post): libvdpau-devel
  56. Requires(post): libvorbis-devel
  57. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.7}
  58. Requires(post): libXvMC-devel
  59. %{?_with_opencore_amr:Requires(post): opencore-amr-devel vo-amrwbenc-devel}
  60. %{!?_without_openal:Requires(post): openal-soft-devel}
  61. %{?_with_opencv:Requires(post): opencv-devel}
  62. %{?_with_openjpeg:Requires(post): openjpeg-devel}
  63. ##Requires(post): schroedinger-devel
  64. Requires(post): SDL-devel
  65. Requires(post): speex-devel
  66. ##Requires(post): texi2html
  67. Requires(post): zlib-devel
  68. Requires(post): libogg-devel
  69. Requires(post): yasm
  70. Requires(post): self-build-a52dec
  71. Requires(post): self-build-faac
  72. Requires(post): self-build-faad2
  73. Requires(post): self-build-lame
  74. Requires(post): self-build-libdca
  75. Requires(post): self-build-x264 >= 0.129
  76. Requires(post): self-build-xvidcore
  77. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  78. BuildArch: noarch
  79. Packager: munepi
  80. %description
  81. FFMpeg is a complete and free Internet live audio and video
  82. broadcasting solution for Linux/Unix. It also includes a
  83. digital VCR. It can encode in real time in many formats
  84. including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
  85. real, mjpeg, and flash.
  86. If you install this package, it automaticaly downloads source
  87. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  88. And the created rpm packages are automatically installed
  89. if installation is executed by apt-get command or synaptic
  90. package manager.
  91. [Note]
  92. This package requires many other packages to compile
  93. target software. So it consume more disk space than usual.
  94. Also installation takes longer time because of compilation.
  95. (This will take a few minutes to quarter or half of an hour,
  96. depends on building environment)
  97. [About self-build package]
  98. For some kind of software, distributing of binary package
  99. may viorate the patent or law. Therefore we chose self-build
  100. packge, create binary package on your machine, for such kind
  101. of softwares instead of distributing binary package.
  102. Please obey the national law when you use the created binary
  103. packages. And if you want to use the softwares using patented
  104. thechnology, it may be required to get a permission, make an
  105. agreement or purchas a license. Please consider it with your
  106. purpose or way of use and take appropriate action.
  107. %description -l ja
  108. FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
  109. ブオーティオ・ビデオブロードキャスティングソリューションです.
  110. またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
  111. MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
  112. 多様なフォーマットをリアルタイムにエンコードすることができます.
  113. このパッケージをインストールすると、自動的にソースコードを
  114. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  115. の rpm パッケージを作成します。
  116. また apt-get コマンドや synaptic パッケージマネージャから実行
  117. した場合は、作成された rpm パッケージのインストールも自動的に
  118. 行います。
  119. [注意]
  120. コンパイルに必要な多くの関連パッケージを要求するので通常より
  121. ディスクの領域を多く消費します。
  122. またインストール時にコンパイルを行うため、通常より時間がかか
  123. る場合があります。(環境にもよりますが数分から数十分程度)
  124. [self-build パッケージについて]
  125. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  126. 違反する可能性があるものがあります。その為、このような問題が
  127. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  128. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  129. ジという方法を採っています。
  130. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  131. アのライセンス、および利用する国の各種法令に従ってください。
  132. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  133. センスの購入などが必要となる場合がありますので、利用する目的
  134. や形態に応じて各自で判断し適切な対応を取ってください。
  135. %prep
  136. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  137. %install
  138. %{__rm} -rf ${RPM_BUILD_ROOT}
  139. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  140. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  141. %{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  142. %clean
  143. %{__rm} -rf ${RPM_BUILD_ROOT}
  144. %posttrans
  145. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 86000
  146. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  147. %{pkgname}-libs-%{version}-%{release} \
  148. %{pkgname}-devel-%{version}-%{release}
  149. ## Rebuild gpac with ffmpeg-devel
  150. # set locale
  151. case $LANG in
  152. ja*)LOCALE=ja ;;
  153. *) LOCALE=C ;;
  154. esac
  155. Rebuild_gpac_C(){
  156. echo -n " "
  157. echo "Rebuild gpac with ffmpeg-devel"
  158. }
  159. Rebuild_gpac_ja(){
  160. echo -n " "
  161. echo "ffmpeg-devel で gpac をリビルドします。"
  162. }
  163. Rebuild_gpac_$LOCALE
  164. %{gpac_postinstall}
  165. ## Rebuild x264 with ffmpeg-devel
  166. # set locale
  167. case $LANG in
  168. ja*)LOCALE=ja ;;
  169. *) LOCALE=C ;;
  170. esac
  171. Rebuild_x264_C(){
  172. echo -n " "
  173. echo "Rebuild x264 with ffmpeg-devel"
  174. }
  175. Rebuild_x264_ja(){
  176. echo -n " "
  177. echo "ffmpeg-devel で x264 をリビルドします。"
  178. }
  179. Rebuild_x264_$LOCALE
  180. %{x264_postinstall}
  181. %files
  182. %defattr(-,root,root)
  183. %{_datadir}/%{name}
  184. %changelog
  185. * Fri Oct 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.4-1
  186. - new upstream release
  187. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.3-1
  188. - new upstream release
  189. - added %%{x264_postinstall} in %%post
  190. * Wed May 22 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2.1-1
  191. - new upstream release
  192. - added man pages
  193. - added Source10: ffmpeg-1.2.1-doc.tar.xz
  194. * Thu Apr 4 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.2-1
  195. - new upstream release
  196. * Tue Mar 12 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.3-1
  197. - new upstream release
  198. * Sun Feb 3 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-2
  199. - libvpx >= 0.9.7
  200. * Sun Jan 20 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
  201. - new upstream release /x264-0.129
  202. * Thu Sep 27 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.2-1
  203. - new upstream release
  204. * Mon Jun 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11.1-1
  205. - new upstream release
  206. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.11-1
  207. - new upstream release
  208. * Wed Jan 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.1-1
  209. - new upstream release
  210. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  211. - new upstream release
  212. - enable CELT decoding via libcelt
  213. - enable FreeType support
  214. - drop faad2 support (dropped upstream)
  215. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  216. - added BuildArch: noarch
  217. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  218. - new upstream release
  219. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  220. - new upstream release
  221. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  222. - required latest x264 build
  223. - added BuildRequires: librtmp-devel >= 2.3
  224. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  225. - new upstream release
  226. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  227. - unpacked source archives
  228. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  229. - fixed some dependencies
  230. - Requires(post): libva-devel
  231. - Requires(post): libvpx-devel >= 0.9.1
  232. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  233. - new upstream release
  234. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  235. - bumped version to pre-0.6
  236. - updated source snapshot 20100410
  237. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  238. - fixed self-build log size
  239. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  240. - added ffprobe.1.gz
  241. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  242. - updated source snapshot 20100401
  243. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  244. - renamed %%{Source0} to ffmpeg-vl.spec
  245. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  246. - updated source snapshot 20100216
  247. - rebuild with recent x264-devel
  248. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  249. - added BuildRequires: libvdpau-devel
  250. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  251. - dropped BuildArch: noarch
  252. - added ffmpeg.1, ffplay.1, ffserver.1
  253. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  254. - avoided to execute self-build-rpm.sh on RPM transaction
  255. - moved %%post actions to %%posttrans
  256. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  257. - added BuildArch: noarch
  258. - added ffmpeg-0.5-disable-texi2html.patch
  259. - dropped PreReq: texi2html
  260. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  261. - added %%{gpac_postinstall} in %%post
  262. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  263. - corrected release number
  264. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  265. - new upstream release
  266. - added PreReq:
  267. - speex-devel
  268. - bzip2-devel
  269. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  270. - change release to sync with ffmpeg
  271. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  272. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  273. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  274. - 20090202 snapshot
  275. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  276. - 20090110 snapshot
  277. - dropped some patches
  278. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  279. - source updated (r15488)
  280. - fixed License: GPLv2+
  281. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  282. - added BuildRequires: yasm (only %%ix86)
  283. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  284. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  285. - spec in utf8
  286. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  287. - run pre-allocate-rpm.sh in %%post
  288. - set PreReq: self-build-setup >= 0.8
  289. - change release number
  290. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  291. - add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
  292. include Source1 in the binary package.
  293. - drop "Source100: ffmpeg-vine.patch".
  294. - drop "PreReq: subversion".
  295. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  296. - build with new versioning policy
  297. - change to use svn export from svn checkout on post install
  298. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  299. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  300. - For all pre-required package that is provied by self-build,
  301. changed to its self-build package
  302. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  303. - initial build for Vine Linux 4.2
  304. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  305. ### end of file