openhpi-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341
  1. Summary: Hardware Platform Interface library and tools
  2. Summary(ja): ハードウエアプラットフォームインタフェースライブラリおよびツール
  3. Name: openhpi
  4. Version: 3.0.0
  5. Release: 1%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://www.openhpi.org
  9. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. Source1: %{name}.initd
  11. Source2: %{name}.sysconfig
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: sysfsutils-devel, net-snmp-devel, OpenIPMI-devel, glib2-devel
  14. BuildRequires: libtool-ltdl-devel, openssl-devel, ncurses-devel
  15. BuildRequires: libxml2-devel, docbook-utils, libuuid-devel
  16. Requires(post): chkconfig
  17. Requires(preun): chkconfig
  18. Requires(preun): initscripts
  19. %description
  20. OpenHPI is an open source project created with the intent of providing an
  21. implementation of the SA Forum's Hardware Platform Interface (HPI). HPI
  22. provides an abstracted interface to managing computer hardware, typically for
  23. chassis and rack based servers. HPI includes resource modeling; access to and
  24. control over sensor, control, watchdog, and inventory data associated with
  25. resources; abstracted System Event Log interfaces; hardware events and alerts;
  26. and a managed hot swap interface.
  27. OpenHPI provides a modular mechanism for adding new hardware and device support
  28. easily. Many plug-ins exist in the OpenHPI source tree to provide access to
  29. various types of hardware. This includes, but is not limited to, IPMI based
  30. servers, Blade Center, and machines which export data via sysfs.
  31. %package libs
  32. Group: System Environment/Libraries
  33. Summary: The system libraries for the OpenHPI project
  34. Summary(ja): OpenHPI のシステムライブラリ
  35. Obsoletes: %{name} < 2.10.2-1
  36. %description libs
  37. The system libraries for the OpenHPI project.
  38. %package devel
  39. Group: Development/Libraries
  40. Summary: The development environment for the OpenHPI project
  41. Summary(ja): OpenHPIの開発環境
  42. Requires: %{name}-libs = %{version}-%{release}
  43. Requires: glib2-devel, pkgconfig
  44. %description devel
  45. The development libraries and header files for the OpenHPI project.
  46. %prep
  47. %setup -q
  48. # fix permissions
  49. chmod a-x plugins/simulator/*.[ch]
  50. chmod a-x clients/*.[ch]
  51. %build
  52. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  53. %configure --disable-static
  54. # Don't use rpath!
  55. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  56. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  57. make %{?_smp_mflags}
  58. %install
  59. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
  60. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  61. mkdir -p $RPM_BUILD_ROOT%{_initddir}
  62. mkdir -p -m1777 $RPM_BUILD_ROOT%{_var}/lib/%{name}
  63. make install DESTDIR=$RPM_BUILD_ROOT
  64. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/openhpid
  65. install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/openhpid
  66. install -p -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/openhpid
  67. rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
  68. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
  69. %clean
  70. rm -rf $RPM_BUILD_ROOT
  71. %post
  72. /sbin/chkconfig --add openhpid
  73. %preun
  74. if [ $1 = 0 ] ; then
  75. /sbin/service openhpid stop >/dev/null 2>&1
  76. /sbin/chkconfig --del openhpid
  77. fi
  78. %postun
  79. if [ "$1" -ge "1" ] ; then
  80. /sbin/service openhpid condrestart >/dev/null 2>&1
  81. fi
  82. %post libs -p /sbin/ldconfig
  83. %postun libs -p /sbin/ldconfig
  84. %files
  85. %defattr(-,root,root,-)
  86. %doc COPYING README README.daemon openhpi.conf.example
  87. %dir %{_sysconfdir}/%{name}
  88. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  89. %config(noreplace) %{_sysconfdir}/%{name}/%{name}client.conf
  90. %config(noreplace) %{_sysconfdir}/openhpi/simulation.data
  91. %{_initddir}/openhpid
  92. %config(noreplace) %{_sysconfdir}/sysconfig/openhpid
  93. %attr(1777,root,root) %{_var}/lib/%{name}
  94. %{_bindir}/*
  95. %{_sbindir}/*
  96. %{_libdir}/%{name}
  97. %{_mandir}/man1/*
  98. %{_mandir}/man7/*
  99. %{_mandir}/man8/*
  100. %files libs
  101. %defattr(-,root,root,-)
  102. %{_libdir}/*.so.*
  103. %files devel
  104. %defattr(-,root,root,-)
  105. %doc COPYING
  106. %{_libdir}/*.so
  107. %{_includedir}/%{name}
  108. %{_libdir}/pkgconfig/*.pc
  109. %changelog
  110. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  111. - new upstream release
  112. - remove Patch0
  113. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.1-2
  114. - rebuild with openssl-1.0.0d
  115. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
  116. - initial build for Vine Linux
  117. * Wed Feb 24 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-3
  118. - update initscript (#521648, #521830)
  119. * Fri Jan 15 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-2
  120. - added fix for inconsistent SaHpi.h
  121. * Wed Nov 25 2009 Dan Horák <dan[at]danny.cz> - 2.14.1-1
  122. - updated to bug fix release 2.14.1
  123. * Fri Oct 9 2009 Dan Horák <dan[at]danny.cz> - 2.14.0-6
  124. - rebuilt with net-snmp 5.5
  125. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.14.0-5
  126. - rebuilt with new openssl
  127. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.0-4
  128. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  129. * Wed Jul 14 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-3
  130. - add BR: libuuid-devel
  131. * Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-2
  132. - use upstream default config
  133. - libtoolize/autoreconf is not needed
  134. * Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-1
  135. - update to 2.14.0
  136. * Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-2
  137. - fix ppc/ppc64 builds
  138. * Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-1
  139. - update to 2.13.3
  140. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.13.1-3
  141. - rebuild with new openssl
  142. * Tue Nov 25 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-2
  143. - shorten Summary
  144. * Thu Nov 20 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-1
  145. - update to 2.13.1
  146. * Mon Nov 17 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-2
  147. - rebuild for new libtool
  148. * Sat Jul 26 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-1
  149. - update to 2.12.0
  150. * Thu Jun 27 2008 Dan Horak <dan[at]danny.cz> - 2.11.3-1
  151. - update to 2.11.3
  152. * Thu Apr 18 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-2
  153. - enable the sysfs plugin
  154. - add missing R: for -devel subpackage
  155. * Thu Mar 13 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-1
  156. - update to 2.10.2
  157. - spec file and patch cleanup
  158. * Thu Feb 28 2008 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-3
  159. - Removed incorrect patch for IBM BC snmp_bc plugin
  160. - Fixed GCC 4.3 rebuild problems
  161. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.10.1-2
  162. - Autorebuild for GCC 4.3
  163. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-1
  164. - Updated to openhpi-2.10.1
  165. - Bump release and rebuild due to new openssl
  166. * Thu Aug 23 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-5
  167. - Bump release and rebuild because of PPC issues
  168. - Fix rebuild problems due to new glibc open macro
  169. * Fri Jul 20 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-4
  170. - Fix for hpipower segfaulting when using -b option out of range (#247279)
  171. * Tue Jul 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-3
  172. - Fixed a bug where the snmp_bc plugin didn't work in IBM BC (#247280)
  173. * Mon Jun 04 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-2.fc7
  174. - Fixed missing e2fsprogs-devel and openssl-devel build requires
  175. * Fri Mar 30 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-1.fc7
  176. - Update to openhpi-2.8.1
  177. * Thu Feb 08 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-3.fc7
  178. - Fixed some silly bugs in the specfile
  179. * Wed Feb 07 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-2.fc7
  180. - Bump and rebuild.
  181. * Tue Feb 06 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-1.fc7
  182. - Update to openhpi-2.8.0
  183. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-7.fc7
  184. - Rebuilt due to new net-snmp-5.4
  185. - Small specfile updates
  186. * Fri Sep 29 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-6
  187. - Fixed file conflicts for openhpi-switcher (#205226)
  188. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-5.1
  189. - rebuild
  190. * Mon Jul 10 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-5
  191. - Had to disable sysfs support due to new libsysfs and incompatible API.
  192. - Added missing ncurses-devel buildrequires
  193. * Wed Jun 07 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-4
  194. - Rebuilt with final memset patch
  195. - Added missing pkgconfig buildprereq (#191935)
  196. * Fri May 26 2006 Radek Vokal <rvokal@redhat.com> - 2.4.1-2
  197. - rebuilt for new libnetsnmp and net-snmp-config changes
  198. * Wed May 24 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-1
  199. - Fixed buggy use of memset throughout the code
  200. - Made the package build and install properly
  201. * Fri May 19 2006 Phil Knirsch <pknirsch@redhat.com>
  202. - Added missing glib2-devel build prereq (#191935)
  203. - Update to latest stable version openhpi-2.4.1
  204. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.2
  205. - bump again for double-long bug on ppc(64)
  206. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.1
  207. - rebuilt for new gcc4.1 snapshot and glibc changes
  208. * Mon Jan 9 2006 Peter Jones <pjones@redhat.com> 2.2.1-4
  209. - Don't use -Werror, it doesn't build with that on ppc64 currently.
  210. * Mon Jan 06 2006 Jesse Keating <jkeating@redhat.com> 2.2.1-3
  211. - Fix to not use stict-aliasing.
  212. * Wed Jan 04 2006 Radek Vokal <rvokal@redhat.com> 2.2.1-2
  213. - Rebuilt against new libnetsnmp
  214. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  215. - rebuilt
  216. * Fri Nov 11 2005 Phil Knirsch <pknirsch@redhat.com> 2.2.1-1
  217. - Update to stable openhpi-2.2.1
  218. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-5
  219. - Rebuilt to link against latest openssl lib.
  220. * Mon Nov 07 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-4
  221. - Added the openhpi config file
  222. - Added missing /var/lib/openhpi dir with proper rights
  223. - Added a few missing BuildPreReqs
  224. * Thu Nov 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-3
  225. - Rebuild against new net-snmp libs
  226. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-1
  227. - Moved the pkgconfig files to the devel package (#152507)
  228. - Update to openhpi-2.0.3
  229. - Had to manually disable ipmi support for now until openhpi builds correctly
  230. against it again
  231. - Dropped net-snmp-config patch, not needed anymore
  232. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-5
  233. - Fixed gcc4 rebuild problems
  234. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-4
  235. - bump release and rebuild with gcc 4
  236. * Mon Feb 14 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-3
  237. - Rebuilt for new rpm-4.4
  238. * Mon Dec 20 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.2-2
  239. - Fixed overflow in plugins/sysfs/sysfs2hpi.c
  240. - Fixed rebuild problem with latest net-snmp
  241. - Removed is_simulator patch, not needed anymore
  242. * Fri Nov 26 2004 Florian La Roche <laroche@redhat.com> 1.9.2-1
  243. - update to 1.9.2
  244. * Tue Nov 02 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.1-1
  245. - Added proper BuildRequires
  246. - Drop ia64 for first build, something fishy with the compiler and warning.
  247. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  248. - Initial version
  249. - Disable dummy plugin, doesn't compile
  250. - Fix missing () in snmp_bc_session.c