perl-Bit-Vector-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. Summary: Efficient bit vector, set of integers and "big int" math library
  2. Name: perl-Bit-Vector
  3. Version: 7.1
  4. Release: 1%{?_dist_release}
  5. License: distributable
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/~stbey/Bit-Vector/
  8. Source0: http://www.cpan.org/authors/id/STBEY/Bit-Vector-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: perl >= 0:5.00503
  11. BuildRequires: perl-Carp-Clan >= 5.3
  12. Requires: perl
  13. Requires: perl-Carp-Clan >= 5.3
  14. Conflicts: perl-Date-Calc < 5.0
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. Bit::Vector is an efficient C library which allows you to handle
  19. bit vectors, sets (of integers), "big integer arithmetic" and
  20. boolean matrices, all of arbitrary sizes.
  21. The library is efficient (in terms of algorithmical complexity)
  22. and therefore fast (in terms of execution speed) for instance
  23. through the widespread use of divide-and-conquer algorithms.
  24. The package also includes an object-oriented Perl module for
  25. accessing the C library from Perl, and optionally features
  26. overloaded operators for maximum ease of use.
  27. The C library can nevertheless be used stand-alone, without Perl.
  28. %prep
  29. %setup -q -n Bit-Vector-%{version}
  30. %build
  31. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  32. make
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. make DESTDIR=$RPM_BUILD_ROOT pure_install
  36. find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
  37. sed "s@^$RPM_BUILD_ROOT@@g" | \
  38. grep -v perllocal.pod | \
  39. grep -v %{_mandir} | \
  40. grep -v "\.packlist" > Bit-Vector-%{version}-filelist
  41. if [ "$(cat Bit-Vector-%{version}-filelist)X" = "X" ] ; then
  42. echo "ERROR: EMPTY FILE LIST"
  43. exit -1
  44. fi
  45. install -m 0644 blib/man3/* %{buildroot}%{_mandir}/man3
  46. find examples -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
  47. %check
  48. make test
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %files -f Bit-Vector-%{version}-filelist
  52. %defattr(-,root,root)
  53. %doc CHANGES.txt CREDITS.txt README.txt examples Artistic.txt GNU_GPL.txt GNU_LGPL.txt
  54. %dir %{perl_vendorarch}/auto/Bit
  55. %dir %{perl_vendorarch}/auto/Bit/Vector
  56. %dir %{perl_vendorarch}/Bit
  57. %dir %{perl_vendorarch}/Bit/Vector
  58. %{_mandir}/man3/*3pm*
  59. %changelog
  60. * Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 7.1-1
  61. - new upstream release
  62. - add Vendor and Distribution tags
  63. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4-1
  64. - new upstream release
  65. - built with perl-5.10.0
  66. * Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 6.4-0vl1
  67. - new upstream release
  68. - update Summary and description
  69. - add Requires: perl-Carp-Clan >= 5.3
  70. - add some license documents
  71. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 6.3-0vl1
  72. - version up to 6.3
  73. - add directories in %%files section
  74. - add some documents
  75. - add Conflicts: perl-Date-Calc < 5.0
  76. * Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 6.1-12vl1
  77. - build Rawhide-6.1-12 for Vine Linux
  78. * Wed Jan 30 2002 cturner@redhat.com
  79. - Specfile autogenerated