perl-Clone-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. Name: perl-Clone
  2. Version: 0.31
  3. Release: 1%{?_dist_release}
  4. Summary: Recursively copy perl datatypes
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Clone
  8. Source0: http://search.cpan.org/CPAN/authors/id/R/RD/RDF/Clone-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  10. BuildRequires: perl(ExtUtils::ParseXS), perl(Taint::Runtime), perl(Test::More)
  11. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  12. # don't "provide" private Perl libs
  13. %global _use_internal_dependency_generator 0
  14. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u
  15. %global __find_provides /bin/sh -c "%{__grep} -v '%_docdir' | %{__grep} -v '%{perl_vendorarch}/.*\\.so$' | %{__deploop P}"
  16. %global __find_requires /bin/sh -c "%{__grep} -v '%_docdir' | %{__deploop R}"
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: shaolin
  20. %description
  21. This module provides a clone() method which makes recursive
  22. copies of nested hash, array, scalar and reference types,
  23. including tied variables and objects.
  24. clone() takes a scalar argument and an optional parameter that
  25. can be used to limit the depth of the copy. To duplicate lists,
  26. arrays or hashes, pass them in by reference.
  27. %prep
  28. %setup -q -n Clone-%{version}
  29. find . -type f -exec chmod -c -x {} ';'
  30. %build
  31. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  32. make %{?_smp_mflags}
  33. %install
  34. rm -rf $RPM_BUILD_ROOT
  35. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  36. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  37. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  38. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  39. chmod -R u+w $RPM_BUILD_ROOT/*
  40. %check
  41. make test
  42. %clean
  43. rm -rf $RPM_BUILD_ROOT
  44. %files
  45. %defattr(-,root,root,-)
  46. %doc Changes
  47. %{perl_vendorarch}/auto/Clone/
  48. %{perl_vendorarch}/Clone.pm
  49. %{_mandir}/man3/*.3*
  50. %changelog
  51. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.31-1
  52. - initial build for Vine Linux
  53. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-9
  54. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  55. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.31-8
  56. - Perl mass rebuild
  57. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-7
  58. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  59. * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-6
  60. - 661697 rebuild for fixing problems with vendorach/lib
  61. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-5
  62. - Mass rebuild with perl-5.12.0
  63. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.31-4
  64. - rebuild against perl 5.10.1
  65. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-3
  66. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  67. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.31-2
  68. - filter private Perl solibs from provides
  69. - remove some executable bits -- keep rpmlint happy
  70. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.31-1
  71. - update to 0.31
  72. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-5
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  74. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.28-4
  75. - Rebuild for perl 5.10 (again)
  76. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.28-3
  77. - Autorebuild for GCC 4.3
  78. * Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-2
  79. - rebuild for new perl
  80. * Wed Nov 28 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-1
  81. - bump to 0.28
  82. * Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-2
  83. - license fix
  84. * Fri Jul 27 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-1
  85. - bump to 0.27
  86. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.22-1
  87. - bump to 0.22
  88. * Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-2
  89. - bump for fc6
  90. * Fri Mar 31 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-1
  91. - bump to 0.20
  92. - new BR: perl-Taint-Runtime
  93. * Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-3
  94. - bump for FC-5
  95. * Fri Jan 6 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-2
  96. - don't pass optflags twice
  97. - remove .bs files
  98. * Thu Jan 5 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-1
  99. - Initial package for Fedora Extras