perl-Log-Dump-vl.spec 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. %define pkgname Log-Dump
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 0.09
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: yasumichi
  13. Summary: simple logger mainly for debugging
  14. Summary(ja): 主にデバッグのための簡単なロガー
  15. # Dependency
  16. Requires: perl
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl
  19. %description
  20. Log::Dump is a simple logger mix-in mainly for debugging. This installs five
  21. methods into a caller (the class that used Log::Dump) via Sub::Install. The
  22. point is you don't need to load extra dumper modules or you don't need to
  23. concatenate messages. Just log things and they will be dumped (and
  24. concatenated if necessary) to stderr, and to a file if you prefer. Also, you
  25. can use these logging methods as class methods or object methods (though
  26. usually you don't want to mix them, especially when you're doing something
  27. special).
  28. #%%description -l ja
  29. %prep
  30. %setup -q -n Log-Dump-0.09
  31. %build
  32. perl Makefile.PL
  33. %{__make}
  34. %install
  35. %{__rm} -rf ${RPM_BUILD_ROOT}
  36. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  37. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  38. sed "s@^$RPM_BUILD_ROOT@@g" |
  39. grep -v ^%{_mandir} |
  40. grep -v perllocal.pod |
  41. grep -v "\.packlist" > %{name}.files
  42. if [ "$(cat %{name}.files)X" = "X" ] ; then
  43. echo "ERROR: EMPTY FILE LIST"
  44. exit -1
  45. fi
  46. # remove unnecessary files.
  47. %{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  48. %{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Log/Dump/.packlist
  49. %clean
  50. %{__rm} -rf ${RPM_BUILD_ROOT}
  51. %files -f %{name}.files
  52. %defattr(-,root,root)
  53. %doc Changes README
  54. %dir %{perl_sitelib}/Log/Dump
  55. %{_mandir}/*/*
  56. %changelog
  57. * Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.09-1
  58. - initial build for Vine Linux