perl-Package-DeprecationManager-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. # Test::Kwalitee and Test::Requires not available in EPEL < 6
  2. %global extra_tests_available %(expr 0%{?fedora} + 0%{?rhel} '>' 5)
  3. Name: perl-Package-DeprecationManager
  4. Version: 0.11
  5. Release: 3%{?dist}
  6. Summary: Manage deprecation warnings for your distribution
  7. Group: Development/Libraries
  8. License: Artistic 2.0
  9. URL: http://search.cpan.org/dist/Package-DeprecationManager/
  10. Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Package-DeprecationManager-%{version}.tar.gz
  11. Patch0: Package-DeprecationManager-0.11-old-EU::MM.patch
  12. Patch1: Package-DeprecationManager-0.11-old-Test::More.patch
  13. Patch2: Package-DeprecationManager-0.10-no-Test::Requires.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
  15. BuildArch: noarch
  16. BuildRequires: perl(Carp)
  17. BuildRequires: perl(ExtUtils::MakeMaker)
  18. BuildRequires: perl(List::MoreUtils)
  19. BuildRequires: perl(Params::Util)
  20. BuildRequires: perl(Sub::Install)
  21. BuildRequires: perl(Test::EOL)
  22. BuildRequires: perl(Test::Fatal)
  23. BuildRequires: perl(Test::More)
  24. BuildRequires: perl(Test::NoTabs)
  25. BuildRequires: perl(Test::Output)
  26. BuildRequires: perl(Test::Pod)
  27. BuildRequires: perl(Test::Pod::Coverage)
  28. BuildRequires: perl(Pod::Coverage::TrustPod)
  29. BuildRequires: perl(Test::CPAN::Changes)
  30. %if %{extra_tests_available}
  31. BuildRequires: perl(Test::Kwalitee)
  32. BuildRequires: perl(Test::Requires)
  33. %endif
  34. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  35. %description
  36. This module allows you to manage a set of deprecations for one or more modules.
  37. When you import Package::DeprecationManager, you must provide a set of
  38. -deprecations as a hash ref. The keys are "feature" names, and the values are
  39. the version when that feature was deprecated.
  40. %prep
  41. %setup -q -n Package-DeprecationManager-%{version}
  42. # If we don't have Test::Requires, we need to patch it out of the test suite
  43. %if ! %{extra_tests_available}
  44. %patch2 -p1
  45. %endif
  46. %build
  47. perl Makefile.PL INSTALLDIRS=vendor
  48. make %{?_smp_mflags}
  49. %install
  50. rm -rf %{buildroot}
  51. make pure_install DESTDIR=%{buildroot}
  52. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  53. find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
  54. %{_fixperms} %{buildroot}
  55. %check
  56. make test RELEASE_TESTING=1
  57. %clean
  58. rm -rf %{buildroot}
  59. %files
  60. %defattr(-,root,root,-)
  61. %doc Changes LICENSE README
  62. %{perl_vendorlib}/Package/
  63. %{_mandir}/man3/Package::DeprecationManager.3pm*
  64. %changelog
  65. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.11-1
  66. - initial build for Vine Linux
  67. * Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 0.11-3
  68. - Fedora 17 mass rebuild
  69. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.11-2
  70. - Perl mass rebuild
  71. * Mon Jun 20 2011 Paul Howarth <paul@city-fan.org> - 0.11-1
  72. - Update to 0.11:
  73. - Allow an empty hash for the -deprecations parameter
  74. - BR: perl(ExtUtils::MakeMaker)
  75. - BR: perl(Test::CPAN::Changes)
  76. - BR: perl(Pod::Coverage::TrustPod) unconditionally
  77. - Update patches for old ExtUtils::MakeMaker and Test::More compatibility
  78. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10-3
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  80. * Sat Jan 08 2011 Paul Howarth <paul@city-fan.org> - 0.10-2
  81. - Update patches for old Test::More and no Test::Requires
  82. - perl(Pod::Coverage::TrustPod) now available everywhere except EPEL-4
  83. * Sat Jan 08 2011 Iain Arnell <iarnell@gmail.com> - 0.10-1
  84. - Update to 0.10:
  85. - Test suite uses Test::Fatal instead of Test::Exception
  86. * Mon Oct 18 2010 Paul Howarth <paul@city-fan.org> - 0.09-1
  87. - Update to 0.09:
  88. - Added a compilation test
  89. * Fri Oct 15 2010 Paul Howarth <paul@city-fan.org> - 0.08-1
  90. - Update to 0.08:
  91. - The use of regular expressions in ignores didn't really work in 0.06
  92. - Added missing deps on List::MoreUtils and Test::Requires
  93. - Replaced Test::Warn with Test::Output in the tests
  94. - Made the tests actually test what they should be testing
  95. - BR: Test::Output rather than Test::Warn
  96. - Update patches
  97. * Fri Oct 15 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
  98. - Update to 0.06:
  99. - Removed hard dep on Test::Warn for the benefit of Moose
  100. - Fixed what looked like a bug in -ignore handling
  101. - The -ignore parameter now accepts regexes as well as package names
  102. - Update compatibility patches
  103. - BR: List::MoreUtils
  104. - BR: Test::Requires where possible, patch it out elsewhere
  105. * Tue Jul 27 2010 Paul Howarth <paul@city-fan.org> - 0.04-2
  106. - Clean up for Fedora submission
  107. * Mon Jul 26 2010 Paul Howarth <paul@city-fan.org> - 0.04-1
  108. - Initial RPM version