perl-Test-Classy-vl.spec 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576
  1. %define pkgname Test-Classy
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 0.09
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/%{pkgname}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: yasumichi
  13. Summary: write your unit tests in other modules than *.t
  14. Summary(ja): *.t 以外のモジュールで単体テストを書く
  15. # Dependency
  16. Requires: perl
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl
  19. %description
  20. This is yet another Test::Class-like unit testing framework. As stated in
  21. Test::Class pod, you don't need to care if your tests are small and working
  22. correctly. If not, this may be one of your options.
  23. Unlike Test::Class, Test::Classy (actually Test::Classy::Base) is based on
  24. Test::More and exports everything Test::More exports. Test::Classy doesn't
  25. control test flow as fully as Test::Class, but it may be easier to skip and
  26. limit tests.
  27. #%%description -l ja
  28. %prep
  29. %setup -q -n Test-Classy-0.09
  30. %build
  31. perl Makefile.PL
  32. %{__make}
  33. %install
  34. %{__rm} -rf ${RPM_BUILD_ROOT}
  35. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  36. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  37. sed "s@^$RPM_BUILD_ROOT@@g" |
  38. grep -v ^%{_mandir} |
  39. grep -v perllocal.pod |
  40. grep -v "\.packlist" > %{name}.files
  41. if [ "$(cat %{name}.files)X" = "X" ] ; then
  42. echo "ERROR: EMPTY FILE LIST"
  43. exit -1
  44. fi
  45. # remove unnecessary files.
  46. %{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  47. %{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Test/Classy/.packlist
  48. %clean
  49. %{__rm} -rf ${RPM_BUILD_ROOT}
  50. %files -f %{name}.files
  51. %defattr(-,root,root)
  52. %doc Changes README
  53. %dir %{perl_sitelib}/Test/Classy
  54. %{_mandir}/*/*
  55. %changelog
  56. * Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.09-1
  57. - initial build for Vine Linux