perl-XML-LibXML-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154
  1. Summary: Perl interface to the libxml2 library
  2. Name: perl-XML-LibXML
  3. # NOTE: also update perl-XML-LibXSLT to the same version, see
  4. # https://bugzilla.redhat.com/show_bug.cgi?id=469480
  5. Version: 1.70
  6. Release: 2%{?_dist_release}
  7. License: GPL+ or Artistic
  8. Group: Development/Libraries
  9. URL: http://search.cpan.org/dist/XML-LibXML/
  10. Source0: http://www.cpan.org/authors/id/P/PA/PAJAS/XML-LibXML-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: %(perl -MConfig -le 'if (defined $Config{useithreads}) { print "perl(:WITH_ITHREADS)" } else { print "perl(:WITHOUT_ITHREADS)" }')
  13. Requires: %(perl -MConfig -le 'if (defined $Config{usethreads}) { print "perl(:WITH_THREADS)" } else { print "perl(:WITHOUT_THREADS)" }')
  14. Requires: %(perl -MConfig -le 'if (defined $Config{uselargefiles}) { print "perl(:WITH_LARGEFILES)" } else { print "perl(:WITHOUT_LARGEFILES)" }')
  15. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  16. BuildRequires: perl >= 2:5.8.0
  17. BuildRequires: perl(XML::NamespaceSupport)
  18. BuildRequires: perl(XML::SAX)
  19. BuildRequires: perl(ExtUtils::MakeMaker), perl(Test::More)
  20. BuildRequires: libxml2-devel
  21. Provides: perl-XML-LibXML-Common = %{version}
  22. Obsoletes: perl-XML-LibXML-Common <= 0.13
  23. %description
  24. This module implements a Perl interface to the GNOME libxml2 library
  25. which provides interfaces for parsing and manipulating XML files. This
  26. module allows Perl programmers to make use of the highly capable
  27. validating XML parser and the high performance DOM implementation.
  28. %prep
  29. %setup -q -n XML-LibXML-%{version}
  30. %build
  31. %__perl Makefile.PL SKIP_SAX_INSTALL=1 INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  32. %__make %{?_smp_mflags}
  33. %install
  34. %__rm -rf $RPM_BUILD_ROOT
  35. %__make install \
  36. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT \
  37. INSTALLARCHLIB=$RPM_BUILD_ROOT%{perl_archlib}
  38. find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
  39. -o \( -name '*.bs' -a -empty \) \) -exec %__rm -f {} ';'
  40. find $RPM_BUILD_ROOT -type d -depth -exec %__rmdir {} 2>/dev/null ';'
  41. %__chmod -R u+w $RPM_BUILD_ROOT/*
  42. for i in Changes; do
  43. /usr/bin/iconv -f iso8859-1 -t utf-8 $i > $i.conv && %__mv -f $i.conv $i
  44. done
  45. %check
  46. %__make test
  47. %clean
  48. %__rm -rf $RPM_BUILD_ROOT
  49. %triggerin -- perl-XML-SAX
  50. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  51. perl -MXML::SAX -e "XML::SAX->add_parser(q($p))->save_parsers()" \
  52. 2>/dev/null || :
  53. done
  54. %preun
  55. if [ $1 -eq 0 ] ; then
  56. for p in XML::LibXML::SAX::Parser XML::LibXML::SAX ; do
  57. perl -MXML::SAX -e "XML::SAX->remove_parser(q($p))->save_parsers()" \
  58. 2>/dev/null || :
  59. done
  60. fi
  61. %files
  62. %defattr(-,root,root,-)
  63. %doc Changes LICENSE README
  64. %{perl_vendorarch}/auto/XML
  65. %{perl_vendorarch}/XML
  66. %{_mandir}/man3/*.3*
  67. %changelog
  68. * Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.70-2
  69. - rebuild with perl-5.12.3
  70. * Thu Aug 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-1
  71. - new upstream release
  72. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1:1.70-5
  73. - Mass rebuild with perl-5.12.0
  74. * Fri Jan 8 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-4
  75. - remove BR XML::LibXML::Common
  76. * Mon Nov 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-3
  77. - corrected version of obsoletes
  78. * Thu Nov 26 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-2
  79. - 541605 this package now contains XML::LibXML::Common
  80. * Fri Nov 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.70-1
  81. - update to fix 539102
  82. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-3
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  84. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.69-2
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  86. * Thu Dec 11 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1:1.69-1
  87. - update to 1.69
  88. * Fri Aug 01 2008 Lubomir Rintel <lkundrak@v3.sk> - 1:1.66-2
  89. - Supress warning about nonexistent file in perl-XML-SAX install trigger
  90. * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.66-1
  91. - new upsteream release
  92. - built with perl-5.10.0-2
  93. - changed Group to Development/Libraries
  94. * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl2
  95. - changed Group to Development/Languages
  96. - rebuilt with libxml2-2.6.26
  97. * Sun Apr 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.58-2vl1
  98. - rebuilt for Vine Linux
  99. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.2
  100. - bump again for double-long bug on ppc(64)
  101. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.58-2.2.1
  102. - rebuilt for new gcc4.1 snapshot and glibc changes
  103. * Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 1.58-2.2
  104. - rebuild for new perl-5.8.8
  105. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  106. - rebuilt for new gcc
  107. * Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
  108. - rebuilt for new gcj
  109. * Sat Mar 19 2005 Joe Orton <jorton@redhat.com> 1.58-2
  110. - rebuild
  111. * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
  112. - #121168
  113. - Update to 1.58.
  114. - Require perl(:MODULE_COMPAT_*).
  115. - Handle ParserDetails.ini parser registration.
  116. - BuildRequires libxml2-devel.
  117. - Own installed directories.
  118. * Fri Feb 27 2004 Chip Turner <cturner@redhat.com> - 1.56-1
  119. - Specfile autogenerated.