preload-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. Name: preload
  2. Version: 0.6.4
  3. Release: 5%{?_dist_release}
  4. Summary: an adaptive readahead daemon
  5. Summary(ja): 適応的先読みデーモン
  6. Group: Applications/System
  7. License: GPLv2+
  8. URL: http://preload.sf.net/
  9. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. #Patch0: preload-0.6-start-late.patch
  11. Patch0: preload.init.in.patch
  12. #This patch prefered to http://sourceforge.net/tracker/index.php?func=detail&aid=2183212&group_id=143398&atid=755420
  13. Patch1: preload-conf.patch
  14. #This patch from http://preload.svn.sourceforge.net/viewvc/preload/trunk/src/cmdline.c?revision=122
  15. Patch2: logrotate_619384
  16. #http://patch-tracker.debian.org/patch/series/view/preload/0.6.4-2/logrotate_619384
  17. #This patch from Mandriva
  18. #Patch3: preload-0.6.3-glib214.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: basesystem, glib2-devel, help2man
  21. Requires: basesystem, logrotate
  22. Requires(post): /sbin/chkconfig
  23. Requires(post): /sbin/service
  24. Requires(preun): /sbin/chkconfig
  25. Requires(preun): /sbin/service
  26. Requires(postun): /sbin/service
  27. %description
  28. preload monitors applications that users run, and by analyzing this data,
  29. predicts what applications users might run, and fetches those binaries and
  30. their dependencies into memory for faster startup times.
  31. %description -l ja
  32. preload は起動中のアプリケーションを監視し、監視したデータを分析することで、
  33. 度のアプリケーションユーザが起動されるかを予想し、バイナリと依存する
  34. ライブラリをメモリに取り込み、起動時間を高速にします。
  35. %prep
  36. %setup -q
  37. %patch0 -p1
  38. %patch1 -p1
  39. %patch2 -p1
  40. #%patch3 -p1
  41. %build
  42. %configure
  43. %{__make}
  44. %install
  45. %{__rm} -rf $RPM_BUILD_ROOT
  46. %{__make} install DESTDIR=$RPM_BUILD_ROOT
  47. %clean
  48. %{__rm} -rf $RPM_BUILD_ROOT
  49. %post
  50. /sbin/service preload restart >/dev/null 2>&1
  51. /sbin/chkconfig --add preload
  52. /sbin/chkconfig preload on
  53. %preun
  54. if [ $1 = 0 ]; then
  55. /sbin/service preload stop >/dev/null 2>&1
  56. /sbin/chkconfig --del preload
  57. fi
  58. %postun
  59. if [ "$1" -ge "1" ]; then
  60. /sbin/service preload condrestart >/dev/null 2>&1 || :
  61. fi
  62. %files
  63. %defattr(-,root,root, -)
  64. %doc README AUTHORS COPYING ChangeLog TODO THANKS NEWS
  65. %{_sbindir}/preload
  66. %{_datadir}/man/man8/preload.8.gz
  67. %{_sysconfdir}/rc.d/init.d/preload
  68. %config(noreplace) %{_sysconfdir}/preload.conf
  69. %config(noreplace) %{_sysconfdir}/sysconfig/preload
  70. %config(noreplace) %{_sysconfdir}/logrotate.d/preload
  71. %attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/preload.log
  72. %attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/lib/preload/preload.state
  73. %attr(0755,root,root) %dir %{_localstatedir}/lib/preload
  74. %changelog
  75. * Thu Jun 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-5
  76. - added Patch2 from Debian sid to fix path of pidof
  77. - added BuildRequires: help2man
  78. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-4
  79. - rebuilt with gcc-4.4.3-3 on ppc
  80. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-3
  81. - rebuilt with rpm-4.8.0-3 (on ppc)
  82. * Wed Feb 3 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-2
  83. - rebuilt with new toolchain
  84. * Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-1
  85. - new upstream release
  86. - dropped Patch2,3 (merged)
  87. * Thu Mar 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-4
  88. - added patch3 (import from Mandriva 2009.1)
  89. * Mon Dec 22 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-3
  90. - changed patch0 (Prefered to Mandriva 2009.0 package in preload-0.6.3-prcsys.patch)
  91. * Mon Dec 8 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-2
  92. - Removed preload-0.6-start-late.patch
  93. - Added patch0, patch1, patch2
  94. Patch0: start preload daemon later, changed default-start
  95. Patch1: changed mapprefix&exeprefix section
  96. added /opt, for some applicaton (ex. Adobe Reader, OpenOffice.org)
  97. Patch2: fix segfault src/cmdline.c
  98. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  99. - new upstream release
  100. - drop all patches, they are all obsolete by upstream.
  101. - add Patch0 to start preload daemon lator. (use readahead daemon for bootup)
  102. * Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
  103. - applied new versioning policy, spec in utf-8
  104. * Sat Mar 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vl1
  105. - initial build for VineSeed based on Fedora package
  106. # * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp0
  107. # - rebuild for Vine Linux 4.2
  108. #
  109. # * Wed Mar 5 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp1
  110. # - initial build for VineSeed based on Fedora package
  111. * Wed Jan 16 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-5
  112. - Removed auto start from init
  113. - Added all the CVS patches prior to next release
  114. * Sun Jan 6 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-4
  115. - Removed debian patch and added patches from upstream instead
  116. - Patches fix 64 bit, ionice, sysconfig and loading.
  117. * Fri Nov 9 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-3
  118. - Used Debian Patch it consists of:
  119. - Close the file descriptor when writing state to a file in src/state.c,
  120. - Parse the dev field in /proc/%%d/maps as hexadecimal, not as unsigned
  121. integer. Thanks to Johan Kiviniemi for the patch.
  122. - Sort the readahead file list by device, block and inode and not file
  123. path to reduce seeking. Adapted by Johan from a patch for readahead
  124. by Scott James Remnant.
  125. - Added my patch to verbosity to 1 due to 30 second log writing
  126. * Thu Nov 8 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-2
  127. - Fixed config lines
  128. - Fixed source lines
  129. - Added Requires: Logrotate
  130. - Default preload sequence is stopped
  131. - %{?_smp_mflags} does not work
  132. * Sat Oct 16 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-1
  133. - Creation from start
  134. ### end of file