python-django-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175
  1. Summary: A high-level Python Web framework
  2. Summary(ja): Python の高度なウェブフレームワーク
  3. Name: python-django
  4. Version: 1.3
  5. Release: 2%{?_dist_release}
  6. Group: Development/Languages
  7. BuildArch: noarch
  8. License: BSD
  9. URL: http://www.djangoproject.com/
  10. Source0: Django-%{version}.tar.gz
  11. Source1: simplejson-init.py
  12. Patch0: Django-hash-compat-13310.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: python-devel
  15. BuildRequires: python-sphinx
  16. Requires: python-simplejson
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: owa, munepi
  20. %description
  21. Django is a high-level Python Web framework that encourages rapid
  22. development and a clean, pragmatic design. It focuses on automating as
  23. much as possible and adhering to the DRY (Don't Repeat Yourself)
  24. principle.
  25. %description -l ja
  26. Django はハイレベルな Python Web フレームワークであり、素早い開発と
  27. クリーンで実用的な設計を勧めています。Django は可能な限りの自動化と
  28. 無駄な繰返しを徹底的に排除することに注目しています。
  29. %package docs
  30. Summary: Documentation for Django
  31. Group: Documentation
  32. Requires: %{name} = %{version}-%{release}
  33. %description docs
  34. This package contains the documentation for the Django high-level
  35. Python Web framework.
  36. %prep
  37. %setup -q -n Django-%{version}
  38. #%patch0 -p3
  39. # remove bundled simplejson
  40. cd django/utils/simplejson/
  41. %__rm -rf *
  42. # and put the replacement stub in place
  43. %__cp -p %{SOURCE1} __init__.py
  44. %build
  45. %{__python} setup.py build
  46. %install
  47. %__rm -rf $RPM_BUILD_ROOT
  48. %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  49. # Permission fixes
  50. pushd $RPM_BUILD_ROOT%{python_sitelib}/django
  51. chmod +x conf/project_template/manage.py*
  52. chmod +x contrib/admin/media/js/compress.py*
  53. chmod +x bin/profiling/gather_profile_stats.py*
  54. #chmod +x bin/compile-messages.py*
  55. chmod +x bin/daily_cleanup.py*
  56. chmod +x bin/django-admin.py*
  57. #chmod +x bin/make-messages.py*
  58. chmod +x bin/unique-messages.py*
  59. popd
  60. # Fix items in %{_bindir}
  61. %__mv $RPM_BUILD_ROOT%{_bindir}/django-admin.py $RPM_BUILD_ROOT%{_bindir}/django-admin
  62. # install man pages
  63. %__mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
  64. %__cp -p docs/man/* $RPM_BUILD_ROOT%{_mandir}/man1/
  65. # Handling locale files
  66. # This is adapted from the %%find_lang macro, which cannot be directly
  67. # used since Django locale files are not located in %%{_datadir}
  68. #
  69. # The rest of the packaging guideline still apply -- do not list
  70. # locale files by hand!
  71. %__rm -f %{name}.lang
  72. (cd $RPM_BUILD_ROOT && find . -name 'django*.mo') | %{__sed} -e 's|^.||' | %{__sed} -e \
  73. 's:\(.*/locale/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:' \
  74. >> %{name}.lang
  75. find $RPM_BUILD_ROOT -name "*.po" | xargs %__rm -f
  76. %clean
  77. rm -rf $RPM_BUILD_ROOT
  78. %files -f %{name}.lang
  79. %defattr(-,root,root,-)
  80. %doc AUTHORS LICENSE README
  81. %{_bindir}/django-admin
  82. %{_mandir}/man1/*
  83. %{python_sitelib}/django/bin/*.py*
  84. %{python_sitelib}/django/bin/profiling/
  85. # Include everything but the locale data ...
  86. %{python_sitelib}/django/db/
  87. %{python_sitelib}/django/*.py*
  88. %{python_sitelib}/django/shortcuts/
  89. %{python_sitelib}/django/utils/
  90. %{python_sitelib}/django/dispatch/
  91. %{python_sitelib}/django/template/
  92. %{python_sitelib}/django/views/
  93. %{python_sitelib}/django/contrib/
  94. %{python_sitelib}/django/forms/
  95. %{python_sitelib}/django/templatetags/
  96. %{python_sitelib}/django/core/
  97. %{python_sitelib}/django/http/
  98. %{python_sitelib}/django/middleware/
  99. %{python_sitelib}/django/test/
  100. %{python_sitelib}/django/conf/*.py*
  101. %{python_sitelib}/django/conf/project_template/*.py*
  102. %{python_sitelib}/django/conf/app_template/
  103. %{python_sitelib}/django/conf/urls/
  104. %{python_sitelib}/django/conf/locale/*/*.py*
  105. %{python_sitelib}/django/conf/locale/*.py*
  106. %{python_sitelib}/Django-%{version}-py%{pyver}.egg-info
  107. %files docs
  108. %defattr(-,root,root,-)
  109. %doc docs/*
  110. %changelog
  111. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-2
  112. - rebuild with python-2.7.2
  113. * Mon May 02 2011 Shu KONNO <owa@bg.wakwak.com> 1.3-1
  114. - updated Django to 1.3
  115. * Wed Feb 16 2011 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1
  116. - updated Django to 1.2.5 (include CVE-2011-0696, CVE-2011-0697)
  117. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.3-1
  118. - updated Django to 1.2.3
  119. - dropt Django-hash-compat-13310.patch
  120. * Thu Sep 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-2
  121. - added simplejson-init.py: removed bundled simplejson, and put the __init__.py
  122. - added Django-hash-compat-13310.patch: http://code.djangoproject.com/changeset/13310 per BZ#601212
  123. - added BR: python-devel python-sphinx
  124. - added RQ: python-simplejson
  125. - removed po files (per BZ#529188)
  126. - install man1
  127. (merged from 'Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - Django-1.2.1-1')
  128. * Sun Aug 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.1-1
  129. - updated Django to 1.2.1
  130. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
  131. - rebuild with python-2.6
  132. * Sun Oct 18 2009 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1
  133. - updated Django to 1.1.1
  134. * Fri Jul 31 2009 Shu KONNO <owa@bg.wakwak.com> 1.1-1
  135. - updated Django to 1.1
  136. - added japanese description
  137. * Fri Nov 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
  138. - updated Django to 1.0.2-final
  139. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl5
  140. - packaged new