scim-prime-vl.spec 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. # -*- coding: utf-8-unix -*-
  2. %define name scim-prime
  3. %define version 1.0.0
  4. %define release 1%{?_dist_release}
  5. Summary: An SCIM IMEngine module for PRIME
  6. Summary(ja): PRIME のための SCIM IMEngine モジュール
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Group: System Environment/Libraries
  11. License: GPL
  12. URL: http://sourceforge.jp/projects/scim-imengine/
  13. Source0: %{name}-%{version}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. Requires: prime
  16. Requires: scim
  17. BuildRequires: prime
  18. BuildRequires: scim-devel
  19. BuildRequires: automake, libtool-ltdl
  20. %description
  21. scim-prime is an SCIM IMEngine module for prime.
  22. %description -l ja
  23. scim-prime は PRIME のための SCIM IMEngine モジュールです.
  24. %prep
  25. %setup -q
  26. %build
  27. [[ ! -x configure ]] && ./bootstrap
  28. ## temporary hack to fix ltmain.sh version
  29. set -x
  30. aclocal -I m4
  31. autoheader
  32. libtoolize -c --automake
  33. automake --add-missing --copy --include-deps
  34. autoconf
  35. %configure
  36. # (tv) parallel build is broken: --> OK???
  37. %{__make} %{?_smp_mflags}
  38. %install
  39. %{__rm} -rf $RPM_BUILD_ROOT
  40. %{__make} DESTDIR=$RPM_BUILD_ROOT install
  41. %find_lang %{name}
  42. # remove unpackaged files
  43. rm -f $RPM_BUILD_ROOT%{_libdir}/scim-1.0/*/Helper/*.{a,la}
  44. rm -f $RPM_BUILD_ROOT%{_libdir}/scim-1.0/*/IMEngine/*.{a,la}
  45. rm -f $RPM_BUILD_ROOT%{_libdir}/scim-1.0/*/SetupUI/*.{a,la}
  46. %clean
  47. %{__rm} -rf $RPM_BUILD_ROOT
  48. %post -p /sbin/ldconfig
  49. %postun -p /sbin/ldconfig
  50. %files -f %{name}.lang
  51. %defattr(-,root,root)
  52. %doc AUTHORS COPYING ChangeLog README
  53. %{_datadir}/scim/icons/*
  54. #%{_libdir}/scim-1.0/*/Helper/*.so
  55. %{_libdir}/scim-1.0/*/IMEngine/*.so
  56. %{_libdir}/scim-1.0/*/SetupUI/*.so
  57. %changelog
  58. * Sat Nov 01 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
  59. - initial build for VineSeed
  60. * Sat Mar 29 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1vl5
  61. - initial build for VineSeed
  62. ### end of file