slang1-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: shared library for C like extension language
  3. Summary(ja): C とよく似た拡張言語ライブラリ
  4. Name: slang1
  5. %define ever 1.4.9
  6. %define jver jp0
  7. Version: %{ever}
  8. Release: 1%{?_dist_release}
  9. License: GPL
  10. Group: System Environment/Libraries
  11. Source: ftp://space.mit.edu/pub/davis/slang/v1.4/slang-%{ever}.tar.bz2
  12. Patch0: slang-%{ever}%{jver}.patch
  13. Patch10: slang-1.4.9-nointerlibc.patch
  14. Patch20: slang-1.4.9-fix.patch
  15. Patch30: slang-1.4.9-buildfix.patch
  16. URL: http://space.mit.edu/~davis/slang.html
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. Provides: slang = %{version}-%{release}
  19. Obsoletes: slang < %{version}-%{release}
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  23. %description
  24. S-lang (pronounced ``sssslang'') is a powerful stack based interpreter
  25. that supports a C-like syntax. It has been designed from the beginning
  26. to be easily embedded into a program to make it extensible. Slang also
  27. provides a way to quickly develop and debug the application embedding it
  28. in a safe and efficient manner. Since slang resembles C, it is easy to
  29. recode slang procedures in C if the need arises.
  30. This is Japanese visible version.
  31. This package is patched for linux console and kon.
  32. %description -l ja
  33. S-lang (``sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  34. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  35. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  36. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  37. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  38. ## to build compat32 for x86_64 architecture support
  39. %package -n compat32-%{name}
  40. Summary: shared library for C like extension language
  41. Group: System Environment/Libraries
  42. %description -n compat32-%{name}
  43. S-lang (pronounced ``sssslang'') is a powerful stack based interpreter
  44. that supports a C-like syntax. It has been designed from the beginning
  45. to be easily embedded into a program to make it extensible. Slang also
  46. provides a way to quickly develop and debug the application embedding it
  47. in a safe and efficient manner. Since slang resembles C, it is easy to
  48. recode slang procedures in C if the need arises.
  49. This is Japanese visible version.
  50. This package is patched for linux console and kon.
  51. %prep
  52. %setup -q -n slang-%{ever}
  53. %patch0 -p1 -b .jp
  54. %patch10 -p1 -b .nointerlibc
  55. %patch20 -p1 -b .fixed-tick
  56. %patch30 -p1 -b .buildfix
  57. %build
  58. %if %{build_compat32}
  59. export CC='gcc -m32'
  60. %endif
  61. #CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=-s ./configure --prefix=%{_prefix}
  62. CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=-s %configure
  63. make all elf "ELF_CFLAGS=$RPM_OPT_FLAGS -fPIC"
  64. ( cd src
  65. make untic "ELF_CFLAGS=$RPM_OPT_FLAGS -fPIC"
  66. )
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  70. make DESTDIR=$RPM_BUILD_ROOT \
  71. install_include_dir=%{_includedir}/slang \
  72. install install-elf
  73. install -s -m 755 src/objs/untic $RPM_BUILD_ROOT%{_bindir}
  74. chmod 755 $RPM_BUILD_ROOT%{_libdir}/libslang.so.%{ever}
  75. ln -sf libslang.so.%{ever} $RPM_BUILD_ROOT%{_libdir}/libslang.so.1
  76. # remove unneeded files
  77. rm -rf $RPM_BUILD_ROOT%{_includedir}
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,so}
  79. rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
  80. rm -rf $RPM_BUILD_ROOT%{_bindir}
  81. %post -p /sbin/ldconfig
  82. %postun -p /sbin/ldconfig
  83. %if %{build_compat32}
  84. %post -n compat32-%{name} -p /sbin/ldconfig
  85. %postun -n compat32-%{name} -p /sbin/ldconfig
  86. %endif
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %if !%{build_compat32}
  90. %files
  91. %defattr(- , root, root)
  92. %doc README COPY* UPGRADE.txt NEWS INSTALL* changes.txt
  93. %doc doc/ slang-j.doc
  94. %{_libdir}/libslang.so.*
  95. %endif
  96. %if %{build_compat32}
  97. %files -n compat32-%{name}
  98. %defattr(- , root, root)
  99. %{_libdir}/libslang.so.*
  100. %endif
  101. %changelog
  102. * Sun May 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-1
  103. - rename to slang1
  104. - build as compat package
  105. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
  106. - update to slang-1.4.9
  107. - rediffed slang_jp patch
  108. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
  109. - change ./configure to %%configure
  110. - uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
  111. - added compat32-* packages for x86_64 architecture support
  112. * Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
  113. - rebuild with new toolchains
  114. - s/Copyright/License/
  115. * Sat Feb 9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
  116. - bug fixed canna input for jed
  117. - change patch: bug fixed slsng-console.patch
  118. * Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
  119. - rebuild with glibc-2.2.4
  120. * Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
  121. - update to 1.4.4
  122. - use jp0 patch
  123. - use better macros
  124. - use Release No for Vine Linux
  125. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  126. [1.2.2_jp-7]
  127. - Japanese summary and description
  128. - change group
  129. * Mon Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
  130. - rebuild for new environment.
  131. * Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  132. [1.2.2_jp-5]
  133. - Updated to 1.2.2j056
  134. * Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
  135. [1.2.2_jp-4]
  136. - fix box bug with KANJI
  137. * Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  138. [1.2.2_jp-2]
  139. - Updated to 1.2.2j054
  140. * Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
  141. [1.2.2j052-2]
  142. - patch for linux console and kon
  143. - bug fix for no-kanji version
  144. - separate devel
  145. * Sat Jul 4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  146. [1.2.1j-1]
  147. - Updated to 1.2.2 (j052)
  148. * Fri Jun 5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  149. [1.2.1j-1]
  150. - japanize patch added
  151. * Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
  152. [1.2.1-1]
  153. - Updated to 1.2.1
  154. * Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
  155. [1.2.0-1]
  156. - Updated to 1.2.0, the first 1.x non-beta version
  157. * Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
  158. [1.0.3-1]
  159. - Updated to 1.0.3
  160. - Minor fixes
  161. * Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
  162. - Earlier changes were lost, because of misplacement of RPM:
  163. - BuildRoot
  164. - RPM_OPT_FLAGS
  165. - %clean section
  166. - other minor spec file changes
  167. - Should be buildable by non-root now
  168. - Included untic, a very cool terminfo interpreter (this probably out to be
  169. split out eventually)
  170. - Added bug fix from JED
  171. * Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
  172. - upgraded to 1.0.2
  173. * Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
  174. - Apparently so, Donnie. :)
  175. - upgraded to 1.0.0beta
  176. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  177. - spec file cleanups
  178. * Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
  179. - upgraded to 0.99.38 (will it EVER go 1.0???)
  180. - all patches removed (all appear to be in this version)
  181. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  182. - built against glibc