subversion-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498
  1. %define neon_version 0.25.5
  2. %define swig_version 1.3.29
  3. %define apache_dir /usr
  4. %define db_version 4.3.29
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.7.7
  12. Release: 1%{?_dist_release}
  13. License: ASL 2.0
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. Packager: iwaim
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. SOURCE0: subversion-%{version}.tar.bz2
  20. SOURCE1: subversion.conf
  21. SOURCE2: httpd.davcheck.conf
  22. SOURCE3: filter-requires.sh
  23. Patch3: subversion-1.7.0-rpath.patch
  24. Patch4: subversion-1.7.2-ruby19.patch
  25. Requires: db4 >= %{db_version}
  26. Requires: expat
  27. Requires: neon >= %{neon_version}
  28. BuildRequires: apache2-devel
  29. BuildRequires: apr-devel, apr-util-devel
  30. BuildRequires: autoconf >= 2.53
  31. BuildRequires: db4-devel >= %{db_version}
  32. BuildRequires: expat-devel
  33. BuildRequires: gdbm-devel
  34. BuildRequires: libtool >= 1.4.2
  35. BuildRequires: neon-devel >= %{neon_version}
  36. BuildRequires: openssl-devel
  37. BuildRequires: python
  38. BuildRequires: python-devel
  39. BuildRequires: swig >= %{swig_version}
  40. BuildRequires: texinfo
  41. BuildRequires: zlib-devel
  42. BuildRequires: openldap-devel
  43. BuildRequires: ruby >= 1.8.2
  44. BuildRequires: ruby-devel >= 1.8.2
  45. BuildRequires: perl >= 5.8.0
  46. BuildRequires: sqlite3-devel
  47. BuildRequires: krb5-devel
  48. BuildRequires: keyutils-libs-devel
  49. BuildRequires: dbus-devel
  50. BuildRequires: libgnome-keyring-devel
  51. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  52. %define __perl_requires %{SOURCE3}
  53. %description
  54. Subversion is a concurrent version control system which enables one
  55. or more users to collaborate in developing and maintaining a
  56. hierarchy of files and directories while keeping a history of all
  57. changes. Subversion only stores the differences between versions,
  58. instead of every complete file. Subversion is intended to be a
  59. compelling replacement for CVS.
  60. %package devel
  61. Group: Development/Libraries
  62. Summary: Development package for Subversion developers.
  63. Requires: subversion = %{version}-%{release}
  64. Requires: apr-devel, apr-util-devel
  65. %description devel
  66. The subversion-devel package includes the static libraries and include files
  67. for developers interacting with the subversion package.
  68. %package mod_dav_svn
  69. Group: System Environment/Daemons
  70. Summary: Apache server module for Subversion server.
  71. Requires: httpd >= %{apache_version}
  72. Requires: subversion = %{version}-%{release}
  73. %description mod_dav_svn
  74. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  75. the Apache directories and configuration.
  76. %package tools
  77. Group: Development/Tools
  78. Summary: Tools for Subversion
  79. BuildRequires: perl >= 5.8.0
  80. Requires: perl >= 5.8.0
  81. Requires: subversion = %{version}-%{release}
  82. %description tools
  83. Tools for Subversion.
  84. %package perl
  85. Group: Development/Libraries
  86. Summary: Perl bindings to the Subversion libraries
  87. Requires: subversion = %{version}-%{release}
  88. Requires: perl >= 5.8.0
  89. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  90. %description perl
  91. This package includes the Perl bindings to the Subversion libraries.
  92. %package ruby
  93. Group: Development/Libraries
  94. Summary: Ruby bindings to the Subversion libraries
  95. Requires: subversion = %{version}-%{release}
  96. Requires: ruby >= 1.9.3
  97. %description ruby
  98. This package includes the Ruby bindings to the Subversion libraries.
  99. %package python
  100. Group: Development/Libraries
  101. Summary: Python bindings to the Subversion libraries
  102. Requires: subversion = %{version}-%{release}, python
  103. %description python
  104. This package includes the Python bindings to the Subversion libraries.
  105. %prep
  106. %setup -q
  107. %patch3 -p1 -b .rpath
  108. %patch4 -p1 -b .ruby19
  109. rm -rf neon apr apr-util db4
  110. %build
  111. ./autogen.sh
  112. # fix shebang lines, #111498
  113. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  114. # override weird -shrext from ruby
  115. export svn_cv_ruby_link="%{__cc} -shared"
  116. export svn_cv_ruby_sitedir_libsuffix=""
  117. export svn_cv_ruby_sitedir_archsuffix=""
  118. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
  119. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  120. --with-swig --with-neon=%{_prefix} \
  121. --with-ruby-sitedir=%{rarchdir} \
  122. --with-apxs=%{_bindir}/apxs \
  123. --with-gnome-keyring \
  124. --disable-mod-activation \
  125. --disable-static \
  126. --disable-neon-version-check
  127. # 1.3.0 tarball ships with generated swig sources
  128. make extraclean-swig-headers
  129. make %{?_smp_mflags} all tools
  130. make swig-py swig-py-lib %{swigdirs}
  131. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  132. %install
  133. echo %{rarchdir}
  134. rm -rf $RPM_BUILD_ROOT
  135. make install \
  136. install-swig-py \
  137. install-swig-pl-lib \
  138. install-swig-rb \
  139. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  140. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  141. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  142. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  143. # Add subversion.conf configuration file into httpd/conf.d directory.
  144. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  145. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  146. # Set up tools package files.
  147. mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
  148. cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
  149. # Remove unpackaged files
  150. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  151. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  152. $RPM_BUILD_ROOT%{_libdir}/*.la
  153. # remove stuff produced with Perl modules
  154. find $RPM_BUILD_ROOT -type f \
  155. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  156. -print0 | xargs -0 rm -f
  157. # make Perl modules writable so they get stripped
  158. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  159. xargs -0 chmod 755
  160. # unnecessary libraries for swig bindings
  161. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  162. # Remove unnecessary ruby libraries
  163. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  164. # Trim what goes in docdir
  165. rm -rf tools/*/*.in tools/test-scripts
  166. # Rename authz_svn INSTALL doc for docdir
  167. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  168. %clean
  169. rm -rf $RPM_BUILD_ROOT
  170. %post -p /sbin/ldconfig
  171. %postun -p /sbin/ldconfig
  172. %post tools -p /sbin/ldconfig
  173. %postun tools -p /sbin/ldconfig
  174. %files
  175. %defattr(-,root,root)
  176. %doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
  177. %doc subversion/LICENSE
  178. %{_bindir}/*
  179. %{_libdir}/libsvn_*.so.*
  180. %{_localedir}/*/*/subversion.mo
  181. %{_mandir}/man*/*
  182. %dir %{_sysconfdir}/subversion
  183. %exclude %{_mandir}/man*/*::*
  184. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  185. %exclude %{_libdir}/libsvn_swig_py*.so.*
  186. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  187. %files devel
  188. %defattr(-,root,root)
  189. %{_includedir}/subversion-1
  190. %{_libdir}/libsvn*.so
  191. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  192. %exclude %{_libdir}/libsvn_swig_py*.so.*
  193. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  194. %files mod_dav_svn
  195. %defattr(-,root,root)
  196. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  197. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  198. %files tools
  199. %defattr(-,root,root)
  200. %{_prefix}/lib/subversion/tools
  201. %files perl
  202. %defattr(-,root,root,-)
  203. %{perl_vendorarch}/auto/SVN
  204. %{perl_vendorarch}/SVN
  205. %{_libdir}/libsvn_swig_perl*
  206. %{_mandir}/man*/*::*
  207. %files ruby
  208. %defattr(-,root,root,-)
  209. %{_libdir}/libsvn_swig_ruby*
  210. %{rarchdir}/svn
  211. %files python
  212. %defattr(-,root,root,-)
  213. %{_libdir}/libsvn_swig_py*
  214. %{python_sitearch}/libsvn
  215. %{python_sitearch}/svn
  216. %changelog
  217. * Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
  218. - update to 1.7.7
  219. - rebuild with ruby-1.9.3
  220. * Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
  221. - new upstream release
  222. - update License
  223. - update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
  224. - drop deplibs patch (Patch1)
  225. - drop obsolete patch files: Patch6, 10
  226. * Fri Jun 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  227. - new upstream release with security fix (CVE-2011-1752, 1783, 1921)
  228. - add configure option with-gnome-keyring
  229. - add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
  230. - fix Packager name
  231. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
  232. - build with perl 5.12.3
  233. - add Requires: perl(:MODULE_COMPAT_...)
  234. * Sat Mar 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
  235. - new upstream release with security fix
  236. - add Vendor/Distri tags
  237. * Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
  238. - new upstream release
  239. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  240. - fix <BTS:VineLinux:941>
  241. - using rpm macro: rarchdir
  242. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  243. - using rpm macros: perl_vendorarch and python_sitearch
  244. - add BuildRequires: sqlite3-devel krb5-devel
  245. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  246. - new upstream release
  247. - update URL
  248. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  249. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  250. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  251. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  252. * Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  253. - new upstream release
  254. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  255. - new upstream release
  256. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  257. - rebuilt with python-2.5.2
  258. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  259. - new upstream release
  260. - rebuild with neon-0.28.2
  261. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  262. - added Patch6, 8, 9, 10 from Fedora Core
  263. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  264. - Correct install location of java stuff (#433295)
  265. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  266. - fix build with new glibc open()-as-macro
  267. - build all swig code in %%build, not %%install
  268. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  269. - build /usr/bin/* as PIEs
  270. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  271. - rebuild with expat-2.0.1
  272. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  273. - new upstream release
  274. - add Patch10 to build with neon.
  275. 1.3.2-0vl5 does not support neon..
  276. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  277. - rebuild with new neon
  278. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  279. - rebuilt with new toolchain and db4-4.3.x
  280. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  281. - modified %%files section for lib64 architecture
  282. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  283. - new upstream release
  284. - rebuild with new openldap-2.3.24
  285. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  286. - new upstream release
  287. - change Group to Develoment/Tools
  288. - build with apr-1.2.7/apr-util-1.2.7
  289. - require apr/apr-util instead of apache2-apr
  290. - build with swig-1.3.29
  291. - split {perl,python,ruby} related files to subpackage.
  292. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  293. - new upstream release
  294. - add noreplace option for config file
  295. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  296. - fix Requires and BuildPreReq.
  297. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  298. - new upstream release.
  299. - add swig-runtime to 'BuildPreReq:'.
  300. - fix %%files.
  301. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  302. - require neon version 0.24.7 for ra_dav
  303. - add BuildPreReq: openldap-devel
  304. - replace BuildPreReq: httpd to BuildPreReq: apache2
  305. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  306. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  307. - new upstream release
  308. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  309. - new upstream release
  310. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  311. - new upstream release
  312. - clean up specfile.
  313. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  314. - new upstream release
  315. - build with apache2-2.0.47
  316. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  317. - build Vine Linux
  318. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  319. - Enabled RA_DAV checking.
  320. Now requires httpd package to build because of RA_DAV tests.
  321. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  322. - Created tools package to hold the tools.
  323. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  324. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  325. version of APR/APR-UTILS as of 2003.01.15.
  326. - Added svnversion command.
  327. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  328. - Create a svnadmin.static which is copied to svnadmin-version-release
  329. when the package is erased, so users can still dump/load their repositories
  330. even after they have upgraded the RPM package.
  331. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  332. - SWIG now builds so we can use cvs2svn.
  333. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  334. - Made cvs2svn conditional (at least until we can get it to build consistently
  335. and work).
  336. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  337. - Added SWIG dependencies to add cvs2svn capabilities.
  338. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  339. - Now requires neon-0.22.0.
  340. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  341. - Took out loading mod_dav_svn from subversion.spec file and put it in
  342. subversion.conf file which goes into the apache conf directory.
  343. - Simplify what gets put into httpd.conf to only the include for the
  344. subversion.conf file.
  345. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  346. me to do this).
  347. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  348. - Updated to APR/APR-UTIL 2002-08-08.
  349. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  350. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  351. - Previous version had a few problems because of missing apache error/ files.
  352. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  353. - Updated to apache-2.0.40-0.3.
  354. - Updated to subversion-0.13.1-2318.
  355. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  356. - Updated for RedHat 7.3 (autoconf253).
  357. - Added a bunch of pre-requisites I didn't know were needed because I built a
  358. new machine that didn't have them already installed.
  359. - Fixed installation of man and info documentation pages.
  360. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  361. - Back to apache-libapr* stuff, hopefully to stay.
  362. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  363. - Fixed expat.patch to not have to make so many changes by writing a small
  364. shell script that changes libexpat to -lexpat.
  365. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  366. - Updated to neon-0.19.2.
  367. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  368. - Back to using apr and apr-util separately from apache.
  369. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  370. - Updated to APR and APR-UTIL 2002.02.11.
  371. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  372. - Took out a (now non-existant) documentation file.
  373. - Moved SPEC file changelog to after all package definitions.
  374. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  375. - Updated to neon-0.18.5.
  376. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  377. apache-apr-utils, and apache-apr-utils-devel.
  378. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  379. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  380. - Now builds without the separate APR package as it is built into and
  381. "exported" from apache-2.0.31-0.3.
  382. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  383. - Took out patches to install procedure now not required because of fixes
  384. in rev 1130.
  385. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  386. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  387. program was added.
  388. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  389. - Release M5-r340: Added the subversion-server package.
  390. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  391. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  392. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  393. - Release M3-r117: Initial Version.