system-config-lvm-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. # -*- RPM-SPEC -*-
  2. Summary: A utility for graphically configuring Logical Volumes
  3. Summary(ja): LVM をグラフィカルに設定するためのユーティリティ
  4. Name: system-config-lvm
  5. Version: 1.1.15
  6. Release: 1%{?_dist_release}
  7. URL: http://www.redhat.com/
  8. License: GPLv2
  9. Group: Applications/System
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: %{name}-%{version}.tar.gz
  14. BuildArch: noarch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. Requires: usermode-gtk, /sbin/chkconfig
  17. Requires: gnome-python, pygtk2, pygtk2-libglade
  18. Requires: urw-fonts
  19. Requires: lvm2
  20. Requires: python
  21. BuildRequires: perl(XML::Parser)
  22. BuildRequires: gettext
  23. BuildRequires: intltool
  24. BuildRequires: desktop-file-utils
  25. %description
  26. system-config-lvm is a utility for graphically configuring Logical Volumes
  27. %prep
  28. %setup -q
  29. for i in src/* ;do
  30. perl -pi -e 's|python2|python|g' $i
  31. done
  32. %build
  33. %configure
  34. make %{?_smp_mflags}
  35. %install
  36. rm -rf %{buildroot}
  37. make DESTDIR=%{buildroot} install
  38. desktop-file-install --vendor system --delete-original \
  39. --dir %{buildroot}%{_datadir}/applications \
  40. --remove-category Application \
  41. --remove-category SystemSetup \
  42. --remove-category X-Red-Hat-Base \
  43. --add-category Settings \
  44. --add-category System \
  45. %{buildroot}%{_datadir}/applications/system-config-lvm.desktop
  46. %find_lang %name
  47. %clean
  48. rm -rf %{buildroot}
  49. #Replace the files line with the one commented out when translations are done
  50. %files -f %{name}.lang
  51. #%files
  52. %defattr(-,root,root)
  53. %doc COPYING
  54. %{_sbindir}/*
  55. %{_bindir}/*
  56. %{_datadir}/applications/system-config-lvm.desktop
  57. %{_datadir}/system-config-lvm
  58. %config(noreplace) %{_sysconfdir}/pam.d/system-config-lvm
  59. %config(noreplace) %{_sysconfdir}/security/console.apps/system-config-lvm
  60. %changelog
  61. * Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.15-1
  62. - new upstream release
  63. - remove R: rhpl
  64. * Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-1
  65. - initial build for Vine Linux
  66. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-5.1
  67. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  68. * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.1.4-4.1
  69. - Rebuild for Python 2.6
  70. * Mon Oct 27 2008 Matthias Clasen <mclasen@redhat.com> 1.1.4-3.1
  71. - Require usermode-gtk
  72. * Fri Oct 10 2008 Matthias Clasen <mclasen@redhat.com> 1.1.4-3.0
  73. - Fix up BuildRequires
  74. * Thu Oct 9 2008 Matthias Clasen <mclasen@redhat.com> 1.1.4-2.0
  75. - Properly install the desktop file (#442910)
  76. * Tue Apr 25 2008 Jim Parsons <jparsons@redhat.com> 1.1.4-1.0
  77. - Build for fedora
  78. * Tue Mar 25 2008 Ryan McCabe <rmccabe@redhat.com> 1.1.3-2.0
  79. - Fix for bz247325
  80. - Restore missing translations.
  81. * Wed Feb 06 2008 Ryan McCabe <rmccabe@redhat.com> 1.1.3-1.0
  82. - Fix for bz332651
  83. * Fri Sep 28 2007 Ryan McCabe <rmccabe@redhat.com> 1.1.2-1.0
  84. - Update the spec, configure.in, and Makefile.am files
  85. - Some other minor build tweaks
  86. - Bump the version number
  87. * Tue May 01 2007 Stanko Kupcevic <kupcevic@redhat.com> 1.1.1-1.0
  88. - Update pam file
  89. - Update translation files
  90. * Mon Jan 22 2007 Stanko Kupcevic <kupcevic@redhat.com> 1.0.22-1.0
  91. - Fixed 223518 (s-c-lvm fails to probe CS5 properly)
  92. - fixes bz223518
  93. * Mon Dec 18 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.21-1.0
  94. - Fixed 216569 (some messages not localized)
  95. - Fixed 218126 (Can't resize ext3 fs online)
  96. - fixes bz216569, bz218126
  97. * Mon Oct 16 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.20-1.0
  98. - Updated translation files
  99. * Mon Jul 10 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.19-1.0
  100. - Version bump
  101. * Thu Jun 01 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.18-1.0
  102. - Version bump
  103. * Fri May 12 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.17-1.0
  104. - Fixes for 175077, 171117, 175131, 176967, enable mirroring, 159455, 159456
  105. * Thu Feb 16 2006 Jim Parsons <jparsons@redhat.com> 1.0.16-1.0
  106. - Disabled mirroring support in UI.
  107. * Mon Feb 14 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.14-1.0
  108. - Fixes for bz180281, 159457, 180269. Mirroring support available with
  109. constants in lvmui_constants file by setting MIRRORING_UI_SUPPORT to True
  110. * Fri Feb 10 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.13-1.0
  111. - Fix failure to display all unused space
  112. * Mon Feb 06 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.12-1.0
  113. - Under certain conditions, labels might show partially
  114. * Fri Feb 03 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.11-1.0
  115. - Fixes for bz175077,169860,178128,161917,171117,175131,178195
  116. * Thu Jan 05 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.10-1.0
  117. - Fix for bz176967
  118. * Fri Dec 2 2005 Jim Parsons <jparsons@redhat.com> 1.0.9-1.0
  119. - Removed cLVM test.
  120. * Mon Nov 14 2005 Jim Parsons <jparsons@redhat.com> 1.0.8-1.0
  121. - Fixes for bz171744,171746,171747,171751,171753,171754,171755,171758,159457
  122. * Mon Sep 26 2005 Jim Parsons <jparsons@redhat.com> 1.0.7-1.0
  123. - Version bump.
  124. * Mon Sep 26 2005 Jim Parsons <jparsons@redhat.com> 1.0.6-1.0
  125. - Version bump for FC.
  126. * Wed Sep 13 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.5-1.0
  127. - Fix for bz167671.
  128. * Wed Sep 08 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.4-1.0
  129. - Fix for bz167662, 167643.
  130. * Mon Aug 15 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.3-1.0
  131. - Fix for bz159457: Temporary removal of mirroring support.
  132. * Tue Aug 02 2005 Jim Parsons <jparsons@redhat.com> 1.0.2-1.0
  133. - Major new release that supports snapshotting, mirroring, and resizing.
  134. * Mon Jul 26 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.52-1.0
  135. - Alpha release: Strings, minor bugs, GFS, GFS2, mirrors on diff HDs
  136. * Fri Jul 15 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.51-1.0
  137. - Alpha release: mirroring, multipath, GPT, zoom, ...
  138. * Tue Jun 21 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.50-1.0
  139. - Alpha release: snapshotting, resizing, lv properties
  140. * Thu May 26 2005 Jim Parsons <jparsons@redhat.com> 0.9.33-1.0
  141. - Version bump for rhel
  142. * Thu May 26 2005 Jim Parsons <jparsons@redhat.com> 0.9.32-1.0
  143. - Fix for 158872; x86_64 pam file path
  144. * Mon May 23 2005 Jim Parsons <jparsons@redhat.com> 0.9.31-1.0
  145. - Version bump for RHEL4
  146. * Mon May 23 2005 Jim Parsons <jparsons@redhat.com> 0.9.30-1.0
  147. - Fixed bz157744
  148. * Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.29-1.0
  149. - Version Bump
  150. * Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.28-1.0
  151. - Version Bump
  152. * Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.27-1.0
  153. - Fix for bz154458,153042,155438,157743
  154. * Thu May 05 2005 Jim Parsons <jparsons@redhat.com> 0.9.26-1.0
  155. - Fix for bz156957
  156. * Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.25-1.0
  157. - Version bump.
  158. * Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.24-1.0
  159. - Changed permissions on Icon file.
  160. * Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.23-1.0
  161. - Subtle change to .desktop file moves app launcher to system settings
  162. * Wed Apr 06 2005 Jim Parsons <jparsons@redhat.com> 0.9.22-1.0
  163. - Version Bump.
  164. * Wed Apr 06 2005 Jim Parsons <jparsons@redhat.com> 0.9.21-1.0
  165. - Changed path to lvm command for Fedora.
  166. * Mon Feb 21 2005 Jim Parsons <jparsons@redhat.com> 0.9.20-1.0
  167. - Added desktop icon file.
  168. * Mon Feb 21 2005 Jim Parsons <jparsons@redhat.com> 0.9.19-1.0
  169. - Added desktop file.
  170. * Wed Nov 24 2004 Jim Parsons <jparsons@redhat.com> 0.9.18-1.0
  171. - Adjustments to configure.in so this builds in fedora as well as RHEL.
  172. * Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.17-1.0
  173. - Fixes for bz140413 and bz 140562
  174. * Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.16-1.0
  175. - Strips whitespace off of all incoming command handler args.
  176. * Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.15-1.0
  177. - Fixes for two small nits.
  178. * Mon Nov 22 2004 Jim Parsons <jparsons@redhat.com> 0.9.14-1.0
  179. - Fixes for bz140413, 140386, 140355, 140359, 140419, 138103, 140529.
  180. * Thu Nov 18 2004 Jim Parsons <jparsons@redhat.com> 0.9.12-1.0
  181. - Fix for bz137041, 139711 plus require for new RHPL pkg.
  182. * Tue Nov 16 2004 Jim Parsons <jparsons@redhat.com> 0.9.11-1.0
  183. - Fix for bz138019 -- extent segs correct for stripe corner case
  184. * Mon Nov 15 2004 Jim Parsons <jparsons@redhat.com> 0.9.10-1.0
  185. - Fixes for bz137291, 138008, and 137122
  186. * Thu Nov 11 2004 Jim Parsons <jparsons@redhat.com> 0.9.9-1.0
  187. - Fixes for bz137111, 138887, 138006,138097. Also removed fstab checkbox
  188. and added it as a feature at 138831 for next release.
  189. * Wed Nov 10 2004 Jim Parsons <jparsons@redhat.com> 0.9.8-1.0
  190. - Fixes for bz137930, 137872, 137292, 137052, 137054
  191. * Tue Nov 9 2004 Jim Parsons <jparsons@redhat.com> 0.9.7-1.0
  192. - Improved handling of garbage in the size string -- try catch in place
  193. now that traps for ValueError
  194. - Improved handling of sizes/units for new LV creation
  195. - Now 'Unused' sections in Logical View of VGs, are unselectable. Also,
  196. if there are no LVs associated with a VG, the Logical view buttonpanel
  197. button for "Remove selected extents" is set to not be sensitive, as
  198. there is nothing to remove from this case.
  199. - Revamped PV removal code, so that proper checking is done before moving
  200. extents.
  201. - Added new method that checks if dm-mirror mod is loaded in kernel. If not,
  202. an appropriate error message is generated.
  203. - Fixed tree selection mechanism by preventing multiple VG selection.
  204. - Handle delete-event on VG creation dialog, so it is hidden.
  205. - Fixed bz137099, 137071, 137869, 137434, 138085
  206. * Mon Nov 1 2004 Jim Parsons <jparsons@redhat.com> 0.9.6-1.0
  207. - Changed gtk.mainloop to gtk.main to address bz137288.
  208. * Mon Nov 1 2004 Jim Parsons <jparsons@redhat.com> 0.9.5-1.0
  209. - Added Menubar to address bz137293.
  210. * Fri Oct 29 2004 Jim Parsons <jparsons@redhat.com> 0.9.4-1.0
  211. - Fixes for bz137190 empty vg name field validation,
  212. - bz137048 removes resizable checkbox for vgcreate,
  213. - bz137208 unique vg name checking fixed,
  214. - bz137107 remove autobackup checkbox,
  215. - bz137231 warn on extend vg when init'ing a new entity.
  216. * Tue Oct 26 2004 Jim Parsons <jparsons@redhat.com> 0.9.3-1.0
  217. - Version bump.
  218. * Tue Oct 26 2004 Jim Parsons <jparsons@redhat.com> 0.9.2-1.0
  219. - Fixed bz137118 warningMessage error. This is a critical mustfix.
  220. * Wed Oct 20 2004 Jim Parsons <jparsons@redhat.com> 0.9.1-2.5
  221. - Fixed size selection issue, bz136217.
  222. * Wed Sep 01 2004 Jim Parsons <jparsons@redhat.com> 0.9.1-1
  223. - Initial copy